13:01:29 <mattdm> #startmeeting Council (2017-05-17)
13:01:29 <zodbot> Meeting started Wed May 17 13:01:29 2017 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:01:29 <zodbot> The meeting name has been set to 'council_(2017-05-17)'
13:01:32 <mattdm> #meetingname council
13:01:32 <zodbot> The meeting name has been set to 'council'
13:01:34 <mattdm> #chair mattdm jkurik jwb langdon robyduck bexelbie
13:01:34 <zodbot> Current chairs: bexelbie jkurik jwb langdon mattdm robyduck
13:01:36 <mattdm> #topic Introductions, Welcomes
13:01:45 <jkurik> .hello jkurik
13:01:46 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
13:02:05 <mattdm> hi jkurik!
13:02:38 <jkurik> hi mattdm
13:02:45 <mattdm> hmmm, just the two of us? :)
13:02:56 <robyduck> .hello robyduck
13:02:57 <zodbot> robyduck: robyduck 'Robert Mayr' <robyduck@gmail.com>
13:03:05 <langdon> .hello langdon
13:03:06 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
13:03:56 <mattdm> ah, that's better :)
13:04:03 <jwb> Hi
13:04:18 <mattdm> okay, so just missing bexelbie...
13:04:59 <mattdm> let's go ahead with putting together the agenda
13:05:06 <bexelbie> .hello bex
13:05:06 <mattdm> #topic Open Floor Agenda Construction
13:05:07 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
13:05:17 <mattdm> First up:
13:05:23 <mattdm> Finalizing mission update. https://pagure.io/Fedora-Council/tickets/issue/114
13:05:40 <bexelbie> LATAM FAD: https://pagure.io/Fedora-Council/tickets/issue/116
13:05:46 <mattdm> *nod*
13:06:22 <bexelbie> if we have time, maybe 112?
13:06:24 <mattdm> There's a whole mess of open CoC and in general community behavior tickets... do we want to touch any of that today?
13:06:28 <bexelbie> user inactivity
13:06:55 * bexelbie suggests we focus on the other topics atm - I think there is nothing pressing in there that has to have immediate resolution
13:06:57 <bexelbie> but I am open
13:07:11 <mattdm> bexelbie: that's my feeling too
13:07:49 <mattdm> There are several open trademark reports; I'll handle those with legal out of meeting
13:08:10 <mattdm> bexelbie: do you want to throw in 113 re LATAM budget?
13:08:12 <bexelbie> if we still have time we can talk budget
13:08:30 <bexelbie> I'd need to review it again, but I think 113 is partially solved via the FAD and we need to look at more details from them
13:08:48 <bexelbie> I am trying to get time to get both LATAM and NA to update their budget requests with the data we asked for
13:09:22 <mattdm> what about also 88, the FUDCon ticket?
13:10:07 * bexelbie looks
13:10:25 <bexelbie> my understanding is 88 is now wrapped up in the FAD too
13:10:29 <jkurik> 88 looks like they expect some answer, so I am +1 to have it on agenda
13:10:47 <mattdm> ok, so let's put it all together in one item
13:10:51 <bexelbie> there has been some discussion on the LATAM ML - but yes, we should answer it
13:10:58 <mattdm> and let's start with this and see how far we get :)
13:11:04 <mattdm> #topic Finalizing the mission update
13:11:08 <mattdm> https://pagure.io/Fedora-Council/tickets/issue/114
13:11:32 <mattdm> bexelbie, langdon, did you see my rewording from a couple of days ago?
13:11:47 * langdon notices he is even more behind than he thought..
13:11:49 <mattdm> #info Initial draft: Fedora creates an innovative platform that lights up hardware, clouds, and containers for software developers and community members to build tailored solutions for their users.
13:11:53 <langdon> should I read now?
13:12:05 <mattdm> #info Proposed rewording after discussion: Fedora creates an innovative platform for hardware, clouds, and containers that enables software developers and community members to build tailored solutions for their users.
13:12:27 <mattdm> langdon: read that :)
13:12:37 * jkurik already voted +1
13:12:48 * robyduck too
13:13:04 <mattdm> as did jwb and robyduck :)
13:13:20 * langdon reads
13:13:59 <langdon> yeah.. i still have some caveats.. but it is good.. im +1 .. ill stick that in the ticket
13:14:10 <bexelbie> +1
13:14:19 <jwb> yay
13:14:29 <mattdm> #info Proposal is also to put this statement in a draft page (mattdm to write) which includes context of freedom foundation (as well as features / upstream-first and the rest)
13:14:34 <mattdm> okay, sold :)
13:14:47 <mattdm> #agreed council is unanimously in favor of this
13:14:57 <mattdm> well that was easy :)
13:15:00 <robyduck> yeah bought
13:15:54 <mattdm> I know people still have some concerns about free software and open source needing to be right there. My suggestion is that if we find this to be actively misinterpretted in practical way "in the wild", we can revisit that as needed.
13:15:57 * langdon looks for his bonbons to be delivered today
13:16:06 <mattdm> and for now, moving on to latam :)
13:16:32 <mattdm> #topic LATAM FAD (and FUDCon and Budget)
13:16:43 <mattdm> bexelbie: you want to summarize?
13:17:04 <jkurik> #link https://pagure.io/Fedora-Council/tickets/issue/116
13:17:22 <bexelbie> My understand from alexove is that there is a need to have an organization FAD in LATAM
13:18:05 <bexelbie> the goals include: getting the region to think more regionally and figure out what is going on with events and goals for the region; budget planning and figuring out how cooperate and operate in the new budget concept (budget.next); leveraging success and sharing it to other regions
13:18:24 <bexelbie> they also want to work on their internal issues with the way ambassadors is structured
13:18:33 <bexelbie> and I know robyduck and FAMSCo have some comments there
13:18:45 <bexelbie> I believe alexove is looking for feedback from the council
13:18:57 <bexelbie> so that the preplanning can be effective in LATAM
13:18:58 <mattdm> bexelbie: Is this to be just ambassadors, or other people with interest in the region? (Translators, etc.?)
13:19:10 <bexelbie> we have a month before their proposed dates need travel purchased so they ahve time
13:19:18 <mattdm> (It's okay with me if the answer is "ambassadors only; if other people are interested, join the ambassadors and wear two hats)
13:19:28 <bexelbie> My understanding is that they are working on one rep per country drawn from the Ambassadors
13:19:52 <bexelbie> the host country will have two people present, but one will abastain from votes, for coordination and discussion management
13:20:07 <bexelbie> if that made sense - basically the second person helps moderate
13:20:21 <bexelbie> they've asked me to attend as well to bring in council/fcaic commentary
13:20:32 <mattdm> I'm not sure I personally would draw country lines as the main separator, but I guess that's fine
13:20:35 <bexelbie> I could see asking them to think about functions, but I don't see a great way to manage that request on their side
13:21:01 <bexelbie> I believe they are trying to plan regionalized strategy at a macro and micro level and feel very country oriented not function oriented
13:21:05 <bexelbie> as this is driven out of ambassadors
13:21:27 <bexelbie> I also believe that the way menotrship has worked has encouraged country-centric thinking
13:21:30 <bexelbie> and they want to work on that
13:21:39 * bexelbie is making some suppositions
13:22:04 <mattdm> I'm not necessarily _opposed_ to country-centric if that's what the people in the region feel works best for that region
13:22:17 <mattdm> I'm not sure it would work so well in other regions.
13:22:33 <bexelbie> I believe in EMEA and APAC they also look at country-level reps for these kinds of things
13:22:59 <mattdm> Like, NA, where there are just three countries....
13:23:03 <bexelbie> In LATAM and APAC (and only some of EMEA) the situation on the ground can be very different mechanically from country to country
13:23:27 <mattdm> yeah anyway I should not get hung up on that
13:23:34 <bexelbie> I am not sure that it would work as well in NA, but I also don't know how much MX and CA participate in NA
13:23:43 <bexelbie> (3 acronyms one used twice, I win)
13:23:59 <mattdm> bexelbie: you were saying that the $7k budget included your travel?
13:24:04 <bexelbie> yes
13:24:14 <mattdm> should it? :)
13:24:15 <bexelbie> the proposal has been scaled back to omit my travel and reduce headcount
13:24:25 <mattdm> ok, so what is the total then?
13:24:28 <bexelbie> originally the host country had more attendees as they were cheap to have
13:24:33 <bexelbie> for now, my travel should not be included
13:24:41 <bexelbie> I'll ask the council directly if I run out of cash :)
13:24:58 <mattdm> I'm generally in favor of this. I think the goals are good and with good moderation it should have good results.
13:25:01 <bexelbie> per the wiki they are requesting $5200
13:25:15 <bexelbie> I am not sure they need a money commit today as much as an "idea commit" and "open questions"
13:25:23 <langdon> i like it
13:25:29 <bexelbie> I'd like to nail down money if council will commit within 3 weeks so we can get travel bought
13:25:38 <alexove> .fas alexove
13:25:39 <zodbot> alexove: alexove 'Alex Irmel Oviedo Solis' <alleinerwolf@gmail.com>
13:25:44 <bexelbie> I'll try to route through a provider so we can minimize reimbursement, if possible and with council approval
13:25:52 <bexelbie> sweet, alexove can talk to this now :)
13:26:02 <alexove> Hello all, sorry I'm late
13:26:19 <mattdm> hi alexove!
13:26:34 <mattdm> I'm not sure I have any questions. :)
13:26:52 <mattdm> jwb, robyduck, what do you think?
13:27:02 * robyduck reads backlog...phone (sorry)
13:27:11 <mattdm> jkurik: fpgm vote not strictly necessary here but I'd like your opinion too :)
13:27:22 <jkurik> :)
13:27:59 <alexove> What are your questions? :-)
13:28:17 <jkurik> mattdm: in general I am in favor of letting the decision on the ambassadors as they know the local situation
13:28:50 <langdon> alexove, what is the "output" of this event?
13:29:26 <mattdm> alexove: My main concern is whether country lines are really the best divider for Fedora (do we transcend political boundaries?)... but if you all think it's best, or just for that matter _practical_, that's ok with me.
13:29:27 <jwb> hm
13:30:18 <robyduck> I already added my thoughts (or better alex did it for me). I'm not sure if the request of the budget can be compared with the output of a FAD like this.
13:30:50 <alexove> langdon: As you can read in the page, we have problems with communication
13:31:03 <langdon> alexove, ha.. don't we all ;)
13:31:14 <jwb> i have no strong opinions either way.  i'm fine backing what bexelbie and the ambassadors recommend
13:31:45 <alexove> langdon: This causes problems and fights, I added some list messages to show that problems
13:31:57 <mattdm> robyduck: quick summary for the lazy? :)
13:32:44 <jkurik> mattdm: I do not know the situation in LATAM, but in Europe, comparing i.e. Czech Republic and Germany - it is a different world (at least from the economical point of view) and I understand the need to have a country specific events
13:33:01 <robyduck> mattdm: I understod they want to make a sort of planning FAD, combined with the creation of an internal LATAM Council to get more authority within the region
13:33:20 <alexove> I never seen that figths, My firts goal is put order there with a temporary internal council or empower some old ambassadors
13:33:45 <bexelbie> I ommitted the part about the council because I believe they need to talk that through with FAmSCo and robyduck - but I think LATAM needs a planning FAD regardless of the council
13:33:54 <robyduck> my opinion about this, has 2 thoughts: 1) I'm in favour of a FAD, as it helps to plan the whole FY inside the region and everything can be clear for all
13:34:14 <robyduck> also, speaking face to face helps to avoid misunderstanding (communication problems)
13:34:39 <robyduck> but I'm not in favour of an internal Council, just for the sake of "I decide what you have to do"
13:35:00 <alexove> Then, create a strategy for Latam ambassadors to improve their activities (events, meetups, enrollment process, etc) to match with the new fedora objectives}.
13:35:12 <robyduck> mattdm: mindshare will work in the opposite direction, not by new bodies or rules
13:35:23 <mattdm> robyduck: Yeah, I agree with that
13:35:30 <robyduck> EOF
13:35:58 <mattdm> But that does seem like a seperable issue
13:36:11 <mattdm> Can we get votes on the FAD proposal itself?
13:36:18 <mattdm> I am +1
13:36:25 <jwb> +1
13:37:12 <langdon> i think i am +1 .. but I am still a bit confused on what the output is.. "just" a plan for the year (in quotes because it is hard, i know)?
13:37:23 <langdon> or some other outputs as well?
13:37:32 * alexove He is committed to improving the whole proposal
13:37:34 <bexelbie> +1 to FAD -- Council idea requires support from FAmSCo, imho
13:37:48 <robyduck> I am +1 for having a FAD, but it should be organized together with another event (or planned convention or whatever, to limit the high airfares in LATAM)
13:38:11 <bexelbie> I read part of alexove's proposal as an output being understanding how to better plan as my understanding is that is part of the challenge
13:38:20 <langdon> robyduck, for next year? i see alexove replied to that concern
13:38:30 <mattdm> robyduck: Hmmm. That might be hard, or not help (if it's not an event people were going to anyway)
13:39:03 <robyduck> sure
13:39:08 <langdon> bexelbie, ok.. so I can expect to see a "here is how we will do this in future years" doc as well as the plan for "this" year?
13:39:22 <bexelbie> alexove, ^^
13:39:28 <bexelbie> I don't want to commit LATAM directly
13:39:29 <alexove> ok
13:39:40 <robyduck> do we have alternatives?
13:39:46 <bexelbie> but my personal goal if I go will be to make sure that LATAM is able to effectively work within budget.next and council goals as much as possible
13:39:53 <bexelbie> how they do it will be up to them, I am just going to help them
13:40:13 <alexove> A part will be short term (1 year) but there is another where we will have to work for a lot more time and I want us to have a long term plan
13:40:21 <mattdm> I would like to see a framework that is bigger than just planning for this year
13:40:24 <mattdm> alexove++
13:40:24 <zodbot> mattdm: Karma for alexove changed to 5 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:40:25 <langdon> right
13:40:46 <langdon> ok.. then i am +1
13:41:18 <alexove> For example, we do not have many users of linux or fedora and have collaborators since there is impossible, so we must work on users first and then on collaborators and that will be a long term plan
13:41:41 <mattdm> robyduck: do you want to go to this as part of the Mindshare initiative?
13:41:51 <langdon> alexove, given linux marketshare.. i don't think that is limited to your region.. and is always part of the plan ;)
13:42:34 <robyduck> mattdm: theoretically it would make sense, but I fear I don't have holidays to make it
13:43:24 <mattdm> robyduck: ah well :(
13:43:57 <mattdm> robyduck: Are you okay with doing the FAD as stand-alone if a "colocation" event can't pragmatically be found?
13:44:07 <mattdm> That'd come in at the $5200 budget
13:44:53 <robyduck> mattdm: I'm planning to be at Flock, and already have plans there too for mindshare.
13:45:22 <robyduck> mattdm: yes, if we don't have alternatives we should go for it.
13:45:52 <robyduck> maybe we should make sure the whole FAD will be organized to make sure there will be a concrete and long-term output?
13:46:00 <robyduck> (just thinking loudly)
13:46:28 <bexelbie> robyduck, I agree - this is part of why I am suggesting we not approve $$ today, but get LATAM to come back with a solid plan and answers to any questions we may have
13:46:44 <robyduck> bexelbie: +1
13:46:47 <bexelbie> I think that making this effort is a good thing for LATAM to do - and it represents the way forward - but if it doesn't work that says something too
13:46:58 <mattdm> bexelbie, robyduck: Okay, I can support that.
13:47:11 <mattdm> I guess one alternative would be to get everyone involved to Flock
13:47:16 <bexelbie> and I am happy to help alexove and LATAM with this planning
13:47:38 <bexelbie> mattdm, I'd like to see several reps from LATAM at flock for sure - I think making them all come in August costs another 2-3 months of time
13:47:48 <mattdm> I think inter-latam flights are not much cheaper than latam-boston :)
13:47:57 <robyduck> mattdm: but FLOCK also is rather far away, right?
13:48:02 <mattdm> bexelbie: Okay, so, basically: something quick now, followup in august.
13:48:06 <mattdm> robyduck: coming up fast :)
13:48:16 <robyduck> mattdm: true, it's more or less the same, specially if booked from the US
13:48:21 <bexelbie> mattdm, yeah, I think LATAM is treading water at this point, unless I misread the situation
13:48:43 <mattdm> bexelbie: ok, so, what specifically more do we need from alexove and others?
13:49:14 <bexelbie> I'd like to see them work on the agenda and formally state their output goals
13:49:29 <bexelbie> I think they should resolve this whole LATAM council vs. ideas from FAmSCo issue as well
13:49:38 <bexelbie> the FAD should be about doing an agenda not debating what is to be done
13:49:44 <bexelbie> eom
13:50:53 <mattdm> bexelbie: ok :)
13:51:03 <bexelbie> others should chime in please :)
13:51:10 <bexelbie> alexove, do you have questions about the above?
13:51:14 <mattdm> More on this? Should we move on to Inactive Accounts for the last ten minutes?
13:51:30 <langdon> i agree with you ( bexelbie ) .. so i am not sure what else i would add ;)
13:51:44 <robyduck> bexelbie: I can take that to FAmSCo too, and involve LATAM to work that out in a more "mindsharing" way before coming up to the Council again.
13:51:56 <alexove> no, I don't have questions, I will contact with robyduck and improve the proposal for next week, thanks all :)
13:52:00 <robyduck> mattdm: ^^
13:52:12 <bexelbie> alexove, let me know how I can help
13:52:26 <alexove> thanks a lot bexelbie :)
13:52:33 * langdon hard stop in about 3m
13:52:34 * bexelbie thinks you can easily take two weeks too :) that way LATAM/FAmSCo/robyduck has more time to think
13:53:03 <mattdm> #topic Inactive Accounts policy
13:53:04 <robyduck> thanks alexove for your participation today, that helped a lot
13:53:19 <alexove> bexelbie++
13:53:19 <zodbot> alexove: Karma for bex changed to 18 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:53:24 <alexove> robyduck++
13:53:24 <zodbot> alexove: Karma for robyduck changed to 21 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:53:24 <mattdm> I skimmed this :0
13:53:46 <robyduck> alexove++
13:53:46 <zodbot> robyduck: Karma for alexove changed to 6 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:53:47 <bexelbie> alexove++
13:53:49 <zodbot> bexelbie: Karma for alexove changed to 7 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:53:59 <langdon> mattdm, link?
13:54:00 <mattdm> As I understand it, the ambassadors' issue is resolved -- accounts will be removed from the *group*
13:54:07 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/112
13:54:21 <mattdm> the remaining question is whether we should deactivate accounts *in general*
13:54:26 <mattdm> bexelbie, is that correct?
13:54:29 <robyduck> mattdm: correct
13:54:35 <bexelbie> this is my understanding
13:54:47 * alexove is going to work, thanks all
13:55:27 <langdon> i think deactivating accounts is a terrible idea
13:55:51 <mattdm> smooge wanted clear guidance on whether infra can deactivate accounts to fight spam
13:56:09 <langdon> ohh.. well.. that is different..
13:56:13 <mattdm> and bexelbie wants to close inactive accounts for... some reason :)
13:56:20 <bexelbie> I am in favor of helping new people figure out what is actually working and not working in the project - if deactivating unused accounts as some other groups do, can help things not get directed to people who aren't active then we don't have so much friction
13:56:26 <bexelbie> the same is true for SIGs and Working Groups
13:56:38 <langdon> i think infra can deactivate anyone for any reason they deem appropriate as part of their work.. with an email to some ML about why
13:56:50 <bexelbie> I had a conversation recently where someone was talking about how it took them a while to realize they were talking to the ether by contacting a SIG
13:56:52 <robyduck> mattdm: at this point no subgroup has a rule which deactivates accounts. We should keep the situation as it is and could state as Council, we don't agree for now on deactivation of accounts. However if this is needed in the future, we can reconsider it.
13:57:17 <mattdm> bexelbie: I agree with that goal, but I don't think marking accounts inactive helps particularly
13:57:17 <jwb> eh
13:57:26 <mattdm> It's more about marking wiki pages inactive
13:57:27 <bexelbie> then lets not do it
13:57:28 <langdon> deactivating an account and removing someone from a group are very different things.. i am very happy with "auto-remove inactive" from the groups
13:57:36 <mattdm> yeah.
13:57:45 <mattdm> two minutes left here...
13:57:50 <jwb> so there's one positive aspect of marking an account inactive
13:58:07 <jwb> namely, it gives us a much better metric for how many _active_ contributors we have
13:58:13 <jwb> rather than inflated numbers
13:58:14 <bexelbie> +1 to that
13:58:14 <mattdm> jwb++
13:58:23 <langdon> jwb, also very managable with groups
13:58:30 <bexelbie> It may also prompt new contributions by an individual who times out
13:58:35 <mattdm> also, there is a minor security benefit -- although removing people from groups like _packagers_ might cover that.
13:58:38 <langdon> we can auto-remove the "im an active member" group or something
13:58:43 <bexelbie> as the saying goes, "even if they just contribute to get the T-shirt - you still got the contribution"
13:58:54 <jwb> right
13:59:07 <langdon> bexelbie, wait.. someone has t-shirts?!?!!?
13:59:10 <mattdm> but we wouldn't necessarily need to mark the account inactive in the current sense right now (which locks it and has other consequences)
13:59:22 * bexelbie hands langdon a t-shirt .. please put this on ... srlsy :P
13:59:25 <langdon> mattdm, see above
13:59:30 <langdon> bexelbie, :)
13:59:33 <mattdm> we could just have another flag (or, you know, a group, for that matter).
13:59:47 <mattdm> ok, looks like this needs a bit more discussion than we have time for.
13:59:49 <bexelbie> Why is deactivating unused accounts bad?
13:59:58 <langdon> I feel like I just saw that idea ;)
14:00:00 <mattdm> bexelbie: pain to reactivate
14:00:04 <robyduck> a t-shirt group?
14:00:07 <mattdm> robyduck++
14:00:15 <robyduck> :)
14:00:17 <bexelbie> that assumes that the accounts would ever become active again :)
14:00:19 <mattdm> ending meeting now. jkurik's next meeting starting presently :)
14:00:26 <bexelbie> thank you all
14:00:28 <mattdm> let's take this to the ticket
14:00:35 <langdon> Bye all
14:00:38 <mattdm> #endmeeting