18:04:43 <Rhea> #startmeeting Fedora DotNet (2017-06-13)
18:04:43 <zodbot> Meeting started Tue Jun 13 18:04:43 2017 UTC.  The chair is Rhea. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:04:43 <zodbot> The meeting name has been set to 'fedora_dotnet_(2017-06-13)'
18:04:45 <Rhea> #meetingname dotnet
18:04:45 <zodbot> The meeting name has been set to 'dotnet'
18:04:52 <Rhea> #nick dotnet
18:07:46 <tmds> hi!
18:07:56 <Rhea> #chair amitosh omajid tmds aslice
18:07:56 <zodbot> Current chairs: Rhea amitosh aslice omajid tmds
18:08:05 <tmds> sorry I'm late, I got hung up on a github issue...
18:08:13 <Rhea> #topic Agenda
18:08:15 <Rhea> #info (1) Roll Call
18:08:18 <Rhea> #info (2) Announcements
18:08:22 <Rhea> #info (3) Action items and Tickets
18:08:24 <Rhea> #info (4) Packaging progress / Open Floor discussion
18:08:26 <tmds> you too omajid :D
18:08:28 <Rhea> #topic Roll Call
18:08:32 <Rhea> #info Name; Timezone; Sub-projects/Interest Areas
18:08:35 <Rhea> #action dotnet New members, make sure you introduce yourself on the DotNet mailing list [ https://fedoraproject.org/wiki/SIGs/DotNet ]
18:08:49 <Rhea> If this is your first time at a DotNet meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
18:09:45 <Rhea> #info Radka Janek; UTC+1; CommOps, Diversity, DotNet,...
18:09:53 <amitosh> #info Amitosh S.; UTC+5:30; DotNet, Python, Docker
18:11:06 <Rhea> >_<
18:11:16 <omajid> #info Omair Majid; UTC-4; DotNet, Java
18:13:14 <Rhea> #topic Announcements
18:13:16 <Rhea> #info === "Performance Improvements in .NET Core" ===
18:13:18 <Rhea> #link === https://blogs.msdn.microsoft.com/dotnet/2017/06/07/performance-improvements-in-net-core/
18:13:20 <Rhea> #info === ".NET Core 2 and Visual Studio 2017 (15.3) Preview 2" ===
18:13:22 <Rhea> #link === https://blogs.msdn.microsoft.com/dotnet/2017/06/12/net-core-2-and-visual-studio-2017-preview-2/
18:13:55 <Rhea> #topic Action items and Tickets
18:14:02 <Rhea> #link https://meetbot.fedoraproject.org/teams/dotnet
18:14:04 <Rhea> #link https://pagure.io/fedora-dotnet/issues?tags=meeting
18:14:08 <Rhea> #info How This Works: We look at past #action items from the last meeting for quick follow-up. If a task is completed, we move on to the next one. If it isn't, we get an update and re-action it if needed. If no status, we'll try to get a quick update and move forward.
18:14:13 <Rhea> #info === [WIP] Rhea rewrite the C# developer pages based on pagure #17 ===
18:14:21 <Rhea> #link https://pagure.io/fedora-dotnet/issue/17
18:14:23 <Rhea> #link https://github.com/Fedora-dotnet/developer-portal-content
18:15:04 <Rhea> I'm not going to continue working on it, I don't have time for it... So that small piece of info is what's gonna be at the page.
18:15:27 <Rhea> Just IDE's, download locations and docs, for both mono and netcore...
18:15:35 <Rhea> #topic Packaging progress / Open Floor discussion
18:15:47 <Rhea> omajid: moving on to your little-big success?
18:16:00 <omajid> little big success?
18:16:19 <omajid> Rhea: i am lost :)
18:16:45 <Rhea> Well, you had some luck with 2.0 building... what does it mean for fedora, are we getting closer? o.o
18:17:26 <omajid> Rhea: actually.. tmds might have more to say here. he was telling me about his banana linux work
18:18:23 <omajid> basically, the source-build effort is getting closer and closer to buildin on arbitrary linux (which means Fedora too!)
18:18:30 <Rhea> mmmm... banana with ice cream and chocolate....
18:18:33 <Rhea> o_o
18:18:57 <tmds> I tried compiling the stuff we got from MS after modifying my OS to no longer be fedora.24 but banana.28
18:19:20 <tmds> with some minor patches and after drinking some coffee & eating bananas, a build succeeded
18:20:16 <tmds> so, it looks things will be buildable
18:20:23 <tmds> hooray!
18:20:26 <amitosh> So did you change the lsb_release ?
18:20:35 <tmds> I changed the /etc/os-release
18:21:01 <tmds> which is used to identify an os by .net core
18:21:12 <tmds> the rid (runtime identifier) is derived from that
18:21:23 <tmds> e.g. rhel.7-x64, fedora.24-x64
18:21:43 <tmds> so I built for banana.28-x64
18:22:11 <tmds> so, no parts of the build were using that rid in the wrong place
18:22:24 <Rhea> :D
18:22:25 <tmds> otherwise things would not be able to restore/publish
18:24:11 <Rhea> So my next question would be, what are we missing to be able to satisfy Fedora packaging?
18:24:22 <Rhea> Any binaries or licenses still?
18:25:04 <omajid> on lincenses, everthing should be, or is only its way to being licensed freely. including binaries
18:25:22 <omajid> but binaries themselves are a bit of a problem. this build uses prebuilt binaries.
18:25:38 <omajid> and it is not sufficient to bootstrap itself.
18:25:39 <Rhea> :<
18:27:22 <omajid> i guess we keep bringing up one issue at a time and see how upstream resolves it.
18:27:33 <Rhea> yup
18:27:53 <Rhea> We should be able to build some unofficial packages at least tho
18:28:52 <tmds> why not official?
18:29:07 <omajid> yeah, copr has more relaxed rules, so it would be easier to get that working
18:29:25 <omajid> tmds: official rules require no binaries from outside the distro (with an exception for bootstrapping)
18:31:01 <omajid> (most java build start with a find -name *.jar -exec rm {} for this reason)
18:31:43 <tmds> I can't follow what part needs to change in what way?
18:31:58 <tmds> we need .net to compile it, so that's bootstrapping?
18:32:31 <omajid> yeah. we can use prebuilt binaries (including an existing cli binary, but also roslyn, msbuild, ...) for buildin .net core once
18:32:52 <omajid> but then we must not use any binaries from outside the distro for buildin any future versions of .net core
18:33:13 <omajid> (we can probably get an exception for binaries for 3.0, though)
18:33:44 <omajid> it seems to me like we need to package everything .net core build uses (msbuild? powershell? json.net?) into fedora as well
18:34:58 <tmds> would a double build be ok? step 1: build using microsoft binaries, step 2: build again using binaries built by step 1?
18:35:42 <omajid> yes. catch beinh step 2 must only use binaries from fedora. this includes all build tools. msbuild, powershell, roslyn, *anything* the build uses
18:36:41 <tmds> ok, I have no idea how far we are from that
18:36:57 <omajid> tmds: basically, everything in prebuilt/nuget-packages/ needs to go away.
18:37:18 <amitosh> thats a lot of nuget packages
18:37:24 <omajid> oh. Tools/ as well
18:37:45 <tmds> the road is long
18:37:49 <omajid> yeah :(
18:38:45 <amitosh> Including nuget packages will need dotnet to exist in fedora ? deadlock !
18:39:26 <omajid> amitosh: we have to build them between steps 1 and 2 that tmds mentioned above
18:39:44 <omajid> (and then rebuild them after step 2 using Fedora-binaries)
18:46:14 <tmds> Rhea's gone?
18:46:29 <omajid> droped out ~15 minutes ago
18:48:23 <tmds> let's try and build for fedora when we have a preview2 source drop
18:49:14 <tmds> so that should be in the near future
18:49:25 <tmds> if p2 is planned for end of june
18:49:41 <omajid> +1
18:55:27 <tmds> so, that's the end of the meeting then...
18:55:49 <tmds> see you next week
19:33:06 <Rhea> #endmeeting