18:03:04 <Rhea> #startmeeting Fedora DotNet (2017-06-20)
18:03:04 <zodbot> Meeting started Tue Jun 20 18:03:04 2017 UTC.  The chair is Rhea. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:03:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:03:04 <zodbot> The meeting name has been set to 'fedora_dotnet_(2017-06-20)'
18:03:12 <Rhea> #meetingname dotnet
18:03:12 <zodbot> The meeting name has been set to 'dotnet'
18:03:16 <Rhea> 
18:03:20 <Rhea> lol empty space
18:03:27 <Rhea> #nick dotnet
18:03:59 <Rhea> #info (4) Packaging progress / Open Floor discussion
18:04:03 <Rhea> #undo
18:04:03 <zodbot> Removing item from minutes: INFO by Rhea at 18:03:59 : (4) Packaging progress / Open Floor discussion
18:04:10 <Rhea> #topic Agenda
18:04:13 <Rhea> #link https://fedoraproject.org/wiki/Meeting:DotNet_2017-06-20
18:04:15 <Rhea> #info (1) Roll Call
18:04:18 <Rhea> #info (2) Announcements
18:04:20 <Rhea> #info (3) Action items and Tickets
18:04:22 <Rhea> #info (4) Packaging progress / Open Floor discussion
18:04:38 <Rhea> #chair omajid bt0 pcreech aslice tmds nmilosev
18:04:38 <zodbot> Current chairs: Rhea aslice bt0 nmilosev omajid pcreech tmds
18:04:57 <Rhea> #topic Roll Call
18:05:00 <Rhea> #info Name; Timezone; Sub-projects/Interest Areas
18:05:02 <Rhea> #action dotnet New members, make sure you introduce yourself on the DotNet mailing list [ https://fedoraproject.org/wiki/SIGs/DotNet ]
18:05:06 <Rhea> If this is your first time at a DotNet meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
18:05:47 <Rhea> #info Radka Janek; UTC+1; CommOps, Diversity, DotNet,...
18:06:00 <Rhea> (i always wonder whether it's still +1 when we are on summer time...)
18:06:07 <pcreech> .hello pcreech17
18:06:08 <zodbot> pcreech: pcreech17 'Patrick Creech' <pcreech@redhat.com>
18:06:21 <amitosh> #info Amitosh Swain Mahapatra; UTC+5:30; DotNet, Python
18:06:37 <Rhea> #chair amitosh
18:06:37 <zodbot> Current chairs: Rhea amitosh aslice bt0 nmilosev omajid pcreech tmds
18:06:46 <omajid> #info Omair Majid: UTC-4; DotNet, Java
18:07:01 <bt0> #info Alberto Rodriguez S; UTC-5; CommOps, DotNet, Infra
18:07:20 <aslice> #info Andrew Slice; UTC-4; DotNet, Perl(6), C++
18:07:46 <Rhea> #topic Announcements
18:07:48 <tmds> hi
18:07:49 <Rhea> #info === "Rider EAP 23: .NET Core debugger is back, Code Cleanup, and more" ===
18:07:51 <Rhea> #link https://blog.jetbrains.com/dotnet/2017/06/16/rider-eap-23-net-core-debugger-back-code-cleanup/
18:07:57 <Rhea> Oh hi tmds just in time
18:08:00 <Rhea> For the... above
18:08:03 <Rhea> :D
18:08:04 <Rhea> \o/ debugger
18:08:16 <bt0> awesome
18:08:17 <tmds> I saw the announcement too, has anyone tried it?
18:08:30 <Rhea> I did install it but didn't really need to debug anything
18:08:35 <Rhea> and don't have time to play around >_<
18:08:52 <tmds> Rhea needs to write more bugs :P
18:09:03 <Rhea> I know right...
18:09:22 <nb> .hello nb
18:09:23 <zodbot> nb: nb 'Nick Bebout' <nb@nb.zone>
18:09:32 <amitosh> This build doesnt start for some reason :/
18:09:50 <Rhea> Usually after 8 hours of writing code without any compilation I hit build and it's like zero errors zero warnings... And then I deploy it just to notice a typo in user facing GUI :D
18:10:15 <pcreech> lol, nice Rhea
18:10:23 <Rhea> amitosh: how come, does it.. say anything?
18:10:36 <amitosh> nope, nothing
18:11:03 <Rhea> Hum...
18:11:30 <Rhea> What are you running right now?
18:11:35 <Rhea> 25?
18:12:04 <amitosh> yeah
18:13:07 <Rhea> Interesting
18:13:11 <Rhea> flawless for me
18:14:01 <Rhea> Check ~/.Rider<somethingsomething> for some log files, maybe there is something
18:14:23 <Rhea> Anyway... moving on, no more nothing from me...
18:14:25 <Rhea> #topic Packaging progress / Open Floor discussion
18:14:56 <amitosh> Might be some remnants of config in my home dir, ... but since I mostly do Python & Php now, I'll give it a try sometimes later
18:15:31 <tmds> open floor: I'm working on a new release of Tmds.DBus
18:15:43 <tmds> one new feature is codegen
18:15:53 <Rhea> Yup i'm totally stalking your progress :D
18:15:57 <tmds> which should make it super easy to consume dbus services from .net core apps
18:16:16 <Rhea> What will the usage look like?
18:16:18 <amitosh> Does it break anything ?
18:16:29 <tmds> it doesn't break anything
18:16:31 <Rhea> Say for manipulating units
18:16:46 <tmds> if someone wants to give it a try: https://gist.github.com/tmds/2e2f3fe2f610a41ff790a79d5a53c125
18:17:16 <tmds> the NuGet file gets you the dev feed, and the Example shows how to use this
18:17:25 <Rhea> yup
18:17:43 <amitosh> I have half-built Avahi-Sharp on Tmds.DBus, Avahi docs are scarce >_<
18:18:09 <tmds> feedback is welcome, bugs, github stars -> https://github.com/tmds/Tmds.DBus
18:18:23 <tmds> amitosh: give this a try for the avahi stuff
18:18:24 <Rhea> you've got mine, i can't clone
18:18:27 <Rhea> :D
18:19:02 <tmds> my goal is to get someone be able to consume 'any' dbus service from .net in less than 5 mins :)
18:20:33 <aslice> very nice
18:21:01 <amitosh> .Net can be great for running things in raspberry pi.
18:22:50 <tmds> you need to use a 2.0 sdk
18:23:01 <tmds> codegen is c# 7
18:23:45 <Rhea> Oh right, by the way sorry i got disconnected last meeting
18:23:58 <tmds> I hope some of you try it out and give me some feedback
18:24:29 * pcreech leaves meeting early, \o
18:24:34 <Rhea> pcreech: bai
18:26:11 <tmds> no prob
18:26:17 <Rhea> #info To sum up last discussion - we were talking about source build, 2.0 and F27 - in 2.0 we should be able to have nice copr packages, but there will most likely still be some prebuilt binaries in our way of having it in Fedora officially. Maybe F27
18:26:30 <tmds> after you left we waid we were waiting for the .net core 2.0 sources
18:26:34 <tmds> which still is the case
18:27:06 <Rhea> yup
18:28:31 <Rhea> Okay I would say lets call it :]
18:28:37 <tmds> good call
18:28:39 <Rhea> Unless you have anything else to add
18:28:51 <bt0> nop
18:28:56 <aslice> I'm good.
18:29:07 <Rhea> tmds: by the way I will be rewriting my little application that's fiddling with services, so I can tell you what does that look like (dbus thing)
18:29:25 <Rhea> Dunno when tho... I have so many things to do right now...
18:29:29 <Rhea> like... SO MANY
18:29:34 <Rhea> :D
18:29:37 <amitosh> 'that' application ?
18:29:47 <tmds> Rhea: you only need 5 min to get's started with this (according to the advertising ;)
18:29:55 <Rhea> amitosh: dunno what do you mean but most likely no :D
18:30:06 <Rhea> tmds: cool :D
18:30:10 <tmds> looking forward to your feedback :)
18:30:18 <Rhea> #endmeeting