14:18:44 <jkurik> #startmeeting Prioritized_bugs_and_issues
14:18:44 <zodbot> Meeting started Wed Sep 13 14:18:44 2017 UTC.  The chair is jkurik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:18:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:18:44 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
14:18:46 <jkurik> #meetingname Fedora Prioritized bugs and issues
14:18:46 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
14:18:56 <jkurik> #topic Purpose of this meeting
14:18:57 <jkurik> #info The purpose of this process is to help with processing backlog of bugs and
14:18:59 <jkurik> #info   issues found during the development, verification and use of Fedora distribution.
14:19:10 <jkurik> #info The main goal is to raise visibility of bugs and issues to help
14:19:12 <jkurik> #info   contributors focus on the most important issues.
14:19:13 <jkurik> #link https://fedoraproject.org/wiki/Fedora_Program_Management/Prioritized_bugs_and_issues_-_the_process
14:19:16 <jkurik> #info Currently we have 1 proposed bugs for evaluation and 5 bugs already approved for review.
14:19:29 <jkurik> #topic Roll Call
14:19:31 <jkurik> #chair jkurik mattdm mcatanzaro dustymabe sgallagh roshi
14:19:31 <zodbot> Current chairs: dustymabe jkurik mattdm mcatanzaro roshi sgallagh
14:19:32 <mattdm> oh hi jkurik! fancy meeting you here!
14:19:40 <jkurik> hi mattdm
14:19:49 * roshi wakes up
14:20:04 <jkurik> nice to read you again roshi
14:20:05 <mattdm> roshi!
14:20:07 <sgallagh> I'm here today, I guess
14:20:21 <roshi> you pinged, I answered :)
14:20:29 <roshi> same to you jkurik!
14:20:32 <mattdm> we need a thing like .fire that is "buys coffee"
14:20:39 <mattdm> or whisky, whichever
14:20:56 <roshi> and an actual bot to deliver said libation
14:20:59 <roshi> :)
14:21:12 <jkurik> so, we have more people than usually today, so lets start
14:21:17 <jkurik> #topic Evaluation of bug #1390198: [abrt] gnome-shell: st_bin_dispose(): gnome-shell killed by SIGABRT
14:21:18 <jkurik> #link https://bugzilla.redhat.com/show_bug.cgi?id=1390198
14:22:11 <mattdm> Ok, so this *really* seems like a TopIcons Plus bug
14:22:22 <mattdm> By design, GNOME Shell lets extensions do things which could cause crashes
14:22:39 <mattdm> It's a tradeoff of power vs. safety
14:22:56 <roshi> if you get rid of that extension, does it still crash?
14:23:19 <mattdm> roshi: People are reporting that getting rid of it solves the problem, and putting it back causes crashes again
14:23:26 <mattdm> However, it's a very popular extension
14:23:28 <sgallagh> right
14:23:49 <sgallagh> And only likely to become more so in F27
14:23:51 <mattdm> And, GNOME is removing the awful bottom notifications popout thing *completely* in the future
14:23:57 <sgallagh> Right, that
14:24:11 <mattdm> and recommending that topicons or topicons plus be installed if you want to run software that needs it
14:24:23 <dustymabe> hi jkurik
14:24:28 <jkurik> hi dustymabe
14:24:34 <mattdm> #link https://github.com/phocean/TopIcons-plus/issues/73
14:24:44 <mattdm> is *probably* it, but is marked "can't reproduce"
14:26:13 <sgallagh> So, I'm not really sure what marking this Prioritized would accomplish.
14:26:22 <roshi> yeah
14:26:27 <sgallagh> Upstream is aware of the issue (but having difficulty coming up with a consistent reproducer)
14:26:28 <roshi> especially if it's in a plugin
14:26:36 <mattdm> Well, we could maybe ask someone from the desktop team if they could assist in finding a reproducer
14:26:42 <sgallagh> Hmm
14:27:44 <jkurik> so, I am probably -1 to have this as a prioritized bug, bud +1 to ask desktop team to help find a reproducer
14:28:12 <mattdm> I'm making a comment in the bug
14:28:13 <sgallagh> Yeah, what jkurik said
14:28:20 <roshi> same
14:29:21 <jkurik> proposed #agreed We see no benefit to have this bug as Prioritized however we consider this as important one and we will ask desktop team to help finding a reproducer
14:29:33 <roshi> ack
14:29:41 <sgallagh> patch
14:30:14 <sgallagh> proposed #agreed We aren't marking this as Prioritized because we don't have appropriate resources at our disposal, however we consider this as important one and we will ask desktop team to help finding a reproducer.
14:30:38 <mattdm> who is taking the action item to do that asking?
14:30:43 <jkurik> ack, it is more diplomatic :)
14:30:49 <jkurik> mattdm: me
14:30:50 <sgallagh> mattdm: I thought that's what you just did?
14:30:53 <roshi> ack
14:30:54 <sgallagh> But okay
14:30:58 <mattdm> thanks jkurik :)
14:31:17 <mattdm> sgallagh: no i'm posting a general "provide info to upstream" please comment
14:31:39 <sgallagh> gotcha
14:31:50 <jkurik> #action jkurik to ask destop team to help finding a reproducer for #1390198
14:32:08 <jkurik> that's all for the new proposals
14:32:14 <jkurik> now we have some reviews ....
14:32:23 <jkurik> #topic Review of bug #1366004: [abrt] setroubleshoot-server: service.py:647:_message_cb:SystemError: <built-in function isinstance> returned a result with an error set
14:32:25 <jkurik> #link https://bugzilla.redhat.com/show_bug.cgi?id=1366004
14:34:14 <jkurik> looks like there was not much done; does the dbus-python component falls under Python-SIG ?
14:36:02 <mattdm> hmmm looks like someone was on it and then vanished :(
14:36:12 <jkurik> right
14:37:38 <mattdm> As I understand it, the severity here is that it masks real problems from being reported
14:39:19 <mattdm> how about we reassing it back to setroubleshoot and ask the maintainers of that to take another look?
14:39:34 <mattdm> because I am sure that "Alternative GTK desktop environment SIG" is not right
14:39:38 <roshi> sounds reasonable
14:40:58 <jkurik> yeah, "Alternative GTK desktop environment SIG" is definitely not right
14:41:33 <jkurik> I was thinking of asking cstratak@redhat.com what his pov is
14:42:09 <mattdm> bugzilla is really slow right now
14:42:11 <jkurik> as he was already playing with some patches
14:45:56 <mattdm> oh look now it's assigned to dan walsh
14:46:24 <jkurik> ?
14:47:03 <mattdm> that's what happened when I changed the component to setroubleshooter
14:47:03 <jkurik> ah, ok :)
14:47:20 <mattdm> asking cstratak seems like a good move
14:48:01 <jkurik> #action jkurik to ask cstratak what is the current status of #1366004
14:48:18 * cstratak waves
14:48:29 <jkurik> #info Bug #1366004 has been re-assigned back to setroubleshooter component
14:48:37 <jkurik> Hi ‎cstratak‎‎
14:48:45 <cstratak> taking a fast look
14:49:36 <jkurik> you were working on this, so we wanted to check with you whether you have any status update
14:49:44 <cstratak> ah as I recall I had prepared some 'kinda debug' builds for people to try but I got no answer
14:50:11 <cstratak> comment 47 was where I was left off. No more updates from that
14:50:53 <cstratak> and as I have no way of reproducing the issue, I can only provide some debug builds and wait for people who experience the bug to test them, as it is.
14:51:55 <mattdm> cstratak: for what it's worth, looks like we have a lot more dupes with similar crashes than we did a year ago :-/
14:53:14 <cstratak> I see. Not sure what would be the best course of action here.
14:53:48 <cstratak> I could certainly update the debug builds to more recent ones
14:54:29 <cstratak> but apart from that there must be some people who can reproduce it and are willing to test the builds
14:55:11 <cstratak> so as it is, I'll try to provide updated builds sometime this or the next week with a requests for people to test it. Would that be a sufficient things for the time being?
14:55:40 <jkurik> Thanks, it definitely helps.
14:56:14 <jkurik> We will revisit in two weeks (or so) and we will see then, whether there is any progress in testing.
14:56:28 <jkurik> cstratak: thanks
14:56:58 <jkurik> #info ‎cstratak‎ is going to provide updated builds sometime this or the next week with a requests for people to test it
14:57:36 <jkurik> #info We will revisit this on the next meeting and see whether there is any progress in testing
14:58:00 <jkurik> during the last 2 minutes....
14:58:04 <jkurik> #topic Review of bug #1375468: [abrt] nautilus: nautilus_window_slot_get_allow_stop(): nautilus killed by SIGSEGV
14:58:05 <jkurik> #link https://bugzilla.redhat.com/show_bug.cgi?id=1375468
14:58:08 <roshi> thanks cstratak
15:01:02 <jkurik> hmm... this seems to be in a similar state as the previous bug - not having a reliable reproducer
15:01:31 <jkurik> ok, time is up, lets finish the review on a next meeting
15:01:39 <jkurik> #undo
15:01:39 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x554b490>
15:02:03 <jkurik> Thanks all for comming
15:02:10 <jkurik> #endmeeting