15:00:51 <adamw> #startmeeting Fedora QA meeting
15:00:51 <zodbot> Meeting started Mon Oct 16 15:00:51 2017 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:51 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:55 <adamw> #meetingname fedora-qa
15:00:55 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:58 <adamw> #topic Roll Call
15:01:02 <adamw> morning folks, who's around?
15:01:10 * coremodule is here!
15:01:44 <adamw> morning coremodule
15:02:00 * sumantrom[m] is here
15:02:05 <sumantrom[m]> Morning adamw
15:02:25 <sumantrom[m]> coremodule: hii :)
15:02:42 <coremodule> Morning adamw, long time! Glad to be here.
15:02:55 <coremodule> Hi sumantrom[m] :)
15:03:09 <adamw> hi sumantro
15:03:38 * sumantrom[m] missed coremodule
15:04:15 <adamw> me too, but i've reloaded the custard pie gun and i'm ready to try again
15:04:31 * adamw wonders if anyone else is thinking of turning up
15:04:39 <adamw> i did actually send the invitation, right?
15:04:56 <sumantrom[m]> Yes you did :)
15:05:58 <adamw> whew, not my fault then :P
15:08:46 <adamw> well, if no-one else shows up, i'm not sure if it's worth going through the agenda...what do you guys think?
15:10:14 <coremodule> I do agree
15:10:31 <sumantrom[m]> We can still talk about couple of them and post the meeting logs with updates about what we did and where are we now . Also I would like to propose an on boarding session for fedora QA with specific emphasis on modular server testing. If the test cases and stuffs are ready.
15:11:42 <adamw> i don't think so :/
15:11:52 <adamw> i also don't think it's really testable yet - but i need to talk to sgallagh about that
15:12:02 <adamw> let's do a sorta quick run through then...
15:12:11 <sumantrom[m]> Okay
15:12:13 <adamw> #info due to short attendance we'll be a bit more informal than usual today
15:12:19 <adamw> #topic Previous meeting follow-up
15:12:29 <sgallagh> adamw: I am around-ish
15:13:58 <adamw> #info looks like we didn't have anything from last meeting
15:14:08 <adamw> sgallagh: i'll ping you somewhere else in a minute :)
15:14:16 <sgallagh> ack
15:14:51 <adamw> #topic Fedora 27 status
15:15:01 <adamw> sooo, this is where i was hoping people can fill me in, kinda :)
15:15:08 <adamw> sumantrom[m]: what's your take on current f27 status?
15:16:15 <sumantrom[m]> It's good except for the kernel bug. I would like to although point some specific upgrade issues. Rest look good to me.
15:16:20 <adamw> (and fill coremodule in too, of course)
15:17:09 <adamw> #info main F27 release process is running along quite smoothly, we are still worried about the kernel bug with VMs using qxl
15:17:36 <adamw> aiui, for Server we've basically split it off to its own release process, yes, but this seems to be getting done as we go along?
15:18:34 <sumantrom[m]> Yes I know
15:19:25 <adamw> #info Server (modular) release process has been de-coupled from main release process and is intended to deliver a month behind main process dates, process for handling this is being made up as we go along apparently
15:19:50 <adamw> i was thinking we could at least do with separate blocker tracker bugs for Server
15:19:59 <adamw> and are we using the same blocker review meetings, or doing separate ones?
15:20:22 <tflink> is the plan to release a traditional server product or to skip that for 27?
15:22:32 <adamw> i heard that it's not blocking at least
15:22:38 <adamw> i'm not sure if we're still planning to ship it at all
15:23:02 <adamw> #info we're not sure whether a traditional Server product will be produced / delivered at all, but we at least know it does not block the main release process
15:23:28 <sumantrom[m]> Yes I concur with adamw , we probably should have the modular blocker bug separate meeting.
15:23:35 <adamw> #action adamw to create separate blocker/fe tracking bugs for Server and update appropriate pages
15:23:56 <adamw> #info need to decide if modular Server blocker bugs will be discussed in regular blocker review meetings or separate ones
15:24:08 <tflink> do we create new milestones in the blockerbugs app, then?
15:25:05 <adamw> hmm, yeah, that's a point, maybe i'd better check if that'll work first
15:26:06 <tflink> I suspect it would work
15:26:22 <tflink> if all else fails, the milestone would be something like beta-server
15:27:06 <adamw> yeah, but i'll just need to play with it a bit first to figure it out.
15:27:29 <adamw> sgallagh: well, if you're around, i suppose we might as well do this on the record if you don't mind...?
15:27:33 <alciregi> .hello alciregi
15:27:34 <zodbot> alciregi: alciregi 'Alessio Ciregia' <alciregi@gmail.com>
15:27:40 <sgallagh> >.>
15:27:54 <adamw> sgallagh: 'this' being: so what *is* the status of modular server right now, exactly? is it at a point where we can usefully test...anything?
15:28:19 <adamw> basically all i know right now is we have modular composes that produce ISOs which seem to boot straight to the installer's text mode. and...that's it.
15:28:21 <sgallagh> adamw: Short answer: no. Slightly longer answer: we've been at the cusp of "yes" for a week now.
15:28:48 <adamw> The Cusp Of "Yes": little-known album of live tracks and b-sides
15:29:24 <adamw> sgallagh: so, is there an ETA on when we're likely to *reach* yes?
15:29:28 <sgallagh> As of right now, we're probably not going to have something useful in time for this week's go/no-go
15:29:58 <sgallagh> If things go smoothly, we should have a testable image by Thursday, but it's not enough time to expect a "Go" decision
15:30:07 <adamw> okay.
15:30:13 <sgallagh> well, "smoothly" meaning "no worse than they have been"
15:30:21 <adamw> heh.
15:30:37 * Southern_Gentlem is glad that modularity doesnt block f27
15:30:38 <sgallagh> We have a list of the remaining blockers to a testable image
15:30:48 <sgallagh> It needs some massaging and should be public by EOB today
15:30:49 <adamw> do you know how things are going on defining required test coverage, criteria etc.? I know that was at least partly assigned to me but i also heard someone else was trying to do something about it
15:31:30 <sgallagh> adamw: Some of that will be covered by the document I just mentioned.
15:31:33 <adamw> okay.
15:32:01 <sgallagh> We also have an internal list of known things that would violate the release criteria as run in F26, but we need to push that out somewhere visible
15:33:28 <adamw> #info per sgallagh, modular Server is not currently in a usefully-testable state but may reach it by Thursday. the team has lists of known blockers (both to a testable state and under the existing release criteria) that it's working to make public.
15:33:43 <adamw> is that a reasonable summary?
15:33:46 <sgallagh> ack
15:33:49 <adamw> thanks.
15:34:36 <sgallagh> I'll be missing the blocker triage today in the interest of shortening those lists :)
15:34:48 <adamw> we're not actually planning on running one...
15:35:12 <adamw> although we do now have two proposed blockers (there were none on friday)
15:35:41 <adamw> so, i guess that about covers it for 27...did anyone have any other notes?
15:37:17 <sumantrom[m]> Nopes :)
15:37:36 <coremodule> Nothing here, we'll run a mini-blocker-review on Thursday at the go/no-go, right?
15:38:04 <adamw> for server, yeah
15:38:12 <coremodule> Gotcha, okay.
15:38:13 <adamw> for regular, maybe we can vote in-bug on the two proposed final blockers
15:39:26 <adamw> #topic Test Day status
15:39:32 <adamw> sumantrom[m]: any notes on test days?
15:41:25 <sumantrom[m]> Everything ran well and as expected. We might want to have commblog access to continue to engage more audience
15:42:10 <adamw> yeah, i'm still trying to talk to them about that...
15:42:19 <adamw> maybe when bex is back (not sure if he is yet) we'll get further...
15:43:23 <sumantrom[m]> Sure!
15:43:44 <adamw> so we don't currently have any more scheduled for f27, right? but you're interested in doing something for server when we can?
15:44:02 * bexelbie is back tomorrow :)
15:44:10 <sumantrom[m]> Yes sure , awaiting :)
15:44:11 * bexelbie should be ignored for today :)
15:45:22 * adamw studiously doesn't look at the bex behind the curtain
15:46:25 <adamw> #info planned test days for F27 cycle went well, we may do another event for server/modularity once it's in testable shape
15:46:30 <adamw> #topic Open floor
15:46:37 <adamw> so, any other business?
15:47:16 <sumantrom[m]> Nothing from my end
15:47:39 <tflink> nothing here, either
15:47:58 <adamw> alright
15:49:56 <adamw> thanks for coming along, everyone
15:50:01 * adamw sets fuse
15:51:26 <adamw> #endmeeting