14:00:06 <bexelbie> #startmeeting fedora-docs
14:00:07 <zodbot> Meeting started Mon Oct 30 14:00:06 2017 UTC.  The chair is bexelbie. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:07 <zodbot> The meeting name has been set to 'fedora-docs'
14:00:22 <bexelbie> #topic roll call
14:00:24 <bexelbie> .hello bex
14:00:25 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
14:02:17 * rkratky has a conflicting mtg but will lurk around
14:02:21 <x3mboy> .hello x3mboy
14:02:22 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
14:03:05 <bexelbie> o/ rkratky x3mboy
14:03:23 <bexelbie> While we give people a few minutes, any agenda items?
14:03:25 <bexelbie> I have a few
14:03:33 <bexelbie> discuss docs.stg.fp.o as it looks now
14:03:41 <bexelbie> talk about stg -> prod automatic idea
14:03:47 <bexelbie> release notes retrospective
14:03:54 <bexelbie> docs CI
14:04:11 * jhradilek waves.
14:04:18 <bexelbie> o/ jhradilek
14:04:30 <x3mboy> o/ jhradilek
14:04:38 <x3mboy> bexelbie, nothing specific from my side
14:05:15 <bexelbie> I feel like we don't have quorum, but I am worried that we actually do
14:05:19 <bexelbie> therefore let's press forward
14:05:36 <bexelbie> #topic docs.stg.fp.o publish what is there now
14:06:35 <bexelbie> please looks at docs.stage.fedoraproject.org
14:06:53 <bexelbie> it represents the latest built source with changes suggested by rkratky and mattdm for formatting the site
14:07:03 <bexelbie> does anyone feel like pushing this to prod is a bad idea?
14:07:10 <jhradilek> "Firefox can’t find the server at docs.stage.fedoraproject.org."
14:07:32 <bexelbie> sorry
14:07:32 <mattdm> .stg.
14:07:36 <bexelbie> docs.stg.fedoraproject.org
14:07:38 <mattdm> +1 ship it :)
14:07:43 <bexelbie> I got all expansion happy
14:07:50 <jhradilek> Ah, that works. Thanks, looking.
14:08:44 <jhradilek> Looks good to me.
14:08:45 <pbokoc> looks good to me
14:08:47 <pbokoc> hehe
14:08:59 <jhradilek> pbokoc: Reading my mind again? :)
14:09:20 <bexelbie> x3mboy, rkratky ?
14:09:30 <bexelbie> I am going with "consensus" here but I want to give you all a moment
14:09:31 <rkratky> +1 to ship
14:09:34 <x3mboy> Looks perfect
14:09:35 <x3mboy> +1
14:09:36 <bexelbie> especially as rkratky is double-meeting
14:09:46 <bexelbie> #action bex to "ship it" and push stg to prod
14:09:53 <bexelbie> #topic Auto publishing to prod
14:09:56 <bexelbie> #info https://lists.fedoraproject.org/archives/list/docs@lists.fedoraproject.org/thread/QIXWG4TADGWTHS2JLYY5W5VV4MGON7PM/
14:10:20 <bexelbie> It has been proposed that we automatically push new changes to prod as there is a 60 minute update window (fixed in time) everytime we push to stg
14:10:36 <bexelbie> stg becomes our "quick final look" and we can always fix something that hits prod within 60 min
14:10:44 <bexelbie> this will speed contributors seeing their contributions live
14:10:50 <bexelbie> no one has objected in email, but discussion has been light
14:10:57 <bexelbie> any further comments before I, "make it so"
14:11:02 <bexelbie> ?
14:11:16 <x3mboy> As I comment before, I'm +1 to this
14:11:25 <randomuser> hey, sorry i'm late
14:11:25 <randomuser> bexelbie, please do - I understood automated publishing to be a goal of ours for a few years now
14:11:30 <x3mboy> It's a great idea to push that quick
14:11:34 <bexelbie> o/ randomuser
14:11:47 <bexelbie> any comments from others?
14:12:08 <jhradilek> No objections here, I agree with what randomuser said.
14:12:43 <bexelbie> ok, moving forward with consensus
14:12:44 <pbokoc> I'd prefer automatic staging but requiring manual action to publish to prod. Something simple, hit a button in an admin interface somewhere. Someone would have to build that interface and figure out permissions, though
14:12:51 <bexelbie> waiting
14:13:02 <bexelbie> pbokoc, is this a blocker for you? or just a "0"
14:13:09 <pbokoc> bexelbie, not a blocker
14:13:14 <bexelbie> as in you're willing to not block and may even be ok if we find no problems
14:13:16 <bexelbie> ok
14:13:18 <bexelbie> undrestand
14:13:25 <bexelbie> then with one "0" moving forward
14:13:44 <bexelbie> #action bex to begin pushing to prod when he stages new work manually - he is to also inform CI that we want this when it happens
14:13:48 <bexelbie> which leads too ...
14:13:54 <bexelbie> #topic Docs CI
14:13:59 <bexelbie> I have an update here
14:14:41 <bexelbie> I have a meeting tomorrow with another (world famous and totally awesome) Brian, bstinson.  We will be talking about how to enable fedmsg triggers for docs repos into the CentOS CI build system.  We will also be talking about how to store hte GPG key for push authority
14:14:49 <bexelbie> this should get us 10-20% of the way to docs CI
14:15:09 <randomuser> good news!
14:15:14 <bexelbie> I also have likely access to Nigel Babu who has done similar work for Gluster so my hope is to have a rudimentary build job in place RSN
14:15:37 <bexelbie> The execution code will remain in our repos so we can collaborate on it and make it much better
14:15:49 <bexelbie> but I'd like to get the 0.1 release out ASAP
14:16:10 <bexelbie> does anyone want to work on this at this stage? does anyone want to take this task over?
14:16:52 <randomuser> you have the contacts and meetings, bexelbie, might be best for you to run with it for now
14:17:12 <bexelbie> I figured that ... I was hoping people would be excited to help make the script less ... bexy :P
14:17:21 <bexelbie> but let's get the first version out
14:17:27 <bexelbie> so this was mostly for info - unless there are questions
14:17:47 <bexelbie> ok, moving on
14:17:52 <bexelbie> we have some open administrative issues
14:17:58 <bexelbie> #topic Mindshare Representative
14:18:06 <bexelbie> #link https://lists.fedoraproject.org/archives/list/docs@lists.fedoraproject.org/thread/C7TTBKRNCJ3W5UCGYPQA6V5JCXXMDJKS/
14:18:27 <bexelbie> Docs is part of the Mindshare work being done to increase communication amongst user facing groups
14:18:35 <bexelbie> We get an appointed representative to the committee
14:18:41 <bexelbie> there are also two at large seats that are elected
14:18:55 <bexelbie> I am a named member of the committee because I also serve as FCAIC
14:19:06 <bexelbie> It'd be great if we could find someone who has the bandwidth to participate in our group
14:19:12 <randomuser> oh wow, I completely missed this Mindshare Committee
14:19:14 <bexelbie> if we don't I will advocate on behalf of docs as much as I can
14:19:30 <bexelbie> Mindshare is what FOSCo became when it couldn't become...
14:19:44 <x3mboy> How much time we can wait for this?
14:19:50 <bexelbie> robyduck, is trying to bring conversation and unity of action (but not dictated action) to our groups
14:20:03 <bexelbie> We need to have a rep selected by the time the next election cycle FINISHES
14:20:13 <x3mboy> I want to wait until mktg discussion before deciding any team to represent
14:20:21 <x3mboy> But I'd love to be part of it
14:20:47 <randomuser> i think it's interesting, but I've been trying to spend my docs cycles working towards actually writing docs and I don't think I have enough time for both
14:20:48 <bexelbie> the only other deadline is this
14:21:12 <bexelbie> if we are not going to send a rep, we need to let robyduck know as it may affect the number of elected seats (those range from 2-3 to keep hte group odd-numbered)
14:21:50 <randomuser> can we voluntell pbokoc to do it?
14:22:00 <bexelbie> I am not hearing anyone step up immediately, let's keep this open, but I suggest we let robyduck know something by November 5 so he can let jkurik know about elections
14:22:03 * bexelbie looks to pbokoc
14:22:28 <pbokoc> absolutely not
14:22:39 <pbokoc> fight me :)
14:22:45 <randomuser> heh
14:22:54 <bexelbie> on that note .. I think we can move on :)
14:23:01 <bexelbie> #topic F27 release process
14:23:04 <bexelbie> #link https://lists.fedoraproject.org/archives/list/docs@lists.fedoraproject.org/thread/WRYEGC26DV75CLENOCJO6C7KZIIXZAHJ/
14:23:15 <bexelbie> I've started an issue https://pagure.io/fedora-docs/docs-fp-o/issue/38
14:23:16 <bexelbie> #link https://pagure.io/fedora-docs/docs-fp-o/issue/38
14:23:43 <bexelbie> to try to build up our release process.  We winged it with F26 and I think with F27 we should try to get it better documented with the new system
14:23:50 <bexelbie> and any packages that need to be built, etc
14:23:57 <bexelbie> I am open to other ideas for fixing this up
14:24:04 <randomuser> i will take that issue, bexelbie
14:24:08 <bexelbie> +1
14:24:21 <randomuser> and also build a release notes package, if that still needs doing
14:24:22 <bexelbie> I would like to see this documented in pagure in our build repo, if we are cool with that
14:24:22 <x3mboy> +1
14:24:28 <x3mboy> .thanks randomuser
14:24:32 <x3mboy> .thank randomuser
14:24:32 <zodbot> x3mboy thinks randomuser is awesome and is happy they are helping! (Please don't forget to randomuser++ also)
14:24:36 <bexelbie> ultimately I think we should put it in a published repo with our "how to contribute" docs
14:24:49 <randomuser> agreed
14:25:05 <bexelbie> #action randomuser to help rebuild hte F27 release process https://pagure.io/fedora-docs/docs-fp-o/issue/38
14:25:11 <bexelbie> let me know how I can help you with information
14:25:14 <bexelbie> on what I know
14:25:30 <bexelbie> #topic Release Notes Retrospective
14:25:47 <bexelbie> For two releases now we have created issues in pagure and tagged Change contributors to try to build release notes
14:26:03 <bexelbie> I think we should have a retrospective meeting of release notes writers to find out what works and doesn't in this process
14:26:06 <bexelbie> wdyt?
14:26:31 <pbokoc> we could really use a way to automate creating those issues
14:26:34 <x3mboy> I think a meeting will be good
14:26:35 <randomuser> i think the process could benefit from evaluation, definitely
14:26:50 <pbokoc> oh, sorry, I thought you meant to do the retrospective now :)
14:26:54 <bexelbie> Does someone want to take ownership of scheduling the meeting and/or soliciting feedback?
14:27:05 <bexelbie> I wasn't going to suggest doing the retro now :)
14:27:10 <randomuser> automating issues, or generally helping the release wrangler create changes in an automated way that includes docs pagure issues, would be good
14:27:40 <bexelbie> exactly, I've mentioned what randomuser said to jkurik and it isn't necessarily out of scope
14:27:44 <randomuser> I'd also like to get more developer involvement, it feels like we finish with the release notes just in time to start on them for the next release
14:28:42 <bexelbie> randomuser, is this something you have time to own?
14:28:48 <pbokoc> that was just this one release since it follows the previous one much closer than usual
14:28:51 <randomuser> hrmm... yeah, I can start this process
14:29:04 <bexelbie> #action randomuser to schedule/figure out a release notes retrospective
14:29:26 <bexelbie> I have no other direct topics
14:29:27 <pbokoc> also, do we need to have a meeting? I feel like these things can just as well be done over mail, or in an etherpad, without requiring a bunch of people to be present at the same time. That way you don't have to bother with timezones
14:29:41 <bexelbie> +1 to not requiring a meeting
14:29:55 <bexelbie> but I think we have to actively solicit feedback if there isn't a meeting
14:30:00 <randomuser> pbokoc, we (like you and I and others here) might arrange a time for an IRC gripe session and take action items from it
14:30:00 <bexelbie> otherwise people forget
14:30:20 <pbokoc> true
14:30:51 <bexelbie> ok to move forward?
14:30:58 <bexelbie> well, it's just
14:31:00 <bexelbie> #topic open floor
14:31:23 <bexelbie> It'd be cool if some of hte ideas in https://lists.fedoraproject.org/archives/list/docs@lists.fedoraproject.org/thread/NERSM4D7LTRGJ4NDOXS4DBBPFU6P5OPI/ got rounded up (the next button discussion) and made into pagure issues
14:31:24 <bexelbie> #link https://lists.fedoraproject.org/archives/list/docs@lists.fedoraproject.org/thread/NERSM4D7LTRGJ4NDOXS4DBBPFU6P5OPI/
14:31:28 <bexelbie> any other open floor?
14:31:35 <bexelbie> or discussion continuation?
14:32:35 <randomuser> Petr said everything I would in the next button thread
14:33:04 <bexelbie> Should we put together a hackfest/fad to actually try to bang out tools like that?
14:33:09 <bexelbie> or to improve our publishing
14:33:17 <bexelbie> the council would be amenable, I believe
14:33:38 <x3mboy> !
14:33:45 <bexelbie> x3mboy, go for it
14:33:57 <randomuser> IMO if the council has money they want to spend on feature development, give it to devs
14:34:12 <bexelbie> randomuser, what do you mean?
14:34:32 <randomuser> technical writers are not inherently qualified developers because they are in a room together, it feels like we've tried that
14:34:41 <bexelbie> randomuser, ahh
14:34:43 <x3mboy> Sorry, I was looking the stg and the subprojects part is empty, Can I push this documentation to stg or should I wait until it gets into prod?
14:34:56 <bexelbie> I was wondering if we could get some devs there to take feature needs and turn them into code
14:34:58 <bexelbie> not just wour writers
14:35:29 <shaunm> you can throw some tooling problems at me
14:35:33 <bexelbie> x3mboy, once your PR to the repo is accepted, I can rebuild it
14:35:50 <pbokoc> yeah, I'm not a huge fan of FADs and hackfests as in "sitting down and trying to bang out something", it's not how I work. It might be helpful for others but I prefer to work at my own pace (and also with multiple displays :)
14:36:35 <x3mboy> bexelbie, ok
14:36:36 <bexelbie> sounds like, in general then, we don't want to meet to do this work, but are people willing ot define it well enough that people like shaunm (or an asciibinder hackfest that might happen) could implement?
14:36:39 <randomuser> i think they are useful for planning and requirements gathering and such
14:37:17 <randomuser> but yeah, should be just as feasible without the expense
14:38:19 <bexelbie> the one thing that a hackfest/fad can do is force time on people's calendars
14:38:30 <bexelbie> in a sense the money buys time which gets us hte output
14:38:37 * randomuser nods
14:39:20 <randomuser> presuming the people involved have the relevant skillset.
14:39:37 <bexelbie> that is a key - I thikn we can identify who can come and offer the needs brainstorming
14:39:54 <randomuser> there are lots of NTH features but a FAD won't make me a ruby developer
14:40:05 <bexelbie> and I am hoping we can get the devs who can short-commit to implementation or people like shaunm who can long-commit
14:40:19 <randomuser> Personally, i want to focus on content for a bit
14:40:24 <bexelbie> agreed, but I am not sure we have the NTH in a state that an interested ruby dev could implement
14:40:33 <bexelbie> I am a huge +1 to content focus
14:40:38 <randomuser> we can't have everyone hacking on platform tools to keep republishing unmaintained docs
14:41:51 * bexelbie will brb
14:42:29 <randomuser> no objections to anyone that wants to work on tools, but i'll be spending my time on mostly content
14:42:54 <randomuser> for example, I heard Fedora has a 'cloud' version now, maybe we could document that
14:43:02 * bexelbie is back
14:43:40 <bexelbie> on a content note, I'd like us to think about splitting installation guidance into separate content for each edition instead of trying to do it all in one document
14:43:54 <bexelbie> and yes, that means we need reuse
14:43:56 <bexelbie> :)
14:45:28 <x3mboy> I think the idea of atomic docs, like we talk at FAD Latam it's still the best approach we should get, and that include installation
14:46:05 <x3mboy> For e.g. a doc with partioning with blivet-gui
14:46:38 <randomuser> let's start filing issues on pagure for topics that should be broken out
14:49:21 <bexelbie> +1
14:49:34 <bexelbie> BTW - we should also try to mark some easyfix if we can
14:49:41 <bexelbie> to get some level of visibility, imho
14:50:43 <bexelbie> other conversatoin for today, or shall I close
14:50:53 <bexelbie> #chair randomuser x3mboy jhradilek pbokoc rkratky shaunm
14:50:53 <zodbot> Current chairs: bexelbie jhradilek pbokoc randomuser rkratky shaunm x3mboy
14:50:56 <bexelbie> did I miss anyone?
14:51:00 * bexelbie fell behind on that
14:51:37 <x3mboy> EOF for me
14:52:05 <randomuser> i'm good, thanks for running the meeting, bexelbie
14:52:18 <pbokoc> +1
14:53:34 <bexelbie> thank you all
14:53:37 <bexelbie> closing in 5
14:53:56 <bexelbie> 4
14:54:01 <bexelbie> pi
14:54:09 <bexelbie> e
14:54:16 <bexelbie> 1
14:54:21 <bexelbie> 0
14:54:25 <bexelbie> i
14:54:27 <bexelbie> #endmeeting