15:35:09 <Rhea> #startmeeting Fedora DotNet (2018-02-15)
15:35:09 <zodbot> Meeting started Thu Feb 15 15:35:09 2018 UTC.  The chair is Rhea. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:35:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:35:09 <zodbot> The meeting name has been set to 'fedora_dotnet_(2018-02-15)'
15:35:15 <aslice> howdy
15:35:16 <Rhea> #meetingname dotnet
15:35:16 <zodbot> The meeting name has been set to 'dotnet'
15:35:19 <Rhea> #nick dotnet
15:35:25 <Rhea> #topic Agenda
15:35:27 <Rhea> #info (1) Roll Call
15:35:30 <Rhea> #info (2) Announcements
15:35:35 <Rhea> #info (3) Action items and Tickets
15:35:37 <Rhea> #info (4) Packaging progress / Open Floor discussion
15:35:43 <Rhea> #topic Roll Call
15:35:53 <Rhea> #action dotnet New members, make sure you introduce yourself on the DotNet mailing list [ https://fedoraproject.org/wiki/SIGs/DotNet ]
15:35:56 <Rhea> If this is your first time at a DotNet meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
15:36:02 <Rhea> #topic Announcements
15:36:16 <Rhea> Anyone got 2.1 roadmap link handily available?
15:36:24 <ymdatta> hello everyone, i am ymdatta
15:36:30 <ymdatta> :)
15:36:39 <Rhea> Oh I skipped roll call.. whatever :p
15:36:46 <omajid> https://blogs.msdn.microsoft.com/dotnet/2018/02/02/net-core-2-1-roadmap/
15:36:47 <Rhea> Welcom ymdatta
15:36:59 <aslice> Hello ymdatta!
15:37:00 <Rhea> ymdatta is a GSOC project applicant if that's the right word eh
15:37:11 <Rhea> Thanks omajid
15:37:16 <pcreech> \o ymdatta
15:37:23 <Rhea> #undo
15:37:23 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x4fad40d0>
15:37:26 <Rhea> #info === 2.1 Roadmap ===
15:37:33 <Rhea> #link https://blogs.msdn.microsoft.com/dotnet/2018/02/02/net-core-2-1-roadmap/
15:37:56 <Rhea> #chair omajid aslice axels pcreech
15:37:56 <zodbot> Current chairs: Rhea aslice axels omajid pcreech
15:37:59 <tmds> I/O all
15:38:02 <Rhea> #chair tmds
15:38:02 <zodbot> Current chairs: Rhea aslice axels omajid pcreech tmds
15:38:11 <omajid> hello ymdatta!
15:38:27 <ymdatta> hi omajid and pcreech :)
15:38:38 <Rhea> There was JB post about profiling on a server, I'm not sure if it includes linux or is only about winblows servers tho...
15:38:43 <Rhea> Anyone read https://blog.jetbrains.com/dotnet/2018/02/13/profiling-app-server-options/ ?
15:38:54 <tmds> I haven't
15:39:35 <Rhea> I wonder if there is linux agent, to remotely profile from windows workstation
15:41:40 <tmds_> got disconnected
15:41:59 * x3mboy is lurking
15:42:00 <omajid> "currently working on adding the Mono + Linux support"
15:42:36 <Rhea> hmmm would be nice, but mono?
15:43:08 <Rhea> #topic Action items and Tickets
15:43:15 <Rhea> Pagure seems to work as well as ever.
15:43:21 <omajid> hahaha
15:43:46 <Rhea> Well, who remembers what was in it... I know that we had the dnf install dotnet hacked by omajid++
15:43:56 <Rhea> Any news on the actual fix?
15:44:16 <Rhea> How's the clang thing going?
15:44:17 <omajid> Rhea: i think it's a fundamental issue in copr. i hope it wont happen in fedora proper
15:44:31 <omajid> clang issue was fixed too. that's how i could build the 'install dotnet' hack :)
15:44:38 <Rhea> Yup
15:44:57 <Rhea> So if pagure opens the ticket, we can close https://pagure.io/fedora-dotnet/issue/35 ?
15:45:05 <Rhea> the clang one
15:45:24 <omajid> sorry about that. i will close it.
15:45:33 <Rhea> And the "Create a dotnet-sdk meta package" https://pagure.io/fedora-dotnet/issue/31
15:45:54 <Rhea> I assume that's just different name and we decided to go with just `dotnet` instead
15:46:02 <omajid> i think we should wait for upstream conversations that tmds kicked off before changing packages around a bit
15:46:37 <Rhea> This was, i think, only about the `dnf install dotnet` basically
15:46:47 <omajid> for some context, there's a few proposals going around that are about changing how packages work (how they are named, upgrade, install, version bump)
15:46:53 <omajid> oh. i can close it, in that case.
15:47:03 <Rhea> It's like i'm 20 seconds ahead of pagure x_X
15:47:18 <Rhea> OH OH
15:49:10 <aslice> oh oh?
15:49:17 <Rhea> check out https://cloud.rhea-ayase.eu/s/j2XKAHX7pLJ51Gy
15:49:22 <Rhea> and https://cloud.rhea-ayase.eu/s/ahK8pMnL7T0jZBN
15:49:37 <Rhea> it's not live yet but that's the css I was working on for the IDE's table
15:50:10 <aslice> Oh, nice!
15:50:20 <Rhea> The current table is quite... bad...
15:50:30 <Rhea> https://developer.fedoraproject.org/tech/languages/csharp/csharp-ide.html
15:50:30 <aslice> Definitely an upgrade to what was there before.
15:50:35 <omajid> that's a nice table!
15:50:54 <tmds_> c# plugin for vscode has non MIT stuff
15:51:06 <DiscordBridge> <Axel> ^
15:51:18 <DiscordBridge> <Axel> The C# plugin is proprietary as far as I know
15:51:23 <Rhea> reaaaaally
15:51:25 <tmds_> I wonder, does monodevelop has its own .NET Core debugger, or does it violate the MS license
15:51:39 <Rhea> (╯°□°)╯︵ ┻━┻
15:52:05 <Rhea> monodevelop doesnt support netcore at all as far as i know
15:52:16 <tmds_> ah ok, it's C# IDE
15:52:17 <Rhea> jetbrains have their own debugger
15:52:45 <Rhea> Do we need to point that out in the page about the plugin?
15:53:19 <DiscordBridge> <Axel> I think we should
15:53:28 <ymdatta> yeah, i think we should
15:53:33 <DiscordBridge> <Axel> Full disclosure and stuff
15:54:59 * Rhea begs pagure to not fail to update the ticket
15:56:00 <Rhea> #info === Move the SIG wiki page to the new docs ===
15:56:14 <Rhea> #link https://pagure.io/fedora-dotnet/issue/38
15:56:41 <Rhea> We will need a repo for this, or a branch or whatever... It should be pagure, not github.
15:57:09 <Rhea> Do we want to create it as dotnetsig project / docs page repo, away from the current `fedora-dotnet`?
15:57:17 <Rhea> Hmm.
15:57:19 * bt0 wants to help with this
15:57:39 * amitosh late to the meeting because the debugger was behaving weirdly
15:57:46 <Rhea> bt0: Yup and you can jump on it as soon as we know what are we doing haha :)
15:57:52 <Rhea> amitosh: best excuse ever
15:57:57 <Rhea> :D
15:58:13 <Rhea> omajid: was todays dotnet meeting canceled or im confusing...
15:58:22 <Rhea> omajid: that was java canceled i think
15:58:53 <omajid> today's meeting it still on, i think
15:59:03 <Rhea> bt0 do you know the structure of our new docs and stuff?
16:00:18 <ymdatta> just checked, c# extension is proprietary
16:00:50 <Rhea> I'll work on updating the page again then to add a mention about that as well :<
16:01:45 <Rhea> And we've got other meetings now so we will have to cut this one short >_<
16:02:00 <Rhea> bt0: I'll talk to you about the docs in a bit, if I can make it before dinner...
16:02:12 * omajid has to step away too
16:02:28 <Rhea> Moving back to #fedora-dotnet to continue there then... at slower pace
16:02:31 <Rhea> #endmeeting