16:00:34 <adamw> #startmeeting Fedora QA meeting
16:00:34 <zodbot> Meeting started Mon Feb 19 16:00:34 2018 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:34 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
16:00:40 <adamw> #meetingname fedora-qa
16:00:40 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:45 <adamw> #topic Roll Call
16:00:51 * sumantro is here
16:01:00 <adamw> ahoyhoy folks, who's around for happy fun qa meeting time?
16:01:20 * sumantro waves at adamw :D
16:02:06 <adamw> hi sumantro
16:02:49 <sumantro> hi adamw , how are you? :)
16:02:56 <adamw> good good thanks
16:03:04 <adamw> frantisekz: morning
16:03:16 <frantisekz> .hello2
16:03:17 <zodbot> frantisekz: frantisekz 'FrantiĊĦek Zatloukal' <fzatlouk@redhat.com>
16:03:21 <frantisekz> Hey :)
16:03:28 <sumantro> frantisekz, hey :)
16:04:18 * kparal is here
16:05:02 <adamw> joining us from the birch meeting room, kparal? ;)
16:05:18 <sumantro> hi kparal!
16:06:28 <tflink> .hello2
16:06:29 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
16:07:16 <kparal> adamw: I deny everything
16:08:21 <adamw> always a solid policy
16:11:19 <adamw> alrgithy
16:11:25 <adamw> i guess that's everyone, and also i can't speel
16:11:30 <adamw> #topic Previous meeting follow-up
16:12:23 <adamw> #info "sumantro to file ticket(s) for progress on doc migration work" - that got done, and the tickets are being updated, thanks sumantro!
16:12:39 <sumantro> np adamw  :)
16:13:42 <adamw> #link https://pagure.io/fedora-qa/issue/529
16:13:59 <adamw> so, the other one: "adamw tflink kparal to work on resolving abicheck issues and work with factory 2.0 folks on 'lack of expected tests' issue"
16:14:17 <adamw> i know there's been some work on narrowing the abicheck test's focus
16:14:23 <adamw> what all else is going on, tflink, kparal?
16:14:24 <kparal> dodji is working on implementing a fix for abicheck
16:15:04 <kparal> #link https://pagure.io/task-abicheck/issue/8
16:15:25 <adamw> oh right, chairs
16:15:27 <adamw> #chair kparal tflink
16:15:27 <zodbot> Current chairs: adamw kparal tflink
16:15:42 <kparal> #link https://pagure.io/task-abicheck/issue/8
16:15:55 <kparal> not sure about the second part of that action item
16:16:09 <kparal> was there some ticket for it?
16:16:32 <adamw> which action item?
16:17:07 <kparal> " work with factory 2.0 folks on 'lack of expected tests' issue"
16:18:35 <tflink> no specific work that I know of on our end
16:19:41 <adamw> ah right
16:19:54 <adamw> well, i believe that was meant to cover 'make sure the darn tests get run'
16:19:54 * Southern_Gentlem 
16:19:57 <adamw> have we got anywhere with that?
16:20:00 <adamw> hiya southern_gentlem
16:20:16 <tflink> not that I'm aware of, no
16:20:57 <kparal> I don't know about anything
16:21:43 <tflink> there was talk about writing a "look for missing results once a day" task but I don't think anyone has worked on it
16:22:37 <adamw> alright. is there at least a ticket for it yet?
16:22:52 <tflink> if there isn't there probably should be
16:22:54 * tflink looks
16:23:24 <kparal> I don't think so
16:23:53 <kparal> it's a pretty difficult thing to do, just saying
16:23:55 <tflink> yeah, I don't see one
16:24:03 * tflink files one
16:25:58 <adamw> #info "adamw tflink kparal to work on resolving abicheck issues and work with factory 2.0 folks on 'lack of expected tests' issue" - task-abicheck is being refined by dodji (see ticket link above). we have not yet started working on fixing test triggering issues, ticket is now filed
16:26:30 <adamw> anything else followup-y?
16:26:41 <tflink> https://pagure.io/taskotron/issue/253
16:28:13 <adamw> thanks tflink
16:28:19 <adamw> #topic Fedora 28 status and branching
16:29:26 <adamw> so, we had kind of a rough ride with the mass rebuild, gcc 8 and the inadvertent libevent soname bump, but we're somewhere close to being back on track now
16:29:52 <adamw> rawhide is at least composing again, and not entirely broken. branch point is set for this week
16:30:04 <adamw> dgilmore: i believe we're still on track for the set date?
16:30:30 <dgilmore> adamw: I am on PTO and not working today, but yes, branching is on track for tomorrow
16:31:18 <dgilmore> adamw: aarhc64 promotion has been mostly done also
16:31:54 <adamw> okay. i still don't have the aarch64 machines for openqa, though.
16:32:05 <dgilmore> adamw: well the delivery portion is done
16:32:24 <adamw> #info F28 branch point is set for tomorrow, 2018-02-20
16:32:25 <dgilmore> we should follow up with pwhalen pbrobinson and infra on the openqa side
16:32:29 <adamw> yeah.
16:32:40 <adamw> #action adamw to kick things again re aarch64 openQA workers
16:33:39 <pbrobinson> dgilmore: pwhalen is on PTO today (some bank holiday), I've got tomorrow afternoon scheduled to work on this with pwhalen
16:34:45 <dgilmore> pbrobinson: excellent
16:35:59 <adamw> also note that a change has landed to Workstation which is intended to reduce duplication between anaconda and gnome-initial-setup
16:36:12 <adamw> basically, chunks of anaconda won't be visible when installing from workstation lives
16:36:22 <adamw> so, be prepared for that
16:36:34 <sumantro> adamw, roger
16:36:44 <adamw> i'll be fixing openqa around it
16:38:14 <adamw> any other notes/thoughts on f28 status?
16:38:36 <adamw> #info Rawhide is now through the mass rebuild, gcc 8, pykickstart and libevent fun times and at least composing again
16:39:11 <adamw> #info Workstation change https://fedoraproject.org/wiki/Changes/ReduceInitialSetupRedundancy has landed, be aware of changed behaviour in Workstation live installs
16:41:26 <adamw> #topic TCMSes again
16:41:53 <adamw> so, this is just a quick note that we're thinking yet again about whether and how to replace wikitcms
16:42:37 <adamw> relval-ng is still an option, but tflink noted that nitrate (the system rh wrote for internal use) is alive again upstream, and there's also now a sort of competing fork of it:
16:42:45 <adamw> https://github.com/Nitrate/Nitrate
16:42:53 <adamw> http://kiwitcms.org/
16:43:03 <adamw> so, we have both of those options to look at as well.
16:43:26 <adamw> both the authors would allegedly be keen to work with us.
16:43:50 <adamw> on the other hand, moztrap appears to be pretty dead now, so that's out of the race for now
16:44:08 <Southern_Gentlem> TCMS?
16:44:29 <adamw> test case management system
16:44:32 <Southern_Gentlem> ok
16:44:45 <adamw> basically, 'how we store and access and analyze test cases and test results'
16:45:16 <adamw> Wikitcms is the name i use to describe the current 'system' whereby we store them in the wiki, see https://fedoraproject.org/wiki/Wikitcms .
16:46:20 <adamw> so, we don't have any specific plans yet, but just wanted to air it out, and note that it's a live topic if anyone wants to pick it up and take a deeper look at nitrate and/or kiwi (or tflink, were you volunteering?)
16:46:59 <adamw> #info Wikitcms replacement is still a live goal, news here is that Moztrap seems to be dead now, but Nitrate and a competing fork called Kiwi are both now alive, see links above
16:47:03 <tflink> I'm willing to do it but it might take me a while with the other stuff I'm supposed to be doing
16:47:14 <adamw> #info relval-ng (that is, writing our own new system) is still also an option, we still have the designs from design team
16:47:18 <adamw> roger
16:47:59 <adamw> ok, moving along...
16:48:08 <adamw> #topic Available tickets
16:48:33 <adamw> so here I just wanted to flag up that there are several fairly small tasks open in our task tracker: https://pagure.io/fedora-qa/issues
16:49:03 <adamw> i've tagged just one with an 'easyfix' tag, i'll go through and tag a few more in a minute
16:50:06 <kparal> are we integrated into https://fedoraproject.org/easyfix/ ?
16:50:23 <adamw> ooo, good idea. i don't think so, but we should be!
16:50:52 <adamw> so, anyway, there are a few 'write a test case' tickets and the like there which could be knocked out in a day or two
16:50:59 <adamw> if someone's looking for a nice achievable goal with an end point
16:51:40 <adamw> #info there are a few relatively simple tasks open at https://pagure.io/fedora-qa/issues - please consider picking one up if you have a bit of time and would like a nice achievable task with a clear end point
16:53:56 <adamw> #topic Open floor
16:54:06 <adamw> OK then, that's teh agenda...any other thoughts / notes / topics / questions?
16:54:16 <kparal> nothing from me
16:54:20 <adamw> note I forgot to send out a cancellation mail, but there's no blocker review meeting today, there are no blockers to review
16:55:34 <kparal> \o/
16:56:12 <adamw> you can move on to another^H^H^H^H^H^H^Hthe bar now, kparal
16:57:28 <kparal> almost there!
16:59:41 <adamw> welp, sounds like that's all
16:59:44 <adamw> thanks for coming out, folks!
16:59:46 * adamw sets the fuse
17:00:39 * tflink runs
17:00:51 * adamw sets the fuse to tflink homing mode
17:01:26 * tflink quickly makes a roadrunner-esque arrow sign saying "go that way" (towards adamw)
17:02:39 * adamw wears an 'i'm with stupid' tshirt (pointing at tflink)
17:02:47 <adamw> alrighty, folks, thanks for coming :P
17:02:57 <adamw> #endmeeting