15:29:20 <Rhea> #startmeeting Fedora DotNet (2018-03-08)
15:29:20 <zodbot> Meeting started Thu Mar 8 15:29:20 2018 UTC. The chair is Rhea. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:29:20 <zodbot> The meeting name has been set to 'fedora_dotnet_(2018-03-08)'
15:29:24 <Rhea> #meetingname dotnet
15:29:24 <zodbot> The meeting name has been set to 'dotnet'
15:29:27 <Rhea> #nick dotnet
15:29:30 <Rhea> #topic Agenda
15:29:33 <Rhea> #info (1) Roll Call
15:29:36 <Rhea> #info (2) Announcements
15:29:40 <Rhea> #info (3) Action items and Tickets
15:29:46 <Rhea> #topic Roll Call
15:29:56 <Rhea> If this is your first time at a DotNet meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
15:29:58 <Rhea> 1
15:30:03 <Rhea> #action dotnet New members, make sure you introduce yourself on the DotNet mailing list [ https://fedoraproject.org/wiki/SIGs/DotNet ]
15:30:04 <Rhea> :D
15:30:09 <Rhea> that random one is awesome
15:30:10 <Rhea> Hi everyone
15:30:50 <aslice> Howdy
15:31:15 <amitosh> .hellomynameis
15:31:15 <zodbot> amitosh: (hellomynameis <username>) -- Return brief information about a Fedora Account System username. Useful for things like meeting roll call and calling attention to yourself.
15:31:38 <Rhea> #chair aslice bt0 amitosh
15:31:38 <zodbot> Current chairs: Rhea amitosh aslice bt0
15:31:39 <aslice> .hellomynameis amitosh
15:31:39 <zodbot> aslice: amitosh 'Amitosh Swain Mahapatra' <amitosh.swain@gmail.com>
15:31:57 <Rhea> @Axel you awake?
15:33:05 <Rhea> #chair tmds
15:33:05 <zodbot> Current chairs: Rhea amitosh aslice bt0 tmds
15:33:12 <tmds> .hello tmds
15:33:13 <zodbot> tmds: tmds 'Tom Deseyn' <tom.deseyn@gmail.com>
15:36:03 <Rhea> #topic Announcements
15:36:16 <Rhea> #info === Announcing .NET Core 2.1 Preview 1 ===
15:36:20 <Rhea> #link https://blogs.msdn.microsoft.com/dotnet/2018/02/27/announcing-net-core-2-1-preview-1/
15:36:29 <Rhea> #link https://blogs.msdn.microsoft.com/dotnet/2018/02/27/announcing-entity-framework-core-2-1-preview-1/
15:37:01 <Rhea> #chair omajid
15:37:01 <zodbot> Current chairs: Rhea amitosh aslice bt0 omajid tmds
15:37:16 <Rhea> What would you guys like to talk about today :]
15:37:20 <Rhea> Got anything to mention?
15:37:34 <Rhea> #topic Open Floor discussion
15:37:34 <tmds> nothing really
15:38:22 <amitosh> New LINQ queries are good
15:38:26 <Rhea> I was poking JetBrains to give us a bunch of licenses for dotnet enablement on Fedora, and they did, you probably received an email with it by now
15:38:51 <tmds> I had one already, but I did get an email
15:39:01 <omajid> can't say i am terribly excited for more proprietary software :)
15:39:08 <Rhea> #info JetBrains gave us a bunch of Rider standalone licenses for dotnet enablement.
15:39:08 <tmds> now I have two licenses I'm not using
15:39:22 <Rhea> Yeah, proprietary, and still the best for large projects :P
15:39:31 <Rhea> (on linux)
15:40:00 <aslice> For some definitions of 'best', yes.
15:41:06 <Rhea> Well aside from the code editing itself I value *the rest* of the IDE features, I quite like the debugger as opposed to... the only other option. I like the that it has package manager, unlike other "text editors with language plugin"
15:41:21 <Rhea> And well frankly i like that it doesn't need plugins :D
15:41:34 <amitosh> And identifier renaming that works
15:42:01 <Rhea> Using the same IDE and configuration on my desktop (windows) is a plus as well, like last night when I leave my laptop in the office
15:42:36 <Rhea> Wish any of the open source IDEs were anywhere near this experience...
15:42:38 <Rhea> :<
15:42:43 <aslice> Oh sure, I would say it is most likely the most feature complete IDE, I don't think any of us are arguing that. But not everyone judges based on that standard (just most people). :)
15:43:38 <tmds> does it use tabs or spaces by default :P ;)
15:43:59 <Rhea> Spaces i think? I don't know, I change it to tabs.
15:44:22 <Rhea> I was using monodevelop for a decade or something stupid, and rider is close to it with its interface, closer than anything else... o.o
15:44:27 <Rhea> So it feels friendly for me
15:44:28 <aslice> I'm going to have to put up a code project at some point that uses unicode emdashes for spacing...
15:44:41 <Rhea> o.o
15:45:06 <Rhea> aslice: why aren't you quality engineer? You really like breaking things... (zodbot the other day too)
15:45:08 <Rhea> :D
15:45:43 <aslice> I just think that the holy way could use some spicing up. We all know the memes by now.
15:45:49 <omajid> i will let the data speak for itself: https://stackoverflow.blog/2017/06/15/developers-use-spaces-make-money-use-tabs/
15:45:53 <omajid> :P
15:46:11 <Rhea> I don't need more money, I'm happy where I am ;p
15:46:17 <Rhea> I use spaces for everything except C#
15:46:23 <tmds> in other news, I got a commit hash that starts with 'bad' today
15:46:25 <Rhea> C# is kinda legacy tab thing for me
15:46:41 <aslice> omajid: Since when has consensus for sure determined quality? Should we rewrite kernels in JS because it is the most studied language?
15:46:59 <aslice> tmds: It's an omen.
15:47:21 <Rhea> :D
15:47:27 <tmds> aslice, next on my list is one that starts with 'deadbeef' ... but might be a while
15:47:37 <Rhea> :D
15:48:19 <aslice> tmds: Thank you, the deadbeef reference makes me happy.
15:49:10 <aslice> And just to throw my (most hated) opinion in there: tabs for indention, spaces for alignment.
15:49:23 <Rhea> Since bt0 doesn't seem to be around to tell us something about docs, amitosh do you know what's the status?
15:50:33 <DiscordBridge> <Axel> I'm here o/
15:50:48 <DiscordBridge> <Axel> Sorry, I'm late, was dealing with some stuff
15:50:58 <Rhea> You missed tmds' commit
15:51:05 <Rhea> It was.. bad
15:51:35 <omajid> lol
15:51:52 <Rhea> :D
15:51:55 <DiscordBridge> <Axel> Define 'bad'
15:52:04 <Rhea> Read up a few messages :D
15:52:28 <DiscordBridge> <Axel> LOL
15:52:40 <amitosh> Rhea: We completed porting all wiki pages to AsciiDoc
15:53:03 <Rhea> amitosh: how do we hook it up, is it already?
15:53:30 <amitosh> Next step was to contact with the docs council to do some checks about content organization etc
15:54:52 <Rhea> hmmm okay o.o
15:55:00 <amitosh> This would probably be another PR to another repo, or something similar.
15:55:13 <Rhea> yup
15:55:24 <Rhea> Does anyone have anything to mention?
15:55:54 <omajid> maybe a quick note here about dotnet on fedora 28 and later
15:56:30 <omajid> the ncurses project switched to a new format. that breaks all existing builds of dotnet on fedora 28 and later
15:56:54 <omajid> the fix was included into (what will become) dotnet 2.1 and also backported to 2.0
15:57:16 <omajid> actually, even going back to 1.x series
15:57:30 <omajid> so future builds will be okay, but current builds are all broken
15:57:36 <omajid> that's all.
15:58:30 <Rhea> oookay o.o
15:58:58 <Rhea> Interesting
15:59:04 <DiscordBridge> <Axel> Huh
15:59:04 <omajid> i have to run now. another meetings.
15:59:06 <Rhea> Okay thank you omajid
15:59:08 <Rhea> Yup
15:59:22 <Rhea> Seeya'll next time with some other topic of the meeting :D
15:59:29 <Rhea> #endmeeting