19:00:30 <bcotton> #startmeeting Council (2018-08-01)
19:00:30 <zodbot> Meeting started Wed Aug  1 19:00:30 2018 UTC.
19:00:30 <zodbot> This meeting is logged and archived in a public location.
19:00:30 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:30 <zodbot> The meeting name has been set to 'council_(2018-08-01)'
19:00:51 <bcotton> #meetingname council
19:00:51 <zodbot> The meeting name has been set to 'council'
19:01:04 <bcotton> #chair mattdm bcotton jwb langdon robyduck bexelbie dperpeet Amita nb dgilmore pbrobinson
19:01:04 <zodbot> Current chairs: Amita bcotton bexelbie dgilmore dperpeet jwb langdon mattdm nb pbrobinson robyduck
19:01:10 <dgilmore> hi all
19:01:13 <bexelbie> .hello bex
19:01:14 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bexelbie@redhat.com>
19:01:16 <mattdm> hi!
19:01:21 <bcotton> #topic Introductions, Welcomes
19:01:30 <jwb> hello
19:01:59 * bcotton will be careful not to mention too many nicks, as the spam prevention bot is very angry right now
19:02:04 <mattdm> brian and I are in brno. wifi is a bit laggy so I asked ben to run tis meeting
19:02:16 <mattdm> also the spam seems KINDA out of control
19:02:44 <bcotton> just a smidge
19:02:46 <mattdm> This is supposed to be the subproject report meeting -- do we have pbrobinson, dperpeet, and langdon?
19:02:47 <dgilmore> freenode is a bit crazy today
19:02:49 <langdon> .hello2
19:02:50 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
19:03:00 <pbrobinson> I am here
19:03:06 <mattdm> cool.
19:03:26 <mattdm> i don't think this time slot works for dominik :(
19:03:31 * langdon would prefer to go towards the beginning.. packing
19:03:47 <bcotton> langdon: your wish is my command
19:03:48 <pbrobinson> langdon: you think you're special in that regard ;-)
19:04:01 <langdon> ohh im "special" all right
19:04:11 <pbrobinson> LOL.... no comment :-P
19:04:23 <bcotton> #topic Fedora Modularity
19:04:34 <bcotton> the floor is yours, langdon
19:05:22 <langdon> ok.. so.. easy first.. we are considering changing the wg rules to be more like the server ones.. if you show up to the meeting(s) you can vote.. what do i need to do for "approval" for that? aside from the wg?
19:06:04 <mattdm> that's fine -- the wg can just decide that
19:06:25 <langdon> ok
19:06:26 <nb> IMPORTANT ANNOUNCEMENT!
19:06:27 <langdon> cool
19:06:29 <langdon> ok..
19:06:31 <nb> If you want to speak, you must register your nick
19:06:40 * nb thinks people may not notice the /topic
19:06:40 <langdon> and if you don
19:06:43 <langdon> 't want to?
19:06:57 <nb> langdon, don't want to register? we can remove that requirement
19:07:05 <langdon> speak :)
19:07:07 <nb> but we just added that yesterday to stop the spammers
19:07:17 <langdon> Modules for Everyone (change bz) -- https://bugzilla.redhat.com/show_bug.cgi?id=1599413 seems to be going a bit better
19:07:20 <nb> oh, if you don't want to speak you should register anyway, but that isn't a requirement :)
19:07:29 <mattdm> heh. sorry langdon, you must keep your registration :)
19:07:30 <langdon> we have some good dnf love in rawhide now..
19:07:49 <langdon> experimentation seems to be going on
19:07:50 <mattdm> I heard the phrase "fit and finish" wrt dnf and modularity
19:07:57 <langdon> yeah
19:08:03 <mattdm> can you elaborate? :)
19:08:29 <langdon> we have found one problem though which is stream expansion doesn't work properly if you mismatch buildrequires and requires.. basically, it doesn't make it through the infra correctly
19:08:54 <langdon> elaborate? fit & finish.. i think is clean up of edge cases, code, bugs etc
19:08:55 <mattdm> which confused me at first, but: this isn't _supposed_ to work, really
19:09:14 <langdon> welll.. maybe.. depends on who you ask.. but it makes sense why it was missed
19:10:15 <mattdm> I kinda think "error: buildrequires does not match requires" is a good answer there
19:10:22 <langdon> ha..
19:10:40 <langdon> yeah.. i wonder if we could get that in on f29.. cause that would be mbs
19:10:53 * langdon writes note to file bug
19:11:25 <mattdm> I looked at the feature tracking bug and there's just the two big previous issues linked to it -- where are the fit and finish issues being tracked?
19:11:51 <langdon> mattdm: ohh.. i don't know.. i hadn't heard anyone say that.. i thought that was your remark.. now i am less confused
19:12:24 <mattdm> And I am more confused :)
19:12:56 <langdon> oh... actually .. now i know what you mean.. i bet it is the ones about making the dnf command line more usable.. e.g. dropping version from the module listing
19:13:05 <langdon> ill track them down and tie them to the change
19:13:14 <mattdm> cool thanks.
19:13:32 <mattdm> so nothing release-blocking really at this point?
19:13:57 <langdon> assuming those two big tickets pass qa/release, no
19:14:14 <mattdm> cool. anything else? anything you need before flock?
19:14:19 <mattdm> anything you need *for* flock?
19:14:28 <langdon> if someone could write my talks.. that would be great
19:14:32 <langdon> but no..
19:14:54 <mattdm> ok thanks :)
19:15:16 <bcotton> #info Modules for Everyone on track for F29
19:15:33 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1599413
19:15:44 <bcotton> anything else for or from langdon before we move on?
19:15:59 <langdon> not from me
19:16:40 <bcotton> #topic Fedora IoT
19:16:44 <bcotton> pbrobinson: take it away
19:16:46 <dgilmore> langdon: anything that I can help you with?
19:16:55 <dgilmore> langdon: answer out of band
19:18:43 <mattdm> pbrobinson: still with us? :)
19:19:57 <mattdm> bots got him? :)
19:20:02 <bcotton> RIP pbrobinson
19:20:11 <bcotton> well i can say this much
19:20:40 <bcotton> #info the IoT team is working on a product requirement doc (still very draft form, should get meatier at Flock)
19:20:43 <bcotton> #link https://fedoraproject.org/wiki/InternetOfThings/PRD
19:21:16 <mattdm> awesome, thanks ben
19:21:42 <bcotton> i guess we'll move on, such as we can
19:21:48 <bcotton> #topic Fedora CI
19:21:59 <pbrobinson> sorry
19:22:03 <bcotton> #undo
19:22:03 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f56ddaa0610>
19:22:27 <pbrobinson> yes, nothing else really to note
19:22:46 <pbrobinson> working to get fedora-release-iot in place so we can start to do security policies and the like
19:22:59 <pbrobinson> lots of stuff happening at flock next week
19:23:00 <mattdm> I don't think we have dominik here for ci anyway
19:23:12 <mattdm> thanks peter for working on the fedora-release package stuff
19:23:23 * mattdm files changes, tricks peter into doing work
19:23:27 <pbrobinson> slowly starting to ramp up, the weekly meetings are getting more active which is fab
19:23:44 <pbrobinson> just never enough time
19:23:44 <bcotton> pbrobinson: anything you need or want to share about the flock activities?
19:24:03 <pbrobinson> so for flock I have my Objectives talk slot
19:24:23 <mattdm> that's the first-day plenary session
19:24:29 <mattdm> 15-20 minutes
19:24:30 <langdon> can we #info that probinson just said "fab"?
19:24:34 <pbrobinson> we have a BoF which I'm looking forward to an actively community discussion on direction etc
19:24:45 <dgilmore> #info pbrobinson said fab
19:24:50 <mattdm> lol
19:24:52 <pbrobinson> ideas, what people want, what people can contribute etc
19:24:57 <bexelbie> he said bof too :P
19:25:05 <langdon> Umm what... objective talk slot?
19:25:17 <dgilmore> the council talk
19:25:22 <mattdm> langdon: the one you are also on the hook for one of? :)
19:25:27 <pbrobinson> langdon: we were going to tell you when you were due on stage :-P
19:25:32 <bcotton> #info IoT BoF at Flock is Thurday 4:45-5:15
19:25:34 <bcotton> #link https://flock2018.sched.com/event/Fjdl/bof-iot-use-cases
19:25:39 <mattdm> I'm, like, 92% sure we talked about this :)
19:25:46 <langdon> lol.. now three talks..
19:25:55 <pbrobinson> and the hackfest which I need to do an agenda for but have lots of ideas
19:25:59 <pbrobinson> plus I'
19:26:10 <bexelbie> objective talks on the first day
19:26:22 <bexelbie> the opening session has 20 min slots for each edition and objective
19:26:27 <bexelbie> that's you all :D
19:26:27 <pbrobinson> plus I'll be co-presenting with spot on supporting the Raspberry Pi in Fedora
19:26:38 <bexelbie> I just have to say "It's Dresden, and Flock and woo!"
19:26:47 <bcotton> #info IoT Hackfest at Flock is Saturday 9-10:50a
19:26:49 <bcotton> #link https://flock2018.sched.com/event/Fje5/iot-hackfest
19:26:56 <pbrobinson> do I get 40 mins because I am an edition and an objective? :_P
19:26:59 <pbrobinson> :-P
19:27:32 <bexelbie> you're not an edition yet
19:27:33 <bexelbie> :)
19:27:42 <pbrobinson> phew!
19:28:59 <bcotton> anything else to or from pbrobinson?
19:29:16 <pbrobinson> I don't think so unless anyone has questions for me
19:29:36 <dgilmore> I have nothing for pbrobinson
19:29:49 <mattdm> I'll save them for heckling at the talks
19:29:53 <mattdm> Thanks pbrobinson
19:29:56 <pbrobinson> YASS!!!
19:30:12 <bcotton> #topic Fedora CI
19:30:25 <bcotton> since dperpeet isn't here, is anyone able to be a reasonable dperpeet approximation?
19:30:52 <mattdm> I'm afraid not. This is kind of worrisome, really.
19:31:00 <bexelbie> bstinson, ??
19:32:19 <bstinson> hi! how can i help?
19:32:55 <bexelbie> mattdm, bcotton ^^
19:33:08 <mattdm> bstinson: we're looking for an update on the state of Fedora CI
19:33:08 <dgilmore> any CI updates?
19:33:34 <mattdm> this timeslot is apparently awful for dperpeet (and it's basically nighttime, so, fair)
19:33:49 <mattdm> but it's really been a long time since we've had news
19:34:26 <dgilmore> and he will not be at flock
19:34:44 <dgilmore> mattdm: we should try get someone at flock from Fedora CI
19:34:56 <bstinson> hmmm i've been sort of focused more on infra things recently (not directly related to the Fedora Objective) during the day
19:36:00 <bcotton> i'll contact dperpeet and see if someone more timezone-adjacent can represent CI at these meetings
19:36:17 <bstinson> i'm happy to act as a go-between if needed
19:36:24 <mattdm> bcotton, bstinson thanks
19:36:53 <bstinson> i'll be speaking a bit about the Fedora CI processes (and the infra) at FLOCK too
19:37:06 <bcotton> #action bcotton to contact dperpeet and see if someone more timezone-adjacent can represent CI at these meetings
19:37:08 <mattdm> I think this timeslot isn't working out very well anyway. dgilmore, if we move it back to the us/morning slot we had before will hat work for you during the school year?
19:37:32 <dgilmore> mattdm: what was the time?
19:37:43 <mattdm> #action mattdm to also contact dperpeet to see about flock coverage
19:37:50 <mattdm> dgilmore: it was at 8am Central
19:38:21 <mattdm> that time is good for europe, and apparently also livable for india
19:38:32 <dgilmore> mattdm: I have a fortnightly meeting at 8:30
19:39:12 <mattdm> anyway, that's not necessarily to decide now
19:39:17 <dgilmore> mattdm: actually looking at the wrong day. I can make it work
19:39:38 <bcotton> mattdm: if you want, i can take finding a new time as an #action
19:39:49 <mattdm> bcotton: okay but good luck with that :)
19:39:58 * bexelbie wonders why dgilmore gets to meet in castles
19:39:59 <bexelbie> :D
19:40:03 <mattdm> there are two hard problems in computer science.....
19:40:08 <bcotton> well, let me say "attempting to" :-)
19:40:20 <bexelbie> mattdm, and off by six error
19:40:26 <Evolution> mattdm: you didn't account for daylight savings time. so there are now 6.
19:40:43 <bcotton> #action bcotton to make noble attempt at finding a new time for this meeting
19:41:10 <dgilmore> bexelbie: I meet from the basement dungeon
19:41:39 <bexelbie> castles have dungeons ... question stands
19:42:10 <mattdm> I....
19:42:15 <mattdm> so, meeting done? :)
19:42:28 <bcotton> sounds like it. last call for on-topic comments
19:42:43 <mattdm> thanks for running bcotton
19:42:48 <dgilmore> thanks bcotton
19:43:14 <bcotton> my pleasure :-)
19:43:18 * bcotton bangs gavel
19:43:21 <bcotton> #endmeeting