14:00:55 <pbrobinson> #startmeeting Fedora IoT Working Group Meeting
14:00:55 <zodbot> Meeting started Wed Oct 10 14:00:55 2018 UTC.
14:00:55 <zodbot> This meeting is logged and archived in a public location.
14:00:55 <zodbot> The chair is pbrobinson. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:55 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:00:55 <pbrobinson> #chair pwhalen pbrobinson bcotton
14:00:55 <zodbot> Current chairs: bcotton pbrobinson pwhalen
14:00:56 <pbrobinson> #topic roll call
14:01:01 <pbrobinson> who is about?
14:01:10 <bcotton> .hello2
14:01:11 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:01:14 * pwhalen is here
14:01:26 <pwhalen> good morning everyone
14:01:38 <pbrobinson> morning pwhalen
14:01:43 <lorbus> .hello2
14:01:47 <zodbot> lorbus: lorbus 'Christian Glombek' <c@petersen-glombek.de>
14:02:19 <tdawson> hello2
14:02:33 <pbrobinson> hey tdawson lorbus
14:02:41 <lorbus> o/
14:02:51 <pbrobinson> We'll give people a minute or so more to gather
14:03:05 <pbrobinson> I don't think we'll have jsmith today
14:04:56 <pbrobinson> #topic 1) ==== Working Group process and admin ====
14:05:07 <pbrobinson> so a few things today on this topic!
14:05:42 <pbrobinson> firstly thanks to bexelbie and a few others we now have a first pass at a docs site
14:05:56 <lorbus> nice
14:05:58 <pbrobinson> we'll be moving all the bits off the wiki to here
14:06:02 <pbrobinson> #link https://docs.fedoraproject.org/en-US/iot/
14:06:39 <pwhalen> awesome
14:06:46 <pbrobinson> the upstream bits are all in git so if people wish to assist they can even do pull requests
14:06:51 <pbrobinson> #link https://pagure.io/fedora-iot/iot-docs
14:07:06 <tdawson> That looks nice
14:07:25 <pbrobinson> #info IoT docs now on docs.fedoraproject.org and all wiki pages will be moved over by end of next week
14:07:55 <pbrobinson> #info if people wish to contribute PRs can be done to https://pagure.io/fedora-iot/iot-docs and I'm happy to have co-maintainers!
14:08:00 <pbrobinson> more the merrier IMO
14:08:32 <pbrobinson> Next up is a kanban board
14:08:40 <pbrobinson> #link https://tree.taiga.io/project/nullr0ute-fedora-iot/kanban
14:09:11 <pbrobinson> at the moment it's on my own account while fedora sorts out what they're going to do
14:09:45 <pbrobinson> #info I plan to put all todo items in here and tag things, add epics etc to assist in enabling more people to get involved
14:09:47 <lorbus> I was gonna ask about that. is Taiga still widely used by Fedora?
14:10:28 <pbrobinson> lorbus: well its' used, there's discussion of getting a Fedora general instance so projects can actively use it, but details are still being worked out
14:10:28 <bcotton> lorbus: not exactly, but we're working on coming up with a consolidated solution that will make it easier to be widely used
14:10:41 <pbrobinson> yes, what bcotton said
14:10:50 <tdawson> I know the fedora module group is using it.
14:11:00 <bcotton> right now we have an instance that infra hosts but doesn't really touch, plus some people use tagia dot io and there are probably a few other kanban boards scattered about
14:11:23 <lorbus> ok cool
14:12:53 <pbrobinson> anyway I've only got as far as creating the instance, I need to work out how access etc works but I plan in the next few days/weeks to put as much stuff in there as I can from my head
14:13:12 <pbrobinson> anyone who wishes to suggest process please do!
14:13:16 <lorbus> pbrobinson++
14:14:27 <pbrobinson> #info I will be moving the PRD over to docs.fp.o too
14:14:42 <pbrobinson> does anyone else have anything to bring up around the WG process etc
14:15:27 <pbrobinson> #info staging IoT Website, feedback welcome https://tree.taiga.io/project/nullr0ute-fedora-iot/kanban
14:15:32 <pbrobinson> #undo
14:15:32 <zodbot> Removing item from minutes: INFO by pbrobinson at 14:15:27 : staging IoT Website, feedback welcome https://tree.taiga.io/project/nullr0ute-fedora-iot/kanban
14:15:49 <pbrobinson> #info staging IoT Website, feedback welcome https://iot.stg.fedoraproject.org/
14:16:01 <pbrobinson> bcotton: anything else on your list?
14:16:10 * bcotton has nothin'
14:16:19 <pbrobinson> pwhalen: ^^, anyone else?
14:16:29 <pbrobinson> #topic 2) ==== Nightly builds ====
14:16:52 <pbrobinson> #link https://download.fedoraproject.org/pub/alt/iot/
14:17:17 <pbrobinson> #info nightly image generation and pushes public have been cleaned up
14:17:42 <pbrobinson> #info rawhide/f29/f28 nightly builds pushed with both pre generated images as well as installers
14:18:21 <pbrobinson> I'm much happier with this and things should be more straight forward
14:18:51 <pbrobinson> next up for the nightlies is to work out how to automate things more and start to add some level of CI/CD
14:19:08 <pbrobinson> #info next up for the nightlies is to work out how to automate things more and start to add some level of CI/CD
14:20:21 <pbrobinson> you're all very quiet, no queries around nightlies?
14:21:01 <pwhalen> looks good, easier to navigate
14:21:18 <tdawson> pbrobinson: The only question I had was, if I start using and testing them, are there any specific things you want me to test and report?
14:21:21 <pbrobinson> yes, and also much closer to mainline
14:21:49 <pbrobinson> tdawson: well to begin with feedback on the getting started guide would be very useful
14:22:05 <pbrobinson> things that need adding/updating, etc
14:23:18 <tdawson> That sounds like something I can do as I start ramping up.
14:23:28 <pbrobinson> now it's been converted over to asciidoc I'll be going through it by the end of the week to make sure it flows but as a daily user it's very easy for me to miss useful things
14:24:56 <lorbus> I'll go thru it too, hopefully this week still
14:25:00 <tdawson> I'm still used to just throwing fedora on a pi, so I'll have a fresh pair of eyes.
14:25:39 <pbrobinson> thank you both
14:25:41 <pbrobinson> #topic 3) ==== Fedora 29 status for IoT ====
14:25:58 <pbrobinson> so feedback on the website and docs is useful here
14:26:11 <pbrobinson> also testing and feed back on all bits of that
14:26:27 <pbrobinson> #info fedora 29 is in freeze for the final release
14:26:53 <pbrobinson> #info fedora 29 IoT images should now be looking close to their final bits
14:27:03 <pbrobinson> so testing and verification it useful
14:27:58 <pbrobinson> #info any issues file bugs against packages and add 'IoT' as a blocker (it's our RHBZ blocker alias) and we can review and see if we need a freeze exception for it
14:28:46 <pwhalen> I did some iso installation testing last week, found the installed system seemed to hang after starting initial-setup. I believe pbrobinson has already fixed that in this weeks composes
14:28:50 <pbrobinson> #info if you have any queries for Fedora 29 release please ask on the IoT mailing list or on #fedora-iot on freenode for assistance
14:29:07 <pbrobinson> yes, I think that's fixed
14:29:25 <pbrobinson> pwhalen: I do believe you also had an action for release criteria
14:29:43 <pwhalen> either way, I dont think we want initial-setup on the installed system
14:30:04 <pwhalen> yes, I did an initial pass - https://fedoraproject.org/wiki/InternetOfThings/IoT_Release_Criteria
14:30:04 <pbrobinson> pwhalen: we don't currently have a choice
14:30:21 <pwhalen> ok, enabled on the installed system
14:31:16 <pbrobinson> sure, it should now not be enabled on the installed system, it will be enabled on the pre-canned disk images as people need to be able to create users
14:33:04 <pbrobinson> any one have anything else for F-29?
14:33:14 <pwhalen> I'll move the release criteria over to the docs site today as well, please feel free to add to it or make changes
14:33:48 <lorbus> so it looks like greenboot is a release criterium. its in the testing repo now, but probably wont make it into first stable release due to the freeze
14:34:22 <lorbus> you can still vote up its karma tho :) https://bodhi.fedoraproject.org/updates/FEDORA-2018-99a12ff4ba
14:34:36 <pwhalen> lorbus, I added it more as a placeholder - I think the functionality will be important to us but I know its not quite ready
14:34:43 <pbrobinson> lorbus: i think what we'll do with greenboot is add it to rawhide composes and we can start testing there
14:34:55 <pwhalen> pbrobinson, sounds good
14:35:00 <lorbus> sounds like a plan!
14:35:29 <pbrobinson> I also need to do a PR/FBR to enable updates-testing composing in bodhi for IoT so people can use that
14:35:54 <pbrobinson> #action pbrobinson to add greenboot to rawhide IoT composes for enable easy testing
14:36:10 <pbrobinson> #pbrobinson to do bits to enable bodhi updates-testing for IoT
14:36:26 <pbrobinson> #action pbrobinson to do bits to enable bodhi updates-testing for IoT
14:37:31 <pbrobinson> #action pwhalen to move the release criteria to the iot docs.fp.o page
14:38:04 <pbrobinson> anything else?
14:38:51 <pbrobinson> #topic 4) ==== Fedora 30 planning ====
14:39:28 <pbrobinson> at the moment i don't have much for this that builds on anything from last week
14:39:56 <pbrobinson> I plan to start to put together the beginning of the IoT Toolbox container in the next few weeks to enable people to start to play with that
14:40:36 <pbrobinson> anyone have any bits on Fedora 30?
14:40:39 <tim-jone_> probinson what will the Toolbox container contain?
14:41:38 <pbrobinson> tim-jone_: open to suggestions, things like i2c-tools, bluez, other such things, some of which we currently have in the main base image
14:42:23 <pbrobinson> the idea is that those sorts of things should be in the toolbox for those that want to play with them, but they're not generally always there for those that want much tighter/smaller systems
14:42:44 <tim-jone_> we use open-zwave - would that be sensible (most used protocol in home automation)
14:43:30 <pbrobinson> tim-jone_: yes, that would be a possibility, it's already packaged in fedora as openzwave package
14:43:33 <lorbus> it should also be possible to layer those on top of the base, right? in case you dont want to run them as a container
14:43:51 <pbrobinson> tim-jone_: can you recommend a good openzwave adapter available in the UK
14:43:57 <lorbus> but having them all in a toolbox container sounds great!
14:44:12 <pbrobinson> lorbus: you can layer anything on top of base if that's your thing
14:44:50 <tim-jone_> probinson: we have used several but now use https://z-wave.me/uzb/
14:46:32 <pbrobinson> tim-jone_++ thanks
14:47:02 <pbrobinson> anything else for F-30 this week?
14:48:09 <pbrobinson> #topic 5) ==== Open Floor ====
14:48:32 <pbrobinson> open floor now, if anyone has anything to bring up please do
14:56:10 <pbrobinson> ON
14:56:17 <pbrobinson> OK, thanks folks
14:56:21 <pbrobinson> #endmeeting