14:00:57 <pbrobinson> #startmeeting Fedora IoT Working Group Meeting
14:00:57 <zodbot> Meeting started Wed Oct 17 14:00:57 2018 UTC.
14:00:57 <zodbot> This meeting is logged and archived in a public location.
14:00:57 <zodbot> The chair is pbrobinson. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:57 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:00:58 <pbrobinson> #chair pwhalen pbrobinson bcotton
14:00:58 <zodbot> Current chairs: bcotton pbrobinson pwhalen
14:00:58 <pbrobinson> #topic roll call
14:01:03 <pbrobinson> who's here?
14:01:04 <bcotton> .hello2
14:01:05 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:01:09 <lorbus> .hello2
14:01:10 <zodbot> lorbus: lorbus 'Christian Glombek' <cglombek@redhat.com>
14:01:10 <tim-jone_> Hi
14:01:18 <lorbus> Hi everybody!
14:01:51 <tdawson> .hello2
14:01:52 <zodbot> tdawson: tdawson 'None' <tdawson@redhat.com>
14:02:26 * tdawson is just a None-body :)
14:02:56 <lorbus> Hi Nonebody :)
14:03:05 * pwhalen is here
14:03:21 <pwhalen> good morning folks
14:03:30 <tdawson> Hi
14:04:27 <pbrobinson> let's get started
14:04:29 <pbrobinson> #topic 1) ==== Working Group process and admin  ====
14:04:59 <pbrobinson> #info the IoT PRD has moved to the Fedora docs site
14:05:06 <pbrobinson> #link https://docs.fedoraproject.org/en-US/iot/
14:05:12 <pbrobinson> feedback welcome
14:05:43 <pbrobinson> #info all docs are now basically here, all new docs will be here
14:06:09 <tdawson> pbrobinson: If I have some minor edits (bad spelling) ... do you want pull requests?  Or how should I feed this back?
14:06:23 <bcotton> lgtm
14:06:58 <tim-jone_> ditto
14:07:00 <lorbus> looks great!
14:07:13 <pbrobinson> #info docs improvements, fixes, spelling corrects can be filed as issues or PRs here https://pagure.io/fedora-iot/iot-docs
14:07:14 <tim-jone_> agree - very clear
14:07:29 <tim-jone_> OK
14:08:44 <tdawson> I agree that it's very well layed out, and easy to read.  Just had a few things I found when I was going through the process's outlined.
14:09:19 <pbrobinson> yes, improvements to all the docs are welcome
14:09:46 <pbrobinson> I'm going to try and do another pass through all of them later this week, adjust a few sections
14:09:53 <pbrobinson> but I feel they're a good start
14:10:35 <pwhalen> agreed! pbrobinson++
14:10:37 <zodbot> pwhalen: Karma for pbrobinson changed to 12 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:11:20 <pbrobinson> thanks also to bexelbie++ for helping me get started and bcotton++
14:11:20 <zodbot> pbrobinson: Karma for bex changed to 11 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:11:47 <pbrobinson> anyone with any other admin?
14:11:58 <lorbus> pbrobinson++ bcotton++ bexelbie++
14:11:58 <zodbot> lorbus: Karma for bcotton changed to 16 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:12:01 <zodbot> lorbus: Karma for bex changed to 12 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:12:02 <pbrobinson> bcotton: do you know what the latest is for the website?
14:12:33 <bcotton> i do not
14:12:46 <bcotton> #action bcotton to follow up with relrod to check on the website
14:13:46 <pbrobinson> #action pbrobinson to do another pass on the IoT docs site and then get it added to the main docs.fp.o landing page
14:14:01 <pbrobinson> #topic 2) ==== Nightly builds  ====
14:14:35 <pbrobinson> I know there's an issue with the Raspberry Pi on F29 here, I need to dig into it, I haven't tested yesterday's image to see if that improves it
14:16:08 <pwhalen> nor I, will do so today
14:16:08 <pbrobinson> anyone with issues or feedback here?
14:16:33 <pbrobinson> tdawson: did you have a chance to try and get any up and running?
14:16:36 <tdawson> I tried it on x86_64 and things went ok.
14:17:13 <tdawson> I'm still in the middle of re-arranging my office so I have my pi's (and others) available for testing.
14:17:29 <pwhalen> tim-jone_, have you tried power cycling your pi to get past that boot failure?
14:17:42 <pbrobinson> tdawson: cool, let me know if you've got any queries
14:18:25 <tdawson> pbrobinson: Will do.  I'm hoping to have things setup tonight, so hopefully tonight or tomorrow I'll be able to have pi feedback.
14:18:42 <tim-jone_> Yes - just gets a stream of errors as described here: https://pastebin.com/CPgA71Gm
14:19:21 <pbrobinson> tim-jone_: does it get as far as mounting the rootfs?
14:20:11 <pbrobinson> tim-jone_: can you fpaste the entire boot output and provide the link on #fedora-iot
14:20:15 <pwhalen> tim-jone_, ok, I think I've seen similar with some SD's
14:20:25 <tim-jone_> Sorry did not look specifically for this and have now reburnt 28 & rebased ->29 instead
14:21:46 <pbrobinson> tim-jone_: sorry, can you confirm the issue you're seeing is f28 or f29
14:22:14 <tim-jone_> pbrobinson - sorry if being stupid, but how would I capture the output when the pi does not boot?
14:23:14 <tim-jone_> pwhalen - the card was the sd card provided with the official pi starter kit which we have been buying in bulk
14:23:22 <pbrobinson> tim-jone_: well it depends on how far it gets, it could be not booting and outputting more than the 3 lines you've pasted, the full output might provide more context
14:23:44 <pbrobinson> tim-jone_: is it branded?
14:23:48 <pwhalen> tim-jone_, USB to TTL Serial Cable - https://canada.newark.com/adafruit/954/usb-to-ttl-serial-cable-raspberry/dp/44W3509?mckv=sPAHdDGZa_dc|pcrid|59878609972|plid||kword||match||slid||product|44W3509|&CATCI=pla-294680686006&CAAGID=23354969332&CMP=KNC-GCA-GEN-SHOPPING&CAGPSPN=pla&gclid=EAIaIQobChMI4_iqv9aN3gIVCiaGCh3nWwSAEAQYASABEgIU8PD_BwE&CAWELAID=120185770000602371
14:23:54 <pwhalen> terrible link
14:24:41 <tim-jone_> pwhalen - will take a look at the link shortly
14:25:14 <pbrobinson> tim-jone_: 3.3 volt usb to TTL serial adapter basically
14:25:30 <tim-jone_> the sd card is a class 10 16gb micro sd 1 HCI branded integral
14:27:08 <pbrobinson> tim-jone_: OK, I've seen issues with integral branded cards across a number of devices in the past
14:27:53 <pbrobinson> I tend to recommend Samsung or Sandisk personally
14:27:55 <tim-jone_> OK - well I could try to dig out a samsung card, which is the other brand we have used, to see if that makes any difference
14:28:10 <pwhalen> that would be great, thanks tim-jone_
14:28:18 <pbrobinson> but lets take this to #fedora-iot channel for ongoing testing
14:28:25 <pbrobinson> #topic 3) ==== Fedora 29 status for IoT ====
14:28:28 <tim-jone_> PS Tim Coote was getting exactly the same problem (not sure what brand card he was using however)
14:28:35 <pbrobinson> #undo
14:28:35 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7ff787226810>
14:29:05 <pbrobinson> tim-jone_: I'm aware of an issue with the RPi, I need to investigate it further
14:29:22 <pbrobinson> atm I've had other escalations/problems, i've just not got to it yet
14:29:24 <pbrobinson> #topic 3) ==== Fedora 29 status for IoT ====
14:29:56 <pbrobinson> right, I think, bar the RPi issue we're mostly looking OK for release
14:31:24 <pwhalen> agreed, I'm not aware of any other issues
14:32:59 <pbrobinson> I have one change I intend to make around the streams, just aligning the bits there
14:41:47 <tdawson> I've only tested it for x86_64 (virtual machines), but for that, it was fine.
14:44:26 <pwhalen> I think we lost pbrobinson
14:44:41 <bcotton> seems that way
14:45:24 <pwhalen> anything else for f29?
14:45:41 <pbrobinson> and will send out details of the change once it's complete
14:45:53 <bcotton> it's a live!
14:47:53 <pwhalen> #info the ostree branches naming moving from iot/29/<arch> to iot/stable/<arch> and from there we'll have stable/testing/devel "streams"
14:48:32 <pwhalen> #topic 4) ==== Fedora 30 planning ====
14:48:42 <pwhalen> #topic 4) ==== Fedora 30 planning ====
14:48:56 <pwhalen> #info proposed F-30 schedule https://fedoraproject.org/wiki/Releases/30/Schedule
14:49:14 <pwhalen> <pbrobinson> anyone have anything for F-30 cycle/timeframe to discuss?
14:51:42 <tim-jone_> is podman shared networking within scope?
14:52:56 <pwhalen> yes, but it depends on the use case. Might be good to talk about that one the list
14:53:21 <tim-jone_> OK will discuss on #fedora-iot
14:54:00 <pwhalen> #topic 5) ==== Open Floor ====
14:55:16 <pwhalen> anything else for today?
14:56:29 <pwhalen> #endmeeting