14:02:20 <pbrobinson> #startmeeting Fedora IoT Working Group Meeting
14:02:20 <zodbot> Meeting started Wed Nov  7 14:02:20 2018 UTC.
14:02:20 <zodbot> This meeting is logged and archived in a public location.
14:02:20 <zodbot> The chair is pbrobinson. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:02:20 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:02:21 <pbrobinson> #chair pwhalen pbrobinson bcotton
14:02:21 <pbrobinson> #topic roll call
14:02:21 <zodbot> Current chairs: bcotton pbrobinson pwhalen
14:02:27 <pbrobinson> who is here?
14:02:47 <jsmith> .hello2
14:02:48 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
14:02:51 <bcotton> .hello2
14:02:52 * pwhalen is here
14:02:52 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:03:19 <tdawson> .hello2
14:03:20 <zodbot> tdawson: tdawson 'None' <tdawson@redhat.com>
14:04:08 <pbrobinson> we'll give everyone just a minute to arrive, i had my head in kernel things, thanks bcotton for the reminder
14:04:25 <bcotton> bcotton++
14:04:25 <zodbot> bcotton: You may not modify your own karma.
14:04:31 <bcotton> i can, too, zodbot
14:05:20 <pbrobinson> ha, bcotton++ fighting with a bot is amusing, and trying to karma himself is funnier :-P
14:05:21 <zodbot> pbrobinson: Karma for bcotton changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:05:45 <pbrobinson> #topic 1) ==== Working Group process and admin  ====
14:05:52 <pbrobinson> not sure there's much to cover here
14:06:23 <pbrobinson> I need to follow up a few things around the web site, that will be covered under F-29 I think
14:06:34 <pbrobinson> also some cleanups and changes for the docs
14:06:49 <pbrobinson> does anyone else have anything here?
14:07:19 <tdawson> not for this topic
14:08:44 <pbrobinson> #topic 2) ==== Fedora 29 status for IoT ====
14:08:57 <pbrobinson> so we're not quite there for the F-29 IoT release
14:09:11 <pbrobinson> but from yesterday's compose I think we're now close(r)
14:10:00 <pwhalen> do we want to go over the remaining issues?
14:10:13 <pbrobinson> there's an issue with initial-setup not working as expected when a anaconda install is done (as opposed to a pre-canned image)
14:10:20 <pbrobinson> pwhalen: yes
14:10:36 <pbrobinson> pwhalen: want to list the rest?
14:10:45 <pwhalen> sure
14:11:01 <pwhalen> #info initial-setup hangs during boot after IoT installation
14:11:07 <pwhalen> #link https://bugzilla.redhat.com/show_bug.cgi?id=1646568
14:11:34 <pwhalen> #info WARNING at drivers/mmc/bcm2835_sdhost.c:408/bcm2835_send_command()!
14:11:42 <pwhalen> #link https://bugzilla.redhat.com/show_bug.cgi?id=1644873
14:12:15 <pwhalen> this one has been discussed before, not sure where the problem is, but doesnt appear to be the firmware
14:13:05 <pwhalen> I am only seeing this on the rpi3 with a few mmc brands, A-Data being one of them
14:13:26 <pwhalen> Samsung EVO has worked OK
14:14:04 <pbrobinson> I'm trying to test this today, I had to deal with some kernel bits for a deadline this morning and I started flashing out a RPi image and basic testing just now
14:14:55 <pwhalen> hopefully you used a 'lesser' mSD to be able to reproduce
14:14:59 <pbrobinson> #info RPi bcm2835_send_command error is indeterminate, seems to be particular brands of SD cards, why it's triggering on ostree is interesting
14:16:05 <pwhalen> #info ttyAMA ttyAMA0: tty_open: tty->count(2) != (#fd's(1) + #kopen's(0))
14:16:11 <pwhalen> #link https://bugzilla.redhat.com/show_bug.cgi?id=1644884
14:16:43 <pbrobinson> so I think that's systemd claiming a console and bluetooth claiming it as well
14:16:51 <pbrobinson> does that go away with the console change?
14:17:21 <pwhalen> this has changed a little, pbrobinson removed the consoles but for some reason we are still left with console=tty0 which had to be removed for serial to work
14:17:36 <pwhalen> on the rpi3
14:18:05 <pwhalen> but yes, no longer seeing that flood of ttyAMA0 messages
14:18:56 <pbrobinson> right, so I think that's fixed, just investigating where the tty0 comes from
14:19:23 <tdawson> Do we still have normal login?  Or is it then *just* serial console login?
14:20:04 <pwhalen> with this fix, display works as expected, its just serial console that doesnt work until the console=tty0 is removed
14:20:12 <pbrobinson> tdawson: no, both should work
14:20:16 <tdawson> OK, cool
14:21:49 <pbrobinson> there's also the issue around "hangs waiting for eth0" issue reported on the list, I'm seeing that ATM too
14:23:31 <pbrobinson> so any others? tdawson how are you getting on with testing?
14:23:32 <tdawson> Has anyone tested that on the generic Fedora 29 image, to see if this is just a IOT issue?
14:23:41 <pwhalen> which I think we saw before? (waiting for eth0)
14:24:02 * jsmith hasn't had a chance to test yet
14:24:09 <pbrobinson> yes, I think it's the 3B+ lan78xx interface
14:24:17 <jsmith> (I've been swamped because of work travel)
14:24:25 <pwhalen> do we have a bz yet?
14:24:32 <pbrobinson> I'm seeing it on a boot just now
14:24:34 <pbrobinson> pwhalen: no, I
14:24:45 <pwhalen> right, ok
14:24:48 <pbrobinson> no I'm going to ask if the reporter can file one on the list
14:25:26 <pbrobinson> jsmith: no issues
14:25:34 <pbrobinson> nice to see you here
14:26:06 <pbrobinson> anyone else with issues?
14:26:15 <tdawson> pbrobinson: testing is painfully slow for anything but virtual machines.  I've searched through everything for my higher amp power supplied for rpi3, I've come to the conclusion that my daughter took them when she moved back to Illinois.
14:26:30 <pbrobinson> I've also been testing on a HPE GL10 IoT gw, other than the initial-setup issue it's looking good.
14:27:04 <pbrobinson> tdawson: I've had good luck with the Anker IQ chargers if you happen to have any of those
14:27:20 <pbrobinson> tdawson: else I'd just expense one
14:27:38 <tdawson> pbrobinson: I've got some new one's ordered, so hopefully tomorrow I can start real testing.
14:28:22 <tdawson> pbrobinson: But on a similar subject.  I was going to order some new hardware.  Is there anything that people feel would be another good platform to test?
14:29:50 <pbrobinson> tdawson: I'll have a think
14:30:33 <pbrobinson> anything else for f29?
14:31:13 <jsmith> I can't think of anything else for f29
14:32:01 <tdawson> I have one thing to bring up, but I'm thinking it's more of an open floor vs f29.
14:32:26 <pbrobinson> tdawson: cool, we'll be there soon
14:32:37 <pbrobinson> #topic 3) ==== Fedora 30 planning ====
14:33:21 <pbrobinson> I don't have any real updates for here, I've got the f29 release and travel on my high priority over the next few weeks, then I'm shifting toward f30+
14:35:30 <pbrobinson> anyone else?
14:35:58 <pbrobinson> #topic 4) ==== Open Floor ====
14:36:07 <pbrobinson> tdawson: for you
14:37:02 <tdawson> So I was wondering if it would be feasable to create a "testing grid" to go along with the Release Criteria web page
14:37:09 <tdawson> https://docs.fedoraproject.org/en-US/iot/release-criteria/
14:37:43 <tdawson> By "testing grid" I mean something that is a grid of "hardware" vs "tests"
14:37:53 <pwhalen> tdawson, yes we should do that. somewhere to record manual/automated results
14:39:06 <tdawson> I've never setup a page like that, so I don't know how easy/hard it is to create and/or maintain
14:40:15 <tdawson> For me, I'm a "check the box" type of person, and a page like that allows me to check boxes. :)
14:40:21 <bcotton> tdawson: you might talk to adamw and the QA folks. they might have some scripts you can use to build that out
14:41:02 <tdawson> OK, I'll talk to him about that.
14:42:44 <tdawson> That's all I have.
14:42:50 <pbrobinson> tdawson: pwhalen does it for arm now but I think it's in the wiki, I'm not sure we want the output in the docs.fp.o section, but an outline/guide there would be worthwhile
14:43:41 <pwhalen> I did it for arm/aarch64 prior to them being primary, but they were done manually
14:44:12 <pbrobinson> tdawson: pwhalen: can you both take the action on that?
14:44:33 <pwhalen> pbrobinson, sure
14:45:05 <tdawson> pwhalen: Was it a pain to maintain maunually?
14:45:22 <pwhalen> twas :)
14:45:27 <pbrobinson> #action pwhalen tdawson to draw up a release criteria testing grid
14:46:49 <tdawson> pwhalen: I'll talk to adamw, and see if there is an easier way ... I'll cc you on that email.
14:47:20 <pwhalen> tdawson, ok, sounds good
14:48:00 <tdawson> Although I'm a big fan of those grids, if the work to maintain it is more than the work to do the tests ... it might not get updated much.
14:50:01 <tdawson> But, if we can possibly get it easy (or easier) to update, then I think it would be a great thing to have.
14:51:52 <tdawson> I think that's all I have.
14:52:48 <pbrobinson> OK, anyone have anything else? pwhalen jsmith bconoboy
14:53:04 <pbrobinson> bcotton: even, not bconoboy
14:53:35 <bcotton> us bc's are all the same to you
14:53:38 <bcotton> but i got nothin
14:53:53 <bconoboy> Awww.
14:54:15 <pwhalen> :)
14:54:21 * pwhalen has nothing else
14:54:42 <pbrobinson> bconoboy: If you do have something you're more than welcome to comment :)
14:55:08 <bconoboy> No, I'm good ;-)
14:56:45 <pbrobinson> #endmeeting