14:00:26 <pbrobinson> #startmeeting Fedora IoT Working Group Meeting
14:00:26 <zodbot> Meeting started Wed Feb  6 14:00:26 2019 UTC.
14:00:26 <zodbot> This meeting is logged and archived in a public location.
14:00:26 <zodbot> The chair is pbrobinson. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:26 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:00:33 <pbrobinson> #chair pwhalen pbrobinson bcotton
14:00:33 <zodbot> Current chairs: bcotton pbrobinson pwhalen
14:00:33 <pbrobinson> #topic roll call
14:00:40 <pbrobinson> who is here?
14:00:47 <ipcloud> hopley is here
14:00:51 * pwhalen is here
14:00:53 <pwhalen> morning folks
14:00:59 * tdawson is here
14:01:42 * laubersm is here
14:02:15 <pbrobinson> how is everyone
14:02:32 <pwhalen> TBD :)
14:03:01 <tdawson> A bit cold
14:03:02 <ipcloud> getting caffeinated
14:03:19 <pbrobinson> moar kawfee needed?
14:03:36 <laubersm> warm and sunny
14:03:37 <pwhalen> much moar!
14:04:03 <ipcloud> how about you?
14:04:22 <pbrobinson> I'm awake :)
14:04:42 <pbrobinson> right lets get started
14:04:43 <pbrobinson> #topic 1) ==== Working Group process and admin  ====
14:05:07 <pbrobinson> The only item I have here is laubersm's work on the getting started docs
14:05:36 <pbrobinson> #info getting started docs in progress in branch getting-started on https://pagure.io/fedora-iot/iot-docs
14:05:39 <lorbus[m]> .hello lorbus
14:05:40 <zodbot> lorbus[m]: lorbus 'Christian Glombek' <cglombek@redhat.com>
14:05:56 <pbrobinson> laubersm: I think this point I'd like you to basically run
14:06:10 <pbrobinson> #chair laubersm
14:06:10 <zodbot> Current chairs: bcotton laubersm pbrobinson pwhalen
14:06:14 <pwhalen> laubersm++
14:06:14 <zodbot> pwhalen: Karma for laubersm changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:06:24 <pwhalen> lots of commits, looking good
14:06:45 <laubersm> I have been plugging away. since I have not used this image I get to expand what was there by trying it out.
14:06:48 <pbrobinson> #info feed back welcome on getting-started branch
14:07:29 <laubersm> One thing that has come up, I put into the mailing list last night.
14:07:43 <laubersm> I am focusing the getting started on getting the image up and running.
14:07:56 <laubersm> I already moved the switching between stable and nightly out to a User Guide.
14:08:10 <laubersm> But there is some question of if we should call that a User Guide or something more generic.
14:08:25 <laubersm> and should it include all other topics or just next steps.
14:08:43 <laubersm> How granualar do you want to get with user tasks, developer tasks, contributor guide, etc?
14:08:48 <pbrobinson> I've not currently really got an opinion on it, I'll give it some thought over the next few days
14:08:52 <laubersm> Sometimes it is just easier to find it all in one guide.
14:09:44 <laubersm> (I go a little nuts with the OpenShift breakouts)
14:09:44 <pbrobinson> laubersm: sure, I don't disagree with that, have it roll from the very beginning to more advanced topics as you go alone, people being able to stop when they arrive at the destination they need
14:09:47 <pbrobinson> that makes sense
14:10:34 <pwhalen> pbrobinson, agreed. Gradually gets more complex sounds right
14:10:37 <tdawson> I agree.  I prefer things to be all in one guide as much as possible.
14:10:50 <laubersm> It is probably easier to split it later if it gets too big.
14:11:37 <laubersm> Sounds like a working plan. And changing a title from User Guide to something else is easy after people think about it and see some of the content results
14:12:17 <laubersm> I was also looking at the silverblue docs. They seems to have some nice descriptions of ostree
14:12:20 <pbrobinson> laubersm++ makes sense, the comments about developer guide were a off the cuff thought, open to what people think works the best, it should definitely change/evolve as we go
14:12:31 <laubersm> and some tasks that might be of interest to carry over here as well.
14:12:54 <pbrobinson> makes sense
14:12:59 <laubersm> But I welcome ideas from here.
14:13:17 <pbrobinson> the basis of it sounds great
14:13:32 <laubersm> The plan is to flesh out the getting started portions before pouring time into the other topics so everyone has time to think up suggestion :)
14:14:12 <laubersm> Think about what you have had to research or questions you have had to answer.
14:14:20 <pbrobinson> anyone else have anything on the docs?
14:15:30 <pbrobinson> or for working group in general?
14:15:43 <pbrobinson> #topic 2) ==== Fedora 29 release 2 status ====
14:16:18 <pbrobinson> so this has been delayed slightly, I've had to make some changes to take into account mirror platforms/CDN related bits
14:16:56 <pbrobinson> This should largely be in place now, I just need to verify config changes and spin an image
14:17:07 <pbrobinson> ETA for this is likely tomorrow
14:17:26 <pbrobinson> does anyone have anything they need to highlight to be in the images
14:17:47 <pwhalen> excellent, release planned next week?
14:18:36 <pbrobinson> we'll have  the latest 4.20.x kernel, linux-firmware, RPi firmware. The WiFi for RPi 3-Series should be fixed, support for 3A+ etc
14:18:46 <pbrobinson> plus other usual distro enhancements
14:18:50 <tdawson> Ya!!
14:19:07 <pbrobinson> pwhalen: correct
14:19:15 <laubersm> something for me to write applying updates with?
14:19:23 <pbrobinson> laubersm: yes
14:19:23 <laubersm> :)
14:19:35 <pbrobinson> there will be a one off change required for existing images
14:19:58 <pbrobinson> basically to point the updates to the new URL, but updates overall will be the same
14:21:00 <tdawson> What is the new URL?
14:21:45 <pbrobinson> tdawson: will communicate it to the list once I have the final bits
14:21:52 <tdawson> OK
14:23:01 <pbrobinson> no one with anything for F29?
14:23:23 <pbrobinson> #info new 29 release 2 RC due this week
14:23:49 <pbrobinson> #info will have the latest 4.20.x kernel, linux-firmware, RPi firmware. The WiFi for RPi 3-Series should be fixed, support for 3A+ plus other distro updates
14:24:18 <pbrobinson> #info updates will have a new URL, details for changes will be sent to iot mailing list and IRC
14:24:51 <pbrobinson> #info new config will support mirrors etc so updates will be faster
14:25:05 <pbrobinson> #topic 3) ==== Fedora 30 planning ====
14:25:44 <pbrobinson> #info the same mirror changes as outlined for f29 above will apply to F-30 too, should have a new nightly with these updates out today
14:26:26 <pbrobinson> lorbus[m]: how's greenboot 0.6 looking?
14:26:54 <pwhalen> I saw a new rawhide compose yesterday but not had a chance to test, will do so today.
14:27:07 <lorbus[m]> pbrobinson: There is still a selinux policy blocker for the ssh motd generator
14:27:28 <pbrobinson> pwhalen: I think it might have had some issues, needs a change for the new URL
14:27:36 <pbrobinson> or it might have been issues with my image
14:27:48 <pwhalen> ok, will confirm and let you know
14:27:50 <pbrobinson> lorbus[m]: got a link to a bug/tracker?
14:28:09 <lorbus[m]> In order to see the message one need's to run https://github.com/LorbusChris/greenboot/blob/dev/tests/run_test.sh#L16-L17
14:28:52 <lorbus[m]> (note the run_test.sh script isn't really meant to be run as-is, it's more of reference right now)
14:28:55 <lorbus[m]> one sec
14:29:22 <lorbus[m]> #info greenboot v0.6 development
14:29:32 <pbrobinson> lorbus[m]: I suggest reporting a bug to https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=selinux-policy
14:29:36 <lorbus[m]> #link https://github.com/LorbusChris/greenboot/pull/21
14:29:48 <pbrobinson> chair lorbus[m]
14:29:52 <lorbus[m]> #link https://github.com/fedora-selinux/selinux-policy/pull/244
14:30:01 <pbrobinson> #info greenboot v0.6 development
14:30:09 <pbrobinson> #link https://github.com/LorbusChris/greenboot/pull/21
14:30:20 <pbrobinson> #link https://github.com/fedora-selinux/selinux-policy/pull/244
14:30:21 <lorbus[m]> pbrobinson: that is the selinux policy issue: ^
14:30:41 <pbrobinson> lorbus[m]: perfect
14:31:27 <lorbus[m]> I'm working on splitting out the reboot script into its own redboot-reboot.target
14:32:00 <pbrobinson> lorbus[m]: OK, do you have a rough ETA for 0.6 GA>
14:32:36 <lorbus[m]> and an greenboot-update.service that sets the grub vars needed to activate boot counting when the ostreed upgrade happens
14:33:01 <lorbus[m]> when the policy gets merged. the other stuff can wait until 0.7 or later
14:33:16 <pbrobinson> makes sense
14:33:56 <lorbus[m]> not sure how long that's gonna take. I'll ping on the issue again. I think it's ready to be merged
14:34:52 <pbrobinson> OK
14:35:23 <pbrobinson> #info greenboot 0.6 in development, due soon(ish)
14:35:44 <pbrobinson> #info Mozilla IoT Gateway
14:35:50 <pbrobinson> tdawson: you're up ;-)
14:36:26 <tdawson> mozilla-iot-gateway package is ready to start it's fedora packaging process
14:36:40 <pbrobinson> yay! \o/
14:36:51 <pwhalen> tdawson++ awesome
14:36:52 <tdawson> It install's, it works.  I have some basic instructions on how to get it started.
14:37:03 <lorbus[m]> nice!
14:37:45 <tdawson> The one problem is that in order to use the add-on's I most want, we need to create two more packages  ... addon-python and ... addon-node
14:38:27 <tdawson> Most of the generic addon's work just fine, but the one's for my smart lights ... require those add-ons
14:38:58 <pbrobinson> tdawson: is that zigbee, z-wave or something else?
14:39:42 <tdawson> pbrobinson: I believe both zibee and z-wave work with the native gateway stuff ... but I haven't tested them, since I don't have any of either.
14:40:07 <pbrobinson> tdawson: so what functionality do the add-on packages provide?
14:41:06 <tdawson> When you select an add-on, such as zwave or lifx, gateway pulls down that particular add-on, and most of it's dependents, and put's them in your home .mozilla-iot/addons/ directory
14:41:34 <tdawson> But ... if those add-ons are written in python, and you don't have the mozilla-iot-gateway-addon-python installed, they won't work.
14:41:54 <tdawson> I'm not positive about the mozilla-iot-gateway-addon-node ... I haven't found any that need that yet.
14:42:06 <pbrobinson> OK
14:42:26 <tdawson> They -python one is basically the hooks for python to access the gateway.
14:42:43 <pbrobinson> we should probably look at the various addons it could pull down and see if we can't package them up directly, but that's really phase 2 once we have the core gateway working
14:42:52 <tdawson> The -node one ... doesn't really make sense to me since gateway is written in node
14:43:34 <tdawson> pbrobinson: The good thing about it doing the pull down, is if someone creates a new add-on, we don't necessarily have to package it up fast.
14:44:26 <tdawson> But you are right.  If someone wants to have this be on their own seperate network, they would want those packaged.
14:44:51 <pbrobinson> yes, I agree on both sides
14:45:23 <pbrobinson> tdawson: if you could submit the package sooner rather than later for review and assign it to jsmith so he can start review
14:45:46 <tdawson> pbrobinson: Yep, I will try to get the package submitted before the end of this week.
14:45:52 <jsmith> Thanks tdawson
14:45:56 <pbrobinson> I would like to get it available for wider playing sooner rather than later, I know others are interested
14:46:00 <jsmith> I'll do my best to get to the review ASAP
14:46:08 <pbrobinson> why hello jsmith :-D
14:46:12 <pwhalen> looking forward to playing with it
14:46:30 <pbrobinson> tdawson++
14:46:30 <zodbot> pbrobinson: Karma for tdawson changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:46:30 * jsmith sneaks in
14:46:45 <pbrobinson> anything else for moz GW?
14:47:10 <tdawson> I think that's it.  All of the bugs I had were fixed with the 0.7.0 release
14:47:14 <pbrobinson> #action tdawson to submit the moz IoT gateway package for review by end of the week
14:48:04 <pbrobinson> tdawson: I'm going to file some RFE's upstream around supporting NetworkManager for the various network configuration tasks, I think that'll make it more distro agnostic
14:48:30 <tdawson> pbrobinson: That would be nice
14:49:05 <pbrobinson> anyone have anything else for Fedora 30?
14:49:30 <pbrobinson> #info Fedora 30 mass rebuild completed, it's in process of being tagged/signed/composed now
14:51:01 <pbrobinson> #topic 3) ==== Open Floor ====
14:51:20 <pbrobinson> we have 9 mins, does anyone have anything for open floor
14:52:14 <lorbus[m]> I watched the 96boards episode with you in it, pbrobinson! good stuff
14:52:23 <lorbus[m]> (not sure if that was mentioned earlier)
14:53:12 <pwhalen> lorbus[m], agreed :)
14:53:20 <pbrobinson> #link discussion of Fedora IoT in the 96boards ecosystem https://twitter.com/96Boards/status/1092490384318582785
14:53:36 <lorbus[m]> pbrobinson++
14:53:40 <pbrobinson> #link https://www.youtube.com/watch?time_continue=2&v=o5t_tsyI7hQ
14:55:25 <pbrobinson> anyone with anything else?
14:56:49 <pbrobinson> thank you all
14:56:49 <pbrobinson> #endmeeting