14:04:49 <pbrobinson> #startmeeting Fedora IoT Working Group Meeting
14:04:49 <zodbot> Meeting started Wed May 22 14:04:49 2019 UTC.
14:04:49 <zodbot> This meeting is logged and archived in a public location.
14:04:49 <zodbot> The chair is pbrobinson. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:04:49 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:04:49 <pbrobinson> #chair pwhalen pbrobinson bcotton
14:04:49 <zodbot> Current chairs: bcotton pbrobinson pwhalen
14:04:49 <pbrobinson> #topic roll call
14:05:01 <pbrobinson> lets try this again... who is here on the right channel ;-)
14:05:07 * tdawson is still here.
14:05:18 * jsmith is still here...
14:05:27 * bcotton is now here
14:05:46 <pwhalen> heh, I didnt notice
14:06:08 <bcotton> we need to put up different art in the meeting rooms so we can tell them apart
14:06:40 <pwhalen> :)
14:06:47 <pbrobinson> bcotton: I don't think that would have helped my ineptitude but I'm also amused no one called me on it :)
14:06:59 <pbrobinson> #topic 1) ==== Working Group process and admin  ====
14:07:26 <bcotton> o/
14:07:41 <pbrobinson> bcotton: the floor is yours
14:08:37 <bcotton> how are we feeling about the website? there are some tickets still open (i'll #link) and i'm not sure if we need to push on folks or if we can let them close them
14:08:46 <bcotton> #link https://pagure.io/fedora-websites/issue/946
14:09:03 <bcotton> #link https://pagure.io/design/issue/601
14:09:19 <bcotton> #link https://pagure.io/design/issue/596
14:09:38 <bcotton> (there's also a ticket for a badge that i nudged last week. i'll follow up again in a few days)
14:09:41 <bcotton> EOF
14:11:23 <pbrobinson> I spoke with ryan about it but it was in the middle of rhsummit and he was going to get back to me on a few bits as we were potentially going to merge it with getfedora.org when we went to edition
14:12:00 <pbrobinson> that possibility aside I had a couple of design related things in my mind that were outstanding
14:12:36 <pbrobinson> they are basically 1) some IoT specific artwork for the landing page 2) the badge 3) a sticker based on the badge
14:13:29 <pbrobinson> so bcotton based on that I'm happy for you to close things out as you think
14:16:02 <bcotton> pbrobinson: ack. i'll follow up on the tickets as appropriate based on that
14:16:11 <pbrobinson> bcotton++ thanks
14:16:11 <zodbot> pbrobinson: Karma for bcotton changed to 8 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:16:19 <bcotton> #action bcotton to follow up on open website and design tickets
14:16:56 <pbrobinson> the other item I had for this section was move to Edition, it was generally decided to do it some time post f30 GA
14:17:11 <jsmith> Seems reasonable
14:17:24 <pbrobinson> so we probably need a list of items we need to complete to get to that stage
14:17:50 <pbrobinson> the main one I have is cleaning up and making the release process a little more standardised
14:18:23 <bcotton> pbrobinson: is there a taiga card with substasks for this? :-D
14:18:27 <pbrobinson> and probably moving as much as possible of the tracking of that into taiga https://teams.fedoraproject.org/project/fedora-iot/kanban
14:18:40 <pbrobinson> bcotton: you're typing was faster than mine ;-)
14:20:20 <pbrobinson> does anyone else have any other items we need to consider here?
14:22:01 <jsmith> I'm assuming there might be a bit of documentation update that goes along with the promotion to Edition?
14:22:32 <pbrobinson> jsmith: yes, I suspect you're correct. Suggestions and feedback welcome there
14:22:47 <pbrobinson> I did some updates for F-30
14:25:11 <pbrobinson> #topic 2) ==== Fedora 30 ====
14:25:42 <pbrobinson> nothing really to add here, there was a minor release last week I pushed out with the latest security fixes for Intel devices
14:26:09 <pbrobinson> #info a refreshed F-30 and F-29 IoT releases were pushed with fixes for latest HW security issues
14:26:27 <tdawson> Do we expect the 5.1 kernel to make it into next months F30 Iot release?
14:26:28 <pbrobinson> I plan on doing another one by the end of the month
14:26:55 <tdawson> Or are we only doing kernel updates on the major releases, like F31?
14:27:02 <pbrobinson> we expect a 5.1 release this week for F-30 so yes, I suspect it'll be merged/built today given 5.1.4 was just tagged
14:27:10 <tdawson> OK, cool.
14:28:18 <pbrobinson> tdawson: as I'm sure I've said before the Fedora releases get the latest stable kernel around the time it hits .3 (depending on timing) and it starts with the newest release, will then be rolled to f29. Doubt it'll hit f28
14:28:29 <pwhalen> any new issues reported in f30 iot?
14:28:40 <pbrobinson> it's the same and has been that process for as long as I can remember :)
14:28:51 <pbrobinson> not that I've seen
14:29:22 <pbrobinson> I've also seen a few community groups start to actively play with F-30 IoT so that's exciting
14:30:00 <pwhalen> nice, hopefully they start showing up here to give us feedback as well
14:30:03 <pbrobinson> and I'm sure we'll get some feedback from them which will be good
14:30:06 <pwhalen> :)
14:30:17 <pbrobinson> there's a few on the iot irc channel so that's good
14:30:35 <pbrobinson> I should probably get into the habit of announcing the meeting there too
14:31:37 <pbrobinson> anyone with anything else for f30?
14:31:59 * jsmith has nothing else
14:32:21 <pbrobinson> #topic 3) ==== Fedora 31 planning ====
14:33:30 <pbrobinson> I'm going to set all the tags and stuff up in taiga for this so people can track it
14:33:58 <pbrobinson> bcotton: can you give a few lines on your proposal to use taiga for general feature planning?
14:33:58 <pbrobinson> I
14:34:38 <pbrobinson> I've not read it closely but was it moving both the RHBZ and wiki bits to taiga or just the RHBZ bits where you track it in RHBZ now?
14:35:02 <bcotton> so the initial approach is to only move the wiki to taiga
14:35:25 <jsmith> Hope this doesn't derail the conversation -- does Taiga track changes?
14:35:40 <bcotton> i'd like to maybe eventually replace RHBZ trackers and fesco tickets with something more centrailized, but there are a lot of dependencies to resolve first
14:35:51 <jsmith> One feature I use heavily in the Wiki is to look at page history... and see what changed, when...
14:35:53 <bcotton> jsmith: yes it does, at least to description content. not sure about metadata
14:37:01 <pbrobinson> bcotton: how does that then translate to the summary changes page in the wiki out of interest?
14:37:44 <pbrobinson> and does it allow linking between say bits in the iot board vs the board you plan to use?
14:37:48 <bcotton> pbrobinson: do you mean like https://fedoraproject.org/wiki/Releases/30/ChangeSet ?
14:37:54 <pbrobinson> yes
14:38:39 <bcotton> so we'll either have the script generate that page or generate a static html page that will live alongside the schedule. i have a weak preference for the latter because the wiki isn't supposed to be for permanent stuff
14:38:59 <bcotton> i'm not sure about linking between projects, but that would be helpful in some cases. i'll look into it
14:40:17 <pbrobinson> OK, thanks, it's on my list to read the thread as I want to put a bunch of the Arm ones in there so we can get wider publicity there as generally I've done a terrible job at that and over all it'll be good for the project as a whole (both Arm and IoT)
14:40:41 <pbrobinson> anyone else got anything for f31 planning
14:40:54 <pbrobinson> tdawson: did you have anything on your todo list?
14:42:43 <pbrobinson> over all I plan on ensuring our U-Boot builds are as close to EBBR compliance as possible.
14:43:00 <pbrobinson> the IoT releases already use the firmware provided DTs
14:43:53 <pbrobinson> and I need to document a bunch of stuff around config.txt and HATs that actually landed in F-30 but I've not had time to document or blog about details :)
14:44:06 <tdawson> pbrobinson: The only active thing I have on my to-do list is the gateway image ... which someone else is working on.
14:44:22 <tdawson> My IoT time has shrunk for the next month or so.
14:44:42 <pbrobinson> tdawson: yes, we should get them to do a PR for the container image to the iot repo for that once they have it working
14:44:42 <tdawson> I was going to bring up the container image in the open floor
14:44:53 <pbrobinson> OK, lets do that now then
14:45:07 <pbrobinson> #topic 4) ==== Open Floor ====
14:45:18 <pbrobinson> tdawson: the floor is yours
14:45:22 <tdawson> Cool
14:46:03 <tdawson> So Frank Zimmer has been working on the mozilla-iot-container
14:46:22 <tdawson> It looks like he basically has it done, but there is a bug in the startup script for gateway.
14:46:41 <tdawson> He has a patch, that has already been merged in upstream, but it wasn't in time for gateway 8.1
14:46:59 <tdawson> I'm adding that patch to our rpm right now, so hopefully soon he will be unblocked.
14:47:15 <tdawson> https://teams.fedoraproject.org/project/fedora-iot/us/43
14:47:50 <tdawson> Which brings up the next question ... containers ... how do we show ones that are good, or specific for IoT stuff?
14:49:13 <tdawson> Will that be part of the documentation?  Or a tag in Fedora's container repo(s)?
14:49:14 <pbrobinson> I created this repo https://pagure.io/fedora-iot/container-recipes
14:49:48 <pbrobinson> the intention was to use that as a more official collection, and ultimately build them using the container pipeline once we get arch support
14:53:03 <tdawson> OK
14:53:26 <pbrobinson> anyone anything else for open floor
14:53:58 <tdawson> I was also going to try to get a container, with writeup on Home Assistant .... but that's taking longer than I expected.
14:54:17 <tdawson> Home Assistant is so much harder to setup that Mozilla IoT Gateway.
14:54:26 <tdawson> And with that ... nope, nothing else to add.
14:55:20 <pbrobinson> I'm hoping we can work with the Home Assistant people directly, the last I spoke with them they were interested but we weren't quite ready yet, probably time to circle back there. I have a few ideas
14:56:46 <tdawson> pbrobinson: Oh good.  Then if nobody minds ... I'll let that sit.
14:57:02 <pbrobinson> yep, works for me
14:57:10 <pbrobinson> anything else?
14:57:29 <tdawson> not from me.
14:57:55 <pbrobinson> thank you all
14:57:55 <pbrobinson> #endmeeting