12:01:26 <stickster> #startmeeting Magazine editorial board
12:01:26 <zodbot> Meeting started Wed Jun 26 12:01:26 2019 UTC.
12:01:26 <zodbot> This meeting is logged and archived in a public location.
12:01:26 <zodbot> The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:26 <zodbot> The meeting name has been set to 'magazine_editorial_board'
12:01:27 <stickster> #meetingname magazine
12:01:27 <zodbot> The meeting name has been set to 'magazine'
12:01:30 <stickster> #topic Roll call
12:01:32 <stickster> .hello pfrields
12:01:35 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
12:02:03 * jakfrost waves
12:02:23 <jakfrost> .hello
12:02:23 <zodbot> jakfrost: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
12:02:33 <jakfrost> .hello jakfrost
12:02:34 <zodbot> jakfrost: jakfrost 'Steven Snow' <s40w5s@gmail.com>
12:02:37 <bcotton> .hello2
12:02:41 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
12:02:54 <stickster> #chair jakfrost bcotton ryanlerch asamalik cverna
12:02:54 <zodbot> Current chairs: asamalik bcotton cverna jakfrost ryanlerch stickster
12:03:08 <stickster> Hi all!  o/
12:03:12 <cverna> hello o/
12:03:46 * bcotton passes the coffee pot around
12:04:06 * jakfrost takes coffee
12:04:08 <stickster> There's a chance Adam is still traveling from the ContainerDays conference. ryanlerch just pinged me and his laptop died but he's reconnecting and will be here
12:04:14 <stickster> #topic Last week's stats
12:04:20 <cverna> can we have ice tea ? it is quite warm here :-)
12:04:35 <bcotton> RIP ryan's laptop
12:04:37 <ryanlerch> .hello ryanlerch
12:04:38 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
12:04:42 <bcotton> cverna: no. hot coffee every day
12:05:00 <ryanlerch> it just started swapping and then GNOME froze
12:05:11 <stickster> #info Week of June 17: 61.1K pageviews, about average, a little up from week previous
12:05:12 <ryanlerch> too many vms running it seems
12:05:16 <stickster> yikes
12:06:21 <stickster> cverna: I feel for you.. we have a week of 35 C+ temperatures here, but with the high humidity it feels like 45C+
12:06:56 * pingou feels good
12:06:56 <ryanlerch> chilly 15 C here today :)
12:07:01 <stickster> Unfortunately our Jupyter article didn't come in -- the author said he'd be able to work on it but not until this coming weekend
12:07:13 <cverna> yes we have around 31C here today
12:07:13 <stickster> ryanlerch: 😝
12:07:41 <ryanlerch> i did a quick edit of the RPM one in pending before, and was trying to do the image when my laptop froze :)
12:07:51 <stickster> Ah, nice!
12:08:01 <stickster> Might as well #topic over for that
12:08:03 <stickster> #topic Pending review
12:08:09 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=pending&post_type=post
12:08:11 <ryanlerch> wasnt sure if we +1ed it, but figured we could use it for today if we wanted to
12:08:14 <stickster> #info --- RPM packages ---
12:08:28 <stickster> ryanlerch: can you post the public preview link
12:08:48 <ryanlerch> #link https://fedoramagazine.org/?p=28479&preview=1&_ppp=d0ed0a75e8
12:10:11 * stickster just did a quick scan
12:10:30 <stickster> There are some improvements that could be made but it's a pretty darn good draft!
12:10:57 <ryanlerch> i tried to get most of the i / we's out of it already
12:11:23 <stickster> +1 to using the post this week... do we want to shoot for today or hold for tomorrow?
12:11:32 <jakfrost> +1 from me too
12:11:40 <cverna> +1 too :)
12:12:52 <ryanlerch> +1 tomorrow i think
12:13:11 <stickster> OK. ryanlerch I may be able to give it another pass later today
12:13:26 <stickster> A lot of meetings but a couple of them are listen-only
12:14:05 <ryanlerch> stickster: i can do the image tonight. the one there are the moment is old and has been used before
12:14:15 <stickster> ryanlerch: agreed
12:14:28 <stickster> #action ryanlerch finish image for RPM post, stickster to assist with editing and schedule for tomorrow
12:14:44 <stickster> #topic Drafts for review
12:14:49 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=draft&post_type=post
12:15:05 <stickster> #info Only the Jupyter post here, and we know status of that already, author will hopefully submit something this weekend
12:16:05 <stickster> #topic Pitches to review
12:16:13 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=pitch&post_type=post
12:16:30 <stickster> Sadly, nothing new here either :-(
12:16:48 <stickster> we seem to be in the customary summer slump
12:17:02 <stickster> (or winter slump if you're ryanlerch) :-)
12:17:32 <cverna> I have read this blog post yesterday https://blogs.gnome.org/uraeus/2019/06/24/on-the-road-to-fedora-workstation-31/ and thought that could be a good one for the magazine
12:18:11 <stickster> cverna: Oh, good catch! Are you suggesting a "newsy" post that points to that blog?
12:18:50 <cverna> yeah I think that could be cool
12:18:56 <stickster> +1
12:19:18 <jakfrost> +1 on Wayland
12:20:24 * bcotton has a couple of ideas expanding on areas i touched on in my "making of f30" article
12:20:44 <stickster> #agreed go with an "newsy" post pointing to cschaller's latest blog on Workstation 31
12:22:03 <stickster> jakfrost: any chance you want to write this one up? "Newsy" posts as we sometimes call them aren't very long. They typically just have an introduction and a few paragraphs that point off to the news item elsewhere. Basically, clickbait :-D
12:22:14 <stickster> bcotton++
12:22:20 * jakfrost is working out how to move an existing Fedora WS to Silverblue and keep your /home
12:22:31 <jakfrost> bcotton++
12:22:31 <zodbot> jakfrost: Karma for bcotton changed to 14 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:22:31 <stickster> jakfrost: ooo, that sounds cool
12:23:26 <stickster> jakfrost: is that for an upcoming article?
12:23:39 * jakfrost it is cool but I am trying to cover three different scenarios, default setup of WS, custom partitioning of WS, then LUKS encrypted LVM
12:24:12 * jakfrost right now I am struggling with my hardware, it is not cooperating
12:24:36 <stickster> jakfrost: You could consider breaking up into two parts... 1. the basics and the default setup; 2. the more complicated things (what changes)
12:25:01 <jakfrost> stickster: yeah I was thinking it would have to go that way.
12:25:16 <stickster> cverna: Do you want to take the newsy post or I could volunteer to do it?
12:25:48 <cverna> stickster: I am don't think I ll have the time for it, so if you can take it that would be cool :)
12:25:53 * jakfrost I am also working on using awk/gawk and bash to restore a Silverblue system from a Borg backup
12:26:02 <stickster> me neither but I'll go for it!!
12:26:10 <cverna> :-P
12:26:14 <stickster> #action stickster do newsy post for cschaller blog on Workstation 31
12:26:41 <stickster> #topic Open floor
12:26:57 <ryanlerch> just threw in a pitch for the firefox 68 release that is slated for early july
12:26:59 <stickster> OK, time to wrack brains for content. bcotton, did you want to talk about the ideas?
12:27:23 * jakfrost jumped the gun (again)
12:28:10 <bcotton> stickster: sure. i was going to write in greater depth about the blocker bug process, and maybe one about release milestones
12:28:11 <stickster> jakfrost: interested in seeing more on that idea. It seems like a rather esoteric use case for awk
12:28:18 <bcotton> more general than "here's how they happened in f30"
12:28:27 <bcotton> and maybe one on the change proposal process, too?
12:29:41 <stickster> bcotton: there's a unifying thread there... those are all things that most members of the public never concern themselves with. The Magazine has historically tried not to be too "navel gazing" about Fedora *processes*
12:30:10 <bcotton> right. this was ankur's "behind the scenes" idea
12:30:30 <bcotton> i'm very okay with "nah, this isn't appropriate" and figure if we *do* run them, they'd be relatively spaced out
12:30:58 <stickster> Just my $.02, I'd be interested to see if one or more of these can be oriented toward "how you could get involved as an interested non-inner-circle person"
12:31:10 <bcotton> that's a good angle to take :-)
12:31:13 <jakfrost> stickster: I was wanting to tie in both the Borg Backup article I did and the awk article
12:31:33 <bcotton> magazine-as-contributor-recruitment
12:31:42 <stickster> At this point, it's hard to turn down anything ;-)
12:32:26 <bcotton> stickster: i'll probably just sit down and write them at some point. if they're not useful for magazine, having them written down will be useful for me in other venues anyway
12:32:45 <ryanlerch> i think a change propolsa process one couold be spun to be of somewhat interent to users...
12:32:49 <bcotton> so basically it's "ben writes things and gives magazine right of first refusal"
12:33:00 <ryanlerch> "how you get your new features"
12:33:12 <ryanlerch> without going too much down into the proposal weeds maybe
12:33:55 <bcotton> ryanlerch++
12:34:00 <stickster> ack, that sounds pretty good to me
12:34:03 <ryanlerch> like a brewery tour, but you arent allowed behind the rope
12:34:07 <stickster> YES
12:34:43 <bcotton> the blocker process one could take a similar approach: how we make day 0 not suck for you and how you can help
12:35:12 <bcotton> like a distillery tour and at the end you get to dunk a bottle of makers mark into the wax? (this analogy needs improvement)
12:35:31 <cverna> we have a few things to do with fedocal, nuancier and badges (port to python3, fedora-messaging etc ), I was thinking about an article that present these application and invite people that are interested to come and help us with this work
12:36:16 <cverna> we talked to a Friday with Infra where we would be available to help community members to contribute to some of our apps
12:36:17 <jakfrost> cverna++
12:36:17 <zodbot> jakfrost: Karma for cverna changed to 15 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:36:21 <ryanlerch> cverna: IMHO, community blog for that
12:36:58 <bcotton> cverna: agreed that commblog might be a better fit for that, and probably until after infra unveils plans
12:36:58 <cverna> ryanlerch: yes that's why I present the idea here, I am not 100% convince it is right for the magazine
12:37:42 <ryanlerch> yeah its a few steps too removed from the user for the magazine (IMO)
12:37:47 <stickster> yeah, I'd agree with that
12:38:03 <cverna> ok :)
12:38:07 <bcotton> cverna, ryanlerch: otoh, coming back to magazine-as-contributor-recruitment, it might be a way to bring in people who are interested in those things but are not currently in the community
12:38:31 <ryanlerch> like promoting a tour for the bottlecap factory on the side of a beer.
12:38:39 * ryanlerch is done now
12:38:52 <cverna> ryanlerch: haha :)
12:39:02 <bcotton> ryanlerch: i like where you're going with this
12:39:53 <stickster> lol.
12:39:55 <bcotton> speaking of changes
12:40:00 <stickster> bottlecaps--
12:40:12 <stickster> We also need to come up with things to publish next week :-)
12:40:20 <bcotton> dropping i686 has been proposed again. thinking ahead to the F31 release, it might be good to have an article about that and what it means
12:40:33 <bcotton> stickster: i have an idea for that!
12:40:58 <ryanlerch> bcotton: i'm +1 on this idea
12:41:24 <stickster> Is there any firmness around i686? AIUI Ubuntu proposed and backed off, I wonder if we will do the same even though we kind of "demoted" i686 a while ago at least from kernel POV
12:41:25 <bcotton> i'm going to bond my wifi and ethernet interfaces so that my networking isn't a weird when i unplug from the dock. assuming i get it to work, which should be pretty straightforward, i'll write it up
12:41:45 <jakfrost> bcotton: That talk raises the fears of the gaming community and loss of 32 bit support
12:41:45 <stickster> bcotton: neat idea!
12:41:53 <stickster> +1 on i686
12:41:57 <stickster> +1 on bonding
12:42:21 <bcotton> stickster: Ubuntu was going to drop the userspace, too. we're only proposing to drop the kernel. it was proposed a few years ago, people said "no you can't!" and promptly didn't step up to do anything about it
12:42:36 <stickster> the usual, then ;-)
12:42:36 <bcotton> (that's not true. they made a mailing list)
12:42:39 <bcotton> exactly!
12:42:52 <stickster> I'm +1 on dropping the kernel
12:43:04 <stickster> same as when it was proposed a couple years ago ;-)
12:43:14 <jakfrost> I run 64 bit across the board, so I'm okay too
12:43:37 <sdgathman> I have some i686 machines.
12:43:39 <stickster> even gamers will be fine, they can still get multilib packages for gaming support... and show me a serious gamer who's running 32-bit HW.
12:43:58 <sdgathman> But they are used for specialized application (print server, etc).
12:44:06 <jakfrost> There are a lot of 32 bit hardware still being used though, and a good portion are on a 'nix distro of some sort
12:44:14 <ryanlerch> TBH, and weridly, i think some of these dicussions on devel (like dropping 32 bit support) acutally fit into the magazine
12:44:29 <jakfrost> stickster: for sure, just sayin'
12:45:04 <sdgathman> ryanlerch: yep.  An article about the pros, cons, and internal struggles of dropping i686
12:45:04 <stickster> The fact that some HW out there is still 32bit is not a cogent argument for any community distro to continue new kernel support for it
12:45:23 <jakfrost> agreed stickster!
12:45:47 <sdgathman> Certainly not for Intel.  32-bit ARM is another story.
12:45:49 <bcotton> sdgathman: exactly :-D
12:46:03 <stickster> capturing agreements...
12:46:23 <jakfrost> +1
12:46:29 <stickster> #agreed approved: bcotton pitch on "how those new features/changes get into Fedora"
12:46:43 <ryanlerch> bcotton, def raise any more dicussions on devel that might be of interest from users too
12:46:44 <jakfrost> agree
12:47:15 <bcotton> ryanlerch: will do. i am a magical information conduit
12:47:38 <stickster> #agreed approved: bcotton pitch on "bond wifi to ethernet for easier networking mobility"
12:47:52 <jakfrost> ditto
12:48:04 <stickster> #agreed approved: bcotton pitch on "struggling with i686 droppage and what it means to you"
12:48:16 * sdgathman looks sadly at the 32-bit Intel laptop currently acting as mesh node...
12:48:21 <bcotton> does this mean i just volunteered to write the i686 article?
12:48:29 <ryanlerch> stickster: loving these working titles...
12:48:29 <stickster> bcotton: CONGRATULATIONS
12:48:36 <jakfrost> sdgathman: lol
12:48:53 <ryanlerch> i aslo have a quick topic after we do the schedule...
12:49:14 <stickster> #agreed approved: jakfrost pitch on "moving your Workstation to Silverblue" (possibly 2 parts)
12:49:35 * jakfrost starting work on the first part today
12:49:41 <stickster> ryanlerch: We don't have much of a schedule, so go ahead :-)
12:50:02 <stickster> So far I have: tomorrow, RPM; Friday, newsy Workstaiton 31.
12:50:28 <ryanlerch> jsut wondering in anyone else has any ideas of projects we should track to cover on the magazine when they release (and get put into fedora)
12:50:41 <ryanlerch> obviously, fireforx, but any others
12:50:43 <ryanlerch> ?
12:50:54 <ryanlerch> and GNOME
12:51:15 <ryanlerch> was thinking maybe also cockpit, and ansible.
12:51:17 <bcotton> KDE, maybe?
12:51:28 <stickster> LibreOffice, Ansible, CRI-O tools
12:51:48 <bcotton> and maybe a collection of developer tools (in a single article: glibc, gcc, langauges, etc)?
12:51:51 <stickster> OKD if it ever moves from 3.11
12:52:04 <bcotton> i guess it depends in part on what "user" we're wanting to target
12:52:06 <stickster> bcotton: those don't typically move together though
12:52:27 <bcotton> stickster: right, but a roundup once or twice a year of "hey, did you notice these things?"
12:52:50 <ryanlerch> i was more thinking of upstream projects that relese, and typically get packaged straight away into fedora stable
12:52:55 <bcotton> harder to do for the author, which means more beneficial to the reader
12:52:58 <stickster> Yeah, like "user-facing and shiny"
12:53:07 <jakfrost> Possibly something on the open source CAD offerings such as FreCad or OpenSCad
12:54:29 <ryanlerch> okies, will take this list, and investigate the schedules of these projects, and report back next meeting
12:55:11 <ryanlerch> it's just some easy fodder, and helps re-inforce that fedora has the new shinies quite often
12:55:43 <jakfrost> ryanlerch++
12:55:43 <zodbot> jakfrost: Karma for ryanlerch changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
12:56:30 <stickster> OK, we're going to have to wing it next week I guess. I have to run for a meeting.
12:56:38 <stickster> ryanlerch: Are you OK to close out here?
12:56:51 <stickster> I can send notes to the list within an hour
12:57:06 <ryanlerch> stickster: sure! thanks!
12:57:20 <ryanlerch> we have RPM romorrow, and that is about it, right?
12:57:33 <stickster> #idea publishing: Thursday - RPM; Friday (or Monday if emergency) - News on Workstation 31. Wing it rest of week
12:57:40 * stickster out
12:57:47 <ryanlerch> +1
12:57:49 <cverna> +1
12:57:54 <jakfrost> +1
12:58:24 <ryanlerch> we can discuss on the list the wing-ing it procedure.
12:58:53 <ryanlerch> #agreed publishing: Thursday - RPM; Friday (or Monday if emergency) - News on Workstation 31. Wing it rest of week
12:59:11 <ryanlerch> anyone have anything else?
12:59:24 <jakfrost> Got nothing right now
12:59:31 <ryanlerch> 5
12:59:36 <ryanlerch> 4
12:59:41 <ryanlerch> 3
12:59:45 <ryanlerch> 2
12:59:50 <ryanlerch> 1
12:59:59 <ryanlerch> #endmeeting