14:01:37 <pbrobinson> #startmeeting Fedora IoT Working Group Meeting
14:01:37 <zodbot> Meeting started Wed Jul  3 14:01:37 2019 UTC.
14:01:37 <zodbot> This meeting is logged and archived in a public location.
14:01:37 <zodbot> The chair is pbrobinson. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:37 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:01:37 <pbrobinson> #chair pwhalen pbrobinson bcotton
14:01:37 <zodbot> Current chairs: bcotton pbrobinson pwhalen
14:01:37 <pbrobinson> #topic roll call
14:01:43 <pbrobinson> who do we have around today?
14:01:49 * pwhalen is here
14:01:55 * tdawson is here
14:01:56 <bcotton> .hello2
14:01:57 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:01:58 * ipcloud is here
14:03:01 <pbrobinson> we'll give people a minute or so
14:05:01 <pbrobinson> #topic 1) ==== Working Group process and admin  ====
14:06:01 <pbrobinson> I have locally a doc written up for phase one and two for Edition promotion, I'll post that likely later today to the docs site and then a link to the list for feedback
14:06:52 <bcotton> pbrobinson++
14:07:25 <pbrobinson> I've also been cleaning up various bits that doc mentions, unsurprisingly
14:08:03 <pbrobinson> there's nothing of real note, we've discussed most of it pretty widely here and elsewhere
14:08:21 <pbrobinson> bcotton: do you have anything for WG bits?
14:08:38 <bcotton> no sir
14:08:57 <bcotton> i feel like there was something i was going to bring up on the mailing list, but i didn't write it down and i've since forgotten it
14:09:04 <bcotton> OH
14:09:08 <bcotton> i remember!
14:09:41 <pbrobinson> bcotton: go
14:09:53 <bcotton> bug reports: how people should make them. afaict right now we don't have a "here's the place to report bugs", so we get stuff on mailing list, in chat, people yelling at peter on twitter, etc
14:10:09 <bcotton> do we want to have a "this is the place to go", and if so, what should it be
14:10:53 <bcotton> i'm of the idea that we create an IoT component on Bugzilla, because then it's easy to reassign to other components as needed (e.g. most problems probably aren't IoT-specific,b ut a problem with another package)
14:10:56 <pbrobinson> that's a good question, we have had some bug reports in pagure, do we get them to go there, and document that in the docs, and then we translate that to where ever it should be?
14:11:08 <bcotton> the downside here is that bugzilla is...not the most user friendly
14:11:41 <bcotton> pagure is an option, too, but it requires bridging issues to BZ when it's a problem with, e.g., the kernel
14:11:41 <pbrobinson> bcotton: or here? https://pagure.io/fedora-iot/issues
14:12:09 <bcotton> should i take it to the mailing list for further discussion? list out the pros and cons, etc
14:12:27 <bcotton> i don't have a strong opinion either way, since i will be doing very little of the interaction
14:13:20 <pbrobinson> bcotton: yep, that makes sense
14:13:49 <bcotton> #action bcotton to start discussion on mailing list about bug tracking
14:14:33 <pwhalen> pagure is nice to see them all listed together
14:14:40 <pbrobinson> bcotton: we could also have a page "reporting bugs" which provides options with docs as to what goes where, although that also adds confusion https://docs.fedoraproject.org/en-US/iot/
14:15:15 <pbrobinson> pwhalen: problem is you then need a bug wrangler and it can get messy quickly or lost
14:16:15 <pwhalen> right
14:16:26 <bcotton> pbrobinson: ack
14:17:31 <pbrobinson> we have an action for that
14:18:07 <pbrobinson> #action pbrobinson to publish IoT Edition doc to docs.fp.o and send link to list for feedback
14:18:16 <pbrobinson> anything else for WG?
14:19:24 <pwhalen> nothing from me
14:19:54 <pbrobinson> #topic 2) ==== Fedora 31 ====
14:20:23 <pbrobinson> #info should have rawhide nightlies RSN, I'm just debugging a (probably) signing issue
14:20:55 <tdawson> I noticed they tried to be built
14:21:00 <pbrobinson> along with all the other things that seem to have landed in the issues pile this week
14:22:04 <pbrobinson> I've also did a bunch of improvements on Rockchip devices with a focus on IoT and the Rock960
14:22:13 <pbrobinson> should have docs for that hopefully tomorrow
14:22:14 <tdawson> Ya!!
14:22:48 <pbrobinson> the display isn't working in U-Boot yet, so currently needs a serial console, but I'm hoping that should be working RSN too
14:23:58 <pbrobinson> but USB-3 is, as are a bunch of other things and it should be much better in time for beta
14:24:15 <pwhalen> very nice, rockchips would be a great addition. who needs a display :)
14:24:40 <pbrobinson> there's other reasons unrelated to IoT for that TBH
14:26:18 <pbrobinson> once the compose is done we should better know the status of F-31
14:26:30 <pbrobinson> #action pbrobinson will send email to the list one the compose is done
14:26:43 <pbrobinson> anyone else have anything for F-31?
14:28:13 <pwhalen> are we planning on sticking with initial-setup in f31?
14:28:27 <pbrobinson> that is a good question
14:28:40 <pbrobinson> I need to get some good time with ignition to see if it does what we need
14:29:03 <pbrobinson> I wonder if we can put it in side by side with initial setup, else I might have to do a special build for testing
14:29:12 <pbrobinson> I do want to move over if it's sane
14:29:28 <pwhalen> I can try to take a look at that
14:30:00 <pbrobinson> I wonder if it's testable in a general arm image
14:30:10 <pbrobinson> or general image
14:30:29 <pbrobinson> #action pwhalen to investigate moving over to ignition and report back
14:30:29 <pwhalen> right, no idea.. last I looked it wasnt, but that was quite some time ago
14:30:36 <pwhalen> thanks
14:30:41 <pbrobinson> it's changed quite a bit
14:31:13 <pwhalen> good :)
14:31:23 <pbrobinson> anything else?
14:31:43 * pwhalen has nothing else
14:31:45 <pbrobinson> #topic 3) ==== Fedora 30 ====
14:32:11 <pbrobinson> Fedora 30 will move over to the stable branch with the next release
14:32:16 <pbrobinson> #info Fedora 30 will move over to the stable branch with the next release
14:32:34 <pbrobinson> #info that will mean F-29 users will move automatically to F-30
14:32:47 <pbrobinson> I'll send out an email before that happens
14:33:22 <pbrobinson> #action pbrobinson to notify the list before F-30 moves to stable branch which upgrades F-29 users to F-30
14:33:40 <pwhalen> sounds good, I'll test to ensure no issues when you do
14:33:59 <pbrobinson> Current F-30 users will need to rebase onto stable, I believe this is a manual flip but I'm still investigating this
14:34:32 <bcotton> pbrobinson: could be a good fedora magazine article, too. a chance to promote Fedora IoT as "what if your devices actually got software updates" :-)
14:35:18 <pbrobinson> bcotton: good idea, the Edition release will be on the stable branch so once things settle in that regard it should be straight forward for new users there
14:36:16 <pbrobinson> does any one have anything for F-30?
14:36:30 <bcotton> pbrobinson: i can put together some skeleton content if that'd be helpful. i'll need you/others to fill in the details
14:36:44 <pbrobinson> bcotton: that works for me
14:38:27 <pbrobinson> #topic 4) ==== Flock Budapest 2019 ====
14:39:00 <pbrobinson> I've put in two talks, one co-presenting with a customer, plus the half day hack fest
14:39:28 <pbrobinson> has anyone else put any IoT related talks in
14:39:37 <pbrobinson> or got any queries about Flock?
14:40:16 <pbrobinson> #topic 5) ==== Open Floor ====
14:40:18 <bcotton> looks like coremodule and puiterwijk submitted a couple
14:40:29 <pbrobinson> OK
14:41:10 <pbrobinson> The only thing I have for Open Floor is that I'll be travelling next week, in Houston, and I don't yet know my meeting schedule
14:41:24 <tdawson> Just want to say I've finally found some time, and I'm testing the mozilla-iot-gateway-container - https://pagure.io/mozilla-iot-gateway-container
14:41:40 <pbrobinson> so if I'm unavailable pwhalen will be in charge...
14:41:51 <pbrobinson> tdawson++ cool
14:41:52 <zodbot> pbrobinson: Karma for tdawson changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:42:39 <tdawson> pbrobinson: Do you know if you will be going to the Open Source Summit, in San Diego?
14:43:34 <pbrobinson> tdawson: no, I don't yet, I will be @ OSS Europe, and I'll be at Linaro Connect in San Diego when ever it is in Sept
14:43:59 * bcotton will be at OSS NA
14:45:21 <tdawson> As will I .   I'm pretty sure I've met you before bcotton, but it will be good to see you again.
14:45:42 <bcotton> likewise :-)
14:46:10 <pbrobinson> any one with anything else?
14:47:12 <tdawson> nothng from me
14:47:19 <pwhalen> nor I
14:49:11 <pbrobinson> #endmeeting