15:01:31 <adamw> #startmeeting Fedora QA Meeting
15:01:31 <zodbot> Meeting started Mon Sep 16 15:01:31 2019 UTC.
15:01:31 <zodbot> This meeting is logged and archived in a public location.
15:01:31 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:31 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:01:35 <adamw> #meetingname fedora-qa
15:01:35 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:40 <adamw> #topic Roll call
15:01:50 <bcotton> .hello2
15:01:54 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:01:55 * kparal is here
15:01:58 <frantisekz> .hello2
15:01:58 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
15:02:04 <coremodule> .hello2
15:02:05 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
15:02:18 <kparal> .hello42
15:02:25 <kparal> disappointing
15:02:30 <coremodule> Good morning/evening!
15:02:40 <frantisekz> (#me having a PTO and still attending the meeting, gimme some cookies!!! :D )
15:02:48 <kparal> frantisekz++
15:02:48 <zodbot> kparal: Karma for frantisekz changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:03:05 <bcotton> frantisekz--
15:03:09 <frantisekz> :'(
15:03:24 <tflink> .hello2
15:03:25 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
15:03:54 <cmurf> .hello chrismurphy
15:03:55 <zodbot> cmurf: chrismurphy 'Chris Murphy' <bugzilla@colorremedies.com>
15:05:02 <jlanda> .hello2
15:05:03 <zodbot> jlanda: jlanda 'Julen Landa Alustiza' <julen@landa.eus>
15:05:18 <adamw> how's everyone mondaying
15:05:34 <frantisekz> pretty... mondayi
15:05:35 <jlanda> lazy after pto monday on my side =)
15:07:28 <lruzicka> .hello2
15:07:29 <zodbot> lruzicka: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
15:07:52 * lruzicka is perlwise
15:08:30 * adamw genuflects
15:08:35 <adamw> alllllrighty
15:08:41 <adamw> let's get rolling
15:08:49 <adamw> #chair kparal frantisekz
15:08:49 <zodbot> Current chairs: adamw frantisekz kparal
15:08:57 <adamw> #topic Previous meeting follow-up
15:09:56 <adamw> #info "adamw to poke some people about whether we have or can set up an account for EC2 testing so people don't have to spend money to test it" - i did that, and got a lot of 'just use a free tier account!' but also a useful reply from stickster which I will follow up on
15:10:19 <adamw> seems there is a proper setup with amazon which we should be able to get in on.
15:12:19 <sumantrom> .hello2
15:12:20 <zodbot> sumantrom: sumantrom 'Sumantro Mukherjee' <sumukher@redhat.com>
15:13:52 <adamw> hi sumantro
15:13:57 <adamw> alrighty, any other followup from previous meetingh?
15:14:32 <sumantrom> hey adamw!
15:15:04 * satellit_ listening
15:15:51 <adamw> #topic Fedora 31 status
15:16:08 <adamw> so, Beta was signed off and is being released tomorrow
15:16:15 <adamw> #info Beta was signed off on Thursday and is being released tomorrow
15:16:34 <adamw> #action adamw to create and fill out common bugs page
15:18:00 <adamw> nothing else appears to be excessively on fire or anything
15:20:38 <adamw> anyone have any thoughts, notes on f31?
15:21:14 <frantisekz> nothing too special I guess... ton of accepted FEs that didn't make it... but it's beta, so I guess whatever
15:21:56 <satellit_> soas does not login to liveuser..so no insall
15:22:28 <adamw> satellit_: did you file a bug on it yet?
15:22:33 <adamw> frantisekz: yeah, that's fairly normal
15:22:47 <adamw> frantisekz: please tag any that you think are worthy of commonbugs inclusion with CommonBugs keyword
15:23:37 <satellit_> not able to...no component to file against in BZ so no FE possible
15:23:59 <adamw> satellit_: just file against something close...
15:24:05 <satellit_> k
15:24:06 <frantisekz> okay, I didn't go through a whole lot of them yet
15:24:09 <adamw> the login manager or sugar's main desktop component or whatever
15:25:38 <adamw> #info please tag any bugs you think are worthy of Common Bugs inclusion with the CommonBugs keyword
15:25:47 <adamw> #topic Automatic blockers vs. 'last minute' blockers: FIGHT
15:26:02 <adamw> yes, it's time for the main event
15:26:07 <lruzicka> to mattresses
15:26:18 <cmurf> soas folks need a bug report on their mailing list
15:26:20 <adamw> kparal vs. adamw for the Criteria Lawyering Heavyweight World Title
15:26:21 <cmurf> make sure they know
15:26:28 * kparal reads adamw's last reply in test list
15:26:57 <adamw> to be held over 12 deeply soporific rounds during which everyone will get bored and go to the casino
15:27:05 <frantisekz> so... in this area... I feel we don't need to change anything here, I think having late blockers policy applicable to anything should work just fine and we can decide on Go/No-Go meetings on fate of any late blocker
15:27:38 <cmurf> okokok and to add to the hilarity?
15:27:47 <adamw> i think the two policies are workable as they stand, perhaps with a slight clarification of the relationship between them on both pages...but i'm *also* fine with any other reasonable resolution that gets support
15:28:09 <bcotton> +1 to status quo
15:28:17 <cmurf> workstation wg voted something like 6-2 to bump the ISO max size to 3GB, but then didn't ack it upon realizing we didn't actually have to do anything
15:28:29 <cmurf> because of the late blocker policy means beta ships anyway
15:28:38 <cmurf> so we're punting to see if we can in fact get final below 2GB
15:28:51 <frantisekz> cmurf: but, for final, it'd be ideal to change the limit or reduce the size
15:29:07 <cmurf> frantisekz: not ideal, required
15:29:10 <frantisekz> :D
15:29:10 <kparal> cmurf: but it there a reason to have the hard limit set to 2GB?
15:29:21 <kparal> cmurf: why not have the hard limit at 4GB and try to get it under 2GB?
15:29:29 <cmurf> kparal: we're talking about it on fedora-workstation
15:29:34 <cmurf> user experience, long download times, etc
15:29:43 <cmurf> I'm with you though I think it should be 4GB
15:29:43 <frantisekz> anyhow, I am +1 to status quo here
15:30:38 <kparal> I had different point of view on what automatic blockers meant, that's why I have a diverging opinion
15:30:51 <kparal> and I can see it and go both ways, even though I think mine is still better :)
15:30:56 <adamw> kparal: well, per that post you tracked down i think the main 'reason' is that it got bumped to 2GB before then when we asked about bumping it further they demurred and thought it shouldn't get any bigger than 2GB
15:31:15 <adamw> there is also the question of persistence support - i think cmurf suggested that persistence may not work with an image larger than 2GB...
15:31:15 <lruzicka> And I believe if there is a known blocker which only gets proposed in the last time, the policy should NOT apply.
15:31:18 <cmurf> kparal: like you, I like the *result* of the decision but on the logic I'm a little more strict like you are
15:31:19 <satellit_> https://bugzilla.redhat.com/show_bug.cgi?id=1752550
15:31:29 <cmurf> adamw: I was wrong
15:31:34 <adamw> ah, ok
15:31:36 <cmurf> it's 4GB file size limit on FAT32
15:31:42 <cmurf> i thought it was 2GB
15:31:53 <adamw> so there's an argument for *4GB* as a reasonable limit choice?
15:31:59 <adamw> good to know
15:32:15 <cmurf> and in any case persistence is fakaked until we move to plain squash+overlay
15:32:35 <kparal> so, hypothetical situation, the same situation occurs in Final. Should we be able to vote it as a F32 blocker instead? Do we consider it ok?
15:32:41 <cmurf> well if i get my way :D there won't be a meaningful limit
15:32:49 <cmurf> at least not from a file system perspective
15:33:02 <adamw> kparal: i would say it would be an option on the table, but i wouldn't have voted for it for final
15:33:10 <cmurf> no one is thinking of a number above 4GB though
15:33:12 <kparal> because anything can change in the last RC, and therefore the bugs mentioned in automatic blocker will most likely be very often last minute blockers
15:33:32 <frantisekz> kparal: I think, for final, we should still have the right to say it's okay because it was proposed late, but I'd probably vote for it staying a blocker
15:33:33 <cmurf> kparal: no because it's definitely not a late bug
15:33:36 <kparal> DOA images can also be subject to last minute blockers, then?
15:33:46 <adamw> cmurf: i think the scenario is that the same things happen at the same relative times
15:33:52 <cmurf> so last minute blocker policy can't apply - you get one punt
15:34:12 <adamw> cmurf: i.e. say we do an RC on the sunday before the Final go/no-go and find the image is over size
15:34:22 <cmurf> omfg no
15:34:24 <cmurf> no no no
15:34:31 <cmurf> reset the blockeriness every night
15:34:36 <cmurf> that's like
15:34:41 <kparal> say RC1 is correct but a blocker is found, and RC2 is over size or DOA. RC2 will be last minute
15:34:43 <cmurf> if you do that it effectively means there is no size limit
15:34:52 <cmurf> i get what you're saying!
15:35:06 <cmurf> i'm just saying that it'll make kparal 1000% correct
15:35:22 <lruzicka> kparal, Exactly ... and this is not just the only situation when a "last blocker" can jump at us
15:35:37 <cmurf> it'll render the maximum iso size irrelevant, it'll come down to a vote
15:35:39 <kparal> compose issues are hard to report 2 weeks in advance :) and automatic blockers are mostly compose issues
15:35:39 <adamw> kparal: i would say that in theory someone can try to invoke the last minute policy for *any* criterion, but i don't think the attempt would be supported for a doa blocking image
15:36:20 <adamw> kparal: note some of the factors we take into account under the policy:
15:36:27 <adamw> "How prominently visible the bug will be" (DOA image? VERY VISIBLE)
15:36:34 <adamw> "How severe the consequences of the bug are" (DOA image? VERY SEVERE)
15:36:40 <adamw> "How many users are likely to encounter the bug" (DOA image? LOTS)
15:36:46 <cmurf> you know what guys?
15:36:51 <adamw> "Whether the bug could or should have been proposed earlier in the cycle" (DOA image that was only DOA in this RC? no)
15:36:59 <adamw> "Whether the current stable release is affected by the bug" (DOA image? probably not!)
15:37:03 <cmurf> i love that we've solved all of Fedora's other problems that we've spent this much time talking about this issue
15:37:08 <bcotton> cmurf++
15:37:18 <cmurf> seriously I'm cracking up here
15:37:18 <adamw> so...i'd say we'd be very unlikely to apply the last minute policy to a DOA blocking image.
15:37:28 <adamw> cmurf: we're just that good
15:37:31 <cmurf> it's that's hilarious and ridiculous
15:37:55 <kparal> alrighty
15:38:06 <cmurf> due in large part to the earlier workstation wg meeting :D
15:38:17 <cmurf> and btw kparal wins
15:38:19 <adamw> i mean, we can explicitly exclude some severe things from the last minute policy if we want, that's a choice
15:38:19 <cmurf> :P
15:38:45 <lruzicka> adamw, Yes, I'd love to have something like that.
15:38:57 <kparal> adamw: I wouldn't want to make the rules even more complicated (more than "doesn't apply to automatic blockers")
15:38:58 <adamw> if we don't trust the voters to make the right decision :P
15:39:07 <bcotton> eh, once we start excluding things, we imply that other things aren't excluded
15:39:12 <adamw> yeah, that too
15:39:18 <lruzicka> adamw, there should be issues that never are discussed and are blockers any time
15:39:21 <frantisekz> I am still +1 status quo, imo, no clarification is needed here
15:39:36 <adamw> cmurf: btw, solving fedora's other problems is not on the agenda at all, so if that's what you're here for, go grab a donut or something. :P
15:39:39 <bcotton> look. nothing prevents us from ignoring our blockers and saying "WE'RE SHIPPING ANYWAY. YOLO!" so let's trust ourselves to do the right thing
15:39:53 <bcotton> cmurf: please bring a donut for me, too
15:39:54 <cmurf> bcotton: you know me, USS Ship It!
15:40:06 <cmurf> but cmurf, it's totally busted!
15:40:13 <adamw> lruzicka: so, the basic debate here is that that's what kparal thought 'automatic blockers' were, but i don't think they're quite that (and i made them up so i win :>)
15:40:16 * cmurf says yas, ship that thing
15:40:24 <lruzicka> in that case, somebody needs to be USS Nimitz
15:40:32 <cmurf> j/k i never say ship totally broken
15:40:48 <CVN-68> lruzicka: ahoy!
15:40:49 <adamw> hey, it's naval history humor hour
15:40:55 <adamw> here on Soon To Go Very Bankrupt Indeed FM
15:41:00 <kparal> adamw: is it the Munchkin rule - "the owner of the game is always right?" :)
15:41:01 <lruzicka> CVN-68, Ahoj
15:41:05 <adamw> kparal: exactly ;)
15:41:13 <kparal> ok, I yield
15:41:17 <adamw> i mean
15:41:22 <adamw> we could *make* them be that
15:41:23 <kparal> can't argue with the munchking rule
15:41:31 <cmurf> munch king LOL
15:41:32 <lruzicka> The problem is, that the criteria not only should be for us, but also for anyone else, including next generations.
15:41:35 <adamw> but then i'd be sad that we need a three-line whip vote just to say 'this image is bigger than this number' is a blocker
15:41:38 <kparal> typos :)
15:42:00 <cmurf> the typos are way better
15:42:37 <cmurf> i 100% support doing absolutely nothing so that this conversation can be repeated again the next time this contradiction happens
15:42:52 <adamw> or to put it more seriously: i think that it's useful to have an 'automatic blockers' concept as I see it, where it's about obviousness not severity...and it may also be useful to have a concept of 'really super severe blockers' that we could except as a bloc from the last minute policy, but i don't think we have that right now and i don't know if inventing it *as well as* all the other stuff we have gets too complicated
15:42:56 <lruzicka> I still believe if that would be an autoblocker, people would pay more attention to prevent it
15:43:01 <kparal> cmurf: your troll mode gets more advanced each day ;)
15:43:25 <CVN-68> i agree with adamw
15:43:51 <cmurf> kparal: oh i keep the troll mode in a locked box, it's wicked
15:43:59 <adamw> lruzicka: i don't think the current case demonstrates that "people" aren't paying attention, outside of the "people" who look at (or should look at) the matrix pages but didn't file a bug. people like me. :P
15:44:02 <lruzicka> cmurf, ridiculus
15:44:20 <lruzicka> adamw, people like us
15:44:25 <cmurf> lruzicka: well it's not a sound proof lockbox and that troll is within ear shot right now...
15:44:46 <adamw> lruzicka: we can't bag on people for not fixing bugs if we don't file the bugs, basically. and we can still get better at filing bugs even without the 'motivation' of a release slip.
15:44:48 <lruzicka> adamw, so why are we over limit?
15:44:57 <kparal> adamw: I started the discussion with different assumptions. Now that I see other views, I'm fine with the current situation, even though it's slightly off for me.
15:45:16 <adamw> lruzicka: because i didn't file a bug and you didn't file a bug and neither did anyone else.
15:45:21 <cmurf> i'm on the same page and same book as kparal
15:45:28 <adamw> alrighty, i think we've killed this one!
15:45:48 <adamw> proposed #agreed we've talked it through and everyone agrees that I am right as always
15:45:50 <adamw> ^H^H^H^H^
15:46:03 <cmurf> all this over, what was it?
15:46:06 <frantisekz> ack
15:46:06 <cmurf> 40MB? 100MB?
15:46:09 <cmurf> ack
15:46:12 <satellit_> adamw: FE submitted Bug 1752550
15:46:16 <adamw> cmurf: 40MB...but it's not really about that
15:46:38 <cmurf> in effect it is about that because had it been 400MB I will bet you donuts that everyone would have said block
15:46:44 <adamw> proposed #agreed we've talked it through and we agree that the policies can stand as written, with the understanding that 'automatic' blockers are about obviousness not severity
15:46:56 <cmurf> satellit_: can you post that URL on the sugar list?
15:47:03 <frantisekz> ackitty ack
15:47:03 <satellit_> k
15:47:08 <kparal> ack
15:47:14 <cmurf> i'm not certain anyone who can do anything will see it otherwise
15:47:16 <adamw> #action adamw to add a short note to each relevant wiki page (automatic blockers and 'last minute' blockers) to explain the relationship between them
15:47:33 <tflink> ack
15:47:40 <CVN-68> ack
15:47:45 <cmurf> NOTE: adamw will resolve all discontinuities
15:47:50 <adamw> i like that one ;)
15:47:51 <cmurf> by edict
15:48:08 <cmurf> make it so #1
15:48:22 <adamw> #action adamw to resolve all discontinuities
15:48:31 <cmurf> perfect, do it again
15:48:41 <adamw> .fire cmurf you will be resolved
15:48:41 <zodbot> adamw fires cmurf you will be resolved
15:48:51 * cmurf has been resolved
15:48:56 <cmurf> about time!
15:49:00 <adamw> =)
15:49:02 <adamw> alrighty then
15:49:08 <adamw> #topic Test Day / community event status
15:49:24 <sumantrom> Gnome 3.34 Test day is coming on this Wednesday | https://fedoraproject.org/wiki/Test_Day:2019-09-18_Gnome_3.34_Test_Day
15:49:34 <adamw> #chair sumantrom
15:49:34 <zodbot> Current chairs: adamw frantisekz kparal sumantrom
15:49:43 <adamw> #info Gnome 3.34 Test day is coming on this Wednesday | https://fedoraproject.org/wiki/Test_Day:2019-09-18_Gnome_3.34_Test_Day
15:49:44 <sumantrom> Modularity team isnt pretty clear with what they needs testing with and hence we will move with same test cases we had
15:50:10 <sumantrom> Kernel 5.3 Test Week is from 30th Sept- 7th oct
15:50:20 <adamw> #info Kernel 5.3 Test Week is from 30th Sept- 7th oct
15:50:41 <cmurf> it's shipped, i'm running it now
15:50:42 <sumantrom> thats all from my side.. the modularity test day is on 27th
15:51:29 <cmurf> https://koji.fedoraproject.org/koji/taskinfo?taskID=37686057
15:51:34 <adamw> #info Modularity test day will be on September 27th
15:51:43 <adamw> #info please come help with Test Days everyone!
15:51:47 <adamw> thanks sumantro
15:51:57 <adamw> #topic Open floor
15:52:02 <sumantrom> adamw np :)
15:52:07 <adamw> * everyone falls through the floor
15:52:51 <adamw> any other business, folks?
15:52:54 <kparal> now that clipboard works with VMs, has anybody seen your host clipboard acting up strangely and sometimes getting emptied on ctrl+c or ctrl+x? I still have F30 host, though
15:52:59 <adamw> blocker review is in 7 minutes in #fedora-blocker-review
15:53:09 <adamw> kparal: haven't tested it really yet...
15:53:17 <frantisekz> kparal: didn't check that yet
15:53:32 <kparal> it's not related to the fix, because I saw it even before the clipboard got broken
15:53:57 <adamw> hmm, i *have* seen a few cases where a ctrl-c just didn't seem to 'take'
15:54:01 <kparal> ok, I'll need to debug whether it's my specific system issue or not
15:54:05 <adamw> and when i pasted i got whatever was in the clipboard before
15:54:09 <kparal> oh, it's only present on X11 I think
15:54:11 <adamw> but i haven't seen it be *empty* i don't think
15:54:12 <kparal> not Wayland
15:54:13 <adamw> oh, i'm on wayland
15:54:37 <kparal> alright, will debug more
15:55:05 <cmurf> clipboard works?
15:55:09 <cmurf> since when...
15:55:35 <adamw> since the invention of the spring
15:57:39 <adamw> alrighty, seems like there's no other business besides repairing the damn floors in here
15:57:47 <adamw> so i'll see y'all over in #fedora-blocker-review
15:57:49 <adamw> thanks folks
15:57:58 <tflink> thanks for running the meeting
15:58:31 <adamw> #endmeeting