14:01:09 <pwhalen> #startmeeting Fedora IoT Working Group Meeting
14:01:09 <zodbot> Meeting started Wed Feb 26 14:01:09 2020 UTC.
14:01:09 <zodbot> This meeting is logged and archived in a public location.
14:01:09 <zodbot> The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:09 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:01:09 <pwhalen> #chair pwhalen pbrobinson bcotton tdawson puiterwijk
14:01:09 <pwhalen> #topic roll call
14:01:09 <zodbot> Current chairs: bcotton pbrobinson puiterwijk pwhalen tdawson
14:01:13 <pwhalen> Good morning folks
14:01:23 <pwhalen> who's here today?
14:01:31 <coremodule> .hello2
14:01:34 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
14:01:36 * pbrobinson is there
14:01:39 <coremodule> good morning pwhalen
14:01:46 <pwhalen> howdy coremodule
14:01:52 <CHROMICO9> hello
14:02:04 <bcotton> .hello2
14:02:04 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:02:49 <puiterwijk> .hello2
14:02:50 <zodbot> puiterwijk: puiterwijk 'Patrick Uiterwijk' <puiterwijk@redhat.com>
14:03:23 <pwhalen> I think we have the usual suspects, lets get started
14:03:31 <pwhalen> #topic 1) ==== Working Group process and admin ====
14:03:31 <pwhalen> #link https://docs.fedoraproject.org/en-US/iot/
14:03:53 <pwhalen> I have nothing for this topic, anyone else?
14:04:06 <bcotton> o/
14:04:09 <pbrobinson> I think over all we're OK here
14:04:27 <pbrobinson> we're planning on Edition launch just after F-32 GA in early May
14:04:51 <bcotton> #link https://teams.fedoraproject.org/project/fedora-iot/epic/72
14:05:43 <bcotton> pbrobinson: is this the most up-to-date release criteria? https://docs.fedoraproject.org/en-US/iot/release-criteria/
14:05:46 <coremodule> bcotton, have you gotten release criteria?
14:06:09 <pbrobinson> coremodule: can we do that in the F-32 section
14:06:15 <coremodule> aye
14:06:18 <pbrobinson> we need to come up with a new name
14:06:30 <CHROMICO9> Does Fedora IoT plan to make a RTOS for modules like the ESP32 ?
14:06:38 <pbrobinson> but I've no idea the best way to do that so was basically hoping bcotton would ;-)
14:06:50 <pbrobinson> CHROMICO9: no, because they can't run Fedora
14:07:39 <pbrobinson> CHROMICO9: Fedora as a whole might make it easier to develop for those devices on Fedora itself but it;s out of scope for the Fedora IoT initiative
14:08:46 <pwhalen> pbrobinson, any suggestions for the new name?
14:08:46 <CHROMICO9> pbrobinson hmm I see...
14:08:52 <bcotton> pbrobinson: i have some ideas on how to do the name
14:09:11 <bcotton> if that's what you were referrring to, there are three topics being discussed right now
14:10:59 <pwhalen> bcotton, I was. Do you want to share the ideas?
14:11:53 <CHROMICO9> wait so we need to come up for a new name for the Fedora IoT OS correct ?
14:11:59 <pbrobinson> CHROMICO9: we only have small amounts of resources and people to work out it
14:12:20 <bcotton> yeah, so i think the easiest way to do it is to set up a wiki page where people can add ideas. we can cut the ones that are obviously problematic (e.g. trademarks, offensive language, etc) and then set up the voting app to select a winner. we'll send the top 3ish to legal for final vetting
14:12:42 <pwhalen> bcotton, sounds reasonable to me
14:12:51 <coremodule> +1
14:13:41 <pwhalen> ok, does anyone want to take that action item?
14:14:13 <bcotton> i'll take it
14:14:34 <bcotton> i'll put together a timeline and whatnot by EoW and then we can start moving forward with it
14:14:45 <pwhalen> #action pwhalen to create a wiki page to collect possible names for the IoT release. Email to be sent to the list.
14:14:49 <pwhalen> #undo
14:14:49 <zodbot> Removing item from minutes: ACTION by pwhalen at 14:14:45 : pwhalen to create a wiki page to collect possible names for the IoT release. Email to be sent to the list.
14:14:50 <pbrobinson> bcotton: yes ++
14:14:58 <pwhalen> #action bcotton to create a wiki page to collect possible names for the IoT release. Email to be sent to the list.
14:15:21 <CHROMICO9> bcotton sounds good
14:15:22 <pwhalen> thanks bcotton :)
14:15:55 <pwhalen> anything else?
14:16:56 <pwhalen> #topic 2) ==== Fedora 31 status ====
14:16:56 <pwhalen> #info Latest compose available for testing
14:16:56 <pwhalen> #link https://kojipkgs.fedoraproject.org/compose/iot/Fedora-IoT-31-20200223.0/compose/
14:17:46 <pwhalen> I did some testing on this compose, installs, tested the disk image on the rpi3. No issues
14:17:49 <pbrobinson> I synced out a new release today to stable
14:18:46 <pwhalen> has anyone hit any new issues in F31?
14:19:36 <pwhalen> #info Fedora-IoT-31-20200223.0 synced to stable.
14:19:52 <pwhalen> #info No new issues.
14:20:12 <pwhalen> #topic 3) ==== Fedora 32 status ====
14:20:41 <pwhalen> lots to talk about here. who wants to go first?
14:20:42 <pbrobinson> we're in freeze
14:21:24 <pwhalen> #info F32 Beta Freeze on now. Target Beta release - 2020-03-17
14:21:38 <puiterwijk> So, I hit some bugs in 33 that I bet are also in 32. For example, clevis Luks is broken because cracklib-dicts aren’t installed, breaking pw creation
14:21:44 * pingou shivers
14:22:40 <puiterwijk> Additionally, anaconda doesn’t have a dep on auth config or authselect, but if you have neither, it crashes at the end due to lack of /usr/sbin/authconfig, even without “auth” statement in kickstart
14:23:39 <bcotton> puiterwijk: we need to verify this on 32 soon and propose them as release blockers
14:24:12 <pbrobinson> puiterwijk: I'll add cracklib-dicts to the compose as a work around, can we have a bug for it please
14:24:46 <puiterwijk> pbrobinson: sure. I thought you were filing that when we discussed it. But if you didn’t, I will
14:24:54 <pwhalen> puiterwijk, I tried to reproduce the second one, but wasnt able to. If you could give me some more details on how to reproduce
14:27:16 <puiterwijk> pwhalen: use the kickstart generated by zezere with a compose from this week. But will give more instructions after meeting
14:27:24 <pwhalen> Ok, we have those two bugs to file and propose as blockers for discussion.
14:28:12 <puiterwijk> Note that before this week we had authselect in the compose to work around it
14:28:45 <pwhalen> oh :) maybe I just need to try again nwo
14:29:45 <pwhalen> puiterwijk, how is zezere? We are planning a test day for next week (March 4th) and will need the tool. Do you think it will be ready or should we postpone?
14:29:48 <coremodule> bcotton, regarding release criteria, do you have a set, or do you need some updated criteria to continue with the taiga ticket?
14:30:12 <pbrobinson> It should now be working, I plan on getting a demo running so we can use it for test day
14:30:29 <bcotton> coremodule: i'm not even sure why i assigned myself to that ticket, because my understanding is that pbrobinson and sumantrom were already having that conversation
14:30:59 <pwhalen> pbrobinson, excellent! would love to see it/test it. We'll need some test case to replace the initial-setup one as well
14:31:03 <bcotton> coremodule: but basically, if the list at https://docs.fedoraproject.org/en-US/iot/release-criteria/ is valid, then i'm satisfied and the QA team can run with it
14:31:49 <bcotton> i do need a list of blokcing images though
14:31:51 <pwhalen> bcotton, coremodule I spoke with sumantro about it briefly and pointed out that page. Those tests are in additon to many of the standard Fedora tests
14:32:12 <pwhalen> or release criteria
14:32:25 <pbrobinson> bcotton: pwhalen is probably best to lead the criteria, he can bother me when I need to input
14:32:31 <bcotton> pbrobinson: ack
14:32:38 <pwhalen> yes, sumantro and I have been talking about it
14:32:50 <bcotton> pwhalen: okay, great
14:34:13 <pwhalen> bcotton, I think we discussed release blocking would include the aarch64 and x86_64 disk images as well as the installer
14:34:21 <pbrobinson> bcotton: I'd already provided the blocking images somewhere
14:36:09 <coremodule> for this first blocking release, should the test cases *only* cater to the release criteria, or do we want optional tests as well?
14:37:57 <pwhalen> coremodule, I think optional tests would be great, but of course optional :)
14:38:19 <coremodule> roger!
14:39:26 <pwhalen> So test day next week. People feel confident we should have all we need to test?
14:40:19 <coremodule> QA is ready to handle it
14:43:23 <pwhalen> does anyone have anything else to discuss for F32?
14:46:16 <pwhalen> #info Latest compose available for testing
14:46:17 <pwhalen> #link https://kojipkgs.fedoraproject.org/compose/iot/Fedora-IoT-32-20200224.0/compose/
14:46:37 <pwhalen> #info Please test and report issues to the list or #fedora-iot.
14:47:13 <pwhalen> #info Test day scheduled next week - March 4th. Details to be sent to the list.
14:47:27 <pwhalen> #topic 4) ==== Open Floor ====
14:47:47 <pwhalen> Anything for open floor?
14:47:54 <coremodule> nothing here!
14:48:43 * pwhalen leaves it open for a couple of minutes in case someone is typing
14:50:08 <pwhalen> #endmeeting