14:03:21 <pwhalen> #startmeeting Fedora IoT Working Group Meeting
14:03:21 <zodbot> Meeting started Wed Apr 15 14:03:21 2020 UTC.
14:03:21 <zodbot> This meeting is logged and archived in a public location.
14:03:21 <zodbot> The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:03:21 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:03:21 <pwhalen> #chair pwhalen pbrobinson bcotton tdawson puiterwijk
14:03:21 <pwhalen> #topic roll call
14:03:21 <zodbot> Current chairs: bcotton pbrobinson puiterwijk pwhalen tdawson
14:03:34 <bcotton> .hello2
14:03:34 <pwhalen> sorry folks, distracted testing.. who's here today>?
14:03:34 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:03:37 * pbrobinson is here
14:03:44 * tdawson is here
14:03:47 * puiterwijk is here-ish
14:04:18 <pwhalen> ok, lets get started..
14:04:21 <pwhalen> #topic 1) ==== Working Group process and admin ====
14:04:48 <pwhalen> I know I have an action item to update docs, havent had time yet with the pending release.
14:04:54 <pbrobinson> so now we have bcotton I think we just need to close out the naming bits
14:05:07 <pwhalen> Right
14:05:42 <bcotton> is it not closed out? "Fedora IoT" doesn't require much closing :-)
14:06:23 <pbrobinson> bcotton: right, just wanted to make sure it was agreed and noted that we were just going to keep the name as it was basically the winner
14:06:51 <bcotton> #agreed Fedora IoT is the winner of the name contest
14:07:22 <pbrobinson> on pwhalen's note about docs, does anyone have some cycles to assist in updating for the upcoming F-32 release?
14:08:30 <pwhalen> help would be great, I should have more time tomorrow. This is looking like it will be GA, just based on testing
14:09:44 <pwhalen> ok, anything else for admin?
14:10:24 <pwhalen> #topic 2) ==== Fedora 31 status ====
14:10:41 <pwhalen> I dont think anything has changed since the last meeting, any new issues reporteD?
14:11:41 <pbrobinson> I did a compose here last week, not pushed it stable but in the very little testing I did (rpi3/vm) it seemed OK
14:12:14 <pbrobinson> next!
14:12:15 <pwhalen> right, no issues testing here either
14:12:28 <pwhalen> #topic 3) ==== Fedora 32 status ====
14:12:58 * coremodule is present\
14:13:06 <pbrobinson> I think we're looking OK here, provisioning seems OK, it's certainly not perfect but it's working for general use cases
14:13:12 <pwhalen> So we have a test day finally happening which should actually work. The timing could be better with others testing the F32 RC 1.3
14:13:28 <pwhalen> #link https://fedoraproject.org/wiki/Test_Day:2020-04-15_Fedora_32_IoT_Edition
14:13:39 <pwhalen> #link http://testdays.fedorainfracloud.org/events/83
14:13:57 <pwhalen> It would be greatly appreciated if folks could do some testing.
14:14:32 <tdawson> I noticed that someone did testing from the compose two days ago, is this going to affect things?
14:15:48 <pwhalen> oh right. Well, any testing is good, but its not what we flagged as the compose to test
14:15:57 <pbrobinson> tdawson: what do you mean by that?
14:15:59 <pwhalen> any result is good, imo
14:16:43 <pwhalen> pbrobinson, someone tested the 0413, rather than the 0414 we linked on the test page
14:17:11 <tdawson> electronfrost has his machine profile with "Fedora-IoT-32-20200413.0 on RPI3" ... but the one I saw and am testing is Fedora-IoT-32-20200414.0
14:17:29 <pbrobinson> oh, if it worked they can then test upgrades :-P
14:17:42 <pwhalen> heh, right.. silver lining :)
14:17:47 <tdawson> :)
14:18:47 <tdawson> I plan on making the time to test on all my platforms. So hopefully will have some good results.
14:19:03 <pbrobinson> so we should have some more supported devices, and some improvements on a bunch of the current ones
14:19:10 <pwhalen> particularly interested in people using Zezere. I wrote the test case and coremodule quickly found that it could be clearer. So please, if its confusing feel free to edit (it's a wiki)
14:19:16 <pbrobinson> I will update those and try and spend time on docs on Fri
14:19:40 <pbrobinson> pwhalen: will do, I need to circle back around there in the next few days
14:19:54 * pbrobinson needs more round tuits!
14:19:55 <pwhalen> pbrobinson, lets do that, have a little virtual hackfest on friday to get er done
14:21:24 <pwhalen> I think we're looking good. Documentation aside. I have had one issue with a vm looping in ignition, seemingly endlessly.. but hardware installs and other vms were fine
14:21:59 <pbrobinson> pwhalen: did you ask puiterwijk about the looping issue?
14:22:07 <pbrobinson> he might have some thoughts or suggestions
14:22:30 <pwhalen> I didnt, too busy racing through testing. If I reproduce I'll try ot get on the system and see why
14:22:44 <puiterwijk> What is "the looping issue"?
14:22:54 <pwhalen> Was also interested to see if others hit it
14:22:59 <pwhalen> puiterwijk, see above
14:23:14 <puiterwijk> Ah, right. Yeah, it will run ignition ad infinitum for now
14:23:16 <pwhalen> just kept trying to connect
14:24:05 <pwhalen> but other were fine, so maybe a one off. Will let you know if I see it again..
14:24:31 <pwhalen> coremodule++
14:24:35 <pwhalen> sumantro++
14:24:42 <pwhalen> thanks for all the help with the test day.
14:24:44 <puiterwijk> Okay
14:25:07 <coremodule> glad to help, and we'll be around all day in #fedora-test-day, #fedora-qa, and #fedora-iot in case any question arise
14:25:33 <pbrobinson> puiterwijk: so known issue? Should pwhalen file a github issue so we can track it?
14:25:45 <puiterwijk> pbrobinson: I think so
14:25:53 <pwhalen> ok, noted.
14:25:58 <pbrobinson> coremodule: feel free to ping, I'm mostly around and mostly testing bar meetings and other bits
14:26:04 <puiterwijk> From whatI understand from that
14:26:07 <coremodule> wilco
14:26:21 <coremodule> thanks pbrobinson
14:26:43 <pbrobinson> anyone got other queries and questions for F-32?
14:26:57 <pwhalen> it would also be good to show the ip in a MOTD, like server does..so people with dhcp can easily log in
14:27:09 <pwhalen> for f33
14:28:15 <pwhalen> just one final request for testing. At least a run from folks here would be greatly appreciated.
14:28:16 <pbrobinson> pwhalen: we'll log that in github, I have other thoughts about that, but it should have a provisioning URL in the MOTD now I think
14:29:10 <pwhalen> not yet, but that would be good too.
14:29:28 <pwhalen> #topic 4) ==== Fedora 33 status ====
14:29:45 <pwhalen> I havent been looking at it
14:29:53 <pbrobinson> we have mostly regular composes, I suspect mostly untested
14:30:27 <pbrobinson> In the next couple of weeks I'll be looking at what we features we want
14:30:38 <pbrobinson> I have IMA policies on my list
14:31:29 <pwhalen> hrm, last successful test run for f33 was april 1st. I'll look
14:32:27 <pwhalen> pbrobinson, ok and let me know things that will need release criteria
14:33:32 <pbrobinson> pwhalen: for f-33?
14:33:39 <pwhalen> right
14:34:20 <pwhalen> anything else for f33?
14:34:24 <pbrobinson> not from me
14:34:55 <pwhalen> #topic 5) ==== Open Floor ====
14:35:16 <pwhalen> Anything else for today?
14:35:22 <tdawson> I looked at the mozilla-iot-gateway packages from mozilla
14:36:13 <tdawson> They have f30 and f31 packages, but they currently will not install on f32 because it wants pagekite, which (currently) a python2 program, and was removed from f32.
14:36:30 <tdawson> I haven't tried thier container yet.
14:37:04 <pbrobinson> tdawson: OK, what is pagekite, maybe we can report a bug about it not being py3 and see if they can move to some other dep
14:37:13 <tdawson> Anyway, I was thinking if we were thinking of using at least their container, maybe we could think of dropping it from fedora.
14:37:27 <tdawson> pbrobinson: It's a way of seeing your server outside of your firewalls.
14:37:43 <tdawson> And pagekit is almost done with their python3 port.
14:38:15 <pbrobinson> OK, so there's a few options there then
14:39:31 * pwhalen goes back to testing, feel free to close this out when done
14:40:17 <pbrobinson> I think we're done
14:40:22 <pbrobinson> #endmeeting