15:00:37 <bcotton> #startmeeting Prioritized bugs and issues
15:00:37 <zodbot> Meeting started Wed May  6 15:00:37 2020 UTC.
15:00:37 <zodbot> This meeting is logged and archived in a public location.
15:00:37 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:37 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
15:00:38 <bcotton> #meetingname Fedora Prioritized bugs and issues
15:00:38 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
15:00:46 <bcotton> #topic Purpose of this meeting
15:00:47 <bcotton> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
15:00:49 <bcotton> #info The main goal is to raise visibility of bugs and issues to help  contributors focus on the most important issues.
15:00:50 <bcotton> #link https://docs.fedoraproject.org/en-US/program_management/prioritized_bugs/#_process_description
15:00:52 <bcotton> #topic Roll Call
15:02:36 * bcotton wonders if mattdm is too busy with press today
15:04:12 * mhroncok rolls the call
15:04:19 <bcotton> hi mhroncok!
15:04:25 <mhroncok> hey
15:04:31 <mhroncok> bcotton: how are you doing?
15:04:31 <bcotton> now the decisions won't be unilateral :-)
15:04:51 <bcotton> mhroncok: i'm doing quite well today, how are you?
15:04:51 <mhroncok> sorry about that :D
15:05:07 <mhroncok> bcotton: fine, thanks
15:05:12 <bcotton> #topic Nominated bugs
15:05:13 <bcotton> #info 1 nominated bugs
15:05:14 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871664&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%3F
15:05:21 <bcotton> so this is kind of a lie actually
15:05:27 <bcotton> #topic SELinux denials for 'setsched' and 'sys_nice' for various glib-based processes (force glib down a fallback path with performance implications)
15:05:28 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1795524
15:05:58 * mhroncok is confused
15:06:08 <bcotton> #info BZ 1795524 was closed as a duplicate of a closed bug (1811407) fixed by FEDORA-2020-a6cd8de2ed
15:06:28 <mhroncok> bcotton: so the test bug, is... test bug
15:06:43 <mhroncok> I guess we can keep it prioritized
15:06:52 <mhroncok> but how did you find out about the other one?
15:07:24 <bcotton> yeah, i need to see if brendan will close that one
15:07:47 <mhroncok> bcotton: anything to discuss about the closed one?
15:08:29 <bcotton> so i'm thinking, given the history of 1795524, that we should consider 1811407 prioritized instead. it's already closed, but if it reopens, i think we want it to fall under this process
15:09:22 <mhroncok> proposal: don't priorizie closed bugs, get back to them if reopened?
15:09:55 <mhroncok> aka, feel free to move the ? flag to the antiduplicate
15:10:06 <mhroncok> but I don't feel like we need to vote on it if closed
15:10:11 <bcotton> ah, i see what you're saying
15:10:16 <bcotton> yeah, that makes sense
15:10:31 <bcotton> #agreed We will move the ? flag to BZ 1811407 in case it gets reopened
15:10:37 <mhroncok> what's the English world for antiduplicate?
15:10:52 <bcotton> that's...an excellent question
15:11:18 <mhroncok> antiduplicate it is then
15:11:35 <bcotton> \#agreed antiduplicate is the word for the bug that a bug is a duplicate of
15:11:38 <bcotton> #agreed antiduplicate is the word for the bug that a bug is a duplicate of
15:11:43 <bcotton> now it's official
15:11:44 * mhroncok has the benefit of not knowing when something sounds crazy in English
15:12:03 <bcotton> #topic Accepted bugs
15:12:05 <bcotton> #info 2 accepted bugs
15:12:06 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871665&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%2B
15:12:39 <bcotton> #topic Authentication dialog for samba printer provides no input fields
15:12:40 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1715900
15:12:42 <bcotton> #info Accepted as a Prioritized Bug on 2020-02-12
15:12:43 <bcotton> #info update FEDORA-2020-a1eacf6355 is a proposed fix, but it's unclear if it fixes the issue
15:13:02 <bcotton> fwiw the maintainer thinks the report in comment 9 is not the same issue
15:13:28 <mattdm> bcotton: Sorry I am here now
15:13:29 <bcotton> #info bcotton sent a call for testing to the QA team last week
15:13:44 <mhroncok> mattdm: are you sorry for being here? :)
15:13:49 <bcotton> mhroncok: that's how i read it
15:14:01 <mattdm> TBH someone sent me a video about a coronavirus conspiracy theory and I got caught up in being outraged at how dumb the comments are
15:14:14 <mattdm> which is not a good excuse but is the truth :)
15:14:14 <bcotton> that's a valid justifcation
15:15:03 <bcotton> the reporter on this bug can't access the test hardware
15:15:25 <mhroncok> bcotton: in that case I suggest we just keep this for the next meeting
15:15:41 <mhroncok> and if it gets annoying after 2 years of lockdown, we can remove it
15:15:54 <mattdm> sounds good to me
15:16:08 <bcotton> since the maintainer thinks it's fixed and no one has shown otherwise, i'm a little inclined to consider it closed until someone can reproduce it. maybe at the next meeting?
15:16:52 <mattdm> ok :)
15:17:22 <mhroncok> bcotton: next meeting is good
15:17:22 <bcotton> also it was filed against fedora 30, so since the comment 9 is apparently not the same issue, it would get closed EOL soon anyway
15:17:32 <mhroncok> ha, NOTABUG
15:18:28 <bcotton> #agreed If FEDORA-2020-a1eacf6355 isn't confirmed to *NOT* fix this issue by the next meeting, we will close it as fixed
15:18:58 <bcotton> #topic Multiple packages have broken dependencies due to PostgreSQL 12
15:18:59 <mattdm> that's a lot of negatives :)
15:18:59 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1811800
15:19:01 <bcotton> #info Accepted as a Prioritized Bug on 2020-03-11
15:19:02 <bcotton> #info Blocked by BZ 1825327
15:19:04 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1825327
15:19:05 <bcotton> #info panovotn submitted a pull request to rebuild (2020-04-21), bcotton set needinfo (2020-05-01)
15:19:07 <bcotton> mattdm: words are hard
15:19:33 <bcotton> so i propose we send a batsignal to get a provenpackager to tackle this one
15:19:44 <bcotton> (side note: is there a way to send a batsignal to provenpackagers?)
15:19:50 <mhroncok> if the PR builds, let's just merge it?
15:20:08 <mhroncok> clearly, it does
15:20:22 <mhroncok> but only opened for f32 :/
15:20:53 <mattdm> mhroncok: sorry, which PR?
15:21:01 <mhroncok> mattdm: https://src.fedoraproject.org/rpms/pgRouting/pull-request/3
15:21:06 <mhroncok> I've also opened https://src.fedoraproject.org/rpms/pgRouting/pull-request/4
15:21:19 <mattdm> Is that the only one left?
15:21:21 <bcotton> mhroncok: can provenpackagers merge PRs?
15:21:23 <mhroncok> if both build, I'll merge and ship
15:21:26 <mhroncok> bcotton: sure
15:21:38 <mhroncok> mattdm: I think it is, but I haven't checked
15:21:56 <bcotton> mhroncok: okay, cool. i wasn't sure if that permission worked for PRs or just for commits (although i suppose you could do it outside of the web interface)
15:22:15 <mhroncok> question is, what to do if rawhide doesn't build
15:22:30 <mhroncok> merge both anyway, keep it somebody else's problem?
15:23:08 <bcotton> mhroncok: if rawhide doesn't build, we could leave it as-is and see what happens after the f33 mass rebuild
15:23:55 <bcotton> since it's just a release bump, we're probably going to hit that problem in july anyway
15:23:58 <mhroncok> bcotton: ok, rawhide is laready diverged and fails
15:24:05 <bcotton> sadness :-(
15:24:58 <mhroncok> so. I've opend a master merge to f32 instead not to diverge needlessly -- it shoudl also get us a recent enough feeedback on "does it build?"
15:25:11 <bcotton> ok
15:25:29 <mattdm> I'm not sayin' this shouldn't still be worked on, but if it's just one remaining package I think we should clap our hands together briskly and say "well, that's sorted then" -- from a Priortized Bugs perspective
15:25:46 <mhroncok> mattdm: I tend to agree
15:26:02 <bcotton> so for now, i'll just #action mhroncok to use provenpackager powers to rebuild package for f32    ...and the maintainer can worry about rawhide
15:26:23 <bcotton> #action mhroncok to use provenpackager powers to rebuild pgRouting package for f32
15:27:06 <mattdm> It helps if you say "Well, that's sorted then" in a posh british accent, for some reason.
15:27:29 <bcotton> but my question stands: is there a good way to say "hey, i need any provenpackager to do this thing for me"? or is it just a matter of going to a provenpackager and asking them (i mean a message to devel would fit the first, but i didn't know if there was something more specific)
15:27:55 <mhroncok> bcotton: there was a framework for easyfixes
15:27:57 <mhroncok> it didn't work
15:28:10 <mhroncok> so today, it is mostly: bother somebody you know, or ask on devel
15:28:20 <mattdm> yeah, that's the procedure I've always followed
15:28:21 <bcotton> okay, good to know :-)
15:28:24 <mattdm> hi sgallagh :)
15:29:17 <sgallagh> mattdm: Hmm?
15:29:20 <bcotton> i wonder if a pagure repo with all of the provenpackagers added would be a reasonable approach. then requests could be made via issue and there's some state tracking etc. probably more overhead than is needed
15:29:47 <mhroncok> bcotton: too complicated
15:29:50 <bcotton> sgallagh: mattdm is just saying you're his official "hey i need a provenpackager to do things for me"
15:29:56 <mattdm> sgallagh: sorry no action actually needed just poking you as someone I've bothered about things before :)
15:29:57 <sgallagh> Ahh
15:30:06 <mattdm> There's A Process! :)
15:30:28 <bcotton> speaking of Process, let's move on to the next step in ours
15:30:33 <bcotton> (how's that for a segue?)
15:30:37 <bcotton> #topic Next meeting
15:30:39 <bcotton> #info We will meet again on 20 May at 1500 UTC in #fedora-meeting
15:30:46 <mhroncok> bcotton: anyway since I managed to show up on this meeting for some time, you can use me in prioritized bugs that need provenpackager
15:30:57 <bcotton> mhroncok: i appreciate it :-)
15:31:10 <bcotton> #topic Open floor
15:31:19 <bcotton> anything else that needs addressed before we #endmeeting?
15:31:41 <mhroncok> bcotton: but I only agreed to that because you've made antiduplicate official
15:31:46 <bcotton> :-D
15:31:49 <mattdm> mhroncok++
15:31:49 <zodbot> mattdm: Karma for churchyard changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:31:49 <bcotton> mhroncok++
15:31:50 <mattdm> bcotton++
15:31:51 <zodbot> bcotton: Karma for churchyard changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:31:54 <zodbot> mattdm: Karma for bcotton changed to 11 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:31:54 <mattdm> thanks yall
15:32:04 <bcotton> okay, i think that's it then
15:32:06 <bcotton> #endmeeting