14:01:33 <pwhalen> #startmeeting Fedora IoT Working Group Meeting
14:01:33 <zodbot> Meeting started Wed Jul 15 14:01:33 2020 UTC.
14:01:33 <zodbot> This meeting is logged and archived in a public location.
14:01:33 <zodbot> The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:33 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:01:33 <pwhalen> #chair pwhalen pbrobinson bcotton tdawson puiterwijk
14:01:33 <zodbot> Current chairs: bcotton pbrobinson puiterwijk pwhalen tdawson
14:01:33 <pwhalen> #topic roll call
14:01:48 <puiterwijk> .hello2
14:01:49 <zodbot> puiterwijk: puiterwijk 'Patrick "パトリック" Uiterwijk' <puiterwijk@redhat.com>
14:01:54 <pwhalen> Morning folks, sorry was distracted. Who's here today?
14:02:00 * pbrobinson is here
14:02:05 <pwhalen> howdy puiterwijk
14:02:06 <bcotton> .hello2
14:02:07 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:03:16 * tdawson is here also.
14:03:38 <pwhalen> #topic 1) ==== Working Group process and admin  ====
14:03:38 <pwhalen> #link https://docs.fedoraproject.org/en-US/iot/
14:03:59 <pwhalen> I dont have anything for admin, anyone else?
14:05:51 <pwhalen> #topic 2) ==== Fedora 32 status ====
14:06:30 <pwhalen> Any issues with F32?
14:07:10 <pwhalen> #info Latest compose is Fedora-IoT-32-20200603.0
14:07:11 <bcotton> crap, i got distracted, but i have some admin stuff. we can come back to it at the end
14:07:32 <pwhalen> heh, ok
14:08:20 <pwhalen> #info No reported issues.
14:08:28 <pwhalen> #topic 3) ==== Fedora 33 status ====
14:08:28 <pwhalen> #info Latest compose available for testing (Fedora-IoT-33-20200709.0):
14:08:28 <pwhalen> #link https://dl.fedoraproject.org/pub/alt/iot/rawhide/IoT/
14:09:35 <pwhalen> The latest compose included the btrfs change in error and doesnt boot when installed.
14:10:04 <pwhalen> #link https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=33&build=Fedora-IoT-33-20200709.0&groupid=1
14:10:36 <pbrobinson> so the btrfs has stuffed us up a little here
14:10:54 <pbrobinson> but I think that should settle down in the next few days once the anaconda bits are agreed and land
14:11:34 <pwhalen> Sounds good.
14:11:43 <pbrobinson> there's also the PARSEC change
14:11:47 <pbrobinson> #link https://fedoraproject.org/wiki/Changes/PARSEC
14:11:57 <tdawson> Just to clarify ... we aren't putting btrfs in the IoT builds, correct?
14:12:01 <pwhalen> Right, I was looking at that one yesterday
14:12:11 <pbrobinson> no, IoT is sticking to ext4
14:12:16 <tdawson> OK, thanks
14:12:34 <pbrobinson> they're just working out how to detect IoT and hence keep our defaults
14:13:17 <pbrobinson> we didn't previously need profiles because we used the "default" aka ext4, but now it's not the default we need profiles
14:13:39 <pbrobinson> for PARSEC I'm working to get that packaged up and we'll be demoing that in IoT
14:14:24 <pwhalen> We'll need to add some tests for the PARSEC change, let me know when its ready so I can get that started.
14:15:36 <pbrobinson> we're a little out from that ATM
14:16:08 <pwhalen> ok.
14:16:23 <pwhalen> Anything else for F33? Other planned changes? Concerns?
14:17:40 <pwhalen> #topic 4) ==== Open Floor ====
14:17:45 <pbrobinson> not from me
14:17:54 <pwhalen> Anything else for today?
14:18:08 <pbrobinson> I think bcotton had some admin
14:18:13 <tdawson> Nothing from me.
14:18:18 <bcotton> i did! i do!
14:18:19 <pwhalen> right, thanks
14:18:22 <pwhalen> heh
14:18:37 <bcotton> so, first thing is Badges
14:18:55 <bcotton> we now have artwork for an IoT group badge. so we need to figure out how we want to award that
14:19:04 <bcotton> a lot of badges are awarded based on membership in a FAS group
14:19:05 <pbrobinson> bcotton: yay!
14:19:17 <bcotton> alternatively, we can have a few people blessed to manually award them
14:19:38 <bcotton> or if there's some other automated way to award it, we can try to make the badges system work with that
14:19:47 <pbrobinson> what does a FAS group provide us other than auto badging?
14:19:48 <bcotton> but fas group or manual are definitely the most straightforward
14:20:20 <bcotton> not a ton, tbh. it can be used to restrict voting on elections if we ever had something we want to vote on
14:20:37 <bcotton> but it doesn't tie into pague or taiga afaik, so it's not super useful for acls
14:20:58 <bcotton> (this may change with the new AAA system, i'm not sure)
14:21:26 <pbrobinson> it sounds like it might be the easiest, and I can then just add people to the group and they get a badge
14:22:10 <bcotton> it also gets us a -members@fedoraproject.org mailing list that we can use for more private conversations if necessary (generally not necessary)
14:22:30 <bcotton> okay, and with the FAS group, it's easy to add more sponsors who can add others
14:23:23 <bcotton> so i can take getting that group created if that's the route we want to go. i'll get pbrobinson and pwhalen as admins, and then ya'll can add members and sponsors as you see fit
14:23:30 <pbrobinson> yup, I know my way around FAS from secondary arch and rel-eng days enough to be able to deal
14:23:40 <pbrobinson> bcotton: go for it
14:23:41 <pwhalen> thanks bcotton
14:23:54 <bcotton> #action bcotton to get an iot FAS group created with pbrobinson and pwhalen as admins
14:24:07 <bcotton> okay, next thing on my list
14:24:33 <bcotton> #info Fedora Council is considering a defined process for edition promotion (it's still working it's way through that process)
14:24:36 <bcotton> #link https://fedoraproject.org/wiki/Editions/Promotion_Process
14:25:01 <bcotton> so this was developed with input from peter, QA, releng, and the FPL, so it should get through basically as-is
14:25:35 <bcotton> we're past the system-wide change proposal deadline, but since a lot of the work is already done, i don't think FESCo would object to granting it a *very* late exception
14:25:37 <pbrobinson> yes, I should give that a final read through
14:26:12 <bcotton> so by the end of the week, I hope to have a draft comparing where we are and where we need to be, so we can get those boxes checked (and i fully expect to be told I'm wrong on many things)
14:26:26 <pbrobinson> it would be nice to get it closed out, it seems to have been going on for ever
14:26:29 <bcotton> i was really hopign to have that ready by this meeting, but that's not how this works
14:26:44 <bcotton> yeah, that's largely on me taking so long to write this up :/
14:26:50 <bcotton> bcotton-- :-)
14:27:08 <pwhalen> Offhand, any areas that are still of a concern?
14:28:17 <bcotton> i think QA is still a little concerned about the test cases and release criteria
14:28:34 <bcotton> and the website stuff is an open question for the moment
14:28:45 <bcotton> but nothing that's not solvable now that we have a standard to measure against
14:29:06 <pwhalen> hrm, ok. I'll see if I can find out what.
14:29:46 <pbrobinson> bcotton: BTW we had a ticket for artwork, I think it was closed, should it be reopened to update for the latest?
14:30:19 <pbrobinson> and we should probably have a ticket for website refresh with newer artwork
14:30:56 <bcotton> pbrobinson: i think a new ticket would be best. it looks like we have artwork (the three sticks thing) so it's a matter of getting the artifacts, or requesting stickers, or whatever
14:31:41 <bcotton> #link https://pagure.io/design/issue/586#comment-511125
14:31:49 <pbrobinson> bcotton: I seem to remember there was pinkish, blockish artwork too, but maybe I'm misremembering
14:32:10 <bcotton> this one? https://pagure.io/design/issue/raw/files/507c5ed12cab9b249aced58c3c696a70dc0edcd1309e3e50bdbbe37e58dec798-iot-3vars.png
14:32:14 <pbrobinson> yes, that was it
14:32:59 <bcotton> so yeah, i'd open an issue to request those artifacts in a usable form for the website, etc. and if you want stickers, i'd do that as a separate ticket
14:33:07 <pbrobinson> right
14:33:45 <bcotton> want me to open those, or do you want to do it directly?
14:33:47 <pbrobinson> from a quick read of that ticket there was design concerns and a preference for one over the others so I think it needs to evolve it?
14:34:15 <pbrobinson> bcotton: I'd love if you could as I suspect you know more of what actually needs to be requested ;)
14:34:26 <bcotton> yeah, i talked to riecatnor about it a little bit. it's not clear what the actual finalized design is supposed to be
14:34:29 <bcotton> can do
14:34:42 <bcotton> #action bcotton to request design artifacts
14:34:59 <bcotton> so we want images suitable for the website. do we want to request stickers, too? anything else?
14:37:30 <pbrobinson> bcotton: and in real world physical stickers?
14:37:30 <pbrobinson> bcotton: yes, refresh for iot.fp.o
14:37:33 <bcotton> yeah. like hex stickers
14:37:53 <pbrobinson> bcotton: YES! Like who doesn't want stickers?!?!
14:38:02 <bcotton> monsters
14:38:10 <pbrobinson> exactly!
14:38:31 <bcotton> okay, i'll open a ticket for the website, too. i can help with content and the implementation, but not the prettymaking
14:39:26 <pwhalen> thanks bcotton
14:39:30 <pwhalen> Anything else for today?
14:39:47 <bcotton> that's all i have. if i say any more, i'll end up with more #action ;-)
14:40:16 <pwhalen> #endmeeting