15:02:03 <adamw> #startmeeting Fedora QA Meeting
15:02:03 <zodbot> Meeting started Mon Aug 10 15:02:03 2020 UTC.
15:02:03 <zodbot> This meeting is logged and archived in a public location.
15:02:03 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:03 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:02:05 <adamw> #meetingname fedora-qa
15:02:05 <zodbot> The meeting name has been set to 'fedora-qa'
15:02:07 <adamw> #topic Roll call
15:02:09 <adamw> tablepc: morning...sorry, it's been a 'chasing cats around with food' kind of morning
15:02:16 * kparal is here
15:02:19 <bcotton> .hello2
15:02:20 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:02:23 * cmurf was just about to blame the cats
15:02:30 <tablepc> .hello2
15:02:31 <zodbot> tablepc: tablepc 'Pat Kelly' <pmkellly@frontier.com>
15:02:35 * bcotton is only vaguely here, but will be around for at least the first part of the blocker review meeting
15:02:51 <adamw> cmurf: too bad, i took that excuse
15:02:59 <cmurf> I mean for you.
15:03:04 <tflink> morning
15:03:12 <cmurf> I have no kitty katta
15:04:00 * kparal pokes lbrabec frantisekz lruzicka2 coremodule
15:04:10 <adamw> well you're missing out on emergency vet bills and them being as picky eaters as children only they can't talk
15:04:21 <lruzicka2> .hello2
15:04:22 <zodbot> lruzicka2: Sorry, but you don't exist
15:04:31 <lruzicka2> .hello lruzicka
15:04:32 <zodbot> lruzicka2: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
15:04:35 <defolos> .hello2
15:04:39 <zodbot> defolos: defolos 'Dan Čermák' <dan.cermak@cgc-instruments.com>
15:05:09 <tflink> oof, emergency vet bills tend to hurt
15:05:14 <adamw> how's everyone doing today?
15:05:24 <cmurf> adamw: no i'm not :P
15:05:29 <adamw> tflink: oh no, they're very soft and made of paper
15:05:32 <adamw> tflink: it's the paying them that hurts :P
15:05:40 <tablepc> It's a Sunny Happy Day Here! Sorry 'bout your kitty.
15:05:57 <tflink> adamw: fair enough
15:06:16 <adamw> tablepc: sounds good
15:06:42 <lruzicka2> it's totally hot here, my keyboard is literally melting
15:06:46 <cmurf> Dogs have owners, cats have staff? :D
15:07:05 <adamw> cats have human mattresses
15:07:07 <adamw> alrighty
15:07:07 <tflink> for some reason, I'm reminded of people who balk at paying a $200 adoption fee. how much do you think vet bills and food cost?
15:07:09 <defolos> lruzicka2: central europe?
15:07:18 <adamw> tflink: hah, yes, i think that's 80% of the reason for the fee
15:07:19 <tflink> but I'm getting way off topic here
15:07:22 <lruzicka2> yeah, Mikulov area
15:07:50 <adamw> lruzicka2: to be fair, that ice keyboard was a poor buying decision
15:08:00 <adamw> #topic Previous meeting follow-up
15:08:13 <adamw> #info no action items from last meeting
15:08:24 <adamw> you know, i'm sure we used to organize a lot more stuff at these meetings
15:08:26 <adamw> i wonder what changed
15:08:37 <adamw> are we more organized now? are we doing less? is everyone doing it behind my back on discord? :P
15:09:32 <cmurf> QA is using discord?
15:09:38 <lruzicka2> adamw, true, but it had such a nice marketing :D
15:09:48 <adamw> cmurf: i was kidding
15:09:50 <adamw> ...i hope
15:09:54 <kparal> cmurf: we don't know, because it's behind our backs
15:10:01 <cmurf> haha
15:10:03 <adamw> kparal: oh i was figuring you'd be the ringleader
15:10:17 <cmurf> HAHA
15:10:22 <lruzicka2> kparal is the cheerleader
15:10:24 <defolos> I thought there was telegram already?
15:10:28 <cmurf> kparal denies all
15:10:30 <adamw> there is
15:10:34 <kparal> I deny everything
15:11:54 <adamw> you always do
15:12:11 <cmurf> right since there's a DiscordBridge anything that happen there should be here too
15:12:20 <adamw> i mennb
15:12:21 <adamw> i mean
15:12:25 <adamw> not if it was a secret cabal
15:12:28 <adamw> that's sort of the point
15:12:43 <cmurf> a different discord forum without a bridge bot
15:13:01 <adamw> oh well
15:13:02 <lruzicka2> cmurf, I think only the fedora-qa channel is mirrored to telegram
15:13:03 <adamw> next topic!
15:13:13 * cmurf is confused
15:13:19 <adamw> #topic Fedora 33 status
15:13:22 <adamw> good, the plan's working
15:13:26 <adamw> we've got him off-balance
15:13:27 <cmurf> :)
15:13:36 <cmurf> when is he balanced?
15:13:43 <adamw> .....hm
15:14:10 <adamw> so, f33 status is...mostly working
15:14:10 <cmurf> 63 changes?
15:14:17 <adamw> and yes, very Changed
15:14:21 <cmurf> all time record or something?
15:14:24 <adamw> freeipa is very not working due to the java 11 change
15:14:25 <adamw> i believe so!
15:14:47 <adamw> we have a few known issues that are all being tracked, we have blocker review coming up at top of hour
15:15:07 <adamw> we've got about a month till beta release
15:15:18 <adamw> cmurf: what's your feeling on how btrfs-by-default is working out? i haven't seen anything on fire?
15:15:32 <cmurf> i'm posting weekly status updates on desktop@ and devel@
15:15:46 <cmurf> no fires
15:15:54 <tablepc> I have been poking it and haven't had problems so far
15:16:09 <adamw> cmurf: psssh, you expect me to read? :D
15:16:13 <cmurf> armhfp desktop images are now building, have btrfs by default (similar to aarch64 desktop images)
15:16:38 <adamw> ah cool
15:16:42 <kparal> adamw: we all know you have a direct cable connection to your brain, you have no need to parse words
15:16:56 <adamw> that sounds painful
15:17:00 <cmurf> looks like someone counted 7 ways of building images in Fedora
15:17:10 <defolos> ftr I have been running btrfs by default on my fedora machines and had no issues there
15:18:02 <adamw> cmurf: that is less than i expected!
15:18:04 <adamw> count again
15:18:29 <adamw> are we counting that way we try to build arm images that always fails but we ignore it and it's just there to confuse people?
15:18:35 <cmurf> we have an agreed way to enable the btrfs proposal's "options" but at this point I expect only compression is still on the table, window is closing though
15:18:41 <cmurf> i don't know haha
15:18:55 <adamw> cmurf: yeah, if you're planning on adding any of those, before beta freeze would be desirable
15:19:46 <cmurf> yeah i think the next week requires a firm committment to it
15:20:45 <adamw> alrighty
15:20:51 <adamw> #info Fedora 33 is mostly working
15:21:02 <adamw> #info FreeIPA is known broken due to Java 11 migration, team is working on it
15:21:36 <adamw> #info btrfs-by-default is working out well so far, they may consider enabling compression as part of 33 cycle, we would prefer before Beta freeze if so
15:22:17 <adamw> anyone have any other worries/notes about f33? late changes, anything like that?
15:22:35 <tablepc> Not me
15:22:38 <adamw> IoT validation stuff seems to be working okay, anyone have notes on that?
15:23:05 * kparal didn't study that recently
15:24:04 <adamw> pwhalen: around?
15:24:13 <michel_slm> .hello salimma
15:24:14 <zodbot> michel_slm: salimma 'Michel Alexandre Salim' <michel@michel-slm.name>
15:24:28 <adamw> hi michel
15:25:26 <michel_slm> Hi Adam! I'm here to follow the btrfs discussion
15:25:31 <adamw> aha
15:25:34 <adamw> we more or less just had it :D
15:25:40 * adamw brb
15:25:58 <lruzicka2> michel_slm, but you can say something, if you need to
15:29:23 <defolos> will there be an open floor?
15:29:30 <adamw> there will!
15:29:31 <coremodule> ooof, im late, but here
15:29:37 <adamw> sheesh
15:29:40 <lruzicka2> defolos, at the end, there usually is
15:29:40 * adamw taps watch
15:29:54 * defolos will wait
15:30:07 <adamw> gonna throw in an extra topic i forgot about
15:30:17 <adamw> #topic Criteria proposal: login/out
15:30:34 <cmurf> +1
15:30:44 <adamw> coremodule proposed adding explicit requirements related to login/logout to the criteria somehow: https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/PTRPHWTMVEKLTCMVDBGIWYYMYVIBAJYB/
15:30:51 <adamw> any extra thoughts on that?
15:31:27 <kparal> adamw: I did not get whether you agree with my version, the original version, or neither
15:31:36 <adamw> i sorta feel like adding a new separate criterion will mean we have too many login-related bits spread around different places, but i can always look after it's in and re-evaluate
15:31:53 <kparal> I proposed changing the existing one
15:32:10 <kparal> do we have many login-related criteria?
15:32:27 <kparal> Basic says the default user must work. And this would be Beta, all users must work. What else?
15:33:04 <adamw> kparal: approximately: i'd argue we could use criteria judo already but i'm also fine with adding an explicit requirement
15:33:08 <adamw> kparal: i'd have to look again :)
15:33:19 <adamw> kparal: i missed your proposal...at a quick glance it looks good to me
15:33:27 <adamw> well
15:33:54 <adamw> i feel like there's probably an option C out there
15:33:58 <adamw> but A or B would both be OK
15:34:28 <adamw> my only issue with yours is that the existing criterion is sort of a group of 'Ending Things' and this just throws in a single 'Starting Thing'
15:34:57 <adamw> but it's not a showstopper, just a small thing, and i can always propose a tweak later
15:35:15 <cmurf> the gist is we want it to work for all users
15:35:25 <kparal> or we can split it into login/logout and shutdown/reboot separate criteria
15:35:25 <cmurf> work = ability to log out and log in
15:35:51 <cmurf> work = ability to reboot/shutdown and sleep if offered
15:35:57 <kparal> adamw: if you missed my proposal, it means your brain cable is damaged
15:36:09 <tablepc> Given all the discovered failure modes, the test case will be "interesting"
15:37:39 <adamw> kparal: or my list filter thing is working against me in this case :P
15:37:44 <lruzicka2> I still do not understand what is wrong about kparals proposal
15:37:54 <adamw> kparal: i filter mails so ones sent to many lists show up in just one folder for me, but for things like this that's awkward
15:38:56 <adamw> lruzicka2: it's just a small adamw-obsession thing. shutdown, reboot and logout are all kind of "session ending actions", i kinda think of that criterion as being about "ways to end a session"
15:38:58 <kparal> adamw: the 'if kparal then move to trash' filter might be to blame ;)
15:39:09 <adamw> adding "logging in" to it breaks that concept
15:39:22 <kparal> I agree with adamw's objection
15:39:32 <kparal> we just need to decide if we want to re-tweak it now or later
15:39:52 <adamw> i vote for later
15:39:54 <kparal> where later often means never :)
15:39:57 <lruzicka2> adamw, oh I see ... kparal, we need it as soon as possible
15:39:59 <adamw> since people are waiting for open floor :D
15:40:25 <lruzicka2> adamw, I vote for let's make it until the next meeting
15:40:31 <adamw> kparal: i'll write another mail reply later and we can go from there
15:40:31 <lruzicka2> but no later
15:40:32 <kparal> the question is if we can immediately accept it. I haven't seen that much feedback
15:40:34 <cmurf> test days
15:40:34 <kparal> thoughts?
15:40:37 <cmurf> then open foor
15:40:41 <adamw> kparal: that was my thought :D
15:41:00 <kparal> ok, that means we'll have to punt the proposed blocker today
15:41:05 <cmurf> i think it's widely consented to if not explicitly agreed to
15:41:23 <coremodule> i agree with cmurf
15:41:39 <bcotton> i say we accept it and fix it later :-)
15:41:42 <lruzicka2> cmurf, what is?
15:41:44 <cmurf> but you could do another email with the criterion before and the after
15:41:51 <lruzicka2> bcotton, +1
15:42:14 <cmurf> yeah or just accept it and fix it later
15:42:30 <michel_slm> Could it be phrased as ... sessions must clean up after themselves?
15:42:44 <michel_slm> Then it's a session ending criteria
15:42:48 <michel_slm> Criterion
15:42:54 <cmurf> fwiw i brought it up at least week's wg meeting, summarized and showed the URL for kparal's email - so it has visibility
15:43:01 <cmurf> ^workstation wg
15:43:05 <lruzicka2> michel_slm, but that does not cover the loging in, does it?
15:43:33 <adamw> kparal: we can agree that we're gonna adopt one of the two proposals or something with similar effect but better wording, and block on that basis
15:43:37 <adamw> we've done that sort of thing before
15:43:49 <michel_slm> We can say ability to log in is a demonstration of a proper clean up
15:43:51 <adamw> and it has NEVER BEEN A PROBLEM (he said, daring anyone to contradict him)
15:44:01 <adamw> michel_slm: that's sort of my 'criteria judo' argument :D
15:44:14 <defolos> I got a question about respin testing, if there's going to be time
15:44:57 <adamw> proposed #agreed we're still discussing the best layout/wording to add the requirement, but there's strong agreement in principle that we ought to block on logging in as user B after logging out as user A
15:45:10 <adamw> defolos: i'll MAKE time
15:45:22 * adamw stares hard at a clock
15:45:23 <kparal> adamw: ack
15:45:24 <coremodule> im good with that
15:45:25 <coremodule> ack
15:45:33 <bcotton> ack
15:46:17 <Southern_Gentlem> **perk**
15:46:23 <defolos> so, can I add openQA tests for a respin and what should these roughly cover?
15:46:34 <adamw> defolos: can you wait a sec just so the topic lines up?
15:46:44 <adamw> there'll be time, i promise :D
15:46:48 <defolos> sure
15:46:49 <adamw> #agreed we're still discussing the best layout/wording to add the requirement, but there's strong agreement in principle that we ought to block on logging in as user B after logging out as user A
15:47:00 <adamw> #topic Test Day / community event status
15:47:02 <adamw> sumant: around?
15:47:05 <adamw> i guess not!
15:47:08 * adamw looks quick
15:47:31 <adamw> #info a kernel 5.8 test week is being arranged: https://pagure.io/fedora-qa/issue/637
15:47:56 <adamw> #info a second btrfs-by-default test day is also in the works: https://pagure.io/fedora-qa/issue/634
15:48:14 <adamw> don't think there's anything with a definite date coming up
15:48:20 <adamw> i'll try and make sure sumantro's around next week to update us
15:48:28 <adamw> any other notes before open floor?
15:49:18 <adamw> okay then!
15:49:20 <adamw> #topic Open floor
15:49:24 <tablepc> The Devel folks are discussing doing away with BIOS boot and only having UEFI boot. Is there any info as to if this will be a change for F34
15:49:26 <adamw> defolos: fire away :D
15:49:48 <defolos> I'd like to automate testing of the i3 respin
15:49:51 <cmurf> tablepc: seems unlikely
15:50:07 <adamw> tablepc: i'd say nope
15:50:09 <defolos> can I add that to the Fedora openQA tests and if yes what should I try to test?
15:50:25 <adamw> tablepc: note that thread was started by johann, who's not really a core developer on any of that stuff. it was more of an outside proposal.
15:50:37 <adamw> i'm not aware that anyone involved in bootloader, anaconda etc. development is considering that.
15:50:47 <adamw> defolos: absolutely that's possible
15:51:03 <cmurf> re: boothole (the GRUB bug that affects UEFI secure boot and has resulted in all distro keys to be revoked)
15:51:14 <adamw> defolos: it would be logical to start by enabling the existing desktop tests for i3, i guess, or at least as many of them as make sense
15:51:29 <cmurf> there is maybe a 50/50 chance we'll need an f32 respin
15:51:34 <adamw> defolos: all the code is already set up to be sort of generic and then customized by desktop, but for now the only ones we have implemented are kde and gnome
15:51:46 <michel_slm> tablepc: IIRC the discussion pointed out that (a) virtualization is not well tested with UEFI, (b) we have many legacy installs with BIOS, (c) people buying new laptops with FreeDOS would be in BIOS mode unless they toggle it too
15:52:15 <Southern_Gentlem> cmurf,  already happens  (f32 is respin about every 2 weeks)
15:52:16 <pjones> (a) seems like a /bit/ of a stretch, it could be better but it sees pretty regular usage
15:52:45 <defolos> adamw: I guess that you've created some perly-classes and inheritance for that?
15:52:59 <defolos> for the desktop generic stuff
15:53:00 <cmurf> Southern_Gentlem: yeah i mean officially and not just desktop - all of what'd be consumed by a uefi SB enabled system
15:53:45 <Southern_Gentlem> or turn off SB on move in :)
15:53:54 <cmurf> no
15:53:57 <adamw> defolos: you can ping me or lruzicka for help, but very briefly, you'd need to adapt https://pagure.io/fedora-qa/os-autoinst-distri-fedora/blob/master/f/tests/_graphical_wait_login.pm to handle the login manager used on the i3 spin, there's a couple of helper functions in https://pagure.io/fedora-qa/os-autoinst-distri-fedora/blob/master/f/lib/utils.pm and https://pagure.io/fedora-qa/os-autoinst-distri-fedora/blob/master/f/lib/fedoradistribution.pm
15:53:58 <adamw> that you'd need to adapt or check work in i3, and then you'd need to extend the desktop tests and needles themselves and update https://pagure.io/fedora-qa/os-autoinst-distri-fedora/blob/master/f/templates.fif.json and https://pagure.io/fedora-qa/fedora_openqa so tests actually get scheduled on i3
15:53:59 <lruzicka2> adamw, do you think you would add the i3 logic to the existing test cases?
15:54:14 <pwhalen> adamw: here now
15:54:51 <adamw> pjones: i might phrase it as 'using uefi on a vm is a bit more of a pain than using bios and brings zero benefits 99% of the time, so people would moan'
15:54:59 <lruzicka2> adamw, so I believe what you have just written means yes.
15:55:03 <defolos> adamw: ok, thanks a lot! I'll take a look at that
15:55:03 <pjones> sure.
15:55:08 <adamw> pjones: oh, btw, do virtualbox and co support uefi? i have no idea
15:55:18 <Southern_Gentlem> cmurf,  it will take time for the motherboard firmware to be updated with the new keys etc by then f32 will be eol
15:55:24 <cmurf> virtualbox does, but not sure if they support uefi secure boot
15:55:25 <lruzicka2> defolos, it can be tricky, ping me, if you need help.
15:55:26 <adamw> lruzicka2: off the top of my head, that's what i'd start out looking at :)
15:55:31 <pjones> I have seen patches from virtualbox people in the past in efivar/efibootmgr, so I assume so, but I've never looked.
15:55:44 <defolos> lruzicka2: sure, will do
15:55:53 <adamw> defolos: yeah, there's a bit of a learning curve with openqa at first, it's a bit out of the scope of the meeting but me and lruzicka can definitely help
15:56:05 <cmurf> qemu+kvm->libvirt->virt-manager does support both uefi and uefi secure boot out of the box now
15:56:11 <lruzicka2> adamw, I agree with the start, but I believe that the i3 (based on key activities rather than a mouse) could have its own versions of the desktop tests
15:56:14 <defolos> adamw: could I also get these tests to run when I push an update to the i3 package via bodhi?
15:56:20 <adamw> cmurf: where's the 'do we need to officially respin f32' discussion happening?
15:56:45 <cmurf> adamw: good question
15:56:51 <adamw> lruzicka2: well, a lot of the code in the tests winds up being just conditionalized anyway, so it's effectively each desktop's "own version" :)
15:56:54 <defolos> <adamw "defolos: yeah, there's a bit of "> I know that, got a bit familiar with openQA thanks to $dayjob ;-)
15:57:25 <adamw> defolos: lruzicka2: good example is https://pagure.io/fedora-qa/os-autoinst-distri-fedora/blob/master/f/tests/desktop_notifications.pm#_80 , the block to line 134
15:57:34 <cmurf> adamw: it's a "heads up" at this point, i might file a fesco ticket for tracking
15:57:35 <lruzicka2> adamw, yeah, which means it gets another branch of conditions and thigs are going to be even more complicated :D
15:57:50 <adamw> we'd probably wind up with more of that :D and some of the tests likely won't make sense to run on a minimal WM, and we might want some i3 specific ones i guess. but that's what i'd *start* with doing.
15:58:00 <adamw> cmurf: sounds like a plan. pjones, you have any thoughts on that?
15:58:18 <adamw> defolos: oh right, i forgot this isn't your first rodeo :D
15:58:23 <adamw> lruzicka2: PROGRESS!
15:58:56 <defolos> well, I'm still at trial and error ;-)
15:59:00 <pjones> I can't quite figure out what you're asking for my thoughts on.
15:59:11 <defolos> but thanks for the links, I'll give that a try and look how far I get
15:59:46 <adamw> pjones: whether we need to do an official respin of f32 for boothole
15:59:53 <adamw> cmurf said he thinks it's a 50/50 chance
16:00:09 <pjones> I don't think we will, but if we do it won't be soon
16:00:13 <adamw> okay, thanks
16:00:22 <lruzicka2> defolos, so why not start with booting up and logging in :)
16:00:51 <adamw> yeah, my starting point would be: add the image to the scheduling code, add the desktop background test to the templates, and try to get that running
16:01:11 <adamw> since you'd have to do basically nothing to the test itself. er, assuming i3 shows a desktop background. :D
16:01:23 <adamw> (heck, even if it doesn't, it's a good 'do nothing' test to start from, i guess)
16:01:27 <adamw> ok, we're over time!
16:01:30 <adamw> thanks for coming everyone
16:01:36 <tablepc> Have a Great Day Everyone!
16:01:37 <adamw> i'll start up the blocker review meeting over in #fedora-blocker-review
16:01:46 <defolos> thanks for your help adamw and lruzicka2 !
16:01:57 <lruzicka2> defolos, you are welcome any time
16:02:21 <lruzicka2> \me is moving to the blocker barbecue
16:02:26 * lruzicka2 is moving to the blocker barbecue
18:24:16 <adamw> #endmeeting