17:00:16 <mattdm> #startmeeting Council (2021-03-18)
17:00:16 <zodbot> Meeting started Thu Mar 18 17:00:16 2021 UTC.
17:00:16 <zodbot> This meeting is logged and archived in a public location.
17:00:16 <zodbot> The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:16 <zodbot> The meeting name has been set to 'council_(2021-03-18)'
17:00:17 <zodbot> bcotton: Error: Can't start another meeting, one is in progress.
17:00:18 <mattdm> #meetingname council
17:00:18 <zodbot> The meeting name has been set to 'council'
17:00:20 <mattdm> #chair bookwar dcantrell jwf riecatnor spot mattdm bcotton asamalik x3mboy sumantrom marianab
17:00:20 <zodbot> Current chairs: asamalik bcotton bookwar dcantrell jwf marianab mattdm riecatnor spot sumantrom x3mboy
17:00:22 <mattdm> #topic Introductions, Welcomes
17:00:24 <mattdm> oh no!
17:00:25 <bcotton> whiios
17:00:32 <mhroncok> what just happened?
17:00:32 <mattdm> wait meeting fight
17:00:34 <nirik> morning
17:00:34 <adamw> ahoy to the oy
17:00:49 <nirik> good ol dst.
17:00:57 <bcotton> lol, i forgot council moved to #fedora-meeting :-)
17:01:03 <mhroncok> :D
17:01:10 <bcotton> we'll move go/no-go to -1
17:01:32 <mattdm> ok whee
17:01:37 <jwf|m> Yes, it is that time of the year where this happens :D
17:01:37 * mboddu is here
17:01:43 <riecatnor> .hello riecatnor
17:01:44 <zodbot> riecatnor: riecatnor 'Marie Nordin' <mnordin@redhat.com>
17:02:01 <jwf|m> .hello jflory7
17:02:02 <zodbot> jwf|m: jflory7 'Justin W. Flory' <foss@jwf.io>
17:02:45 <mattdm> ok, so, yeah, who is here for the Council meeting? :)
17:03:13 <bcotton> if we had just been Go last week, it wouldn't have been an issue :-)
17:03:22 * bcotton is partly here
17:03:44 <mattdm> So far, riecatnor and jwf|m
17:03:58 <mattdm> if it's just the 3.5 of us, this can be a short meeting :)
17:04:51 <bookwar[m]> .hello2
17:04:52 <zodbot> bookwar[m]: Sorry, but you don't exist
17:04:57 <mattdm> ouch
17:04:59 <jwf|m> Rude!
17:05:02 <marianab[m]> .hello marianab
17:05:04 <zodbot> marianab[m]: marianab 'None' <marianaballa848@gmail.com>
17:05:18 <bookwar[m]> .hello bookwar
17:05:19 <zodbot> bookwar[m]: bookwar 'Aleksandra Fedorova' <alpha@bookwar.info>
17:05:34 <mattdm> ok, now we have quorum I think :)
17:05:36 <mattdm> #topic Today's agenda
17:05:38 <mattdm> #info Invitation for Fedora Linux to apply as a Digital Public Good
17:05:40 <mattdm> #info Readout of Websites & Apps team meeting
17:05:42 <mattdm> #info Your topics here!
17:05:43 <bookwar[m]> I think, therefore I am
17:06:31 <mattdm> Any other topics for today?
17:07:02 <jwf|m> none from me
17:07:23 <mattdm> ok, let's dive in then.
17:07:31 <mattdm> #topic Invitation for Fedora Linux to apply as a Digital Public Good
17:07:35 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/354
17:07:52 <mattdm> jwf|m Want to tell us more about this?
17:08:13 <jwf|m> Yeah! The long version is here, but I will summarize for the meeting logs
17:08:19 <jwf|m> https://pagure.io/Fedora-Council/tickets/issue/354#comment-721974
17:08:35 <jwf|m> Really there are four key benefits for Fedora going through this process:
17:08:40 <jwf|m> 1) Discoverability
17:08:47 <jwf|m> 2) Support for adoptability
17:08:55 <jwf|m> 3. Development impact
17:09:03 <jwf|m> 4. Becoming a Digital Public Good
17:09:28 <jwf|m> This is exciting to me at a personal level because it also enables me to connect Fedora Linux work and community work into more conversations in my day to day world.
17:09:43 * riecatnor is reading up
17:09:51 <bcotton> isn't 4 tautological?
17:09:59 <mattdm> bcotton: yes :)
17:10:22 <jwf|m> funnelfiasco: Hahah perhaps. But there is a difference between nomination and going through the review process
17:10:40 <mattdm> jwf can you give an example of the practical benefit this would give to your day to day work?
17:10:45 <bcotton> i also question how much it will increase our discoverability
17:11:07 <jwf|m> Sure
17:12:34 <jwf|m> The public sector is looking harder at Open Source. Historically, the technology and IT systems we build with are often from a single technology vendor who offers a proprietary service. Being able to call Fedora Linux a Digital Public Good enables me to more effectively advocate and promote Fedora Linux in the public sector space as platform for innovation
17:13:06 <bookwar[m]> I am concerned about long term impact. We may comply with the requirements as they are defined now. But does it mean that we should verify every future change in the project on whether or not it breaks those requirements? How the process would look like?
17:13:15 <mattdm> Okay, I can buy that as a benefit
17:13:18 <riecatnor> Looking at the registry, and filtering for those who have been given the DPG, it looks to be mainly applications. Do you think we would have a good chance of actually getting it if we took the time to apply?
17:13:25 <mattdm> But I'm also concerned about the requirements...
17:13:30 <mattdm> #link https://digitalpublicgoods.net/standard/
17:13:56 <jwf|m> <funnelfiasco[m] "i also question how much it will"> funnelfiasco: For discoverability, not in the traditional sense. But it does open up Fedora Linux to a new audience of people. Or enables me to actually promote it as such without getting a sharp stare :)
17:14:00 <mattdm> Some of these are pretty broad
17:14:13 <mattdm> I am particularly concerned about "Do No Harm" as a standard
17:14:20 <mattdm> "All projects must demonstrate that they have taken steps to ensure the project anticipates, prevents, and does no harm."
17:14:31 <mattdm> To be clear, I am ALL FOR not doing harm, in the abstract.
17:15:17 <mattdm> But in the specific... our software runs on computers that use rare earth metals, some of them certainly mined in bad human rights and environmental conditions
17:15:20 <bookwar[m]> mattdm: indeed this may get us in trouble as Fedora Linux goes into rhel which goes into things like military equipment
17:15:32 <mattdm> are we doing harm by providing software that powers these computers?
17:15:37 <jwf|m> <bookwar[m] "I am concerned about long term i"> bookwar: The initial process to nominate is a lengthy application. The Standard is acknowledged at the top of the United Nations by the Secretary-General, so there will be a lot more eyes and projects looking into this standard. With what I know about the process and what I know about Fedora, I think Fedora Linux exceeds the requirements in the standard
17:15:40 <mattdm> Right let alone field of use stuff
17:15:45 <bookwar[m]> Do we even want to open that direction of the conversation?
17:16:52 <mattdm> I'm also concerned with some of the specific legal obligations
17:17:14 <mattdm> I don't want to create _more_ paperwork for us on the data privacy front, for example.
17:17:47 <jwf|m> <mattdm ""All projects must demonstrate t"> Yes, it is broad but I think there are steps Fedora has taken to not do harm. Also think of it in a way like our packaging guidelines and quality assurance process too. Obviously this is not the exclusive meaning of "do no harm", but my point to make here is, you do not need to go to extreme lengths to document how Fedora Linux will not be abused
17:18:19 <jwf|m> <mattdm "I don't want to create _more_ pa"> As I understand, Fedora's in-place GDPR compliance does not make this a concern. A lot of projects we see come through the process have not considered this things too
17:18:27 <jwf|m> For example, the Sugar Labs package collection is also a nominee
17:18:34 <jwf|m> Which is something we ship as a Spin already in Fedora
17:18:34 <mattdm> We might even have trouble with "Use of Approved Open Licenses", as that says "only OSI approved licenses are accepted", but we actually maintain our own list where that is a factor
17:19:19 <jwf|m> <mattdm "We might even have trouble with "> mattdm: That is a great point, re: Use of Approved Open Licenses, but the spirit of the FPCA and our license review process is not exactly typical of most OS projects :) I think there is flexibility here.
17:20:09 <jwf|m> The big question I had is really what process/work this creates on the Red Hat side, because I am not familiar with that part of things. That's why I have suggested others not nominate Fedora Linux on its behalf
17:20:25 <mattdm> I do like that their standard for documentation is "Do you tell people how to run it?" because we've got THAT covered.
17:20:47 <jwf|m> Oh yes 🙂
17:21:06 <mattdm> I guess my main question here is whether these standards are measuring sticks or whether they create obligations
17:21:29 <mattdm> And the famous question: _will we have to sign anything_
17:21:40 <jwf|m> As a side thought, also this would enable me to encourage the different Open Source software start-ups I work with to engage and participate in the Linux packaging community like Fedora, when it makes sense to do so
17:21:52 <jwf|m> <mattdm "I guess my main question here is"> Measuring sticks is my impression
17:21:56 <jwf|m> <mattdm "And the famous question: _will w"> No, as far as I know
17:22:29 <riecatnor> jwf|m, not sure if you saw my question. Most of the DPG certified projects seem to be applications. Basically I am wondering if it is achievable, because as you mentioned the application process is lengthy etc
17:23:13 <jwf|m> riecatnor: I do think it is achievable. I opened the ticket because this conversation started somewhere else, but I figured it should start here first.
17:23:21 <jwf|m> Also it is a little personal for me
17:24:01 <jwf|m> I really think platforms like Fedora Linux and other Linux distros fit a particularly need in innovation/tech work, and I know a good bit about what we do and the work we enable in Fedora
17:24:06 <riecatnor> Makes sense
17:24:09 <jwf|m> I think it would be great to see this work represented in this way
17:24:19 <jwf|m> * I think it would be great to see our community represented in this way
17:25:14 <mattdm> I'm okay with exploring this further if we can be clear about the obligations and agreements part
17:25:44 <jwf|m> I can take some homework questions here :)
17:25:56 <jwf|m> If there are key questions or concerns I was unable to answer adequately
17:26:09 <jwf|m> It is not exactly my team, but I know the folks driving this work and can loop back with them for quick clarifications
17:26:28 <mattdm> I think I'd really like an official, concrete answer to the two questions above
17:26:41 <mattdm> plus also: How is "harm" measured?
17:26:48 <bcotton> just as a matter of procedure, might I suggest "I'd like to start a discussion" topics happen on Discussion and open tickets for when we're ready to make a decision?
17:27:01 <mattdm> bcotton++
17:27:39 <jwf|m> funnelfiasco: Yeah. That is a fair point :-)
17:28:14 <jwf|m> I'll take mattdm's two questions plus seeking clarity of definition of "do no harm" back to the team
17:28:21 <mattdm> jwf|m: thanks!
17:28:30 <jwf|m> Any other questions about this? Or the process?
17:28:41 <mattdm> jwf|m: can you also start a thread on Discussion?
17:28:47 <jwf|m> Yes, can do
17:28:49 <jwf|m> #nick jwf
17:29:04 <jwf|m> #action jwf Post a new Discourse thread about the Digital Public Goods nomination as discussed today
17:29:07 <bcotton> jwf[m]: not yet, but i also haven't done the homework yet :-)
17:29:13 <mattdm> ok next topic
17:29:15 <mattdm> #topic Readout of Websites & Apps team meeting
17:29:19 <jwf|m> <eof> if there are no other questions :)
17:29:24 <jwf|m> thanks
17:29:28 <mattdm> thanks jwf!
17:29:42 <mattdm> This is more of an FYI?
17:30:12 <jwf|m> Want me to summarize, or you or riecatnor?
17:30:26 <mattdm> jwf|m: if you can that'd be awesome
17:30:32 <jwf|m> I don't think there is a clear Council discussion tho
17:30:33 <mattdm> #link https://discussion.fedoraproject.org/t/planning-meeting-for-websites-apps-team-reboot/27911
17:30:34 <jwf|m> That we need action on
17:30:38 <jwf|m> OK cool, but I can summarize
17:30:44 <jwf|m> The link there has a lot of details too
17:31:01 <jwf|m> The short story is, we are taking it slow on booting this work up and identifying the folks we need to involve in these conversations to be successful.
17:31:10 <mattdm> yeah I think it might become a council topic if it gets to the point of wanting an objective. But it's also pretty important een if we don't do that.
17:31:15 <jwf|m> We are likely moving forward with a new Objective proposal.
17:31:47 <jwf|m> There are two newer folks in the community with energy to help drive this. I'll help as an informal "Objective mentor" for some behind-the-scenes and workflow processes
17:32:06 <jwf|m> We meet again tomorrow, our last planned meeting with mattdm and riecatnor
17:32:25 <bcotton> has Rick Elrod been involved in this?
17:32:26 <jwf|m> I hope we can better track how we gather requirements for this Objective, and hopefully can get a rough draft going on the copytext.
17:32:36 <jwf|m> This is the key summary from me. mattdm or riecatnor, anything you want to add?
17:32:50 <riecatnor> I also spoke with lilyx and they are interested in being involved, I believe they plan to be at the next meeting
17:32:56 <jwf|m> funnelfiasco: Not yet. We reached out to him today actually.
17:33:08 <jwf|m> riecatnor: Excellent, looking forward to seeing them there :)
17:33:27 <mattdm> Yeah I was going to ask -- I saw some discussion about relrod's involvement. In retrospect we should have made sure he was at that last meeting
17:33:36 <jwf|m> Yeah :D
17:33:41 <jwf|m> Hindsight is always 20/20
17:34:06 <jwf|m> Anyways, we noticed that he was missing from these conversations and definitely want him to be involved. We invited him to tomorrow's meeting, but it was last minute
17:34:08 <mattdm> In any case this is definitely about more help, not taking anything away
17:34:20 <jwf|m> If he cannot make it tomorrow, we'll find time to get him up to speed on what we are thinking/working on
17:34:24 <jwf|m> mattdm: Yes +1!
17:34:31 <mattdm> jwf|m: awesome
17:34:41 <mattdm> ok, I think that's all on that?
17:34:47 <jwf|m> No more from me :)
17:34:54 <mattdm> #topic Next meeting
17:34:56 <mattdm> #info The next regular business meeting is Thursday 1 April
17:34:57 <jwf|m> Thanks for the initial support getting this going mattdm and riecatnor
17:35:04 <mattdm> obligatory #thisisnotajoke
17:35:23 <mattdm> #topic Do we have anything to announce?
17:35:25 <riecatnor> jwf|m, of course! happy to see it happening
17:35:25 <mattdm> #info This is a regular check to make sure we're communicating to the contributor (via CommBlog) and user (via Magazine) communities
17:35:28 <riecatnor> i have a thing
17:35:42 <mattdm> riecatnor: an annoucement thing or another thing?
17:35:46 <riecatnor> #info Fedora D&I team is having a virtual meetup this weekend
17:35:48 <riecatnor> #link https://hopin.com/events/fedora-diversity-inclusion-team-meetup
17:35:53 <mattdm> an announcement thing! nice.
17:35:57 <riecatnor> and one more
17:36:04 <mattdm> go for it :)
17:36:07 <jwf|m> \o/
17:36:13 <riecatnor> #info Our yearly contributor conference will be virtual, Nest with Fedora 2021 edition
17:36:25 <riecatnor> #link https://communityblog.fedoraproject.org/nest-with-fedora-2021-edition/
17:36:40 <riecatnor> thats it for today!
17:37:10 <mattdm> Looking forward to Flock in Detroit in 2022 for sure :)
17:37:19 <mattdm> I mean, also Nest was awesome and I'm sure it will be again
17:37:33 <riecatnor> I am with you on all points
17:37:34 <mattdm> hey bcotton how did that other meeting go? any outcome to report?
17:37:38 <jwf|m> Simultaneous "yay!" and "awww". But super looking forward to catching up with Fedora friends proper again. Nest 2020 was my #1 virtual event I attended last year
17:37:57 <bcotton> F34 Beta is GO
17:38:02 <riecatnor> WOOOOOO
17:38:08 <jwf|m> Yeaaaaahhhhh!
17:38:15 <mattdm> #info Fedora Linux 34 Beta is GO!
17:38:22 <bookwar[m]> wow
17:38:28 <bookwar[m]> great news!
17:39:12 <mattdm> indeed!
17:39:21 <mattdm> #topic Open floor
17:39:27 <mattdm> anything else anyone wants to talk about?
17:39:48 <mattdm> I'm doing an interview for a new RH podcast in 20 minutes, so I for one wouldn't mind ending early :)
17:40:04 <jwf|m> We're getting close to the end of the cold months in the northern hemisphere. Hope folks are doing well and warm :) But nothing else serious from me
17:40:15 <jwf|m> +1 to end early
17:40:16 <mattdm> ok, thanks everyone!
17:40:19 <mattdm> #endmeeting