17:01:10 <michel_slm> #startmeeting fedora-server
17:01:10 <zodbot> Meeting started Wed Apr  7 17:01:10 2021 UTC.
17:01:10 <zodbot> This meeting is logged and archived in a public location.
17:01:10 <zodbot> The chair is michel_slm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:10 <zodbot> The meeting name has been set to 'fedora-server'
17:01:34 <Southern_Gentlem> michel_slm, yep past time
17:01:52 <Southern_Gentlem> .hello
17:01:52 <zodbot> Southern_Gentlem: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:02:02 <Southern_Gentlem> .hello2
17:02:03 <zodbot> Southern_Gentlem: Sorry, but you don't exist
17:02:07 <Astranox> .hello astra
17:02:08 <zodbot> Astranox: astra 'David Kaufmann' <astra@ionic.at>
17:02:09 <dcavalca> .hi
17:02:10 <Southern_Gentlem> .hello jbwillia
17:02:11 <zodbot> dcavalca: dcavalca 'Davide Cavalca' <dcavalca@fb.com>
17:02:14 <zodbot> Southern_Gentlem: jbwillia 'Ben Williams' <vaioof@gmail.com>
17:02:15 <michel_slm> #topic Introductions
17:02:54 <michel_slm> if others might want to add things to the meeting logs I can make you co-chairs (looking at last week's notes and I don't see anyone)
17:02:56 <michel_slm> .hello salimma
17:02:58 <ab> .hello abbra
17:02:58 <zodbot> michel_slm: salimma 'Michel Alexandre Salim' <michel@michel-slm.name>
17:03:01 <zodbot> ab: abbra 'None' <abokovoy@redhat.com>
17:03:13 <fsaez> .hello fsaez
17:03:14 <zodbot> fsaez: fsaez 'None' <fsaez@fesatel.cl>
17:03:27 <pboyHB> .hello pboy
17:03:28 <zodbot> pboyHB: pboy 'Peter Boy' <pboy@uni-bremen.de>
17:04:15 <michel_slm> #chair pboy
17:04:15 <zodbot> Current chairs: michel_slm pboy
17:04:50 <michel_slm> let's wait another minute for anyone else who might join, then we can continue with the PRD
17:05:40 <michel_slm> #topic Reviewing the PRD update
17:05:43 <pboyHB> IIn the meantime see   https://hackmd.io/@x3mboy/By5OkH71O
17:05:51 <michel_slm> #info draft PRD here https://hackmd.io/@x3mboy/By5OkH71O
17:06:02 <x3mboy> .hello2
17:06:03 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
17:06:06 <michel_slm> #info we are discussing changes to section 7
17:06:15 <michel_slm> #chair x3mboy
17:06:15 <zodbot> Current chairs: michel_slm pboy x3mboy
17:06:30 <michel_slm> #chair pboyHB
17:06:30 <zodbot> Current chairs: michel_slm pboy pboyHB x3mboy
17:06:50 <pboyHB> Specifically 7.1 Personas
17:07:07 <michel_slm> pboyHB: want to take this part?
17:07:24 <pboyHB> michel_slm: OK.
17:07:46 <pboyHB> I added some comments to 7.1 Personas
17:08:49 <pboyHB> First question: Do we have to add an item / another  type of "Personas" ??
17:09:25 <michel_slm> looks like "The Operator" and "Let's make a distribution" personas are new (compared to the original PRD anyway)
17:10:16 <pboyHB> Yes, there was a proposal to add them by daniel-wdt
17:11:06 <pboyHB> My suggestion: Omit Operator, because it is redundant to admin (we have several types of admin)
17:11:13 <michel_slm> for Let's make a distribution - do we still call them remixers in Fedora? If so might be worth adding that term, maybe in parentheses
17:12:11 <pboyHB> I don't know. if we do, we should /use that therm
17:12:18 <michel_slm> dcavalca: might be able to chime in here. my impression is, yeah, there's an overlap between the different admin personas and operator, but what could be missing (that we can reuse some operator parts for) is "the hyperscaler"
17:13:29 <michel_slm> emphasis on automation, budget not constrained but manhour is, so the focus is on fleet health / uptime and redundancy rather than individual server uptimes
17:13:37 <x3mboy> For "Let's make a distribution" I think it's everyone. We all make our own Fedora Server after install
17:13:51 <michel_slm> but... that might not fit many existing Fedora Server users so I'm fine dropping it too
17:14:14 <dcavalca> michel_slm: yeah, I think it boils down to the "servers as cattle not pets" approach
17:14:19 <michel_slm> x3mboy: when I read that part it sounds more like someone who wants to make a spin/remix of server with extra packages / custom branding
17:14:37 <michel_slm> dcavalca: I keep forgetting that phrase, yeah
17:14:40 <pboyHB> x3mboy: we make aour owninstallation, but not our own  distribution, don't we?
17:15:37 <x3mboy> Mmm Ok, makes sense
17:15:48 <x3mboy> I'm on "The Home Admin" field
17:15:53 <pboyHB> michel_slm: I don't find  hyperscale
17:16:28 <michel_slm> pboyHB: hyperscale is what I suggested we replace / turn "The Operator" to
17:16:36 <michel_slm> esp if we think "Operator" is redundant
17:16:46 <pboyHB> OK get it
17:17:39 <pboyHB> michel_slm>: Nevertheless, most of the subiitems are redundant to various admin types obove
17:19:08 <pboyHB> Do we agree to drop Operater, but save the paragraph about automation in one of the other admin types?
17:19:21 <michel_slm> for reference, this is what the CentOS Hyperscale goal / mission is, and I could imagine people contributing there would want to contribute here as well: https://wiki.centos.org/SpecialInterestGroup/Hyperscale
17:20:07 <pboyHB> So, do we agree to keep Operator but ti rename to Hyperscaler ??
17:20:29 <pboyHB> If noene objects I'll agree that
17:20:31 <michel_slm> +1
17:20:42 <dcavalca> works for me
17:20:52 <michel_slm> I can add a comment and suggest minor edits from what we discussed here
17:21:32 <pboyHB> #agreed Operator rename to Hyperscaler and additions / modificationy by michel_slm
17:21:45 <michel_slm> #info next, section 7.2 - Use Cases
17:22:13 <michel_slm> please look at alternate numbering, 1-5, not the original list - the original is just a grab bag of ideas
17:22:58 <pboyHB> Yes, we have to decide if tthat items 1-4 include all relevant arguments
17:23:10 <pboyHB> items 1-5 !
17:23:42 <michel_slm> cloud seems missing, but I suppose unless the cloud people want to join us we shouldn't mention them
17:24:48 <pboyHB> michel_slm: Yes, depending on the discussion we may have to change something
17:25:21 <pboyHB> I see no objections /additions, I'll agree in a minute
17:25:30 <michel_slm> let's discuss cloud separately after this, I'll add it as a topic
17:26:11 <pboyHB> #agreed  section 7.2 7 another numbering as suggested
17:27:04 <michel_slm> #info reviewing section 7.3 Most Important Features
17:28:09 <pboyHB> Maybe we should restrict to 5 most important?
17:28:28 <pboyHB> Or are all items equally importrant?
17:28:32 <michel_slm> that looks more complete to me than last time. but... hmm yes, some of these could be consolidated
17:28:57 <michel_slm> ab: thoughts? IIRC you chimed in on FreeIPA last time
17:29:25 <pboyHB> FreeIPA ist item 3
17:29:33 <michel_slm> I think #1 (deploy and configure) and #5 (redeploy) can be merged
17:29:39 <fsaez> I think this section would be missing a mention of devs
17:29:55 <michel_slm> #2 and #4 as well, it's about monitoring
17:30:24 <pboyHB> #1 und #3 as well, both about IPA
17:30:36 <ab> looking again...
17:31:01 <michel_slm> if 1 and 5 is merged, then #3 can have all the key server apps we want to showcase listed there
17:31:20 <michel_slm> #7 and #8 can be merged to be about everything headless
17:31:28 <michel_slm> then we're down to 5
17:31:58 <pboyHB> michel_slm: +1
17:32:34 <pboyHB> no objections so far,I'll agree in 1 minute
17:32:40 <ab> I think we can move FreeIPA-related part into 3. For example, "The user can simply deploy and configure Fedora Server to provide domain infrastructure with FreeIPA and Samba Active Directory."
17:33:12 <ab> from #1 we can remove examples
17:33:37 <pboyHB> Alternativ: We move part of# 1 (the services) to #3 as michel suggested.
17:33:40 <ab> "domain infrastructure" would cover both domain controllers and domain members while current #3 only talks about domain members
17:33:57 <pboyHB> ab: +1
17:34:24 <ab> pboyHB: #3 is not about services that run on Fedora Server, it is about a very specific act of coordinating fleet of machines in the same identity and authentication space
17:34:41 <michel_slm> ab: I like the wording. one question -- the current #3 suggests FreeIPA joining an existing AD, your new wording suggests it acts as domain controller
17:34:52 <michel_slm> which do we want it written, or both?
17:35:00 <michel_slm> ab: good point, yes
17:35:07 <ab> michel_slm: we need to say 'domain infrastructure'
17:35:20 <michel_slm> ah, so we do want it to cover both cases (implicitly)
17:35:25 <ab> yep
17:35:44 <ab> we do already, so this is just clarification of the state and an attemp to reduce amount of items
17:36:02 <pboyHB> Is it agreed: condense as michel suggested, keep #3 in modified wording as suggested by ab?
17:36:12 <ab> +1
17:36:14 <michel_slm> +1
17:36:16 <Astranox> +1
17:36:35 <dcavalca> +1
17:36:42 <fsaez> +1
17:36:43 <pboyHB> #agreed  condense 7.3  as michel suggested, keep #3 in modified wording as suggested by ab
17:37:02 <michel_slm> so.. that's it for PRD today, next, the new documentation site?
17:37:15 <pboyHB> OK for me
17:37:34 <ab> ok for me too
17:37:36 <michel_slm> #info https://docs.fedoraproject.org/en-US/fedora-server/
17:37:41 <pboyHB> We agreed last meeting about the navigation items.
17:38:03 <pboyHB> We need comments / ideas about the content now.
17:38:05 <ab> sorry, have to leave for birthday's dinner
17:38:12 <michel_slm> in his email pboyHB asked for suggestions and content contribution
17:38:15 <michel_slm> ab: happy birthday!
17:38:40 <pboyHB> ab: Good appetite
17:38:53 <michel_slm> pboyHB: to maintain coherence - should additions be made as pull requests? then either you can approve them or we can review them in this meeting
17:39:29 <pboyHB> michel_slm: Yes either as pull requests or as issue
17:39:49 <michel_slm> +1
17:40:16 <michel_slm> #info please send your PRs adding content to the new docs site
17:40:43 <michel_slm> any specific content suggestion people want to bring up?
17:40:57 <pboyHB> Hui, we are very quick today !
17:41:27 <michel_slm> yeah, we're on a roll :)
17:42:10 <michel_slm> so we do have two more topics before open floor, let's wait another minute here then move on
17:42:40 <michel_slm> #info state of F34 packages
17:43:15 <michel_slm> this one should be fast. apart from nextcloud which is fixed - do we notice anything else we might want to urgently fix?
17:44:29 <michel_slm> nothing is broken :D
17:44:43 <michel_slm> oops, that info was supposed to be topic
17:44:55 <michel_slm> #topic collaboration with Cloud WG
17:45:52 <michel_slm> so... last week it's apparent the Cloud WG knows we want to reach out. should we start engaging more formally? e.g. start a thread in our mailing lists?
17:45:52 <pboyHB> To my knowledge, there is no new status at this time. Maybe smooge knows more?
17:46:44 <copperi_> dustymabe is on the roll again, so definitely should engage more
17:46:47 <pboyHB> From our side smooge is engaged. Perhaps we should trigger him?
17:47:04 <pboyHB> Maybe after F43 is out of the door?
17:47:13 <michel_slm> * F34 :)
17:47:14 <pboyHB> too fast F34
17:47:34 <michel_slm> yeah, not urgent now. I can check with smooge if he is at the EPEL meeting later today
17:48:11 <pboyHB> yeah, we shouldn't rush
17:48:16 <michel_slm> agreed
17:48:38 <michel_slm> that's it, then, for the planned agenda? I'll open the floor
17:48:42 <michel_slm> #topic Open floor
17:49:17 <michel_slm> (speaking of F34, here's to hoping we can launch the new PRD around that time)
17:49:17 <dustymabe> pboyHB: I saw your email. will try to respond.
17:49:25 <pboyHB> I would suggest to continue to announce the agenda on the mailing list. That makes it more widely visible than on pagure.io,
17:49:44 <pboyHB> dustymabe: Thanks
17:50:16 <michel_slm> pboyHB: the way other WGs I see do it, people can file ahead of time, and the meeting chair summarizes the agenda in the calendar so when the meeting reminder get sent out it has a full agenda
17:50:28 <michel_slm> I ... clearly didn't edit the calendar in time this week :)
17:50:49 <michel_slm> but yeah, I think we can hold off on pagure.io until this meeting gets so busy we need to pre-discuss items
17:50:59 <pboyHB> michel_slm: Yeah, we have to find our routines.
17:51:40 <pboyHB> michel_slm: +1 to hold off on pagure
17:51:41 <michel_slm> any volunteer for chairing next week?
17:52:18 <michel_slm> #agreed meeting agenda topics to be solicited in the mailing list for now
17:52:41 <pboyHB> chair?  Not such a scramble
17:53:15 <michel_slm> (if nobody volunteer, I can do it again, but I'll be oncall at work so ... I would prefer not to risk it)
17:53:20 <pboyHB> Michel, you again?
17:53:37 <michel_slm> so I can chair but I need a backup, at lesat
17:53:39 <michel_slm> *at least
17:53:49 <pboyHB> I can do it
17:54:03 <michel_slm> pboyHB++
17:54:17 <michel_slm> #action pboyHB to chair next week's meeting
17:54:52 <michel_slm> last call for other discussion items? otherwise we can have a few minutes back
17:55:04 <pboyHB> I thought about the backup.  :-) But OK we can share the shair
17:55:13 <pboyHB> chair!
17:55:25 <michel_slm> oh, sorry!
17:55:28 <copperi_> you can have several people as chair
17:55:37 <michel_slm> #action michel to chair next week's meeting, with pboyHB as backup
17:55:47 <copperi_> so if one drops next can continue
17:56:10 <michel_slm> yeah, we do have a few people I mark as chairing this time, just so we can share the minute-taking
17:56:53 <michel_slm> ok, that's a wrap for today! thanks everyone for coming
17:57:04 <michel_slm> #endmeeting