17:00:05 <pboyHB> #startmeeting fedora-server
17:00:05 <zodbot> Meeting started Wed Apr 14 17:00:05 2021 UTC.
17:00:05 <zodbot> This meeting is logged and archived in a public location.
17:00:05 <zodbot> The chair is pboyHB. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:05 <zodbot> The meeting name has been set to 'fedora-server'
17:00:16 <pboyHB> hi everyone!
17:00:24 <pboyHB> We should give a few minutes for folks to show up
17:00:34 <pboyHB> #info please say either .hello2  or .hello <fasname>  (the latter if your nick here is not your fasname)
17:00:46 <pboyHB> I’ll post the agenda in a few minutes.
17:01:01 <jdubby> .hello jwhimpel
17:01:01 <zodbot> jdubby: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:03:25 <pboyHB> We seem to be in small group today.
17:03:32 <pboyHB> Nevertheless
17:03:41 <pboyHB> #topic Agenda
17:03:50 <pboyHB> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/JMZY2TI3W6QMKDPNSZ2SRQN5QDW46A4A/
17:04:04 <pboyHB> 1. Welcome
17:04:05 <pboyHB> 2. Agenda
17:04:12 <pboyHB> 3. PRD update discussion
17:04:19 <pboyHB> 4. Status F34 Release
17:04:25 <pboyHB> 5. Contributions to F34 release notes
17:04:42 <pboyHB> 6. Status New Documentation
17:04:45 <pboyHB> 7. Open Floor
17:05:14 <pboyHB> Any additions?
17:05:29 <jdubby> pboyHB: Seems reasonable to me
17:05:38 <pboyHB> OK
17:05:48 <pboyHB> #topic PRD update discussion
17:05:57 <pboyHB> #link  https://hackmd.io/@x3mboy/By5OkH71O
17:06:42 <jdubby> pboyHB: To be honest, I studied engineering in college to avoid taking language classes.  Do not know how much help I will be on editing PRD. :-(
17:07:03 <pboyHB> We have do decide about section 8: future goals
17:07:51 <pboyHB> jdubby: Yes, but perhaps you have ideas about goals?
17:08:03 <pboyHB> No editing text.
17:09:10 <jdubby> pboyHB: Bringing up document now in browser.
17:09:46 <pboyHB> Question is, are the goals beneath 'Another numbering'  valid? Even if they are, do we want do it?
17:11:35 <pboyHB> I have the impression that it would be better to drop this section.
17:12:47 <jdubby> pboyHB: I can only speak for myself.  I use a lot of VM's for testing and production.  I tend to maintain them all in ansible playbooks.  Finding examples of how to create VMs and remote bare-metal installs is hard to find.  I would hope we could address some of that.
17:14:02 <jdubby> pboyHB:  I would especially think #3 would be important for us to do in the near future.
17:14:52 <pboyHB> jdubby: I've written some documentation about bare-metal installs, and VM creation (rsp. I'm in the process to complete.  Probably you can check them for technical correctness?
17:15:25 <pboyHB> jdubby: +1 for use of cloud images
17:15:42 <jdubby> pboyHB: Forward them to jwhimpel@fedoraproject.org and I'll try to find time to review them.
17:16:15 <pboyHB> jdubby: Thanks! I'l mail them tomorrow.
17:17:49 <jdubby> pboyHB:  I do not know how many large sites would be interested in using Fedora as a server, but I would think a lot of SOHO sites might find it attractive.  Many of them do not have experiences SA's on staff.  Examples of configurations/playbooks that are known to work, would always be greatly appreciated as a starting point.
17:18:27 <ab> +1
17:18:28 <jdubby> pboyHB: s/experiences/experienced/
17:19:37 <pboyHB> jdubby: Yes, I'm to write documentation about ansible and Fedora Server. Maybe we can discuss some details, when I start writing?
17:20:33 <pboyHB> The ansible playbook project at github is difficult for me to understand.
17:20:59 <jdubby> pboyHB:  Glad to.  I've been using ansible to maintain my small home datacenter for about six months.  Doesn't make me an expert, but give me some insight on what NOT to do.  :-)
17:21:40 <pboyHB> to know what NOT to do is half the way. :-)
17:22:06 <jdubby> pboyHB:  I have the scars to prove it.
17:22:35 <pboyHB> It you have a look at the unedited items 1- 14, do you thing there is an imortant one which we should add to the edited list?
17:26:48 <jdubby> pboyHB:  I do not know if the PRD is the place to say that our WG should be an active advocate and reviewer of proposed system changes to see how they will affect the Server variant.
17:27:48 <ab> I think it is a good proposal -- as shown with systemd-resolved integration in F33+, being part of those discussions will help to avoid breaking changes
17:28:10 <jdubby> pboyHB:  But I do think that is something that we need to do.  For instance, is XFS or BTRFS better for servers?  If no clear answers, then pros/cons of each solution should be documented.
17:28:19 <pboyHB> jdubby: I think that is an important point and we should really do it.
17:29:09 <pboyHB> XFS - BTRFS is a critical issue, including much protiential for discussion.
17:29:17 <pboyHB> ab: Welcome!
17:30:05 <pboyHB> I think, we should make jdubby proposal to a new addition topic.
17:30:43 <ab> pboyHB: as for the 1-14, most of those are condenced in the edited items.
17:30:50 <jdubby> +1 (obviously)
17:30:57 <pboyHB> Proposal: topics 1, 3, combined 4. and 5. as ansible centered, and new as suggested.
17:30:57 <ab> +1
17:31:38 <pboyHB> agreed: all arguments of uneditied list of topics is
17:31:53 <pboyHB> (1-14) are included in edited list
17:32:14 <pboyHB> Sorry, wrong key pressed. :-)
17:32:45 <pboyHB> Next try:
17:33:09 <pboyHB> #agreed: all arguments of uneditied list of topics (1-14) are included in edited list
17:34:43 <pboyHB> #agreed:  Goals are 1, new 2 as 2 + 3, new 3 is about ansible (4+5) new 4 is about active advocate and reviewer of proposed system ...
17:35:26 <pboyHB> Next Section is "Logistical Concerns"
17:35:38 <pboyHB> Any ideas? I think it is OK as is.
17:37:11 <pboyHB> I see no ideas.
17:37:15 <ab> yes, I think so.
17:37:24 <pboyHB> #agreed: Section 9 as is
17:37:45 <jdubby> pboyHB:  I think we ought to coordinate with the virt-*** people to have them maintain server images for installation in VMs.
17:38:35 <pboyHB> jdubby: Who do you mean by  virt-***. cloud wg?
17:39:14 <jdubby> pboyHB:  Using their current "minimal" image for virt-*** processing currently works, but do not always have server settings.
17:40:05 <pboyHB> Yes, I tried cloud base image, I think it needs some love.
17:40:15 <jdubby> pboyHB:  virt-install  virt-sysprep  virt-build family of commands.  They are very useful via ansible for spinning up quick VMs.
17:40:25 <pboyHB> Are there other server images anywhere on Fedora?
17:41:08 <ab> jdubby: what do you want to do with them? virt-* does not maintain any images, they produce tools
17:41:09 <pboyHB> jdubby: I suppose, they concentrate on the tool, not on produce something with that tools.
17:41:38 <jdubby> I know the team that handles the virt stuff has a repository of images.  As I said, they have minimal, but I don't think they have server.
17:41:57 <ab> those images are not Fedora project deliverables
17:42:03 <pboyHB> jdubby: OK, I didn't know.
17:42:35 <jdubby> I can't recall the exact syntax, but the virt tools has a command to list all of their supported images (far beyond just Fedora)
17:43:15 <pboyHB> What about trying to create ansible playbooks to create good vms?
17:44:10 <pboyHB> II'm not sure about using third party
17:44:34 <pboyHB> I think, we have some Fedora project rules about that.
17:45:59 <pboyHB> We should start a discussion of its own about createing and delivering vm images. (as part of out working goals :-). )
17:46:31 <jdubby> I'm not sure, but I know that many of the virt tools team are RedHat employees.  All of their tools are in the Fedora repositories and they all use these images.
17:47:11 <pboyHB> Good to know. I think it is really worth a dedicated discussion.
17:47:11 <jdubby> I don't disagree with starting a discussion, but it should involve folks a lot more knowledgeable than me.
17:47:41 <pboyHB> jdubby: +1
17:48:00 <pboyHB> We could start on the mailing list.
17:48:34 <pboyHB> What about topic 10: Authors of PRD proposal?
17:49:27 <pboyHB> I think, we should menteion the current list as authors of version 1 and all contributors as authors of version 2?
17:49:52 <jdubby> I personally do not think it's important, but I know that in the academic world it's everything.  Your suggestion seems fine.
17:51:20 <pboyHB> #agreed:  Vor version 2 of PRD a list of contributers here.
17:51:43 <pboyHB> #topic Status F34 Release
17:52:32 <pboyHB> 2 weeks ago we had a short discussion, that in F34 are a lot of changes we have to think about. Any ideas?
17:53:10 <jdubby> I know that test days for F34 have begun, but I haven't has any spare cycles to participate.
17:53:38 <pboyHB> Samefor me. But I try to text virtualization.
17:53:49 <pboyHB> Sorry, my typos !!!
17:54:01 <pboyHB> not text but test
17:54:34 <pboyHB> I couldn't text yet, so there is no text.
17:55:04 <pboyHB> OK, so I guess we have nothing to discuss at the moment.
17:55:21 <pboyHB> #topic Status New Documentation
17:55:24 <ab> There was a regression introduced by systemd 248-1 with regards to FreeIPA installation with integrated DNS server and auto-created reverse DNS zones. The bug for it was made a release blocker for F34. We fixed FreeIPA to recognize this particular situation during install and pushed the changes to Rawhide + F34. It should  be in updates-stable tomorrow.
17:56:10 <pboyHB> ab: good to know.
17:56:30 <pboyHB> But regarding to topic:
17:56:42 <pboyHB> #Link: https://docs.fedoraproject.org/en-US/fedora-server/
17:56:52 <pboyHB> I had recently a short dicussion with Matthew , who ‚ignited‘ the project some time ago.
17:57:01 <pboyHB> His assessment is, we should make the documentation with the current content public as soon as possible and initiate a 'box' on the Fedora Docs page.
17:57:17 <pboyHB> So, we should now start organizing English native speakers to smooth and refine the wording.
17:57:58 <pboyHB> I'm woorking with copperi to split the current repo into 'mein' = final and devel branch.
17:58:12 <pboyHB> That's just an info today.
17:58:45 <Southern_Gentlem> pboyHB, suggest that you have more than one chair for the meeting
17:58:57 <pboyHB> But we should do the final steps as soon as F43 is out of the door and we may have more time
17:59:35 <pboyHB> Southern_Gentlem: Yes, we had today Michel, but he is busy
17:59:55 <Southern_Gentlem> chair jdubby
18:00:16 <Southern_Gentlem> that way is you lost internet the meeting can be closed
18:01:10 <jdubby> I'm afraid my zodbot foo is pretty awful.  My attendance will be spotty next next six weeks.
18:01:36 <Southern_Gentlem> jdubby,  #endmeeting is not that hard
18:01:59 <jdubby> If that is all there is to do, then I could do that!
18:02:10 <pboyHB> Southern_Gentlem: I'm inGermany, We don't loose internet ( least if we have one at all). :-)
18:02:24 <pboyHB> OK:
18:02:31 <pboyHB> #topic Open Floor
18:02:39 <Southern_Gentlem> lot of hops between you and the bot and crap happens
18:03:02 <pboyHB> Southern_Gentlem: Yes, I tried a joke
18:03:16 <jdubby> I need to go.  Face-to-face across town in 30 mins.  Bye
18:03:47 <pboyHB> a joke about Germans and their self-image
18:04:04 <pboyHB> jdubby: by by, I'll send a mail
18:04:41 <Southern_Gentlem> i should be around for mostmeeting (depends on $dayjo)
18:05:17 <pboyHB> OK. time is up. Si i'll close in a minute.
18:06:12 <pboyHB> #endmeeting