11:30:08 <gregbartholomew> #startmeeting Magazine editorial board
11:30:08 <zodbot> Meeting started Wed Apr 21 11:30:08 2021 UTC.
11:30:08 <zodbot> This meeting is logged and archived in a public location.
11:30:08 <zodbot> The chair is gregbartholomew. Information about MeetBot at http://wiki.debian.org/MeetBot.
11:30:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
11:30:08 <zodbot> The meeting name has been set to 'magazine_editorial_board'
11:30:08 <gregbartholomew> #meetingname magazine
11:30:08 <zodbot> The meeting name has been set to 'magazine'
11:30:09 <gregbartholomew> #topic Roll call
11:30:09 <gregbartholomew> #chair ryanlerch cverna asamalik sub_pop gregbartholomew jakfrost misc rwaltr bcotton rlengland
11:30:09 <zodbot> Current chairs: asamalik bcotton cverna gregbartholomew jakfrost misc rlengland rwaltr ryanlerch sub_pop
11:30:17 <gregbartholomew> .hello glb
11:30:18 <zodbot> gregbartholomew: glb 'Gregory Lee Bartholomew' <gregory.lee.bartholomew@gmail.com>
11:31:21 <gregbartholomew> #topic Agenda
11:31:21 <gregbartholomew> #link https://docs.fedoraproject.org/en-US/fedora-magazine/workflow/
11:31:21 <gregbartholomew> #info -- 1/ Last week's stats --
11:31:21 <gregbartholomew> #info -- 2/ In progress followup --
11:31:21 <gregbartholomew> #info -- 3/ Finished articles to review --
11:31:22 <gregbartholomew> #info -- 4/ Articles to edit --
11:31:23 <gregbartholomew> #info -- 5/ Publishing schedule --
11:31:25 <gregbartholomew> #info -- 6/ Editor of the Week --
11:31:27 <gregbartholomew> #info -- 7/ Open floor --
11:31:35 <gregbartholomew> #info Week of April 12: 60K pageviews -- on par with the previous week
11:31:54 <gregbartholomew> #undo
11:31:54 <zodbot> Removing item from minutes: INFO by gregbartholomew at 11:31:35 : Week of April 12: 60K pageviews -- on par with the previous week
11:32:01 <gregbartholomew> #topic 1/ Last week's stats
11:32:07 <gregbartholomew> #info Week of <MONTH DD>: <NN.N>K pageviews -- <COMMENT>
11:32:15 <gregbartholomew> #topic 2/ In progress followup
11:32:15 <gregbartholomew> #info Looking at the 'in progress' column, is there something that's been finished? Anything to follow up on with its author?
11:32:15 <gregbartholomew> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
11:33:56 <gregbartholomew> Looking at #296 which has been moved to the top of the board.
11:35:07 <gregbartholomew> I just realized that I am early to start the meeting :( That explains a lot!
11:35:16 <gregbartholomew> #undo
11:35:16 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f25b3ae7ad0>
11:35:18 <gregbartholomew> #undo
11:35:18 <zodbot> Removing item from minutes: INFO by gregbartholomew at 11:32:15 : Looking at the 'in progress' column, is there something that's been finished? Anything to follow up on with its author?
11:35:19 <gregbartholomew> #undo
11:35:19 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f25b2eb3a90>
11:35:24 <gregbartholomew> #undo
11:35:24 <zodbot> Removing item from minutes: INFO by gregbartholomew at 11:32:07 : Week of <MONTH DD>: <NN.N>K pageviews -- <COMMENT>
11:35:26 <gregbartholomew> #undo
11:35:26 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f25b34615d0>
11:35:31 <gregbartholomew> #undo
11:35:31 <zodbot> Removing item from minutes: INFO by gregbartholomew at 11:31:27 : -- 7/ Open floor --
11:35:33 <gregbartholomew> #undo
11:35:33 <zodbot> Removing item from minutes: INFO by gregbartholomew at 11:31:25 : -- 6/ Editor of the Week --
11:35:40 <gregbartholomew> #undo
11:35:40 <zodbot> Removing item from minutes: INFO by gregbartholomew at 11:31:23 : -- 5/ Publishing schedule --
11:35:43 <gregbartholomew> #undo
11:35:43 <zodbot> Removing item from minutes: INFO by gregbartholomew at 11:31:22 : -- 4/ Articles to edit --
11:35:44 <gregbartholomew> #undo
11:35:44 <zodbot> Removing item from minutes: INFO by gregbartholomew at 11:31:21 : -- 3/ Finished articles to review --
11:35:46 <gregbartholomew> #undo
11:35:46 <zodbot> Removing item from minutes: INFO by gregbartholomew at 11:31:21 : -- 2/ In progress followup --
11:35:47 <gregbartholomew> #undo
11:35:47 <zodbot> Removing item from minutes: INFO by gregbartholomew at 11:31:21 : -- 1/ Last week's stats --
11:35:48 <gregbartholomew> #undo
11:35:48 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f25b4838850>
11:35:51 <gregbartholomew> #undo
11:35:51 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f25b4c34210>
11:35:52 <gregbartholomew> #undo
11:35:52 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f25b2ade4d0>
11:35:54 <gregbartholomew> #undo
11:36:07 <gregbartholomew> #undo
11:36:38 <gregbartholomew> Hopefully that worked.
11:40:29 <gregbartholomew> #undo
12:00:02 <zodbot> gregbartholomew: Error: Can't start another meeting, one is in progress.
12:00:02 <gregbartholomew> #meetingname magazine
12:00:02 <gregbartholomew> #topic Roll call
12:00:02 <gregbartholomew> #chair ryanlerch cverna asamalik sub_pop gregbartholomew jakfrost misc rwaltr bcotton rlengland
12:00:02 <zodbot> The meeting name has been set to 'magazine'
12:00:02 <zodbot> Current chairs: asamalik bcotton cverna gregbartholomew jakfrost misc rlengland rwaltr ryanlerch sub_pop
12:00:34 <bcotton> .hello2
12:00:35 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
12:00:40 <rlengland> .hello rlengland
12:00:41 <zodbot> rlengland: rlengland 'Richard England' <rlengland@gmail.com>
12:01:01 <gregbartholomew> hello everybody!
12:01:31 <rlengland> 'morning
12:01:40 <gregbartholomew> #topic Agenda
12:01:40 <gregbartholomew> #link https://docs.fedoraproject.org/en-US/fedora-magazine/workflow/
12:01:40 <gregbartholomew> #info -- 1/ Last week's stats --
12:01:40 <gregbartholomew> #info -- 2/ In progress followup --
12:01:40 <gregbartholomew> #info -- 3/ Finished articles to review --
12:01:41 <gregbartholomew> #info -- 4/ Articles to edit --
12:01:43 <gregbartholomew> #info -- 5/ Publishing schedule --
12:01:45 <gregbartholomew> #info -- 6/ Editor of the Week --
12:01:47 <gregbartholomew> #info -- 7/ Open floor --
12:01:51 <gregbartholomew> #topic 1/ Last week's stats
12:02:08 <gregbartholomew> #info Week of April 12: 60K pageviews -- on par with the previous week
12:02:22 <gregbartholomew> #topic 2/ In progress followup
12:02:22 <gregbartholomew> #info Looking at the 'in progress' column, is there something that's been finished? Anything to follow up on with its author?
12:02:22 <gregbartholomew> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
12:02:48 <gregbartholomew> It looks like someone helpfully moved #296 to the top of the list.
12:03:35 <gregbartholomew> I notice that the f34 release is scheduled for this upcoming week: https://fedorapeople.org/groups/schedule/f-34/f-34-key-tasks.html
12:04:08 <gregbartholomew> So I take it that we should move #296 over to the review column?
12:04:30 <rlengland> That's my take
12:04:49 <gregbartholomew> OK, moving it over ...
12:05:40 <rlengland> I'll give it a look and probably move it to edit. I think it is pretty much ready to go.
12:05:41 <gregbartholomew> The next one is in a similar category, but the author has a special note indicating that they are waiting on images.
12:05:54 <gregbartholomew> Thanks rlengland!
12:05:55 <rlengland> I pinged them last week. No response
12:06:07 <rlengland> on #305
12:06:49 <bcotton> for the release-related articles, it's probably best to assume that the release isn't going out on tuesday at this ponit
12:07:03 <gregbartholomew> Oh!
12:07:40 <gregbartholomew> In that case, I'll move #296 back to in progress.
12:08:16 <gregbartholomew> Thankfully, it looks like we still have enough articles for the upcoming week. :)
12:09:24 <gregbartholomew> So then, #305 is waiting on something technical. No problem, we can wait. :)
12:09:57 <gregbartholomew> I'm assuming the author for #290 is too busy to work on it. :)
12:11:06 <gregbartholomew> #263 appears to be in progress. The author has a good track record of 3 previous articles, so we'll leave him to it.
12:11:36 <gregbartholomew> #151 has a note that it will take him a while to complete.
12:11:43 * bcotton added cards for the release-related posts from https://fedorapeople.org/groups/schedule/f-34/f-34-magazine-tasks.html
12:13:01 <gregbartholomew> #258 hasn't responded since Feb. Maybe that one should go back to article spec?
12:14:27 <gregbartholomew> I think I'm going to move #258 back to article spec so it doesn't continue to hold things up in the future.
12:14:47 <rlengland> +1
12:15:14 <gregbartholomew> #295 has a note that it should be help until the author gives it the go ahead.
12:16:16 <gregbartholomew> The author(s) of #309 happen to be editors, so they can move that one along at their own pace. :)
12:16:30 <gregbartholomew> #info Are there any upcoming test days?
12:16:30 <gregbartholomew> #link https://apps.fedoraproject.org/calendar/QA/
12:16:50 <gregbartholomew> It doesn't appear so.
12:17:11 * gregbartholomew i think i missed on of those last week
12:17:32 <gregbartholomew> #topic 3/ Finished articles to review
12:17:32 <gregbartholomew> #info Looking at the 'review' column, let's decide which articles are good to go. Move each either to the 'to edit' (finished) or to the 'in progress' (needs more work) and provide feedback.
12:17:32 <gregbartholomew> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
12:17:53 <gregbartholomew> Yay! The review column has 3 cards!
12:18:22 <gregbartholomew> Looking at #303 https://fedoramagazine.org/?p=33286&preview=true
12:19:25 <gregbartholomew> At a glance, #303 looks good. Moving it over to "to edit".
12:19:40 <gregbartholomew> Looking at #307
12:19:49 <gregbartholomew> https://fedoramagazine.org/?p=33312&preview=true
12:20:43 <gregbartholomew> Hmm, there appear to be a lot of screenshots of terminal windows.
12:20:54 <gregbartholomew> I wonder if we should ask the author to redo those?
12:22:23 <bcotton> yeah, those could all be done as text for better accessibility
12:22:35 <gregbartholomew> Thanks bcotton
12:22:56 <gregbartholomew> Moveing it back to "in progress" and adding a note for the author...
12:25:25 <gregbartholomew> OK, looking at #308 https://fedoramagazine.org/?p=33350&preview=true
12:26:09 <gregbartholomew> It looks good to me. Moving #308 over to "to edit".
12:26:49 <gregbartholomew> #topic 4/ Articles to edit
12:26:49 <gregbartholomew> #info Looking at the 'to edit' column, assign an editor and a cover image creator.
12:26:49 <gregbartholomew> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
12:27:30 <gregbartholomew> I have #255 for Friday.
12:27:38 <rlengland> I'll take #308
12:27:51 <gregbartholomew> OK, thanks rlengland
12:28:01 <gregbartholomew> I'll take #303 then.
12:28:02 <rlengland> Don't know Prolog at all but I can run the commands to verify
12:28:39 <gregbartholomew> It looks like it should be an easy one to me. :)
12:29:08 <gregbartholomew> Do you think you can have it ready for Monday?
12:29:23 <rlengland> Yes, I think that can be done
12:31:57 <gregbartholomew> #topic 5/ Publishing schedule
12:31:57 <gregbartholomew> #info Looking at the 'queued' and 'to edit' columns, decide the publishing schedule for the next week period.
12:31:57 <gregbartholomew> #info If there is not enough content, we might also need to look at the 'in progress' or even the 'article spec' columns come up with additional content.
12:31:57 <gregbartholomew> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
12:34:09 <gregbartholomew> #proposed PUBLISHING SCHEDULE: Fri 23 Apr 2021: #255 How to use freenode with matrix with registration and identification (image: glb, edit: glb) -- Mon 26 Apr 2021: #308 How to embed Prolog in Python (image: tbd, rlengland?, edit: rlengland) -- Wed 28 Apr 2021: #303 Setting up Wireguard in Fedora: How to configure the wireguard interface permanently using NetworkManager (image: glb, edit: glb)
12:34:40 <gregbartholomew> I don't have anything for Friday the 30th.
12:34:53 <gregbartholomew> But maybe something will come along.
12:35:10 <bcotton> if not, that's okay
12:35:27 <bcotton> just remember to move cards to the "scheduled" column when they're scheduled in WP :-)
12:35:27 <gregbartholomew> Can I take that as a +1? :)
12:35:32 <bcotton> +1
12:35:40 <rlengland> +1
12:36:34 <gregbartholomew> @bcotton I was leaving the cards in queued so that the authors could more easily find them to request updates, if needed, after publication.
12:36:50 <gregbartholomew> Maybe I shouldn't do that.
12:37:15 <bcotton> they can always ask in IRC or on Discussion
12:37:28 <bcotton> or we can change the process
12:37:52 <gregbartholomew> My only concern with IRC/discussion is that they are much more public forums.
12:38:15 <gregbartholomew> If they are requesting fixes, they may prefer not to announce to the world the error. :)
12:38:34 <gregbartholomew> Also, my IRC bouncer has been down.
12:38:57 <gregbartholomew> I never made good use of the "queued" column anyway.
12:38:58 <bcotton> then propose a change to the process
12:39:08 <gregbartholomew> OK, will do.
12:39:14 <gregbartholomew> back to the schedule...
12:39:33 <gregbartholomew> #agreed PUBLISHING SCHEDULE: Fri 23 Apr 2021: #255 How to use freenode with matrix with registration and identification (image: glb, edit: glb) -- Mon 26 Apr 2021: #308 How to embed Prolog in Python (image: tbd, rlengland?, edit: rlengland) -- Wed 28 Apr 2021: #303 Setting up Wireguard in Fedora: How to configure the wireguard interface permanently using NetworkManager (image: glb, edit: glb)
12:39:36 <bcotton> yeah, queued implies a separate person making images, which i think was historically the case, but hasn't been since i've been around
12:40:09 <gregbartholomew> Ahh, I was wondering how that was supposed to work. Helpful information!
12:40:15 <gregbartholomew> bcotton++
12:40:19 <rlengland> Perhaps it should be considered a location for final author review
12:40:41 <gregbartholomew> Speaking of editors ...
12:40:46 <gregbartholomew> #topic 6/ Editor of the Week
12:40:52 <gregbartholomew> Any volunteers?
12:41:13 <gregbartholomew> Oh, we might also try to move the time. :)
12:41:51 <gregbartholomew> Volunteer first, then we'll tell you when you have to do it! :-O
12:42:31 <gregbartholomew> Let's move along to open floor for now, I'll take it if necessary.
12:42:40 <gregbartholomew> #topic 7/ Open floor
12:42:48 <bcotton> haha
12:42:56 <bcotton> i can take EOW next week
12:43:05 <gregbartholomew> Thanks bcotton!
12:43:13 <gregbartholomew> bcotton++
12:43:53 <gregbartholomew> If that was supposed to be a joke, it may have backfired on you. :)
12:44:13 <bcotton> i never joke
12:44:19 * bcotton looks around shiftily
12:44:31 <gregbartholomew> First, let's rename/repurpose the "queued" column
12:44:37 <gregbartholomew> Name suggestions?
12:44:58 <gregbartholomew> Assuming everyone is on board with repurposing it.
12:45:06 <bcotton> well, let's figure out the flow, and then figure out the names :-)
12:45:20 <gregbartholomew> OK.
12:45:48 <gregbartholomew> So queue is for images, but authors have been doing the images along with their editing.
12:45:59 <gregbartholomew> Do we still need queued?
12:46:34 <rlengland> It feels to me like a place for final review would be useful
12:47:06 <rlengland> Holding pattern, for example.
12:47:08 <gregbartholomew> How so? What do you mean/expect by "final review"?
12:47:16 <bcotton> i agree, but also we don't usually seem to have much time for that :-)
12:47:39 <rlengland> In the case you pointed out where the author may need to make adjustments
12:47:53 <rlengland> in case or errors or recent changes
12:48:00 <bcotton> ideally that's part of the editing process before we schedule it
12:48:02 <gregbartholomew> That can extent to after publication however.
12:48:10 <rlengland> ok
12:49:00 <gregbartholomew> So the new name (if we make one) should be a state that implies it is done, but which does not hide the card for a while.
12:49:45 <bcotton> let's think about it this way: how long post-publication should a card be visible?
12:49:51 <gregbartholomew> The only problem I have with the last column is that it hides the card.
12:50:08 <gregbartholomew> Perhaps a week?
12:50:43 <rlengland> Personally I think scheduled and queued names could be reversed
12:50:51 <gregbartholomew> How about a rule that cards go onto the "queued" column at the top and are pulled off the bottom. Keep around 4 to 6 cards.
12:51:17 <gregbartholomew> I like renaming "queued" to scheduled.
12:51:27 <gregbartholomew> I still don't like queued.
12:51:45 <gregbartholomew> How about we just leave the last column "archived".
12:51:48 <gregbartholomew> ?
12:51:58 <bcotton> so thinking about the flow, we could have "move last week's published articles to whatever we call the archived state" as part of the meeting prep
12:52:22 <rlengland> that works for me
12:52:24 <bcotton> but that potentially only gives articles 4-5 days of post-publish visibility
12:52:37 <gregbartholomew> bcotton, yes, that's what I have in mind.
12:52:37 <bcotton> fwiw, i'm not sold on that behind the "please make corrections" mechanism anyway
12:53:32 <gregbartholomew> I just thought it happens enough that there should be an easy and obvious way for authors to request corrections.
12:53:47 <bcotton> my counter argument to the "it's public" is "for anything that's more than trivial typo/wording fixes, it's good editorial practice to add a note explaining what was edited anyway"
12:54:18 <gregbartholomew> A note in the card?
12:54:31 <gregbartholomew> The card that is hidden under archived?
12:55:09 <bcotton> in the article
12:55:14 <gregbartholomew> Oh.
12:55:29 <gregbartholomew> I've never done that.
12:55:45 <gregbartholomew> I guess the edits have never been very large either.
12:56:12 <gregbartholomew> Well, we are running out of time.
12:56:21 <bcotton> e.g. "Editor's note: updated on 31 Feb 2021 to say that users should not attempt to stick the power cable up their nose"
12:56:44 <rlengland> :-)
12:56:48 <gregbartholomew> Since there does not seem to be agreement, we'll hold off on this change and maybe revisit it later. :)
12:57:07 <bcotton> probably good to bring it to the forum anyway
12:57:25 <gregbartholomew> I'd also like to ask about changing the meeting time, but I'm not sure that there is time.
12:57:42 <bcotton> probably a better asynch question, too :-)
12:58:03 <gregbartholomew> I take it then that you are OK with the normal time for next week? :)
12:58:03 <rlengland> any thing later than 0500 PST is good with me. :-)
12:58:36 <rlengland> agreed
12:58:52 <gregbartholomew> #info bcotton will be Editor of the Week next week
12:59:03 <gregbartholomew> I hope you meant that bcotton. :)
12:59:26 <bcotton> even if i didn't, i'm stuck now :-p
12:59:44 <gregbartholomew> Or we can move the meeting to a later time. :)
12:59:47 <gregbartholomew> #endmeeting