16:00:51 <adamw> #startmeeting Fedora QA meeting
16:00:51 <zodbot> Meeting started Mon Nov 22 16:00:51 2021 UTC.
16:00:51 <zodbot> This meeting is logged and archived in a public location.
16:00:51 <zodbot> The chair is adamw. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:00:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:51 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
16:00:52 <adamw> #meetingname fedora-qa
16:00:52 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:56 <adamw> #topic Roll Call
16:02:34 * coremodule is here
16:03:02 <adamw> ahoyhoy folks, who's around?
16:03:55 <copperi[m]> .hello copperi
16:03:56 <zodbot> copperi[m]: Something blew up, please try again
16:03:59 <zodbot> copperi[m]: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:04:13 <copperi[m]> I am blown :)
16:04:18 <bytehackr> :)
16:05:55 <bytehackr> last day of test day :D
16:15:15 <lruzicka2> .hello lruzicka
16:15:16 <zodbot> lruzicka2: Something blew up, please try again
16:15:19 <zodbot> lruzicka2: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:15:30 <lruzicka2> thank you, zodbot
16:17:48 <adamw> welp, we're a bit short on people, it seems
16:17:50 * adamw not sure if people flunked the timezone change or are on holiday :D
16:17:55 <copperi[m]> I heard many are away
16:18:01 <lruzicka2> Some are also ill.
16:18:09 <adamw> is it a holiday in europe?
16:18:13 <adamw> huh. slackers.
16:18:13 <copperi[m]> nope
16:18:16 <adamw> well, we can run through the agenda quickly anyhow, i guess
16:18:17 <adamw> #topic Previous meeting follow-up
16:18:18 <lruzicka2> not in CZ afaik
16:18:22 <lruzicka2> sure
16:18:26 <adamw> #info "adamw to look into
16:18:26 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=2016253#c34 (f35 audio
16:18:26 <adamw> upgrade bug) more after the meeting" - I did poke this a bit more but we're still not clear on all the possible cases. it's pretty well documented now at least
16:18:32 <adamw> #info "adamw to try and clarify intent of "default application functionality" criterion regarding arches" - didn't get to this yet, other things came up...i'll put it back...
16:18:33 <adamw> #action adamw to try and clarify intent of "default application functionality" criterion regarding arches
16:18:35 <adamw> #info "kparal to draft revised/extended criteria for package management and system settings" - he did this, and there is enthusiastic discussion about the draft ongoing on the list
16:18:37 <adamw> any other followup.
16:18:38 <adamw> ?
16:19:39 <adamw> oh dear
16:19:42 <coremodule> nothing here
16:19:57 <coremodule> whats the matter?
16:20:24 <lruzicka2> I think this bug is a nightmare as it keeps repeating the incorrect workaround all the time.
16:20:46 <lruzicka2> which does not solve the situation but only postpones the problem
16:21:20 <adamw> hmm, what incorrect workaround?
16:22:35 <lruzicka2> adamw, well, they do "sudo dnf swap --allowerasing pulseaudio pipewire-pulseaudio"
16:22:45 <lruzicka2> which does not solve anything around wireplumber
16:22:58 <adamw> yes it does
16:23:00 <lruzicka2> but if it helps them, it means, they must be updating from 33
16:23:18 <lruzicka2> because the step, they are doing, had to be done on F34 already
16:23:30 <adamw> that's not an incorrect workaround
16:23:39 <lruzicka2> so it seems to me, they are fixing a problem from last release
16:23:41 <adamw> what it's doing is removing pulseaudio and replacing it with pipewire
16:23:52 <lruzicka2> yes, what we already wanted for d34
16:23:54 <lruzicka2> f34
16:23:55 <adamw> well, sure, but that doesn't mean it's incorrect
16:24:30 <lruzicka2> It is not incorrect, but it is misleading for people who did that on F34 and do not have wireplumber loaded.
16:24:32 <adamw> it'd be good to figure out why some people somehow didn't get pulseaudio removed on long-term upgrades, but the workaround that's being advised is correct and 'permanent' afaics
16:25:09 <lruzicka2> because they might be upggrading from 33?
16:25:37 <lruzicka2> or because they manually stayed on pulseaudio when upgrading to 34
16:25:38 <lruzicka2> ?
16:27:07 <lruzicka2> I remember this workaround was a fix for sound in F34, when for some people the pipewire was not switched
16:27:09 <adamw> it seems to be in systems upgraded from longer ago than f33
16:27:18 <adamw> we tested f33 to f35 earlier in the cycle, iirc
16:27:24 <adamw> (not sure if we tested f33-f34-f35, though)
16:27:39 <lruzicka2> we only test clean installs
16:27:52 <lruzicka2> which is a problem for people with some tweaks
16:28:57 <lruzicka2> also, when we upgrade our machines we only have one attempt to see "the real" upgrade, which for me for instance, meant to fix sound manually in 34 and 35
16:29:23 <adamw> no, we tested upgrades earlier in the cycle when bugs with it were first reported.
16:29:36 <adamw> not as part of validation, but as part of investigating this bug.
16:29:52 <adamw> oh, iswym. well, yes. but still
16:30:26 <adamw> anyhow, i'll keep looking at it
16:30:42 <adamw> #topic Fedora 36 status
16:30:50 <adamw> so, we had some issues with composes last week, but rawhide is pretty good now
16:30:59 <adamw> i'm not aware of any major fires, is anyone else?
16:31:12 <lruzicka2> maybe I could try install F32 and update one after another and see if it breaks and where
16:35:18 <adamw> yeah, that's what we need to do, i just didn't have time yet
16:35:23 <adamw> i've added the other case to commonbugs, though
16:35:58 <lruzicka2> adamw, ok, I will do it in this week, will have to move my stuff from my desk tomorrow, so dunno how it goes.
16:36:03 <adamw> #info Fedora 36 is currently looking fine, composes are working and passing most tests
16:37:12 <adamw> #topic Fedora 35 Retrospective thoughts
16:37:17 <adamw> so i was hoping to have more people present for this and the next topic, but oh well :)
16:37:47 <adamw> #info we put up a Retrospective wiki page for the first time in a while: https://fedoraproject.org/wiki/Fedora_35_QA_Retrospective
16:38:01 <adamw> there's some good feedback so far, anyone have any further input or thoughts on the feedback that's there?
16:39:00 <lruzicka2> we should probably think about getting a fully covered compose somewhere before Beta branch alredy
16:39:31 <lruzicka2> we talked about this last time, but we somehow slipped this and ended up with blockers that could have been discovered much earlier
16:40:00 <lruzicka2> it's mentioned by Kamil on that list, and frantisekz.
16:40:01 <coremodule> Agreed. I think kparal added that to the list
16:40:19 <lruzicka2> coremodule, yeah :D
16:40:56 <adamw> well, i think for the kde packaging blockers it wasn't exactly that we didn't test a compose earlier, it's that kparal decided he was going to test it much harder than we usually do...
16:40:59 <adamw> i dunno about you folks but when i'm checking that box i don't usually start futzing around with the repository configuration UI :D
16:41:19 <coremodule> lol
16:45:32 <adamw> alrighty, so i'll give it a few more days for anyone to add any more feedback, then start converting it into tickets
16:45:44 <adamw> if you haven't yet had a look, please do so, and add anything you can think of that hasn't been covered. thanks!
16:45:50 <lruzicka2> ok
16:45:56 <adamw> #action adamw to convert retrospective entries to pagure tickets later this week
16:47:52 <adamw> #topic Current criteria / test case proposals
16:47:53 <bytehackr> :D
16:50:25 <adamw> so, we have an extremely enthusiastic discussion going on about package manager criteria, which i didn't get around to contributing to yet
16:51:20 <copperi[m]> It is good issue, trying to help is not so easy...
16:51:30 <copperi[m]> but understand the other side of the coin as well
16:52:09 <adamw> yeah, writing criteria is hard!
16:52:25 <adamw> so, i think it'd be helpful if folks reply to kamil's post asking for feedback on various scenarios
16:53:36 <adamw> #info kamil polled for opinions on various scenarios regarding package manager criteria, it'd be helpful to have as many replies as possible: https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/BQUOUIZA24XLQEENY4NLDES4MMKIPSGN/
16:53:37 <adamw> after that i guess the ball is in his court for a new draft
16:56:15 <adamw> Sumantro Mukherjee: are you around?
16:57:16 <adamw> hmm, i think maybe not
16:57:17 <coremodule> he's on pto today
16:57:40 <adamw> #topic Test Day / community event status
16:58:46 <adamw> #info kernel test week is ending today: https://fedoraproject.org/wiki/Test_Day:2021-11-14_Kernel_5.15_Test_Week
16:59:04 <adamw> get your testing in if you didn't yet!
16:59:05 <adamw> i think that's all for now
16:59:05 <adamw> #topic Open floor
16:59:06 <adamw> any other business quickly?
17:00:07 <lruzicka2> not that I know of
17:00:19 <copperi[m]> Thanks adamw
17:00:26 <bytehackr> :D Thanks
17:01:38 <adamw> alrighty, thanks for coming folks
17:01:56 <adamw> see you next time!
17:01:57 <adamw> #endmeeting