17:00:31 <pboyHB> #startmeeting fedora-server
17:00:31 <zodbot> Meeting started Wed Dec  1 17:00:31 2021 UTC.
17:00:31 <zodbot> This meeting is logged and archived in a public location.
17:00:31 <zodbot> The chair is pboyHB. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:31 <zodbot> The meeting name has been set to 'fedora-server'
17:00:40 <pboyHB> #topic Welcome / roll call
17:00:48 <pboyHB> Welcome to our Server WG IRC meeting!
17:00:52 <jwhimpel> .helo
17:00:59 <pboyHB> As usual, we'll give a few minutes for folks to show up
17:00:59 <pboyHB> Please, everybody who is lurking, say either .hello2 or .hello <fasname>
17:01:02 <jwhimpel> .hello
17:01:02 <zodbot> jwhimpel: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:01:26 <pboyHB> I’ll post the agenda in a few minutes.
17:01:39 <copperi[m]> .hello copperi
17:01:39 <zodbot> copperi[m]: copperi 'Jan Kuparinen' <copper_fin@hotmail.com>
17:01:42 <cmurf[m]> .hello chrismurphy
17:01:46 <zodbot> cmurf[m]: chrismurphy 'Chris Murphy' <bugzilla@colorremedies.com>
17:01:49 <dcavalca> .hi
17:01:49 <zodbot> dcavalca: dcavalca 'Davide Cavalca' <dcavalca@fb.com>
17:02:39 <mowest[m]> Hello everyone.
17:03:32 <jwhimpel> .hello2
17:03:33 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:03:41 <mowest[m]> .hello
17:03:41 <zodbot> mowest[m]: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:04:07 <pboyHB> A hearty welcome to everyone.
17:04:14 <pboyHB> #topic Agenda
17:04:23 <pboyHB> #link https://pagure.io/fedora-server/report/Meeting
17:04:30 <pboyHB> 1. Follow up actions
17:04:38 <pboyHB> 2. New WG Doc Landing Page and Navigation Items
17:04:39 * nirik is doing other stuff, but trying to be here a bit too.
17:04:45 <pboyHB> 3. Migration of unmodified Wiki content
17:04:53 <pboyHB> 4. Decommissioning of (old) SIG Wiki pages
17:05:02 <pboyHB> 6. Facilitated and improved support for Fedora Server Edition VMs
17:05:09 <pboyHB> 7. Using Ansible to install and configure Wildfly
17:05:15 <pboyHB> 8. Open Floor
17:05:23 <pboyHB> Any additional topic ?
17:05:44 <salimma> .hi
17:05:47 <zodbot> salimma: salimma 'Michel Alexandre Salim' <michel@michel-slm.name>
17:06:02 <pboyHB> #topic Follow up actions
17:06:08 * salimma mostly afk
17:06:15 <pboyHB> #info action Moving Wiki Pages to docs.fedoraproject.org (#52) (pboy,mowestusa) done
17:06:23 <pboyHB> Everything has gone very fast this time.
17:06:34 <pboyHB> No sooner had I written to the docs mailing list than we were online. Many thanks to Ben.
17:06:42 <pboyHB> #info New address: https://docs.fedoraproject.org/en-US/server-working-group/
17:07:08 <pboyHB> Any comment? Any other open action that i missed?
17:08:04 <pboyHB> OK
17:08:07 <mowest[m]> The skeleton is there for the Server Working Group. Is there a specific page that you would like me to start working on to "flesh" things out.
17:08:07 <pboyHB> #topic New WG Doc Landing Page and Navigation Items
17:08:16 <pboyHB> #link https://pagure.io/fedora-server/issue/56
17:08:23 <pboyHB> Maybe we start with the =content= of the new page.
17:08:31 <pboyHB> (and then later with the navigation menu)
17:08:40 <pboyHB> The Floor is open
17:10:52 <mowest[m]> Ok, so just do some comparisons between the old wiki pages and our current page in docs and flesh that out with information? Is there new information that we would like up there?
17:11:52 <pboyHB> I would like to add at the end: The last 3 IRC protocols / links.
17:12:32 <mowest[m]> It would be nice to keep the landing page of the Server Working Group short and sweet with other content on the pages of the navigation menu. I would think anyway, just looking at the current structure.
17:12:41 <pboyHB> And I would like to transfer the details of our work projekts to pagure and not add them as sub pages to docs.
17:13:11 <pboyHB> mowest +1
17:13:15 <mowest[m]> That makes sense. There could always be just a link to the pagure issue
17:14:36 <mowest[m]> Ok, thanks for the direction.
17:14:38 <pboyHB> Well, obviously there is no need to change anything in the current version
17:14:50 <pboyHB> #proposed the current landing page is accepted with addition of the last 3 IRC meeting links.
17:15:13 <pboyHB> 3
17:15:21 <pboyHB> 2
17:15:22 <pboyHB> 1
17:15:37 <pboyHB> #agreed the current landing page is accepted with addition of the last 3 IRC meeting links.
17:16:00 <pboyHB> What about the navigation items?
17:16:56 <jwhimpel> do you envision server admins locating server documentation via this landing page?
17:17:40 <mowest[m]> I think it gives us a good structure to work with right now, and see how those pages develop over time if we need to create different categories or sub pages.
17:18:12 <pboyHB> jwhimpel: No, therefore the note on the top about user documentation. But Google may find them.
17:18:35 <mowest[m]> I believe this is page is meant more for introducing people to the Fedora Server Working Group in the hopes that they join the fun.
17:19:06 <pboyHB> #proposed: We start with the navigation items as is
17:20:19 <eseyman> .hello
17:20:19 <zodbot> eseyman: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:20:25 <eseyman> .hello2
17:20:25 <pboyHB> 3
17:20:25 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
17:20:32 <pboyHB> 2
17:20:38 <pboyHB> 1
17:20:54 <pboyHB> #agreed  We start with the navigation items as is
17:21:16 <pboyHB> Question is, do we need staging pages? Or do we rely on mowest and me and then correct / add to it later.
17:22:50 <mowest[m]> I feel staging pages are more necessary for Server Documentation than these pages that will remain mostly static after add the information that is missing.
17:23:16 <pboyHB> Yes, I guess no one has need for stating pages.
17:23:28 <copperi[m]> +1 on that
17:23:35 <pboyHB> #agreed no staging pages needed
17:24:11 <pboyHB> #action mowest and pboyHB continue to migrate the wiki pages.
17:24:26 <pboyHB> #topic Migration of unmodified Wiki content
17:24:36 <pboyHB> #link https://pagure.io/fedora-server/issue/57
17:25:20 <pboyHB> The issue lists those pages we should migrate unmodified.
17:25:37 <pboyHB> Concerns?
17:26:28 <eseyman> none here
17:26:32 <pboyHB> #agreed  as of issue #57 pages will be migrated unmodified
17:26:46 <pboyHB> #topic Decommissioning of (old) SIG Wiki pages
17:26:54 <pboyHB> #link https://pagure.io/fedora-server/issue/59
17:27:33 <salimma> There's a way to set a redirect to docs.fp.o on each wiki page
17:27:49 <salimma> (I think mattdm brought it up in devel@ recently)
17:28:11 <mowest[m]> Does the SIG page predate this wiki page? https://fedoraproject.org/wiki/Server
17:28:24 <pboyHB> Would be good, We should remove outdated content or provide it with warning and link to current content
17:28:40 <copperi[m]> cool, there should be simple note left on page as well that page has moved in case it does not work.
17:29:02 <pboyHB> mowest: At that time there were 2 groups in parallel.
17:29:16 <mowest[m]> I'm in favor of just removing outdated content and streamline sources of information that search crawlers find.
17:29:48 <pboyHB> Are we entiteled  to remove that page or do we need to ask council / fesco ?
17:30:03 <copperi[m]> There might be hard-coded links, so I prefer note and redirect
17:30:50 <mowest[m]> Could we evaluate the hard-coded links and see if any are still relevant and add those to our docs landing page?
17:30:50 <salimma> Yeah, one issue I notice with wiki pages that have moved is that references from outside pages are not updated in timd
17:30:51 <copperi[m]> with other content removed
17:31:05 <salimma> So having a page that warns and redirect is better than just prematurely yanking
17:31:28 <pboyHB> #proposed Old SIG page get a note and redirect to new page
17:31:33 <pboyHB> 3
17:31:33 <mowest[m]> Oh, I see links from outside are the issue.
17:31:39 <pboyHB> 2
17:32:00 <pboyHB> 1
17:32:17 <mattdm> salimma: {{#fedoradocs: https://docs.fedoraproject.org/en-US/council/fpl/}}
17:32:36 <pboyHB> #agreed  Old SIG page get a note and redirect to new page, old content removed / archived
17:32:40 <salimma> +1 to the proposal and to matt
17:32:49 <mattdm> at the top of the page. note that once it's there, it's annoying to edit the page, so get it right hte first time :)
17:32:51 <eseyman> +1
17:33:49 <mattdm> pboyHB: you can redirect any pages that belong to the team (or are related and effecively unclaimed) to docs without asking anyone
17:34:20 <mattdm> If you wanted to redirect to somewhere else, or if it's a shared page or something, then some coordination needed.
17:34:22 <pboyHB> mattdm: OK (I'm just being cautious)
17:34:28 <mattdm> yep :)
17:34:54 <mattdm> also: the advantage of using the macro over putting a notice at the top of the page is that Google will understand it and update links
17:35:39 <pboyHB> #action  mowest and pboyHB modify the old SIG page as agreed
17:36:00 <pboyHB> #topic Review current Fedora Server Technical Specification
17:36:10 <pboyHB> #link  https://pagure.io/fedora-server/issue/58
17:36:42 <pboyHB> Our technical specifications are "a bit" outdated.
17:36:47 <pboyHB> The floor is open
17:38:08 <eseyman> somewhat outdated, yes
17:39:00 <pboyHB> My idea: we proceed as with the PRD. Everyone comments on hackmd and we then merge that into an updated version.
17:39:01 <mowest[m]> Since these are outdated, what new thing has guided the decision made about the last two releases of Fedora Server 34 and 35?
17:39:52 <pboyHB> good question. :-). business as usual and an implicit agreement
17:40:32 <pboyHB> and our discussion of the PRD gave a lot of guidance.
17:40:50 <mowest[m]> So, just wondering, do we need a technical specification if it hasn't been used? I don't want us to go through a lot of work if we it will just get dusty like the last one.
17:42:10 <pboyHB> We have to discuss and enhance our release criteria next. We need a explicit specification to determine release criteria
17:42:55 <eseyman> I like the idea of a tech spec. I just think we should review every 2/3/4 releases to keep it fresh
17:43:28 <mowest[m]> Great, sounds like it would go to good use, and we already have a nice format to start with on hackmd.
17:43:58 <pboyHB> eseyman: +1
17:44:43 <pboyHB> #proposed Everyone will work through the technical specification and comments on hackmd over the next 14 days and then we will discuss details at the next meeting.
17:44:45 <eseyman> .action eseyman hit hackmd this week and comment on tech spec
17:45:01 <eseyman> #action eseyman hit hackmd this week and comment on tech spec
17:45:43 <pboyHB> #proposed  eseyman hit hackmd this week and comment on tech spec, discussion next meeting Dec 15
17:46:16 <pboyHB> 3
17:46:22 <pboyHB> 2
17:46:26 <pboyHB> 1
17:46:38 <pboyHB> #agreed eseyman hit hackmd this week and comment on tech spec, discussion next meeting Dec 15
17:47:06 <pboyHB> #action eseyman hit hackmd this week and comment on tech spec
17:47:27 <pboyHB> #topic Facilitated and improved support for Fedora Server Edition VMs
17:47:35 <pboyHB> #link https://pagure.io/fedora-server/issue/53
17:47:45 <pboyHB> #info On Mailing List: https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/3Z7YAUSYPTZ5HME4OW7WK67L67AM7KHE/
17:47:56 <pboyHB> #info In particular: experience of the Fedora infra Team: https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/message/Y7QX3FKUWCPAYWMJYLLHTUHUK3L627MI/
17:48:28 <pboyHB> One general idea „install thats just enough to boot, have NetworkManager/be on the network and have dnf working so we can install whatever we want. The smaller the better here.“ (nirik)
17:48:36 <pboyHB> Another idea: have an image as close as possible to the default Anaconda install
17:48:43 <pboyHB> (both are practically not so different)
17:48:52 <pboyHB> Floor is open
17:48:54 <nirik> well, we control what anaconda installs. ;)
17:49:16 <eseyman> Kickstart FTW
17:49:50 <eseyman> actually, Kevin's description pretty much matches what I want on my new home server
17:50:22 <nirik> FWIW I think this is what the cloud image was orig going for (but with cloud-init added I suppose).
17:51:25 <pboyHB> Yes, but cloud image drifted into a somehow different direction, unfortunately.
17:52:29 <pboyHB> My wish: the admin experience of a VM image should be as similar as possible to an Anaconda default installation.
17:53:49 <pboyHB> About kickstart: Then we should provide a (default / template) kick start file.
17:54:32 <jwhimpel> pboyHB: Do you mean an interactive anaconda install or an unattended anaconda install?
17:54:54 <bytehackr> :)
17:55:11 <pboyHB> I mean an interactive one
17:55:20 <eseyman> I suspect we'll need several ks files
17:55:38 <pboyHB> eseyman: +1
17:56:10 <pboyHB> time is draining
17:56:50 <pboyHB> I would like to switch soon to Open floor, just in case someone comes up
17:56:55 <jwhimpel> That doesn't work for bringing up new VM's quickly to handle surges in volume.  Or for using ansible and other configuration management tools to do the installation.
17:57:54 <salimma> jwhimpel: could you elaborate?
17:58:22 <pboyHB> jwhimpel: YES, indeed. The result of an interactive discussion should be available as an image or kickstart template, or something else
17:58:56 <pboyHB> OK, let's continue discussion next meeting !
17:58:59 <jwhimpel> We often have a pig going through a snake (large surges of transactions) where we need to spin up a significant number of vm's to handle the surge.
17:59:19 <pboyHB> #topic Open Floor
17:59:22 <salimma> jwhimpel: sure but in that case you'd start with a full VM image, and skip anaconda, no?
17:59:28 <cmurf[m]> i think you could have one or more "VM centric" kickstarts hosted in Fedora somewhere, and provide install media with boot options for each kickstart
17:59:59 <pboyHB> cmurf: +1
18:00:01 <cmurf[m]> where Fedora Server VM's are customized via kickstart, and Cloud is customized via cloud-init
18:00:28 <nirik> sure, but if you are going to do that, why not just make your own kickstart?
18:01:04 <pboyHB> we want to make it easy for the not so skilled admin as well
18:01:51 <pboyHB> OK, time is up. Let's continue in 14 days!
18:01:57 <pboyHB> Thanks to anybody
18:02:06 <eseyman> bye, all
18:02:08 <salimma> Thanks pboy
18:02:15 <pboyHB> #endmeeting