15:00:34 <adamw> #startmeeting Fedora QA meeting
15:00:34 <zodbot> Meeting started Mon Aug 23 15:00:34 2021 UTC.
15:00:34 <zodbot> This meeting is logged and archived in a public location.
15:00:34 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:34 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:34 <zodbot_> Meeting started Mon Aug 23 15:00:34 2021 UTC.
15:00:34 <zodbot_> This meeting is logged and archived in a public location.
15:00:34 <zodbot_> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <zodbot_> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:34 <zodbot_> The meeting name has been set to 'fedora_qa_meeting'
15:00:40 <adamw> #meetingname fedora-qa
15:00:40 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:40 <zodbot_> The meeting name has been set to 'fedora-qa'
15:00:44 <adamw> #topic Roll Call
15:00:57 * bittin is here
15:01:03 <lruzicka2> .hello lruzicka
15:01:04 <zodbot> lruzicka2: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
15:01:05 <zodbot_> lruzicka2: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
15:01:11 <coremodule> .hello2
15:01:12 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
15:01:12 <zodbot_> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
15:01:17 <Lailah> .fas lailah
15:01:17 <zodbot> Lailah: b"lailah 'Sylvia S\xc3\xa1nchez' <BHKohane@gmail.com>"
15:01:18 <zodbot_> Lailah: lailah 'Sylvia Sánchez' <BHKohane@gmail.com>
15:01:31 <lruzicka2> Wow, the luxury of having two servants this time.
15:01:37 <Lailah> Why my name looks so weird?
15:01:44 <Lailah> Anyways, hello everbody!
15:01:51 <bcotton> .hello2
15:01:52 <zodbot_> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:01:52 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:01:57 <geraldosimiao> .hello geraldosimiao
15:01:58 <lruzicka2> Lailah, it seems that one of the zodbots cannot understand utf8
15:01:58 <zodbot> geraldosimiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
15:02:00 <zodbot_> geraldosimiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
15:02:24 <Lailah> lruzicka2 Oh...  that was... unexpected
15:02:26 * sumantro is here
15:02:30 <adamw> Lailah: zodbot has some unicode issues, it looks like (and is still running on python2?)
15:02:35 <adamw> zodbot_ is all cool
15:02:47 * kparal is here
15:02:49 <adamw> nirik: can we lose the stereo zodbots or are we stuck with them?
15:03:30 <bcotton> If one zodbot is good, two zodsbot are better
15:03:46 <Lailah> Stereo zodbots FTW!
15:04:01 <davdunc> .hello davdunc
15:04:02 <zodbot> davdunc: davdunc 'David Duncan' <davdunc@amazon.com>
15:04:02 <zodbot_> davdunc: davdunc 'David Duncan' <davdunc@amazon.com>
15:04:03 <Lailah> adamw: I thought Python2 was dead and buried...
15:04:09 <adamw> Ben Cotton (he/him/his): i hereby approve this plural
15:04:14 <coremodule> ahhh, inspectors general or inspector generals? or, in inspectors generals?
15:04:38 <bcotton> inspectors generaln
15:04:45 <adamw> it should be inspectors general, though absolutely nobody gets that right any more.
15:04:54 * bcotton is nobody
15:05:01 <adamw> remember your place.
15:05:14 <coremodule> :( sorry bcotton
15:05:47 <nirik> adamw: oops. yeah, ill fix
15:06:12 <davdunc> nirik to the rescue... again. ;
15:06:21 <adamw> thanks
15:06:32 <adamw> if nirik ever quits we can just shut fedora and go home
15:06:34 <nirik> sorry about that.
15:07:15 <bcotton> +1
15:07:42 <davdunc> bcotton: adamw and nirik lost and nothing works again ever.
15:08:45 <adamw> welp, let's get rolling
15:08:51 <adamw> #topic Previous meeting follow-up
15:09:39 <adamw> #info "adamw to check with sumantro about plans for an F35 audio test day" - I, uh, completely whiffed on this one. whoops. will do it today
15:10:10 <Lailah> I can help with audio tests if you tell me what to do.
15:10:12 <sumantro> adamw thanks for the reminder! and I am already on it
15:10:20 <adamw> cmurf, we had a couple for you, test day for luks encryption sector size and testcloud/btrfs?
15:10:24 <adamw> oh hey, that solves that, thanks sumantro
15:10:29 <adamw> #undo
15:10:29 <zodbot> Removing item from minutes: INFO by adamw at 15:09:39 : "adamw to check with sumantro about plans for an F35 audio test day" - I, uh, completely whiffed on this one. whoops. will do it today
15:10:30 <lruzicka2> Lailah, there is a bunch of audio tests that you can use
15:10:36 <bittin> Lailah, guessing an announcment will come out when adamw and sumantro has talked :)
15:10:42 <adamw> wait, uh. it seems like we lost both the zodbots now?
15:10:43 <cmurf> hmmm
15:10:48 <cmurf> what was I thinking?
15:10:55 <bittin> there is one zodbot here
15:10:58 <bittin> atleast on my screen
15:10:58 <adamw> oh, no, there we go.
15:11:05 <Lailah> Where? I don't see any
15:11:29 <adamw> well, it acknowledged the #remove, but not the topic change. oh well
15:11:30 <Lailah> "Zodbots out for tea, will be back in two hours. Thanks"
15:11:40 <lruzicka2> Lailah, for instance here https://fedoraproject.org/wiki/Test_Day:2021-03-03_Audio_Test_Day
15:11:46 <adamw> #topic Previous meeting follow-up
15:11:49 <lruzicka2> you could try all those on Fedora 35
15:11:50 <frantisekz> .hello2
15:11:51 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
15:11:51 <adamw> (just in case)
15:12:13 <adamw> #info "adamw to check with sumantro about plans for an F35 audio test day" - sumantro says he's already working on it
15:12:15 <Lailah> lruzicka2  that looks great!
15:12:22 <Lailah> So far my audio has been meh at best
15:12:29 <adamw> cmurf: https://meetbot-raw.fedoraproject.org/teams/fedora-qa/fedora-qa.2021-08-02-15.00.txt
15:12:33 <Lailah> And my BT headphones don't work.
15:12:51 <adamw> hmm, that's bad.
15:13:01 <cmurf> oh i forgot to ask anaconda folks about luks sector size test day... figures
15:13:06 <lruzicka2> Lailah, and did they work previously?
15:13:18 <Lailah> Yes, they did
15:13:33 <Lailah> And they work fine in other systems and devices.
15:13:37 <cmurf> i haven't heard any complaints about testcloud and btrfs :P
15:13:39 <sumantro> cmurf, luks sector size is on my mind too, I will file a ticket and touchbase with you!!
15:13:59 <Lailah> There was like 2 days of improvement before it went downhill  lruzicka2
15:14:00 <adamw> #info "cmurf to look into whether it's necessary/useful to do a test day for
15:14:00 <adamw> https://fedoraproject.org/wiki/Changes/LUKSEncryptionSectorSize" - not done yet, cmurf will do it this week
15:14:07 <adamw> cmurf: how about testcloud/ntrfs?
15:14:09 <adamw> also btrfs
15:14:27 <Lailah> adamw  What is bad?
15:15:04 <cmurf> is testcloud used at all in openqa? i've never used testcloud before
15:15:08 <geraldosimiao> I've seen a few BT complaints recently, theres such a bluetooth test day? it is possible?
15:15:10 <cmurf> fzatloukl around?
15:15:11 <lruzicka2> Lailah, I am not sure, I do have bt headphones and they seem to work fine. Overall, I did not have any problems with audio on the basic daily use so far.-
15:15:17 <frantisekz> imo, testcloud shouldn't care about FS, if guestfs supports it...
15:15:20 <lruzicka2> Firefox cannot play netflix, though
15:15:26 <frantisekz> (libguestfs)
15:15:45 <Lailah> lruzicka2 ....  ah, I'm the unlucky one :'(
15:16:22 <Lailah> geraldosimiao  That would be a great idea!
15:16:42 <cmurf> frantisekz: that's what i'm thinking, it should be invisible
15:16:53 <lruzicka2> geraldosimiao, it for sure is possible if someone writes the test cases and expectations :D
15:16:57 <frantisekz> did the changes already happen?
15:17:02 <adamw> Lailah: headphones not working is bad :)
15:17:19 <Lailah> adamw: That's true
15:17:26 <adamw> cmurf: no, openqa doesn't use it
15:17:39 <frantisekz> I'll give it a try (it's really simple to use, if you wanted/needed sometime: testcloud instance create fedora:rawhide)
15:17:41 <Lailah> Oh BTW adamw  I have something to comment on KDE + Wayland
15:17:47 <adamw> cmurf: the line that prompted the action item was "15:35:45 <cmurf> might need to make sure testcloud is working with the btrfs cloud images? :)"
15:18:41 <bittin> Lailah, sounds like something for the next topic
15:19:05 <Lailah> bittin:  Cool  :-D
15:19:10 <davdunc> cmurf: if you need any help with that lmk.
15:19:17 <sumantro> geraldosimiao, we can surely have one but the problem with BT specfic is the the proprietary drivers, example my one plus z buds would pair but wont playback anything
15:19:36 <geraldosimiao> lruzicka2: I would apply for that if I had any BT experience (I dont have BT here on my notebook and dont use any BT at all)
15:19:38 <cmurf> this is what i get for talking out my ear
15:19:43 <adamw> =)
15:20:02 <cmurf> testcloud should work but also shouldn't care about file system, so i don't think we need a testday to determine if testcloud is still working
15:20:05 <geraldosimiao> sumantro: so its too specific to create some usefull tests?
15:20:16 <adamw> #info "cmurf check in with fzatloukl that testcloud is OK with btrfs images" - we think it should be, hasn't been tested for sure yet though
15:20:20 <cmurf> and i have no reason to think it isn't; but if it's not, and if it's due to the btrfs change then it's a bug and needs to get fixed
15:20:33 <bittin> sumantro, geraldosimiao maybe create a list of non working BT headphones and see if Red Hat / Fedora can email the vendors?
15:20:45 <adamw> #topic Fedora 35 status and Change check-in
15:21:18 <geraldosimiao> bittin: that's possible, I can gatter information on that
15:21:32 <sumantro> geraldosimiao, that would be great!
15:22:09 <bittin> so Lailah you had something about KDE + Wayland on Fedora ?
15:22:11 <Lailah> bittin: Should I add mine?
15:22:18 <Lailah> bittin: Yes
15:22:26 <adamw> so it looks like something changed in gnome-initial-setup over the weekend which is causing openQA to choke, i'll have to look at that after the meeting
15:23:08 <adamw> before that, it was mostly doing okay with a few known issues - backgrounds aren't in yet, a freeipa bug that's getting worked out, a gnome update issue we need gnome folks to look into, and memtest still being busted
15:23:14 <bittin> adamw, looks like all builds works now, but it has been a bit shaky, Lailah go ahead
15:23:30 <Lailah> bittin: Thanks
15:24:18 <Lailah> So the issue is this.  Under Wayland, for some reason, when you change either Plasma theme or Global theme, the wallpaper will change and either show a black screen or reset to default.
15:24:37 <Lailah> Not the theme's default but Fedora's default.
15:24:42 <adamw> huh, that's an interesting one
15:24:48 <Lailah> It
15:25:06 <Lailah> It's more interesting because it doesn't happen in ALL machines.
15:25:32 <adamw> also interesting but could make it harder to debug...
15:25:32 <Lailah> For example, in my Lenovo it's okay but once in a while it shows a black screen.  But most of the time doesn't change.
15:25:32 <bittin> have you reported it at https://bugzilla.redhat.com/ if not that might be a good first step
15:25:42 <Lailah> And it doesn't change if it's on X11
15:25:54 <frantisekz> adamw, cmurf: testcloud works well with btrfs, tested on Fedora-Cloud-Base-35-20210823.n.0.x86_64.qcow2
15:26:03 * cmurf asked about LUKS sector size change in #anaconda
15:26:14 <Lailah> But there's someone in the KDE Telegram group that had this issue consistently and still has it.
15:26:16 <cmurf> frantisekz: ok awesome, thanks
15:26:26 <frantisekz> np, thanks for the heads up about the change
15:26:37 <frantisekz> (completely forgot about it)
15:26:52 <lruzicka2> geraldosimiao, same with me. I am a wire lover.
15:27:13 <Lailah> There was another person in the group who had that problem for a long time but eventually it resolved itself after a major update.
15:27:16 <geraldosimiao> lruzicka2: yeah oldschool here too ;)
15:27:29 <bittin> been thinking of buying a wireless headset but using 3.5" and USB for now
15:27:43 <Lailah> adamw:  AFAIK the only difference is user1 having Nvidia and users 2 &3 having Intel.
15:27:53 <lruzicka2> adamw, openqa chokes on it, it seems the accounts are gone .. but I was not able to run it in the VM, it ended with "oops, something went wrong"
15:27:55 <lruzicka2> all the time
15:28:16 <adamw> lruzicka2: i'll figure out the change in the code later.
15:28:23 <lruzicka2> adamw, also, I wanted to collect some data but it seems liveuser could not be used to enter the system
15:28:27 <Lailah> bittin:  I didn't report it because I was unsure it was worth a bug.
15:28:36 <Lailah> I mean, I've no idea what's going on.
15:28:50 <bittin> Lailah, might be a good idea to get the devs attention (but i can be wrong)
15:28:58 <lruzicka2> Lailah, it's worth any time ... you can close it anytime
15:29:41 <Lailah> Okay, I'll report it then
15:29:58 <Lailah> Thanks for the feedback  bittin lruzicka2 adamw
15:30:06 <lruzicka2> Lailah, no problem
15:30:09 <bittin> np
15:30:17 <geraldosimiao> adamw: about changes on F35, the change "wireplumber as session manager for pipewire" doesnt affect the ticket https://bugzilla.redhat.com/show_bug.cgi?id=1983861 ?
15:30:39 <adamw> geraldosimiao: i think that change is meant to provide a way to solve that bug, but not sure
15:30:53 <geraldosimiao> ok
15:31:56 <lruzicka2> speaking of Wireplumber ... should it not have been the default? I do not think it is the default on my F35
15:32:16 <geraldosimiao> yeah
15:32:19 <geraldosimiao> it should
15:32:31 <geraldosimiao> https://fedoraproject.org/wiki/Changes/WirePlumber
15:33:22 <Lailah> I don't think it is, no
15:33:33 <Lailah> I didn't see Wireplumber until now
15:33:47 <Lailah> In this chat. Not the computer.
15:34:37 <adamw> oh, wait, sorry, i was confused
15:34:54 <cmurf> yeah there's a sound bug on every laptop i've tried f35 on, no input or output device
15:34:54 <adamw> it's https://fedoraproject.org/wiki/Changes/Restart_User_Service_after_Upgrade that helps to fix the bug
15:35:30 <lruzicka2> cmurf, but the workaround is to start the pipewire-media-session which is not wireplumber
15:35:34 <cmurf> https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1518#note_1038386
15:35:46 <adamw> the wireplumber change may possibly be the cause of this bug, in fact
15:35:47 <lruzicka2> cmurf, does it mean, you replace the default with an older solution?
15:36:04 <lruzicka2> ok, that seems possible
15:36:04 <adamw> depending on exactly what pipewire-media-session is
15:36:08 <cmurf> well they are clean installs
15:36:17 <cmurf> pipewire is running but no devices
15:36:45 <adamw> the wireplumber Change was marked MODIFIED with no details. i should probably dig in and figure out what all is going on...
15:37:22 <cmurf> the most recent clean install i did was with 20210811
15:37:25 <adamw> #action adamw to figure out exact current state of pipewire session manager stuff (fresh install vs. upgrade, wireplumber vs. 'example session manager'
15:38:00 <cmurf> what i'm not sure of is if input/output devices show up with a live media boot
15:38:28 <cmurf> i'll try to get some time to test with a newer image and see if there's a diff between live boot and installed
15:38:50 <lruzicka2> cmurf, I can tell you right now. No devices on my live medium right now.
15:40:03 <lruzicka2> cmurf, using systemctl --user start pipewire-media-session did the trick :D
15:40:26 <cmurf> yeah that worked for me as well
15:40:32 <cmurf> with 20210811 + updates
15:40:34 <geraldosimiao> lruzicka2: Looks like
15:40:44 <lruzicka2> cmurf, I am using 20210822 :D
15:40:55 <cmurf> ok well then it's probably not fixed in the past 24 hours
15:41:08 <bittin> 0823 just got released but not sure if its fixed there, still downloading it
15:41:14 <bittin> (as just as a couple of minutes ago)
15:41:40 <adamw> the bugs haven't been updated
15:42:02 <adamw> so either the service that's needed isn't set to be enabled by default, or we're expecting wireplumber to start but it isn't, or something.
15:43:19 <cmurf> yep
15:44:36 <lruzicka2> it seems so
15:45:29 <adamw> alrighty, well, we'll look into it some more
15:45:31 <Lailah> I imagine WirePlumber waiting to start and we're waiting for it to start, and nothing happens  :-P
15:45:36 <adamw> any other notes on f35? major features, problematic bugs?
15:45:40 <adamw> the change set should be fixed now
15:45:48 <adamw> https://fedoraproject.org/wiki/Releases/35/ChangeSet
15:45:59 <Lailah> adamw:  Nothing from my side... that I remember
15:46:11 <bittin> don't have anything
15:47:21 <adamw> rgr
15:47:31 <Lailah> ?
15:47:38 <bittin> roger
15:47:41 <Lailah> Ah
15:48:19 <bittin> and for testdays it sounded like an audio and encrypted disks test day coming up?
15:48:29 <bittin> maybe a Kernel 5.14 too as that comes out on Sunday?
15:48:51 <sumantro> bittin, test days are like the next segment in the show
15:48:52 <bittin> https://www.phoronix.com/scan.php?page=news_item&px=Linux-5.14-rc7
15:49:02 <bittin> sumantro, was trying to go there :D
15:49:08 <adamw> indeed :)
15:49:11 <adamw> sorry, was just making sure we were done
15:49:18 <adamw> #topic Test Day / community event status
15:49:45 <sumantro> So, in the land of Test Days the tickets are filed, I will file a few more tonight
15:50:13 <adamw> awesome
15:50:15 <sumantro> I have contacted maintainers and I will work with cmurf and others for luks and audio test day in the next week
15:50:18 <adamw> did we schedule any yet?
15:50:22 <adamw> great
15:50:40 <sumantro> adamw by next week we will have dates and more info
15:50:52 <bittin> sounds good :)
15:51:14 <adamw> #info audio and LUKS test days will be scheduled soon, watch the mailing list for announcements
15:51:27 <sumantro> I am thinking of now adding a tag called "maintainer contacted" in our pagure in order for contributors to know the status on test days for changesets.. WDY'all think?
15:51:36 <bittin> +1
15:53:25 <sumantro> adamw that's all from my side!
15:53:59 <adamw> yup, sounds good to me
15:54:19 <Lailah> +1
15:54:46 <adamw> #topic Open floor
15:54:50 <adamw> any other business, folks?
15:54:59 <bittin> don't have anything special this time
15:55:04 <frantisekz> adamw, if I'd need a newpackage to go through a FE process, would that be issue? (it's not certain it's going to be the case, it may) , I don't know if I should hurry with https://bugzilla.redhat.com/show_bug.cgi?id=1992627 which may or may not be required for newer gjs ( https://gitlab.gnome.org/GNOME/gjs/-/merge_requests/632 ) which usually goes in under FE umbrella together with rest of GNOME
15:55:20 <Lailah> adamw:  Not from me
15:55:45 <adamw> frantisekz i don't see any particular specific problem there, no
15:55:51 <frantisekz> okay, ty :)
15:55:55 <adamw> if there's an FE justification we could certainly approve a newpackage bug
15:56:23 <adamw> i don't think adding the dist-git repo would require an infra freeze exception, but if it did you could just file a ticket for that too...
15:56:55 <frantisekz> okey dokey, I'll keep that in mind
15:57:25 <geraldosimiao> No more issues here from me
16:00:10 <adamw> alright, thanks for coming, everyone!
16:00:13 <adamw> see you next time
16:00:14 <adamw> #endmeeting