17:00:59 <bcotton> #startmeeting Council (2021-09-02)
17:00:59 <zodbot> Meeting started Thu Sep  2 17:00:59 2021 UTC.
17:00:59 <zodbot> This meeting is logged and archived in a public location.
17:00:59 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:59 <zodbot> The meeting name has been set to 'council_(2021-09-02)'
17:01:06 <bcotton> #meetingname council
17:01:06 <zodbot> The meeting name has been set to 'council'
17:01:33 <riecatnor> .hello riecatnor
17:01:34 <zodbot> riecatnor: riecatnor 'Marie Nordin' <mnordin@redhat.com>
17:01:37 <t0xic0der> .hello2
17:01:38 <zodbot> t0xic0der: t0xic0der 'Akashdeep Dhar' <akashdeep.dhar@gmail.com>
17:01:40 <bcotton> #chair bookwar dcantrell siddharthvipul1 riecatnor spot mattdm bcotton sumantrom marianab bt0 ramyaparimi t0xic0der
17:01:40 <zodbot> Current chairs: bcotton bookwar bt0 dcantrell marianab mattdm ramyaparimi riecatnor siddharthvipul1 spot sumantrom t0xic0der
17:01:44 <mattdm> hello!
17:01:55 <bookwar[m]> hello
17:02:07 <riecatnor> hiya :)
17:02:11 <t0xic0der> o/
17:02:15 <marianab[m]> .hello marianab
17:02:16 <zodbot> marianab[m]: marianab 'None' <marianaballa848@gmail.com>
17:02:29 <marianab[m]> Hi everybody
17:02:50 <riecatnor> I *just* got a tshirt from the opensuse conf and it has the new fedora logo on the back and it looks sooo good
17:03:12 <bcotton> schweet!
17:03:29 <dcantrell> .hello2
17:03:29 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
17:05:49 <bcotton> #topic Introductions, Welcomes
17:05:59 <bcotton> we're already doing this part, might as well make it official :-)
17:06:06 * sumantro is here
17:06:11 <bcotton> #topic Today's agenda
17:06:17 <bcotton> #info Ticket review
17:06:23 <bcotton> #info Your topics here!
17:07:03 <bcotton> #topic Ticket review
17:07:04 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issues
17:07:15 <bcotton> so we haven't met since.... 24 June if my notes are correct?
17:07:18 <mattdm> I have a topic, but I guess it's also a ticket
17:07:23 <bcotton> mattdm suggested we review our open tickets
17:07:30 <bcotton> so i'll let him drive this :-)
17:07:36 <mattdm> Yeah it's definitely time to get back to the routine after a summer break
17:07:44 <mattdm> Wait what? :)
17:07:48 <bt0> right
17:08:15 <mattdm> bcotton: can we tag team it? You drop in the tickets and I'll drive discussion on each?
17:08:35 <bcotton> sure. let's start at the top and work our way down
17:08:41 <mattdm> yep
17:08:43 <dcantrell> whoomp
17:08:43 <mattdm> thanks :)
17:08:46 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/377
17:09:47 <mattdm> ok, this is just "work matthew needs to do", I think
17:10:02 <bcotton> i concur
17:10:11 <mattdm> #action mattdm to do this
17:10:24 <mattdm> I'm trying a new todo list system so we'll see if that works. :)
17:10:55 <bcotton> i believe in you
17:11:02 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/378
17:11:35 <mattdm> wait I'm writing my todo
17:11:46 <mattdm> someone else summarize this while I do that for myself :)
17:12:07 * bcotton sighs
17:13:14 <bookwar[m]> `cat "Ben' tickets" > "Matthew's ToDo list"`
17:13:17 <mattdm> lol
17:13:43 <riecatnor> It looks like bt0 was attempting to start the conversation
17:13:44 <bcotton> bt0: it looks like you never got an actual reply from the mods on your post?
17:14:00 <bt0> yep, I tried, not response on r/fedora
17:15:34 <mattdm> ok, so, we have a code of conduct ticket related to this.
17:16:22 <mattdm> I think our next steps are some private code of conduct discussion
17:16:48 <riecatnor> I think we may need to resolve that to resolve this.
17:16:54 <mattdm> Which again #action mattdm to bring this up privately (since there are sensitive, individual issues involved)
17:16:59 <mattdm> Yeah.
17:17:04 <bcotton> #info There's a related Code of Conduct ticket that will need to be resolved to resolve this
17:17:26 <bcotton> #action mattdm to follow up on the CoC ticket
17:18:33 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/376
17:18:42 <riecatnor> I can take the follow up email actually
17:18:55 <bcotton> #undo
17:18:55 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f6312fb8320>
17:19:03 <bcotton> #undo
17:19:03 <zodbot> Removing item from minutes: ACTION by bcotton at 17:17:26 : mattdm to follow up on the CoC ticket
17:19:07 <bcotton> #action riecatnor to follow up on the CoC ticket
17:19:11 <mattdm> riecatnor++
17:19:11 <zodbot> mattdm: Karma for riecatnor changed to 12 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:19:14 <mattdm> thank you!!!
17:19:14 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/376
17:19:35 <bcotton> riecatnor: you had a proposal for a description update in the ticket
17:19:37 <t0xic0der> For #376, references at https://contributor.link/ mostly direct to the Join SIG
17:19:59 <bcotton> this feels like something we can delegate to the Join SIG. I don't think it needs council-level input?
17:20:16 <t0xic0der> bcotton: We wish to change that
17:20:25 <riecatnor> this is actually something I need to communicate to BKP
17:20:27 <bcotton> s/input/decision/
17:20:30 <mattdm> proposed resolution here: "Fedora Council thinks this is a good initiative but wants to make sure we manage it carefully. Let's delegate this to Mindshare for implementation."
17:20:40 <riecatnor> mindshare seems a better fit
17:20:43 <t0xic0der> Instead of just linking to Join SIG, a lot more teams can be benefited with the contributor inflow.
17:20:49 <bcotton> +1
17:20:53 <bt0> +1
17:20:55 <sumantro> +1
17:21:02 <mattdm> Yeah, in that case this does seem like a mindshare thing
17:21:09 <riecatnor> the idea is that Join SIG is there to guide folks to the right places
17:21:21 <bookwar[m]> t0xic0der: the question is - if those other projects are ready for the incoming requests like this
17:21:49 <mattdm> bookwar[m]: I guess the other side of that question is: if they're not, how can we help them become ready?
17:21:52 <bookwar[m]> Join SIG is not a separate entity, they are the proxy which should helps to direct people further
17:21:59 <t0xic0der> Some of the projects are. It involves reaching out to those teams and checking if at all they are looking for more contributors.
17:22:18 <bookwar[m]> t0xic0der: but isn't it what Join SIG should be doing?
17:22:22 <mattdm> that definitely seems like Mindshare to me. riecatnor and bt0, does that seem right to you?
17:22:31 <riecatnor> yep!
17:22:39 <t0xic0der> Namely W&A Objective Revamp (like I mentioned) and Marketing/Design like @computerkid did.
17:22:48 <bt0> sounds good for me
17:22:59 <riecatnor> we had design team there, and Mo asked me to take it down
17:23:24 <t0xic0der> bookwar[m]: Join SIG can be an entry point for folks who come through but Contributor.link can help us enhance our presence beyond that :)
17:24:38 <t0xic0der> This does look like a Mindshare discussion. Should I action myself to open a ticket there?
17:24:46 <mattdm> t0xic0der: do you want to help drive this in Mindshare? Honestly I like the idea of having something specific like this for Mindshare to work on :)
17:24:51 <mattdm> t0xic0der++
17:24:51 <zodbot> mattdm: Karma for t0xic0der changed to 16 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:24:55 <mattdm> yes perfect
17:25:00 <t0xic0der> mattdm: Yep.
17:25:03 <riecatnor> lol mattdm
17:25:19 <bcotton> #agreed Fedora Council thinks this is a good initiative but wants to make sure we manage it carefully. Let's delegate this to Mindshare for implementation.
17:25:31 <mattdm> I think it'd also be nice to make sure we have someone from council keep an eye on this -- either bt0 as mindshare rep, or one of the community outreach leads if this is something that seems directly in scope for that
17:25:45 <t0xic0der> #action t0xic0der to open a follow up ticket under Mindshare for Fedora-Council#376
17:25:47 <bookwar[m]> +1
17:25:47 <mattdm> that way we're not just "deglegate and forget"
17:25:58 <sumantro> mattdm, I can
17:26:03 <bt0> sure, Also I'm part og the join SIG :P
17:26:10 <mattdm> sumantro++
17:26:10 <zodbot> mattdm: Karma for sumantro changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:26:12 <t0xic0der> bt0++
17:26:12 <mattdm> bt0++
17:26:17 <mattdm> ok awesome :)
17:26:27 <bt0> cool
17:26:55 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/364
17:27:21 <bcotton> So we talked about this at the last vF2F and i haven't done anything with it because 1. I'm trying to get out of the legal biz and 2. it honestly doesn't seem that important :-)
17:27:37 <mattdm> heh.
17:27:53 <bcotton> but...
17:27:54 <mattdm> also there is a discussion on FEdora Legal mailing list wherein Richard Fontana wants to get rid of FPCA entirely
17:28:14 <bcotton> yeah, that also does not motivate me to put effort into this one
17:29:01 <mattdm> I think there are some reasons to not get rid of it, but they're mostly technical.
17:30:41 <mattdm> we actually have some boilerplate...
17:30:51 <mattdm> from https://discussion.fedoraproject.org/tos
17:31:05 <bcotton> i think there's a good non-technical reason to get rid of it, i should post on the list
17:31:07 <mattdm> "All user contributions must be under an acceptable license for Fedora as defined in the Fedora Project Contributor Agreement. User contributions which do not state otherwise are licensed under the Current Default License, which is Creative Commons Attribution-ShareAlike 4.0 as described in the FPCA."
17:31:18 <bcotton> but for now, i'll #action myself to proceed as if we're not getting rid of it :-)
17:31:39 <bcotton> #action bcotton to assemble a list of services that do/don't require FPCA for review
17:31:40 <mattdm> I think we should suggest that rather than requiring the FPCA, we should put similar statements on services like weblate.
17:31:51 <mattdm> I will put this thought in the ticket :)
17:32:12 <bcotton> that's a separate matter, imo
17:32:31 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/354
17:32:39 <bcotton> oh hey, this is done!
17:33:01 <riecatnor> jflory7++
17:33:03 <riecatnor> mattdm++
17:33:03 <zodbot> riecatnor: Karma for mattdm changed to 7 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:33:18 <bcotton> let's leave it open until the announcements are published
17:33:24 <bcotton> (he says, previewing the "do we have anything to announce?" section)
17:33:25 <mattdm> yes! in fact, I have a request there.
17:33:43 <mattdm> the Digital Public Goods folks want to do some splashy PR.
17:33:56 <bt0> cool
17:33:58 <mattdm> I have tagged in John Terrill, one of Red Hat's communication team people
17:34:26 <mattdm> (he's now apparently Director of Communications, which is pretty exciting because I know him as "helpful person who does low-level Fedora stuff for us"
17:34:49 <mattdm> I would like to see if there are people in mindshare who would also like to help from the community side
17:34:55 <mattdm> so it's not jsut all corporate comms
17:35:06 <mattdm> So bt0 I was wondering if you could take this to mindshare as well
17:35:42 <bt0> action meeee
17:35:53 <bt0> :)
17:36:34 <mattdm> yesss :)
17:36:40 <bcotton> #action bt0 to take this to Mindshare for help with community-side communications
17:36:57 <mattdm> #action mattdm connect bt0 to digital public goods folks
17:38:12 <bt0> thanks
17:38:29 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/349
17:38:53 <mattdm> uh, hmm. did they show up at Nest?
17:38:58 <mattdm> I did not see them there.
17:39:10 <dcantrell> I've got problems with associations with shells.com
17:39:32 <dcantrell> and I was disappointed to see them as a sponsor for nest
17:39:33 <riecatnor> I didn't see someone at Nest but the social was 1 hour of a three day event.
17:40:49 <mattdm> dcantrell: yeah, noted. I had a long call with Alex Lee, and he was very eager to have it understood that shells was his business, not his brother's, and distanced himself from the freenode trashfire
17:41:15 <dcantrell> but from a technical perspective, they don't use the Fedora kernel and AFAIK they haven't changed that.  so since their are running their own special bedazzled kernel on Fedora, that's not technically fedora, so I don't think they should use the trademark
17:41:16 <mattdm> He wanted to come to nest to have a chance to talk to people candidly about himself, his company, and their intentions
17:41:19 <mattdm> So I said... okay.
17:41:40 <bookwar[m]> dcantrell: i think we shouldn't boycott by association.
17:42:17 <dcantrell> I'm not convinced it's merely an association
17:42:26 <mattdm> dcantrell: we have some counter-examples -- Fedora Container Image is still branded "fedora" when running on some other kernel.
17:42:32 <bcotton> In any case, like dcantrell said, they're not using our kernel and there's been no action on their part. i say we close this without prejudice
17:42:45 <Eighth_Doctor> actually that's not entirely true
17:42:53 <mattdm> Eighth_Doctor: which part?
17:42:57 <dcantrell> I would be ok with discussing the special kernel if there were a real technical need, but there isn't
17:42:58 <Eighth_Doctor> Zlotan emailed me asking for help trying to get the fedora kernel working in their environment
17:43:23 <Eighth_Doctor> they were struggling to create a working bootable image for Shells
17:43:34 <Eighth_Doctor> I haven't gotten around to responding because August has been a hectic month
17:43:37 <mattdm> dcantrell: yeah that makes sense to me
17:44:01 <mattdm> I am leaning towards bcotton's proposal -- close without prejudice, ask them to come back with these things addressed
17:44:34 <dcantrell> I'm fine with that
17:44:34 <mattdm> I, for one, do not htink that next year will be The Year of The Cloud Desktop, but... I could be wrong. And if it is, it'd be nice for people to have options.
17:44:39 <bookwar[m]> Ben Cotton (he/him/his): +1. I think in our initial trademark conversation with them they said they actually want to run vanilla Fedora, and we were all like : go for it. If that's changed, then I agree that the outcome of the conversation should be different too.
17:45:02 <mattdm> bcotton can you write an appropriately neutral close message?
17:45:34 <bcotton> #action bcotton to write an appropriately neutral close message for #349
17:46:25 <bookwar[m]> But I do not want us to make decision on Shells  based on freenode events. I think we should separate them unless proven otherwise
17:46:45 <bcotton> bookwar: agreed
17:46:51 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/348
17:47:29 <bcotton> this one seems to be waiting on the requester
17:47:37 <bcotton> but i want to go on record as being 100% not keen on "m'distro"
17:47:47 * bcotton will add that to the ticket
17:48:04 <riecatnor> bcotton, +1 on that
17:48:12 <dcantrell> uhhh
17:48:19 <dcantrell> yeah, bcotton +1
17:48:35 <bookwar[m]> I see potential clash with Design team
17:48:42 <mattdm> yeah no m'distro please
17:49:10 <bt0> +1
17:49:20 <riecatnor> I would say if there is a ticket with the design team, should be fine
17:49:40 * t0xic0der looks up what m'distro is
17:49:42 <riecatnor> anything to do with the fedora logo needs approval from mizmo anyways
17:49:43 <mattdm> riecatnor: as a designy sort of person, can you answer the ticket with that
17:49:46 <riecatnor> yep
17:50:16 <bcotton> i don't have strong feelings about whether the design team is involved with creating the designs or not, so long as they approve of the final results
17:50:18 <mattdm> t0xic0der: there was a meme going around a while ago with an awkward guy wearing a fedora saying "m'lady"
17:50:24 <bookwar[m]> Yeah, if Design team will approve the items I think it can work. Not sure if requester will be satisfied with this process, but it makes sense to me
17:50:41 <mattdm> a caricature of a certain sort of nerdy guy
17:51:00 <t0xic0der> mattdm: Lolol, definitely not something I'd like to see :P
17:51:12 <mattdm> And people found it funny to post that and say "m'lady" and "m'distro" in pretty mujch all fedora social media posts for a while
17:51:19 <mattdm> it was pretty tiring tbh
17:51:40 <mattdm> I'll reply in ticket about this stuff
17:52:02 <bookwar[m]> Ben Cotton (he/him/his): if you create some designs for Fedora you are de-facto in Fedora Design team :) it just doesn't exclude you from the approval process
17:53:00 <bcotton> okay, last one since we're running out of time
17:53:02 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/342
17:53:19 <bcotton> (this also tees up the "do we have anything to announce?" section, i think)
17:53:38 <mattdm> SO CLOSE
17:53:44 <bookwar[m]> do we have a separate task for our own server?
17:53:50 <mattdm> we are in the process of getting the the servers set up
17:53:51 <bookwar[m]> as a prerequisite for this one?
17:53:58 <mattdm> nirik and nb are working on it
17:54:27 <Eighth_Doctor> do the servers exist?
17:54:35 <mattdm> once that's done, and we have it up and running, I want to set up the new space, and we'll figure out what to do about the existing matrix.org ones
17:54:50 <mattdm> Eighth_Doctor: yes but not yet fully configured for things like "logging on"
17:55:05 <mattdm> and the dns isn't point at them yet.
17:55:18 <Eighth_Doctor> so that means they're paid up and existing now!
17:55:29 <mattdm> Once this is ready and I've done the initial configuration, I'd like to do a soft launch for the next month or so
17:55:36 <Eighth_Doctor> then all that's left is to start moving the Matrix room primary MXIDs
17:55:57 <mattdm> Eighth_Doctor: well, all of those need to be created, yes
17:56:07 <mattdm> Plus the space hierarchy set up
17:56:28 <bookwar[m]> still, having the actual servers is a great progress!
17:56:29 <Eighth_Doctor> well, the rooms exist, someone just has to log in with a fedoraproject.org MXID to start setting the IDs on the existing rooms
17:56:36 <Eighth_Doctor> and changing the primary IDs over
17:57:18 <mattdm> I'll connect with you separately about how one changes the primary IDs. because that'sa  concern of mine.
17:57:32 <mattdm> For now, let's leave this ticket open and wrap up the meeting because we're almost at time
17:57:40 <bcotton> #topic Next meeting
17:57:46 <bcotton> #info The next regular business meeting is Thursday 16 September
17:58:05 <bcotton> #info There's a video meeting scheduled for Thursday 9 September but....bcotton has not yet scheduled a guest
17:58:31 <bcotton> anyone have ideas on who we could rope into it at the last minute? or should we just skip this time?
17:59:16 <dcantrell> I'm happy to do a video on the US Coast Guards navigational rules and aids to navigation
17:59:19 <mattdm> lol
17:59:34 <mattdm> let's skip this time and then work on our Fall Guest Appearance Slate
18:00:39 <bookwar[m]> invite python folks
18:00:54 <mattdm> for this next time, or future?
18:01:17 <bookwar[m]> there was LWN article about some changes in python and packaging which i didn't read/understand :)
18:01:23 <bookwar[m]> Recent one
18:02:03 <dcantrell> yeah, I've got that on my list of things to read this week.  the battle between module package managers and distribution package managers continues--sort of--in the world of python
18:02:08 <mattdm> I read it -- I think it's more a technical thing than a Council one.
18:02:45 <bcotton> okay, i think we'll call next week a wash. there's a Beta go/no-go at that time anyway :-)
18:03:01 <mattdm> ooh, yeah. what does the crystal ball say?
18:03:04 <bcotton> if anyone ever has suggestions, please feel free to put them in the wiki https://fedoraproject.org/wiki/Council/Video_Meetings#Wish_list
18:03:53 <bcotton> i'm fairly optimistic
18:03:56 <bcotton> but we shall see
18:04:02 <mattdm> ok :)
18:04:04 <bcotton> it only takes one unfixed blocker :-)
18:04:17 <bcotton> #info We will skip the September video meeting
18:04:44 <bcotton> since we're over time and we've already discussed the pending announcements, we'll skip that part
18:04:51 <mattdm> :)
18:04:56 <bcotton> also some of us are presenting at DevConf.US right now ;-) https://app.hopin.com/events/devconf-us-51c1f2ca-9b3d-4a34-bbe5-c7a0f5fa0b12/sessions/bb676a3c-8e88-4f0d-9285-5e2616061bcc
18:04:59 <bcotton> thanks everyone!
18:05:06 <bcotton> #endmeeting