15:00:00 <bcotton> #startmeeting Council (2022-03-02)
15:00:00 <zodbot> Meeting started Wed Mar  2 15:00:00 2022 UTC.
15:00:01 <zodbot> This meeting is logged and archived in a public location.
15:00:01 <zodbot> The chair is bcotton. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:01 <zodbot> The meeting name has been set to 'council_(2022-03-02)'
15:00:01 <bcotton> #meetingname council
15:00:01 <bcotton> #chair bookwar dcantrell siddharthvipul1 riecatnor spot mattdm bcotton sumantrom marianab bt0 t0xic0der
15:00:01 <zodbot> The meeting name has been set to 'council'
15:00:01 <zodbot> Current chairs: bcotton bookwar dcantrell siddharthvipul1 riecatnor spot mattdm bcotton sumantrom bt0 marianab t0xic0der
15:00:21 <bcotton> BOOM! 15:00:00
15:00:28 <bcotton> #topic Introductions, Welcomes
15:00:31 <riecatnor[m]> .hello riecatnor
15:00:32 <zodbot> riecatnor[m]: riecatnor 'Marie Nordin' <mnordin@redhat.com>
15:00:36 <AkashdeepDhar[m]> .hello2
15:00:36 <zodbot> AkashdeepDhar[m]: Sorry, but user 'AkashdeepDhar [m]' does not exist
15:00:37 <dcantrell> .hello2
15:00:39 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
15:01:10 <AkashdeepDhar[m]> .hello2
15:01:12 <zodbot> AkashdeepDhar[m]: Sorry, but user 'AkashdeepDhar [m]' does not exist
15:01:23 <AkashdeepDhar[m]> Ah never mind. Hello everyone
15:01:39 <bcotton> welcome one and all
15:01:44 <mattdm> hello!
15:02:08 <riecatnor[m]> hullo :)
15:02:19 <mattdm> I am not on vacation anymore.
15:02:31 <AleksandraFedoro> .hello bookwar
15:02:32 <zodbot> AleksandraFedoro: bookwar 'Aleksandra Fedorova' <alpha@bookwar.info>
15:02:38 <mattdm> But this is literally the first thing I'm doing on returning from vacation (other than listening to a big internal RH all-hands meeting)
15:02:48 <mattdm> so it's like no time has passed since our last Council meeting, for me.
15:02:53 * bcotton feels special
15:03:26 <mattdm> This was more by way of excuse than meaning to make you feel special... but you SHOULD feel special anyway Ben :)
15:03:48 <bcotton> do you know what else is special?
15:03:48 <bcotton> today's agenda!
15:03:55 <bcotton> #topic Today's agenda... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/9f4911dd3411e6e29eaf15c329e47a62894bef88)
15:04:08 <bcotton> #topic Cloud variant branding for F36
15:04:08 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/389
15:04:23 <davdunc[m> .hello davdunc
15:04:24 <zodbot> davdunc[m: davdunc 'David Duncan' <davdunc@amazon.com>
15:04:34 <bcotton> so stephen tried to get the council to come to a quick decision on this, which was adorable
15:04:49 * mattdm cough-laughs
15:04:54 <bcotton> i weighed in on the ticket, but it would be good to hear from others on it
15:05:04 <bcotton> anyone feel the need to discuss it now?
15:05:31 <mattdm> Since davdunc is here, I want to ask a direct question -- how do things look for the re-Editioning plan?
15:05:47 <davdunc[m> mattdm: we have a good group of plans for making it work.
15:06:20 <davdunc[m> I feel highly confident that we have the support we need to get it done.
15:06:32 <mattdm> If you're feeling confident about it, I think "leave as is, waive blocker" is the best for now.
15:06:47 <mattdm> I can put that in the ticket if that helps Ben Cotton (he/him) and Stephen Gallagher  :)
15:07:52 <mattdm> Does anyone see any value in changing it for F36 and then (hopefully) putting it back for F37?
15:09:06 <davdunc[m> I find it more difficult to reduce the consistency for validations/checking that any user might be relying upon today.
15:09:09 <bcotton> just procedurally. there's not really a defined mechanism for choosing to ignore a release criterion like this. but if there's an approved council vote, that makes the process less ad hoc (and would probably lower adam williamson's blood pressure slightly)
15:09:25 <davdunc[m> I will humbly ask for the exception.
15:09:57 <riecatnor[m]> I think the reason I haven't commented there is because the editions strategy topic is highly debated and I am not sure we have something resolved to use as a reference for how to make decisions wrt editions.
15:10:38 <riecatnor[m]> If we are removing it just to add it back, that part doesnt make much sense to me.
15:10:56 <AleksandraFedoro> I think that changing names in a rush doesn't make sense. If the problem is a blocker state, let's address that as matthew said.
15:12:10 <mattdm> Since this particular criteria is in place to help enforce a council policy, seems reasonable that we should be able to waive it when needed
15:12:27 <mattdm> Should we put this in the form of a proposal and do a formal vote?
15:12:56 <davdunc[m> yes. I would like this to be an exception with the commitment to reestablish the requirements by the next release.
15:12:58 <bcotton> in the ticket, imo
15:13:15 <bcotton> we shouldn't do a vote here
15:13:23 <mattdm> Okay. I'll put it in the ticket.
15:13:43 <bcotton> #action mattdm to propose a waiver in the ticket
15:14:20 <mattdm> Does anyone disagree? I think this is likely a matter of formality, to which I am not opposed, but assuming we're not going to ask for a change, I think there's no particular urgency and we don't need to declare an emergency vote deadline.
15:15:08 <bcotton> #topic COVID-19 In-person event policies
15:15:08 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/379
15:15:19 <bcotton> so riecatnor tells me there's breaking news on this topic
15:15:27 <mattdm> Wait one more thing on the previous?
15:15:57 <riecatnor[m]> mattdm: no disagreement from me.
15:16:28 <AkashdeepDhar[m]> mattdm: None from my end as well.
15:16:34 <mattdm> I want to undo the topic change so this goes in the minutes right :)
15:16:45 <bcotton> #undo
15:16:45 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f6a393cec88>
15:16:46 <mattdm> but I am not going to step on ben's toes and just do it :)
15:16:47 <bcotton> #undo
15:16:47 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f6a394260b8>
15:16:51 <mattdm> thanks :)
15:16:56 <bcotton> ket's do it and move on
15:17:00 <mattdm> #link https://docs.fedoraproject.org/en-US/council/policy/edition-promotion-policy/
15:17:36 <mattdm> #info the Editions Promotion policy document has been updated to include (modernized but substantially the same) text from the 2014 Fedora Board policy about the same.
15:17:46 <davdunc[m> if there is discussion on the cloud-sig in specifically on any of these topics, we would invite you to meet with us during our regular bi-weekly meeting or comment on the COE we published in the cloud-sig issues in pagure.
15:17:58 <mattdm> so it's probably worth reviewing that, davdunc and Cloud WG.
15:18:11 <mattdm> davdunc: Sure, I'd be happy to.
15:18:18 <bcotton> okay, that's not really relevant to the ticket, that's about the future state
15:18:53 <mattdm> Getting to that future state is a requirement for the ticket, though, so... related.
15:18:56 <davdunc[m> mattdm: it's my constant textbook at this point.
15:19:05 <mattdm> And we can move on. Thanks for humoring me Ben :)
15:19:36 <bcotton> #topic COVID-19 In-person event policies
15:19:36 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/379
15:20:05 <riecatnor[m]> good news, I have a draft for review!
15:20:08 <riecatnor[m]> #link https://fedoraproject.org/wiki/In_Person_Event_Guidance_Related_to_Covid-19
15:20:45 <riecatnor[m]> I would like the Council to review this page and note if you see anything problematic, or something you feel is missing
15:20:56 <riecatnor[m]> I will add the link to the ticket as well
15:21:56 <AkashdeepDhar[m]> riecatnor: I skimmed through it, some parts could use some elaboration but it is a good start
15:22:17 <mattdm> what is the breaking news?
15:22:30 <riecatnor[m]> I think its that there is a draft ready for review lol
15:22:33 <AkashdeepDhar[m]> Especially the "Safety Requirements" section could be elaborated upon to leave less things on people's assumption and more on the specific guidelines ;P
15:22:54 <riecatnor[m]> There is a reason it is generic
15:23:11 <riecatnor[m]> 1. every place/country/event has different guidelines
15:23:29 <riecatnor[m]> 2. mindshare and/or the council has no way to make sure each and every guideline is followed. its not feasible
15:24:11 <riecatnor[m]> I would be interested to hear what you would like to add on there, keeping those things in mind
15:25:13 <AkashdeepDhar[m]> Right, we can't quite ensure or elaborate upon those two but I believe that we probably can cover the things (which are kinda obvious to us as of now) but better explicitly stated than assumed.
15:25:30 <AleksandraFedoro> Do we need a requirement to communicate the terms to participants of the event?
15:25:38 <AkashdeepDhar[m]> Take for instance, preventing travel when someone has diagonozed a certain disease
15:25:56 <riecatnor[m]> AleksandraFedoro: this is a good question, I will look into that
15:25:57 <AkashdeepDhar[m]> Then, carrying ample medical supplies and making the management aware of the same etc.
15:26:02 <dcantrell> should this mention something about travel (e.g., international) travel requirements?
15:26:49 <riecatnor[m]> AkashdeepDhar[m]: so add something like "If you have Covid-19, do not travel..."
15:26:54 <riecatnor[m]> * not travel..."?
15:27:00 <dcantrell> also, the page uses Covid-19, Covid, and COVID-19 to all refer to the same thing.  that should be consistent throughout the document.  I suggest COVID-19
15:27:09 <AkashdeepDhar[m]> riecatnor[m]: Something in the same lines but you get the point :D
15:27:19 <riecatnor[m]> dcantrell: can do!
15:27:53 <riecatnor[m]> dcantrell: do you mean a differentiation between in country travel and across border travel?
15:28:40 <dcantrell> yeah, something like that.  under Safety Requirements, I am reading this as being specific to the event/venue in question.  but attendees also need to be aware of and adhere to all travel requirements that will impact them on the trip and that could mean additional costs (e.g., testing, whatever)
15:29:13 <riecatnor[m]> seems like a good addition, I will work that in
15:29:24 <dcantrell> I guess I'm thinking more along the lines of "also, don't forget any specific travel requirements!"
15:29:55 <dcantrell> the number of people I have talked to during the pandemic who either had incorrect information or made assumptions and ended up at an airport and unable to depart has been somewhat high
15:30:21 <dcantrell> riecatnor[m]: oh, I know...reiteration that travel requirements change frequently...like day to day even in some cases
15:30:59 <riecatnor[m]> I agree on all of this
15:31:44 <dcantrell> my last comment:   "Understanding of and adherence to local government requirements."  --> strike "local" from that sentence
15:32:32 <riecatnor[m]> can you provide your thinking behind removing it?
15:32:50 <riecatnor[m]> my thought is because it will be different everywhere, local makes sense, but I am open to changing my mind :)
15:33:14 <dcantrell> local can mean a lot of difference things depending on where you are.  in the US I would take local to mean city and county.  some might include state.  in other countries.... ???
15:33:31 <dcantrell> if you just say 'government', you include everything
15:33:35 <mattdm> And also, maybe your government has requirements for you that apply even when you're not local?
15:33:42 <riecatnor[m]> that makes sense
15:33:53 <riecatnor[m]> i'm convinced! i will remove htat
15:33:57 <riecatnor[m]> s/htat/that/
15:34:55 <riecatnor[m]> anything else?
15:35:35 <riecatnor[m]> I will write up these notes and add them to the ticket with the link.. and I will work on updating the draft.. because most of the changes are small, hopefully the legal review will be quick. I am also including Mindshare in the review process as they are the ones who will be using this
15:35:47 <dcantrell> sounds good!
15:36:03 <AkashdeepDhar[m]> riecatnor: That's pretty much from my end. Great work so far.
15:36:06 <riecatnor[m]> if anyone thinks of more things feel free to add them to the ticket!
15:37:04 <bcotton> #topic F36 Release Party planning
15:37:04 <bcotton> #link https://pagure.io/mindshare/issue/320#comment-783778
15:37:19 <riecatnor[m]> so its that time again 🎉🎉🎉
15:37:39 <riecatnor[m]> I would like to ask the Council to offer topics that they would like to see covered at the next release party
15:38:12 <riecatnor[m]> there is a current list in the ticket, but we could use more, and there is no way for me to know everything that's happening in Fedora ;)
15:38:40 <mattdm> dcantrell: Anything from the FESCo/engineering side that seems of particular note this release?
15:38:56 <riecatnor[m]> for reference here:
15:39:01 <dcantrell> it all feels like a blur because there's a lot of stuff in there
15:39:02 <riecatnor[m]> - Fedora IoT - Peter Robinson and/or Paul Whalen... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/3fd9c63e52d52006cdc3541cdb38522529e3704b)
15:39:17 <mattdm> dcantrell: Yes, same feeling. :)
15:39:23 <AkashdeepDhar[m]> riecatnor: I have a couple of topics that could probably have conflicts so I'd like to note em here.
15:39:29 <mattdm> Ben Cotton (he/him): how about "new docs team stuff"?
15:40:19 <riecatnor[m]> dcantrell: well, I guess ignore the ticket :) the question is really "what relevant things should we make sure to cover at the upcoming release party?"
15:40:28 <AkashdeepDhar[m]> One talk called "Fedora Workstation's State of Gaming" could involve mentions of varied trademarks and footages of video games so I'm wondering if that is allowed ;O
15:40:43 <mizmo> hi just a note bc i got @ pinged.... due to various circumstances i cant really commit to any event appearances, but i can do anything prerecorded
15:40:48 <dcantrell> there's a lot of new versions of things, tool chain stuff, libraries:  https://fedoraproject.org/wiki/Releases/36/ChangeSet
15:41:02 <riecatnor[m]> sure Máirín Duffy :) that will work
15:41:03 <dcantrell> if you want to stir the pot, you could note that the RPM database moved to /usr in this release  :)
15:41:33 <riecatnor[m]> is that enough for a 20 min talk? :) lol
15:41:45 <dcantrell> no
15:42:29 <riecatnor[m]> well, if anyone thinks of things or runs into some cool stuff that is being worked on, please drop me a message or comment on the mindshare ticket
15:42:39 <dcantrell> oh, NVIDIA driver users get Wayland now, so that's a thing
15:42:46 <riecatnor[m]> I like the idea of a gaming related session
15:42:57 <riecatnor[m]> I think bc it is a release party we have the chance to reach more users
15:43:17 <riecatnor[m]> dcantrell: this seems notable
15:43:19 <AkashdeepDhar[m]> riecatnor: It's more of a showcase session. Showing what Fedora Workstation is capable of when it comes to games.
15:43:45 <riecatnor[m]> seems like something Aleksandra Fedorova would be interested in, too
15:43:52 <AkashdeepDhar[m]> We might show show graphs, benchmarks of some prominent games - and these games are well proprietary software so I thought that their might be some objections here and there.
15:44:39 <AleksandraFedoro> I don't think we need to worry about games being proprietary as long as we clearly mark them as such
15:45:01 <riecatnor[m]> mmm I see. well, imo, free software and proprietary software need to co-exist and showing that Fedora is useful for gaming is a positive
15:45:33 <AleksandraFedoro> So we should highlight when we are talking about open source game, when it is about proprietary game and when it is about proprietary and DRMed game. So that users can make their choices
15:45:36 <mattdm> My personal opinion: I feel like games are a special case. I mean, it's cool when they are collaborative, open source projects, but they can also be very personal art. Maybe we could show some with open source game engines, though.
15:45:47 <riecatnor[m]> <mattdm> "Ben Cotton (he/him): how about..." <- also interested in this
15:45:56 <mattdm> And yeah Aleksandra Fedorova +1
15:46:23 <AleksandraFedoro> mattdm: showing demo from games shouldn't be a problem, every streamer does that
15:46:42 <AleksandraFedoro> But it really need to be some short demo from fedora with focus on fedora
15:46:45 <AkashdeepDhar[m]> mattdm: Totally agree to that. I was more into pushing this talk in the wake of the newly introduced Steam Deck - enthusiasts can give Fedora a try if they get to know that they can run games on Steam Deck with Fedora on it
15:47:58 <AkashdeepDhar[m]> I did present a talk in front of CPE about the same thing - benchmarking Control (2019) in DXVK as well as VKD3D.  It was well received and suggested to be presented here too ;P
15:48:02 <riecatnor[m]> t0xic0der: are you also volunteering to do the session? :)
15:48:48 <AkashdeepDhar[m]> AleksandraFedoro: With you on that. We would showcase how easy it is to configure an environment to play games before we show a short clip with a framerate meter ;P
15:49:00 <AkashdeepDhar[m]> riecatnor[m]: Me and $(someoneelse).
15:49:17 <riecatnor[m]> I know Neal has been doing some streaming on fedora
15:49:50 <riecatnor[m]> sonic, iirc :)
15:50:32 <riecatnor[m]> so... anything other ideas? I think we can figure details for each session in the upcoming months
15:50:48 <AkashdeepDhar[m]> riecatnor[m]: Aha nice. We should really push Fedora to the users who are looking for some gaming action - the release party looks a great place to do just that.
15:51:50 <mattdm> Yeah. The release parties are becoming one of our best talk-to-end-users showcase opportunities.
15:52:51 <riecatnor[m]> thanks for all the input!
15:52:57 <bcotton> #topic Moderation Guidelines
15:52:57 <bcotton> #info We'll defer this to the next meeting due to time constraints
15:52:58 <AleksandraFedoro> some robotics could be interesting
15:53:23 <riecatnor[m]> the moderator guidelines is a simple-ish ask
15:53:32 <bcotton> #undo
15:53:32 <zodbot> Removing item from minutes: INFO by bcotton at 15:52:57 : We'll defer this to the next meeting due to time constraints
15:53:32 <bcotton> ok
15:53:35 <bcotton> go ahead
15:53:51 <riecatnor[m]> basically I need to know if I should run that through the council or mindshare
15:53:55 <riecatnor[m]> or both.
15:54:20 <riecatnor[m]> the idea is to establish a set of moderation guidelines to be used across all fedora platforms/spaces
15:54:28 <riecatnor[m]> (with input from stakeholders of those platforms!)
15:55:04 <bcotton> my take: Mindshare should develop it and send to Council for approval
15:55:43 <riecatnor[m]> any other takes? :)
15:55:56 <AkashdeepDhar[m]> Ben Cotton (he/him): Sounds like a plan :)
15:55:58 <mattdm> I'm not convinced it's solely a mindshare thing?
15:56:20 <mattdm> but I'm happy to put it there if people are willign to do the work there :)
15:56:35 <riecatnor[m]> it is really going to be me doing the bulk of the work :)
15:56:56 <riecatnor[m]> But, it sounds like we need both bodies to be aware of the process, do reviews, and then the council will approve?
15:57:42 <mattdm> riecatnor: <3
15:57:57 <mattdm> Yeah, I think this actually should be a council policy.
15:58:05 <riecatnor[m]> I can move forward with that, which is what I needed from ya'll.
15:58:11 <riecatnor[m]> Thanks!
15:58:17 <bcotton> #topic Next meeting
15:58:17 <bcotton> #info The next regular business meeting is Wednesday 16 March
15:58:17 <bcotton> #info The next Video Meeting is 10 March. The guests will be Stephen Gallagher and Justin Forbes talking about ELN SIG
15:58:17 <bcotton> #link https://fedoraproject.org/wiki/Council/Video_Meetings
15:58:31 <bcotton> #topic Do we have anything to announce?
15:58:31 <bcotton> #info This is a regular check to make sure we're communicating to the contributor (via CommBlog) and user (via Magazine) communities
15:58:46 <riecatnor[m]> oh, yes, we are looking for projects/mentors for GSoC and Outreachy!
15:59:01 <bcotton> #help Submit your project and mentor proposals for Outreachy by 3 March: https://communityblog.fedoraproject.org/call-projects-mentors-outreachy-may-2022/
15:59:11 <riecatnor[m]> oh that got extended
15:59:12 <riecatnor[m]> to march 23rd
15:59:15 <riecatnor[m]> I need to update the blog post
15:59:26 <bcotton> #undo
15:59:26 <zodbot> Removing item from minutes: HELP by bcotton at 15:59:01 : Submit your project and mentor proposals for Outreachy by 3 March: https://communityblog.fedoraproject.org/call-projects-mentors-outreachy-may-2022/
15:59:29 <bcotton> #help Submit your project and mentor proposals for Outreachy by 23 March: https://communityblog.fedoraproject.org/call-projects-mentors-outreachy-may-2022/
16:00:05 <riecatnor[m]> if you or someone you know is interested in mentorship, these are both great opportunities
16:00:14 <riecatnor[m]> and for Outreachy it doesn't have to be coding
16:01:20 <riecatnor[m]> thats it from me :)
16:01:44 <bcotton> #topic Open floor... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/32ba63d5238af2a8ca81a5d309014e0c89c87e52)
16:01:50 <mattdm> I have one quick thing -- can people look at https://pagure.io/Fedora-Council/council-docs/pull-request/138? I'd like to merge that. Particularly, though, there are some small changes to the Council charter page (IRC -> Matrix) which Ben and I decided are just procedural and not policy changes. If anyone on the council thinks otherwise, please say so. (Not here. In the PR comments.)
16:02:02 <mattdm> I didn't get that snuck in before the endmeeting. But still please. :)
16:02:24 <riecatnor[m]> thank you Ben Cotton (he/him) for chairing!
16:02:34 <riecatnor[m]> and also to everyone for letting me take up most of today's meeting :)
16:02:42 <bcotton> did zodbot get the endmeeting?
16:02:49 <bcotton> or have i abused the multi-line support in the bridge
16:02:51 <mattdm> i guess we'll see
16:02:54 <mattdm> #endmeeting
16:03:11 <mattdm> zodbot, you there?
16:03:17 <mattdm> .fire zodbot
16:03:17 <zodbot> adamw fires zodbot
16:05:13 <AkashdeepDhar[m]> Gotta head for the dinner - see you folks around! :D
16:06:06 <Ebeneezer_Smooge> zodbot .ping
16:06:17 <Ebeneezer_Smooge> #endmeeting
16:06:42 <Ebeneezer_Smooge> ok this will probably require nirik
16:07:05 <Ebeneezer_Smooge> I have forgotten too much about zod to do this without breaking something
16:08:18 * nirik is in meeting, can look in a bit
16:08:24 <mattdm> thanks Ebeneezer_Smooge , and nirik in advance :)
16:11:13 <nirik> #endmeeting