17:08:40 <pboy> #startmeeting fedora-server
17:08:40 <zodbot> Meeting started Wed Mar 2 17:08:40 2022 UTC.
17:08:40 <zodbot> This meeting is logged and archived in a public location.
17:08:40 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:08:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:08:40 <zodbot> The meeting name has been set to 'fedora-server'
17:08:53 <pboy> #topic Agenda
17:08:59 <pboy> #link https://pagure.io/fedora-server/report/Meeting
17:09:06 <pboy> #info 1. Follow up actions
17:09:12 <pboy> #info 2. Check F36 changes and known issues - final pass
17:09:19 <pboy> #info 3. Specifying F36 manual test requirements - final pass
17:09:26 <pboy> #info 4. Review current Fedora Server Technical Specification – second pass
17:09:32 <pboy> #info 5. Open Floor
17:09:39 <pboy> Any additional topic ?
17:10:13 <pboy> And a hearty welcome to everyone.
17:10:20 <eseyman> hello, all
17:10:23 <pboy> And sorry for my delay !
17:10:23 <cooltshirtguy> hello
17:10:46 <cooltshirtguy> no worries, stuff happens
17:10:57 <eseyman> the other issue is that our meeting does not appear to be on the schedule
17:11:01 <pboy> I forgot the roll call. Please, who is here today?
17:11:05 <eseyman> but that's less important
17:11:18 <cooltshirtguy> me
17:11:20 <eseyman> .hello2 eseyman
17:11:21 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
17:12:03 <cooltshirtguy> .hello2 cooltshirtguy
17:12:04 <zodbot> cooltshirtguy: cooltshirtguy 'Jason Beard' <jas_beard@hotmail.com>
17:12:19 <pboy> eseyman: I'll check that for next meeting. But the invitation was sent by calender.
17:13:35 <pboy> I see no additional Item. So let's start with our agenda.
17:13:44 <pboy> #topic 1. Follow up actions
17:13:51 <pboy> Currently, so far as I see, there are various action running as planned. There is nothing to touch in the moment.
17:14:00 <pboy> So we could save time and skip this topic? Or is there anything I missed? Or any objections to skip?
17:14:37 <pboy> #info Various actions are in progress as planned, see
17:14:39 <eseyman> I'm okay with skipping
17:14:47 <pboy> #link https://pagure.io/fedora-server/boards/Works%20in%20progress
17:15:01 <pboy> #topic 2. Check F36 changes and known issues - final pass
17:15:10 <pboy> #link https://pagure.io/fedora-server/issue/72
17:15:19 <pboy> I have tried to compile the current status
17:15:27 <pboy> https://pagure.io/fedora-server/issue/72#comment-783914
17:15:49 <pboy> Somethin to add / to delete?
17:16:19 <eseyman> FTR, I'll be taking a hard look at OpenLDAP 2.5 starting with F36 Beta
17:16:40 <pboy> eseyman +1
17:17:03 <pboy> We come the that in the next topic
17:17:14 <pboy> Imean: who does what
17:17:32 <pboy> #proposed Comment https://pagure.io/fedora-server/issue/72#comment-783914 finally lists the potential issues for Server Edition in F36 that we need to keep track of.
17:18:12 <pboy> 3
17:18:21 <pboy> 2
17:18:27 <pboy> 1
17:18:36 <pboy> #agreed Comment https://pagure.io/fedora-server/issue/72#comment-783914 finally lists the potential issues for Server Edition in F36 that we need to keep track of.
17:18:52 <pboy> #topic 3. Specifying F36 manual test requirements - final pass
17:19:02 <pboy> #link https://pagure.io/fedora-server/issue/64
17:19:24 <pboy> I have compiled a list of manual tests / track actions from our discussions so far
17:19:34 <pboy> #link https://pagure.io/fedora-server/issue/64#comment-783961
17:20:10 <pboy> May be we wait some minutes so everyone can read
17:20:32 <cooltshirtguy> reading
17:21:08 <eseyman> the openldap will quite probably break existing configuration
17:21:26 <pboy> that's not good
17:22:15 <cooltshirtguy> that's bad
17:22:29 <eseyman> no but the openldap ml has been warning for years it's going to happen
17:23:02 <Southern_Gentlem> so any fix for next week
17:24:17 <pboy> eseyman I added you for openldap.
17:25:36 <eseyman> thank you
17:25:52 <pboy> thank you!
17:26:11 <cooltshirtguy> quick question, where do i post my comments about the cockpit file sharing? I've been testing it.
17:28:06 <pboy> cooltshirtguy I think we should use mailing list for discussion and issue 73 for tracking and documenting
17:28:09 <eseyman> cooltshirtguy: the "Open Floor" topic seems the most appropriate
17:28:30 <cooltshirtguy> ok thanks
17:28:33 <pboy> OK. or open floor here
17:29:26 <pboy> Additional ideas for the list? Otherwise
17:29:36 <pboy> #proposed Comment https://pagure.io/fedora-server/issue/64#comment-783961 summerizes the current items in F36 release process to get monitored by server WG.
17:29:49 <eseyman> no, it looks good
17:30:10 <pboy> 3
17:30:16 <pboy> 2
17:30:21 <pboy> 1
17:30:23 <pboy> #agreed Comment https://pagure.io/fedora-server/issue/64#comment-783961 summerizes the current items in F36 release process to get monitored by server WG.
17:30:35 <pboy> We are quick today
17:30:48 <pboy> #topic 4. Review current Fedora Server Technical Specification – second pass
17:30:57 <pboy> #link https://pagure.io/fedora-server/issue/58
17:31:06 <pboy> #info Created a first draft of a proposal of a complete updated text:
17:31:13 <pboy> #link https://hackmd.io/9or6pDs3Qq6DzzgVzXgmeQ?view
17:31:21 <pboy> Proposal for the thematic structure of the discussion.
17:31:29 <pboy> a. General remarks (please, NOT about single specific content items!)
17:31:38 <pboy> b. Discussion of „supported services“ as part of Fedora Server ( sec. 4 & 4.4)
17:31:45 <pboy> c. Discussion of the requirements for support using Ansible (sec. 4.1)
17:31:52 <pboy> d. Discussion of a possible recourse to Ansible Linux system roles (https://linux-system-roles.github.io/)
17:32:00 <pboy> e. Agreement about next steps
17:32:11 <pboy> Alternative proposals for the ==structure/flow== of the discussion? (NOT for the content!)
17:33:05 <eseyman> nope
17:33:13 <pboy> I see no alternative proposal, so let's begin
17:33:20 <pboy> a. == General remarks == The floor is open
17:34:13 <Southern_Gentlem> so what is the plan for OpenLdap if it is not backward compatible
17:34:40 <eseyman> Southern_Gentlem: we document the migration path
17:34:59 <pboy> Southern_Gentlem could we defer that until the first beta?
17:35:28 <Southern_Gentlem> not really considering the go/NOGO is next week
17:36:29 <cooltshirtguy> nope
17:36:54 <pboy> OK, out of topic. Do we have a dedicated opinion about openldap no/go?
17:37:09 <pboy> Or will we just try to cope with FESDo decision?
17:37:37 <Southern_Gentlem> if it goes in everyone will have to run F36 for ldap to work?
17:37:45 <eseyman> We don't really have a choice. Upstream has ended support for OpenLDAP 2.4
17:38:30 <eseyman> Southern_Gentlem: the configuration of OpenLDAP 2.4 is not compatible with OpenLDAP 2.5
17:38:30 <Southern_Gentlem> so does mean windows,mac boxes will be unable to use our server for ldap?
17:38:55 <eseyman> the LDAP protocol itself will not change
17:39:16 <pboy> I think every admin will have to modify the config
17:39:35 <pboy> either manually, or the update process will do that?
17:39:55 <Southern_Gentlem> eseyman, so if someone upgrades from f35 server they will have to make some changes
17:40:02 <Southern_Gentlem> ??
17:40:17 <eseyman> Southern_Gentlem: yes, your slapd.conf will no longer be read
17:40:33 <cooltshirtguy> that won't be fun
17:40:33 <Southern_Gentlem> so this needs to be documented asap imho
17:41:01 <Southern_Gentlem> so the issue is not the client end but the server end itself
17:41:08 <eseyman> exactly
17:41:43 <Southern_Gentlem> so this needs a commonbugs entry as well as documentation
17:42:12 <pboy> OK, so we won't opt for nogo, but try to make the follow up as easy as possible
17:42:19 <eseyman> pboy: +1
17:42:34 <pboy> Riiiiiiiinnnnnnnnng
17:42:43 <pboy> Our parliamentary president would now ring the bell and refer to the agenda
17:43:08 <pboy> Please, let's resume a. == General remarks == The floor is open
17:44:15 <eseyman> I've already given my input on the TS
17:44:49 <pboy> TS?
17:45:04 <cooltshirtguy> Technical Specs
17:45:17 <pboy> Oh, silly me
17:45:37 <pboy> OK, so let's proceed with
17:45:46 <pboy> b. Discussion of „supported services“ as part of Fedora Server ( sec. 4 & 4.4)
17:46:10 <pboy> Here we find our Ansible project
17:46:59 <pboy> And it is a kind of revitalization of the previous server role using other tools
17:48:34 <cooltshirtguy> so "a mechanism" mean ansible
17:48:57 <pboy> cooltshirtguy. YES
17:49:02 <eseyman> probably since some of us use Ansible
17:49:48 <eseyman> still too soon to decide anything, imho
17:50:44 <pboy> We have been planning to use Ansible for some time. jwhimpel is working on a PoC.
17:51:18 <pboy> eseyman It is a first pass of the new text.
17:52:20 <pboy> We need not to decide anything now. But if there are no comments, we would stay with this version for now . May be we have later better ideas.
17:53:01 <pboy> So, we should step forward:
17:53:11 <pboy> c. Discussion of the requirements for support using Ansible (sec. 4.1)
17:54:12 <pboy> Are the 5 requirement items sensible? Any comments on that?
17:54:23 <eseyman> it all seems sensible
17:55:01 <pboy> No other comment, so:
17:55:10 <pboy> d. Discussion of a possible recourse to Ansible Linux system roles (https://linux-system-roles.github.io/)
17:55:52 <eseyman> still haven't looked at this; won't have time to do so before F36 Beta
17:57:22 <cooltshirtguy> whether to inlcude them ?
17:57:38 <pboy> #proposed Currently no additions or changes to the discussed sections.
17:57:49 <pboy> 3
17:57:53 <pboy> 2
17:57:56 <pboy> 1
17:57:59 <eseyman> cooltshirtguy: or at least point to them and recommend them
17:58:12 <pboy> #agreed Currently no additions or changes to the discussed sections.
17:58:35 <pboy> What are our next step?
17:58:47 <cooltshirtguy> i would defineitly call them out
17:59:24 <pboy> I would continue to fill in the caps and everybody should add ether by editing an alternative wording or propose one as comment
17:59:42 <pboy> caps -> gaps TBD
18:00:14 <eseyman> that sounds fair
18:00:47 <pboy> action pboy will complete the first draft. Everyone should add by comments.
18:01:01 <cooltshirtguy> ok
18:01:02 <pboy> #action pboy will complete the first draft. Everyone should add by comments.
18:01:17 <pboy> #topic 5. Open Floor
18:01:40 <pboy> Our time is up, but we may have some minutes
18:02:21 <eseyman> cooltshirtguy: Cockpit?
18:03:15 <cooltshirtguy> like I said just wondering where i need to put my comments about the samba part of fielsharing
18:03:50 <pboy> OK, so we will watch the ticket and the mailing list.
18:03:51 <cooltshirtguy> it works, but you have to some things at the command promot level.
18:03:58 <eseyman> if you have a short version, here and now
18:04:03 <cooltshirtguy> *prompt
18:04:19 <eseyman> if it requires more time, take it to the ml
18:04:46 <cooltshirtguy> I'll send my thoughts on the ml
18:04:54 <eseyman> yeah, I had to go to the cmd line to install the VM module
18:05:30 <cooltshirtguy> as always selinux plays a part. :)
18:05:57 <pboy> OK guys. Many thanks for comming and see you all in 14 days. And on the Mailing list and at #fedora-server
18:06:06 <pboy> #endmeeting