#fedora-meeting: ELN SIG 2022-03-11

Meeting started by sgallagh at 17:00:13 UTC (full logs).

Meeting summary

  1. Init Process (sgallagh, 17:00:13)
  2. Status Report (sgallagh, 17:04:18)
    1. Composes are timing out and failing, but we did get a good one on Mar. 9 (sgallagh, 17:06:12)
    2. ELN SIG spoke to the Fedora Council yesterday, see recording at https://www.youtube.com/channel/UCnIfca4LPFVn8-FjpPVc1ow when available (sgallagh, 17:08:29)
    3. ELN-Extras is in progress, but slow going due to other commitments. Reviews requested for https://gitlab.com/redhat/centos-stream/ci-cd/distrosync/distrobuildsync/-/merge_requests/37 (sgallagh, 17:11:45)

  3. x86_64-v3 (sgallagh, 17:13:54)
    1. ACTION: sgallagh to discuss the impact of x86_64-v3 on RHEL for Edge with RHEL Pgm (sgallagh, 17:54:10)
    2. Important points raised: v3 was not universally available until 2017, which means existing hardware may need replacement to run (sgallagh, 17:55:20)
    3. non-AVX2 hardware is still in production, and widely deployed in long-lifecycle environments (emdedded/pos/appliances/etc.) that could be impacted by this change (dcavalca, 17:55:30)
    4. Concerns about ISV and integrator cases for x86_64-v3 for RHEL. Would prefer to see us look into supporting multiple flavors for x86_64 in parallel like done in the past with ppc64 with p7 and x86_32 with i586 and i686 (Eighth_Doctor, 17:55:34)
    5. Edge devices frequently use low-power Intel chips such as Atom and many (most?) don't have v3 support (sgallagh, 17:55:47)
    6. Increasing the baseline will lead to smaller code (both in less disk space and higher efficiency) (sgallagh, 17:56:47)
    7. On the other hand, multiple builds in the OS do not clean the pipes for ISVs, which would have to deliver multiple builds as well to avoid support issues. (fweimer, 17:56:51)
    8. The guaranteed availability of AVX2 extensions would benefit high-performance computing, particularly machine-learning. (sgallagh, 17:57:20)
    9. OpenMandriva has an implementation of x86_64 flavors we can use as a basis to understand implementing a similar system for supporting x86_64-vX levels in parallel. (Eighth_Doctor, 17:58:32)


Meeting ended at 18:03:44 UTC (full logs).

Action items

  1. sgallagh to discuss the impact of x86_64-v3 on RHEL for Edge with RHEL Pgm


Action items, by person

  1. sgallagh
    1. sgallagh to discuss the impact of x86_64-v3 on RHEL for Edge with RHEL Pgm


People present (lines said)

  1. Eighth_Doctor (66)
  2. sgallagh (59)
  3. fweimer (37)
  4. jforbes (29)
  5. dcavalca (24)
  6. zodbot (11)
  7. cyberpear (2)
  8. Conan_Kudo (0)


Generated by MeetBot 0.4.