15:05:03 <adamw> #startmeeting Fedora QA meeting
15:05:03 <zodbot> Meeting started Mon Mar 14 15:05:03 2022 UTC.
15:05:03 <zodbot> This meeting is logged and archived in a public location.
15:05:03 <zodbot> The chair is adamw. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:05:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:03 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:05:10 <adamw> #meetingname fedora-qa
15:05:10 <zodbot> The meeting name has been set to 'fedora-qa'
15:05:13 <adamw> #topic Roll Call
15:05:21 <adamw> sorry folks, lost track of the clock
15:05:25 <nielsenb> I'm here
15:05:42 <adamw> ahoyhoy
15:07:41 * coremodule is here.
15:09:25 <pboy> .hello2
15:09:26 <zodbot> pboy: pboy 'Peter Boy' <pboy@uni-bremen.de>
15:12:03 <adamw> hmm, turnout's a bit thin
15:12:55 <nielsenb> I'll take that as a compliment
15:13:34 <adamw> you look great in that!
15:14:03 * bcotton is here now
15:14:17 <nielsenb> Risky thing to say in an era of work from home, who knows what 'that' is :D
15:14:29 <adamw> whatever it is, i'm sure he looks great in it
15:15:47 <adamw> i think europe missed the note about dst
15:15:48 <adamw> silly europe
15:16:23 <pboy> adamw. europe didn't. :-)
15:16:56 <adamw> then where's the rest of you :D
15:18:26 <adamw> alright, well, let's take a quick spin through the agenda
15:18:30 <adamw> #topic Previous meeting follow-up
15:19:12 <adamw> #info "adamw to put the revised default application criterion into production" - I did that: https://fedoraproject.org/w/index.php?title=Fedora_36_Final_Release_Criteria&diff=637469&oldid=636319
15:19:45 <adamw> #info "adamw to update GNOME test day wiki page with links to an ISO with GNOME 42~beta in it" - I also did that: https://fedoraproject.org/wiki/Test_Day:2022-02-28_Fedora_36_GNOME_42#Prerequisites_for_Test_Day
15:19:48 <adamw> any other follow-up?
15:20:53 <adamw> guess not!
15:21:07 <adamw> #topic Fedora 36 status
15:21:12 <nielsenb> Hard to follow the meteting above all the rabble
15:21:14 <adamw> status is...better than last week
15:21:14 <bytehackr> \o
15:21:24 <adamw> hi
15:22:06 <adamw> tests are mostly passing, blockers are mostly fixed. we have one unaddressed blocker that the council isn't trying to waive (more on that later!) and two proposed ones which look to be getting voted down.
15:22:26 <adamw> tests are mostly passing
15:22:45 <adamw> #info f36 is looking much better than last week, most blockers are addressed, tests are passing
15:23:08 <adamw> any other notes on f36?
15:23:37 <nielsenb> Are we moving in the right direction with network-manager / gnome-control-center functionality?
15:23:47 <nielsenb> I've been away for a few days and haven't had a chance to poke at it again
15:24:02 <coremodule> I know it's not the ARM meeting, but ARM testing for F36 beta would be helpful
15:24:32 <adamw> nielsenb: VPN should be fixed in an update
15:24:35 <adamw> libnma is still being worked on
15:24:43 <adamw> coremodule: yes, indeed
15:25:06 <adamw> didn't we decide you were supposed to be doing that ;)
15:25:12 <nielsenb> Are there specific ARM things that should be tested?
15:25:19 <nielsenb> I have only had time for quick smoke tests of minimal
15:25:31 <adamw> #info more help running aarch64 tests on the candidate compose would be great
15:25:39 <coremodule> nielsenb, filling out the test matrix so that come go/no-go we have good coverage
15:25:48 <adamw> nielsenb: the validation tests - https://fedoraproject.org/wiki/Test_Results:Fedora_36_Beta_1.1_Summary
15:27:42 <nielsenb> Quick related question since everyone is here, is server on aarch64 supposed to boot to some kind of configurator (either graphical or CLI), or just cockpit?
15:28:02 <adamw> disk image installs should boot to initial-setup
15:28:08 <adamw> there was a known bug preventing that till recently
15:28:17 <nielsenb> Good to know, thanks
15:28:47 <adamw> it should be fixed since the 20220305.n.0 compose
15:30:27 <adamw> installs from netinst/dvd depend on package set and whether you create a root password or admin account during install.
15:31:53 <adamw> alrighty
15:32:05 <adamw> #topic Current criteria / test case proposals
15:32:32 <adamw> so, a big current proposal is the one filed by ben on friday - topic "Proposal: Explicitly allow Council to waive Edition self-identification"
15:32:46 <adamw> https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/EFTMMXJYAZOW5CHBCON6UHWCUYWF34OY/
15:34:01 <nielsenb> If it's happened twice, I'm sure it will happen again someday, so I think it's nice for the process to be codified
15:34:51 <adamw> well, they're actually a bit different
15:35:23 <adamw> for f35 we waived it on the basis that it was proposed late, which is a legitimate basis to waive something under https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Exceptional_cases
15:35:42 <adamw> for f36 it would be hard to justify waiving it under that same policy
15:36:12 <nielsenb> But had this policy existed for F35, it could have been used in that case, no?
15:36:15 <adamw> also, for f35 it was waived by the right process, i.e. during a blocker review or go/no-go meeting. this time council is trying to waive it, but there isn't any existing process that really says council can do that. so, that's what we want to fix.
15:36:21 <adamw> nielsenb: yes, indeed
15:37:33 <bcotton> "that's what we want to fix" is a key part of the statement. from my perspective, this is fixing a bug in the process, not making a policy change
15:37:52 <nielsenb> Fair
15:40:02 <adamw> ok, so, if anyone has any issues with this proposal, now would be a great time to air them :D
15:42:36 <adamw> alrighty then
15:43:18 <adamw> #info the proposal to allow Council to waive blockers relating to Edition self-identification was discussed and not opposed by anyone
15:44:35 <adamw> we also have the networking criteria proposal outstanding
15:44:39 <adamw> anyone have notes on that?
15:44:49 <adamw> i guess i should amend it to cover enterprise wireless..
15:45:59 <nielsenb> Yes
15:46:44 <bcotton> i'm a little concerned that it will be a can o' worms, but the fact that we don't really have networking criteria right now is Bad
15:46:52 <nielsenb> Right
15:47:31 <nielsenb> None of the other network types seem real explicitly defined, it seems like since gnome-control-center provides a way to configure enterprise wireless, it's just kind of covered by default?
15:48:25 <adamw> uh, quite a lot of types are explicitly defined in the proposal
15:48:40 <adamw> well
15:48:57 <adamw> we say "It must be possible to establish both IPv4 and IPv6 network connections using DHCP and static addressing", without really defining much about how the packets are sent...
15:49:03 <nielsenb> Right
15:49:07 <adamw> i would add some more words there i guess
15:49:14 <adamw> more words always makes everything better
15:49:25 <nielsenb> I'm not sure I would add more rules?
15:49:39 <lruzicka2> I apologise for not being here .... and of course, the more words ...
15:49:40 <adamw> it's not more rules, just more...resolution of the current rules
15:49:43 <nielsenb> I kind of like the flexibility of "if we ship a tool that claims to configure it, it should make it work"
15:50:04 <adamw> i'm not a big fan of just completely whiffing on the 'what kind of networks do we support' question honestly
15:50:39 <adamw> nielsenb: but it doesn't actually say that. and it's a tough line to walk. we ship nm-connection-editor, which can configure all sorts of stuff. heck, we ship nmcli.
15:51:04 <adamw> i can include that suggestion as an option in the proposal, though, and see what people think...
15:51:16 <nielsenb> I guess I can see it either way
15:51:28 <adamw> it would also provide a kind of perverse incentive to disable features in our network config tools
15:51:35 <adamw> oh, there's a bug in that one? turn it off so we can ship! :D
15:51:39 <nielsenb> Yes
15:52:01 <nielsenb> Or "it isn't included as something that blocks so let's just ship it broke"
15:52:06 <nielsenb> Which I really don't like
15:52:19 <adamw> anyway, i'll think about it
15:52:53 <adamw> #action adamw to consider updating network criteria proposal to cover types of network connection (wired, wireless, security types...)
15:53:21 <adamw> .fire lruzicka2
15:53:22 <zodbot> adamw fires lruzicka2
15:53:24 <adamw> #topic Test Day / community event status
15:53:56 <adamw> nielsenb: oh, btw, https://bodhi.fedoraproject.org/updates/FEDORA-2022-3263270e1e is the update that should fix VPN connection editing.
15:55:05 <adamw> #info we had GNOME test week and i18n test week the last two weeks: https://fedoraproject.org/wiki/Test_Day:2022-02-28_Fedora_36_GNOME_42 , https://fedoraproject.org/wiki/Test_Day:2022-03-08_I18N_Test_Day
15:55:31 <adamw> #info both look to have gone off pretty successfully with good participation
15:55:42 <nielsenb> Are there not e-mails going out to test / qa anymore? Or am I just missing them
15:55:51 <nielsenb> I think I saw the i18n one in my inbox
15:56:35 <adamw> i see luna sent an email about the i18n one
15:56:45 <adamw> i don't see an announcement of the gnome one at a quick glance...
15:57:18 <adamw> ah, sumantro did announce the i18n one: https://lists.fedoraproject.org/archives/list/test-announce@lists.fedoraproject.org/thread/VHD3L6NT7RHG7QXDFADGZ4XKPGA32OZB/
15:57:32 <adamw> but yeah it looks like the GNOME one was missed, sorry about that
15:59:48 <lruzicka2> I think the messages are coming, I am seeing them
15:59:56 <adamw> #topic Open floor
15:59:58 <adamw> any other business, folks?
16:03:49 <adamw> aaaaalrighty then, thanks for coming
16:03:54 <adamw> blocker review is starting over in #fedora-blocker-review
16:04:23 <lruzicka2> all righty
18:40:10 <adamw> whoopsie
18:40:11 <adamw> #endmeeting