17:00:05 <bcotton> #startmeeting F36 Final Go/No-Go meeting
17:00:05 <bcotton> #meetingname F36-Final-Go_No_Go-meeting
17:00:05 <zodbot> Meeting started Thu May  5 17:00:05 2022 UTC.
17:00:05 <zodbot> This meeting is logged and archived in a public location.
17:00:05 <zodbot> The chair is bcotton. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:05 <zodbot> The meeting name has been set to 'f36_final_go/no-go_meeting'
17:00:05 <zodbot> The meeting name has been set to 'f36-final-go_no_go-meeting'
17:00:19 <bcotton> #topic Roll Call
17:00:27 <nirik> morning everyone
17:00:27 <salimma> .hi
17:00:28 <zodbot> salimma: salimma 'Michel Alexandre Salim' <michel@michel-slm.name>
17:00:36 <jednorozec> .hello humaton
17:00:37 <zodbot> jednorozec: humaton 'Tomáš Hrčka' <thrcka@redhat.com>
17:00:47 <copperi[m]> .hello copperi
17:00:48 <zodbot> copperi[m]: copperi 'Jan Kuparinen' <copper_fin@hotmail.com>
17:00:55 <mhroncok> .hello churchyard
17:00:56 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
17:01:00 <CRCinAU> .hello CRCinAU
17:01:01 <zodbot> CRCinAU: crcinau 'Steven Haigh' <netwiz@crc.id.au>
17:01:11 * mhroncok is here, but will likely go away really soon
17:01:26 <geraldosimiao> .hello geraldosimiao
17:01:27 <zodbot> geraldosimiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
17:01:34 <coremodule> .hello
17:01:34 <zodbot> coremodule: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:01:41 <coremodule> .hello2
17:01:42 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
17:02:13 <mboddu> .hello mohanboddu
17:02:14 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
17:02:43 <bcotton> big attendance today. i should have put on a tie
17:03:05 * salimma is wearing a three-piece suit
17:03:08 * mattdm is here with my Go-Stick
17:03:11 <salimma> I challenge anyone to prove me wrong
17:03:13 <adamw> .hello adamwill
17:03:14 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
17:03:16 <bcotton> we'll wait another moment to see who else rolls in and then we'll start
17:04:00 <bcotton> #topic Purpose of this meeting
17:04:00 <bcotton> #info Purpose of this meeting is to check whether or not F36 Final is ready for shipment, according to the release criteria.
17:04:07 <bcotton> #info This is determined in a few ways:
17:04:07 <bcotton> #info 1. No remaining blocker bugs
17:04:07 <bcotton> #info 2. Release candidate compose is available
17:04:07 <bcotton> #info 3. Test matrices for Beta are fully completed
17:04:24 <bcotton> #topic Current status - blockers
17:04:40 <bcotton> #info 1 Proposed Blockers
17:04:40 <bcotton> #info 4 Accepted Blockers
17:04:40 <bcotton> #info 0 Accepted 0-day Blockers
17:04:40 <t0xic0der[m]> .hello t0xix0der
17:04:41 <zodbot> t0xic0der[m]: Sorry, but user 't0xix0der' does not exist
17:04:48 <t0xic0der[m]> .hello t0xic0der
17:04:48 <bcotton> #topic (2081326) The terminal does not show username and hostname on the terminal prompt
17:04:48 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=2081326
17:04:48 <bcotton> #link https://pagure.io/fedora-qa/blocker-review/issue/806
17:04:48 <zodbot> t0xic0der[m]: t0xic0der 'Akashdeep Dhar' <akashdeep.dhar@gmail.com>
17:04:48 <Alessio[m]> .hello2
17:04:51 <zodbot> Alessio[m]: Sorry, but user 'Alessio [m]' does not exist
17:04:58 <bcotton> #info Proposed Blocker, gnome-terminal, NEW
17:04:59 <bcotton> #info Ticket vote: FinalBlocker (+2,0,-11) (+asciiwolf, +jpbn, -catanzaro, -bcotton, -geraldosimiao, -mattdm, -humaton, -somethingsomethingfedora, -nb, -coremodule, -kparal, -augenauf, -sgallagh)
17:04:59 <bcotton> #info Ticket vote: FinalFreezeException (+3,0,-0) (+bcotton, +somethingsomethingfedora, +nb)
17:05:11 <nb> .hi
17:05:12 <zodbot> nb: nb 'Nick Bebout' <nick@bebout.net>
17:05:32 <adamw> all indications are that this was some kinda crazy bitflip event
17:05:32 <bcotton> this may be a record for number of ticket votes. the -1s have a clear majority, but since it's still on the list, i figured we should see if anyone can make a case for accepting it
17:05:50 <adamw> Ben Cotton (he/him): i figured at this point we should just save it for this meeting to be sure
17:06:06 <bcotton> agreed on both counts
17:06:22 <adamw> but i'm -1 just on the basis that we've been installing f36 a lot for months and hit this once. or twice. depends if this and the person in irc were the same thing.
17:06:25 <nirik> yeah, -1 FinalBlocker... seems to have gone away/not be reproducable
17:07:03 <adamw> if someone else does run into it we'll just have to tell 'em to reinstall.
17:07:22 <robatino> no easy way to fix manually?
17:07:49 <adamw> robatino: well, you could copy the stuff from /etc/skel in manually i guess, but if that wasn't done, who knows what else might be funky...personally i'd just reinstall, at least if i caught it right away.
17:07:50 <kparal> adamw: Creating a new user is enough, no?
17:07:54 <geraldosimiao> I'll keep my vote the same as already in the ticket
17:07:57 <adamw> kparal: oh, yeah, or that.
17:08:08 <bcotton> proposed #agreed 2081326 - RejectedBlocker (Final) - This bug has no clear reproducer and seems to be extraordinarily rare.
17:08:18 <geraldosimiao> Ack
17:08:21 <nb> ack
17:08:24 <kparal> I'll mark that with CommonBugs and add some advice how to fix it
17:08:24 <mattdm> Ack
17:08:29 <copperi[m]> ack
17:08:30 <jednorozec> ack
17:08:40 <bcotton> kparal: I'm not even sure we should commonbugs it
17:08:44 <mattdm> kparal: I'm not sure it's even commonbugs worthy
17:08:48 <mattdm> jinx
17:08:52 <CRCinAU> any documentation is good documentation.
17:08:55 <kparal> meaning it's that rare, or why?
17:09:01 <geraldosimiao> It's anything but common
17:09:11 <bcotton> mattdm: that's not going to help the rumor that you're just a puppet i control :p
17:09:14 <mattdm> I'm not sure it's even _rare_ — rather maybe "a fluke"
17:09:15 <geraldosimiao> Rarebugs
17:09:20 <adamw> it should go on the rarebugs page
17:09:29 <CRCinAU> even if its phrased as "We've seen X, but only occasionally, and we can't reproduce it. If you see it, do Y to fix"
17:09:32 <geraldosimiao> Flukebugs
17:09:42 <adamw> ack
17:09:42 <kparal> ok, adamw to create a rarebugs page and document it
17:09:46 <bcotton> #agreed 2081326 - RejectedBlocker (Final) - This bug has no clear reproducer and seems to be extraordinarily rare.
17:09:50 <nirik> ack
17:09:51 <coremodule> ack
17:09:54 <mboddu> ack
17:09:56 <nb> ack
17:10:00 <bcotton> #topic (2079344) A new album looks empty until app restart
17:10:00 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=2079344
17:10:00 <bcotton> #link https://pagure.io/fedora-qa/blocker-review/issue/787
17:10:00 <bcotton> #info Accepted Blocker, gnome-photos, VERIFIED
17:10:01 <copperi[m]> ack
17:10:02 <adamw> i seem to have remembered an extremely important appointment i had
17:10:11 <adamw> this is fixed.
17:10:15 <bcotton> anyone care to say this isn't fixed?
17:10:41 <CRCinAU> I'm guessing the Online Accounts part of photos being b0rked is well out of scope for consideration?
17:10:54 <geraldosimiao> It's fixed
17:10:54 * kparal has some stuff to attend to, very urgently
17:10:54 <bcotton> #topic (2081291) album picker duplicates fields, preventing photo organization
17:10:54 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=2081291
17:10:54 <bcotton> #link https://pagure.io/fedora-qa/blocker-review/issue/802
17:10:54 <bcotton> #info Accepted Blocker, gnome-photos, VERIFIED
17:10:55 <bcotton> ditto this one
17:11:05 <mattdm> yay!
17:11:12 <adamw> CRCinAU: it's too late for consideration!
17:11:14 <adamw> this train is leaving
17:11:22 <adamw> yup, this is fixed too
17:11:25 <CRCinAU> thought as much.
17:11:27 <bcotton> #topic (2056303) After upgrade to F36 several packages fail to update due to selinux-related errors
17:11:27 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=2056303
17:11:27 <bcotton> #link https://pagure.io/fedora-qa/blocker-review/issue/756
17:11:27 <bcotton> #info Accepted Blocker, selinux-policy, ON_QA, depends on other bugs
17:12:17 <nirik> this was fixed in -7 I think?
17:12:42 <adamw> we were keeping an eye on it to make sure updates went to f34 and f35 and nobody claimed any more problems
17:13:00 <adamw> we really need -7 to be good enough for this, because -8 didn't make the compose :| but i think it is.
17:13:12 <nirik> yeah, thats one of the two things I was going to note. ;(
17:13:43 <bcotton> #info -7 should have a good enough fix for this
17:13:53 <kparal> I just wonder how many verification test I performed were with -7 and how many with -8
17:14:11 <adamw> kparal: from the bug you mention -7 several times, never -8
17:14:21 <nirik> selinux-policy-36.7-1.fc36 is in the compose, selinux-policy-36.8-1.fc36 is supposed to be in stable... but it only fixes FE's
17:14:26 <adamw> and i don't think any change in -8 is listed as relevant to this
17:14:30 <kparal> but it shouldn't matter for upgrades, I realize. Upgrades will always get -8
17:15:07 <adamw> oh yes that's a good point
17:15:08 <adamw> whew
17:15:19 <adamw> this bug was about upgrades, so it doesn't matter what was on the media
17:15:20 <kparal> should be good (tm)
17:15:20 <bcotton> proposed #agreed 2056303 is fixed for the purposes of the release criteria
17:15:23 <bcotton> anyone disagree with that?
17:15:25 <nb> akc
17:15:27 <nb> ack
17:15:27 <mboddu> ack
17:15:30 <adamw> ack
17:15:31 <nirik> ack
17:15:32 <adamw> we can probably close it
17:15:35 <copperi[m]> ack
17:15:35 <sgallagh> ack
17:15:36 <jednorozec> ack
17:15:55 <bcotton> #agreed 2056303 is fixed for the purposes of the release criteria
17:15:56 <geraldosimiao> Ack
17:16:00 <bcotton> #topic (2072070) Connection to wireless network fails without explanation when other end does not support secure renegotiation
17:16:00 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=2072070
17:16:00 <bcotton> #link https://pagure.io/fedora-qa/blocker-review/issue/729
17:16:00 <bcotton> #info Accepted Blocker, wpa_supplicant, ON_QA
17:16:09 <adamw> this is also confirmed fixed.
17:16:15 <nirik> hurray
17:16:23 <mboddu> Yay
17:16:25 <bcotton> from the comments i've seen, people who could reproduce this report fixes
17:16:27 <geraldosimiao> As described on bug ticket, it's fixed
17:16:48 <adamw> in #c44
17:17:04 <adamw> oh
17:17:08 <adamw> so, i do have a point to bring up here
17:17:15 <bcotton> point away
17:17:20 <adamw> it's generally agreed that we didn't fix this, we worked around it
17:17:52 <adamw> i wanted a subject matter expert to review the workaround, but none of the rh ones have really stepped in. so I mailed Jouni, the upstream author
17:18:22 <CRCinAU> I did notice something weird on wifi.....
17:18:34 <adamw> his take on this is nuanced, but the big picture points are: 1) he would not want to assert that the workaround definitely does not reduce security. he thinks it's at least theoretically possible that in some cases, the workaround does potentially do that
17:18:56 <CRCinAU> So my network supports WPA2 + WPA3. If I set Gnome to use WPA3 Personal, it won't connect - but WPA2 Personal connects ok but the status shows WPA3....
17:18:57 <adamw> 2) it's at least definitely no less secure than f35 was. the workaround effectively does what was already done on f35 (and earlier)
17:19:07 <CRCinAU> so I really dunno wtf its actually supposed to mean these days
17:19:20 <adamw> i think point 2 makes me ok with shipping this, but did want to note that.
17:19:26 <adamw> and see if anyone is concerned about point 1.
17:19:52 <adamw> the "real" fix here would be something more targeted that lets the user allow legacy renegotiation only for a specified network. but we definitely didn't have time to implement that.
17:19:58 * nirik is ok with that, hopefully subject matter experts will weigh in and adjust this before f37 if needed.
17:20:32 <CRCinAU> adamw: I remember raising an issue like this a good 5 or so years ago
17:20:34 <salimma> I noticed the workaround too late, but if additional testing is needed, happy to test and report back (our corporate fleet is affected)
17:20:51 <bcotton> yeah, i'm comfortable with that. a real fix is more of an RFE than a bugfix, imo
17:20:53 <adamw> Michel Alexandre Salim 🎩: more testing can't hurt.
17:21:11 <geraldosimiao> I'm with nirik @nirik:libera.chat: on that
17:21:16 <CRCinAU> where there should be a different set of toggles for wifi infrastructure..... as this kinda thing gets difficult and doesn't get replaced as quick as Fedora disables protocols / ciphers
17:21:19 <adamw> oh yeah, another point jouni made is there may be further similar-but-not-the-same cases which this workaround won't address; i don't think we want to get into speculatively allowing more legacy stuff ahead of bug reports, though. we just need to be on the lookout for such cases.
17:22:00 * nirik nods
17:22:22 <bcotton> proposed #agreed 2072070 is sufficiently worked around for the purposes of the release criteria
17:22:23 <CRCinAU> So there needs to be a seperation between 'internet' security and 'let me connect to wifi' security.
17:22:31 <nb> ack
17:22:33 <mboddu> ack
17:22:36 <CRCinAU> but yes, that's a long term RFE / think about
17:22:39 <geraldosimiao> Ack
17:22:40 <jednorozec> ack
17:22:40 <nirik> ack
17:22:43 <mattdm> ack
17:22:50 <sgallagh> ack
17:22:50 <copperi[m]> ack
17:22:57 <adamw> ack
17:23:27 <bcotton> #agreed 2072070 is sufficiently worked around for the purposes of the release criteria
17:23:27 <salimma> ack
17:23:36 <bcotton> #topic Current status - blockers
17:23:38 <bcotton> #info All accepted blockers are sufficiently resolved
17:23:52 <adamw> yaaay
17:23:58 <bcotton> #topic Current status - test matrices
17:23:58 <bcotton> #link https://fedoraproject.org/wiki/Category:Fedora_36_Test_Results
17:23:59 <nirik> excellent
17:24:38 <adamw> coverage looks really good. don't really have anything to note.
17:24:49 <bcotton> i just want to thank tflink and sgallagh for the fact that we have two consecutive weeks of not needing to pause the meeting to run AD tests
17:24:59 <adamw> only a few spaces where we haven't run a test on one arch, but they're all ones where there's no reason to imagine it'd be broken on just one arch.
17:25:06 <geraldosimiao> Excellent
17:25:12 <adamw> oh, and we don't have any openstack cloud tests. buuuut it's probably fine...
17:25:12 <sgallagh> Hooray for backhanded compliments!
17:25:26 <mboddu> Ship it!
17:25:35 <geraldosimiao> Yes
17:25:39 <nb> Ship it!
17:25:49 <nirik> I've got one thing to note about the compose... aside the selinux issue...
17:26:06 <bcotton> #info Test coverage is good. There are a few missing tests which are not concerning
17:26:07 <bcotton> #topic Current status - RC
17:26:11 <nirik> fedora-cloud-base-gcp image failed due to a network issue.
17:26:19 * sgallagh quickly hits nirik with a sedative
17:26:21 <nirik> all other artifacts are there.
17:26:26 <nb> nirik can we re-run just that artifact?
17:26:28 <sgallagh> not quickly enough :-(
17:26:38 <bcotton> #info RC 5 is the current release candidate
17:26:38 <nirik> sorry, I'll wait...
17:26:58 <bcotton> #info fedora-cloud-base-gcp is the only missing image (failed due to network issue)
17:27:07 <bcotton> no, nirik, your timing was perfect :-)
17:27:30 <nirik> nb: no. we could use the nightly one tho if we desired. I am not sure how much that image is used or when/who uploads it.
17:28:09 <sgallagh> It's a non-blocking deliverable, yes?
17:28:21 <geraldosimiao> +1 for using the nightly one
17:28:30 <nirik> yes, it's not blocking in any way. I just wanted to note it...
17:28:50 <bcotton> anything other questions or comments on RC 5?
17:28:55 <kparal> perhaps use RC4 image instead of RC5?
17:29:18 <kparal> there was no cloud-related change there
17:29:35 <geraldosimiao> Good idea too
17:29:44 <nb> good idea
17:30:13 <geraldosimiao> bcotton: I found the rc5 a good improvement over others
17:30:15 <mboddu> kparal: We will push all the updates stable and will run nightly compose for a day or two to have the last nightly content same as the GOLD RC, so better use nightly
17:30:49 <bcotton> #topic Go/No-Go decision
17:30:57 <bcotton> here comes the fun part!
17:30:59 <bcotton> FESCo?
17:31:01 <nirik> go
17:31:03 <mboddu> kparal: But again, if no cloud-related changes, we can use either
17:31:05 <mboddu> Go
17:31:06 <sgallagh> Go1
17:31:16 <bcotton> Releng?
17:31:19 <mboddu> Go
17:31:19 <jednorozec> go
17:31:24 <nirik> 🎆🎆 go 🎆🎆
17:31:25 <sgallagh> * Go!
17:31:25 * t0xic0der[m]1 is suddenly nervous
17:31:40 <mhroncok> (also go, but late)
17:31:52 <bcotton> QA?
17:31:59 <coremodule> can I say it?
17:32:10 <bcotton> coremodule: do it!
17:32:10 <geraldosimiao> say
17:32:12 <coremodule> GO!
17:32:20 <geraldosimiao> Go
17:32:34 <bcotton> #agreed Fedora Linux 36 Final is GO
17:32:34 <bcotton> #info Fedora Linux 36 Final will release on 2022-05-10
17:32:39 <CVirus> wohoo!
17:32:40 <jednorozec> weeeeeee
17:32:44 <bcotton> #action bcotton to announce decision
17:32:50 <copperi[m]> Good
17:32:50 <nirik> hurray!
17:32:55 <t0xic0der[m]1> Yay! 🎉
17:32:58 <coremodule> Woot!
17:32:59 <nb> Yay! Shipit!
17:32:59 <bcotton> #topic Open floor
17:32:59 <bcotton> Anything else we need to discuss before closing?
17:33:00 <nirik> thanks for all the hard work everyone!
17:33:10 <bcotton> i'm just glad F36 will release before F37 beta does ;-)
17:33:10 <CVirus> thanks everyone really!
17:33:14 <Alessio[m]> 🎉
17:33:25 <copperi[m]> ben :)
17:33:25 <adamw> yaaay
17:33:26 <adamw> thanks everyone
17:33:35 <nirik> #info don't forget to sign up to attend the f36 release party: https://hopin.com/events/fedora-linux-36-release-party/registration
17:33:58 <geraldosimiao> And the release party will be after the release 😁😁😁
17:34:09 <geraldosimiao> 🎉
17:34:46 <mboddu> Thanks everyone for all the work they have done for this release
17:34:53 <bcotton> words cannot express how glad i was that i told Marie we should do it the 13th and 14th instead of the 6th and 7th
17:35:13 <geraldosimiao> 🙏
17:35:24 <nirik> well done past bcotton
17:36:08 <bcotton> alright folks, i guess i have an email to send
17:36:15 <bcotton> thank you and i'll see you at the release party!
17:36:17 <CRCinAU> so in other news, bugs with perl and mysql - how much will that break? :p
17:36:46 <CRCinAU> Seems with the F36 update to MariaDB, it breaks DBD::MySQL and SSL
17:37:00 <CRCinAU> but I'm still trying to get my head around it.
17:37:03 <geraldosimiao> adamw++
17:37:04 <mattdm> YAY Thanks everyone!
17:37:29 <geraldosimiao> bcotton++
17:37:29 <zodbot> geraldosimiao: Karma for bcotton changed to 15 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:37:36 <adamw> CRCinAU: well, it'd break openqa for one thing. :P but we can deal with that post-release. i'll take a look if i get time.
17:37:39 <bcotton> #endmeeting