16:00:47 <sgallagh> #startmeeting ELN (2022-07-15)
16:00:47 <zodbot> Meeting started Fri Jul 15 16:00:47 2022 UTC.
16:00:47 <zodbot> This meeting is logged and archived in a public location.
16:00:47 <zodbot> The chair is sgallagh. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:00:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:47 <zodbot> The meeting name has been set to 'eln_(2022-07-15)'
16:00:53 <sgallagh> #meetingname eln
16:00:53 <zodbot> The meeting name has been set to 'eln'
16:01:01 <sgallagh> #topic Init Process
16:01:03 <sgallagh> .hi
16:01:04 <zodbot> sgallagh: Something blew up, please try again
16:01:07 <zodbot> sgallagh: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:01:07 <smooge> hello
16:01:20 <davide> .hello dcavalca
16:01:23 <zodbot> davide: Something blew up, please try again
16:01:26 <zodbot> davide: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:01:30 <smooge> i expect zodbot needs a relaod
16:01:42 <sgallagh> .hello sgallagh
16:01:45 <zodbot> sgallagh: Something blew up, please try again
16:01:48 <zodbot> sgallagh: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:02:03 <smooge> no i think its nb or nirik
16:02:06 <smooge> not me
16:02:37 <sgallagh> What is?
16:02:48 <smooge> zodbot not knowing how to use hello/hi/etc
16:03:50 <nirik> zodbot: reload Fedora
16:03:50 <zodbot> nirik: Kneel before zod!
16:03:50 <smooge> and that command was needed. I got an error saying I was not on the list to do that
16:03:50 <sgallagh> ah
16:03:50 <smooge> sorry my comments about 'no and not me' was meant for a different channel also
16:03:50 <sgallagh> nirik: thanks
16:03:50 <sgallagh> Will I need to restart the meeting?
16:04:10 <smooge> no it looks like zod could do that part
16:04:11 <Eighth_Doctor> .hello ngompa
16:04:12 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:04:23 <davide> .hello dcavalca
16:04:26 <zodbot> davide: dcavalca 'Davide Cavalca' <dcavalca@fb.com>
16:05:01 <sgallagh> smooge: I was curious if it would forget the meeting due to reload
16:05:13 <sgallagh> .hi
16:05:14 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
16:05:17 <smooge> yeah understood, it is a different subprocess
16:05:28 <smooge> if zod were completely restarted.. then it would forget
16:06:28 <sgallagh> OK, I think we can get started
16:06:32 <sgallagh> #topic Open Floor
16:06:36 <smooge> anyway back to the beating
16:06:41 <sgallagh> I don't have any specific updates this week
16:07:08 <sgallagh> Other than we had an outage that caused the composes to be un-startable for about a week, but that's fixed.
16:07:18 <smooge> so I did.
16:07:34 <sgallagh> I'm still working on getting automated composes back up and running so I'm not starting them manually (mostly) every day.
16:08:02 <davide> the only thing I wanted to bring up was https://github.com/osandov/drgn/issues/188
16:08:20 <davide> it looks like there's an ongoing issue with ELN on packit as we're seeing failures there fairly consistently that point to invalid repos
16:09:44 <sgallagh> They're trying to reach the repos via IPv6... I have no idea if that actually works
16:10:21 <sgallagh> But also, the "Everything" repo went away.
16:10:26 <sgallagh> They won't be able to rely on it.
16:10:32 <smooge> ipv6 is not going to work from odcs
16:10:38 <sgallagh> They need to be using the repos provided by the `fedora-repos-eln` package.
16:11:17 <smooge> no sorry.. it will via the proxies
16:11:19 <davide> my understanding is that packit uses the copr chroots under the hood, so this is probably an issue in copr then
16:11:41 <smooge> i misread the error and thought that odcs system was trying to get to an ipv6 item
16:12:03 <sgallagh> Davide Cavalca: https://github.com/rpm-software-management/mock/commit/aa512e124775a43d5ac6e0cfbf8c75a4e2f84eb0
16:12:16 <smooge> davide, yes most likely the mock configs etc it nee.. what sgallagh is pointing to
16:12:17 <sgallagh> Whenever that gets into production, it should be resolved.
16:12:28 <sgallagh> Please feel free to pester Pavel Raiskup about it :)
16:12:37 <davide> will do, thanks!
16:12:59 <smooge> so I had a more 'process' oriented question which may be already answered but my google skills failed me
16:13:39 <smooge> would it be useful to have a process similar to the Fedora Change Process but just aimed at ELN items like: move to AVX-9, making debs the default packaging tool, etc (all made up for maximum laughter/crying) mostly to get a deadline for when they should be put into the system to meet any other timetables
16:14:06 <davide> I think that would definitely be useful for visibility
16:14:45 <davide> is the idea that future deviations meant for RHEL would show up first as a Change for ELN?
16:16:00 <sgallagh> I figured we could just use the Fedora Change process for that.
16:16:34 <smooge> I thought so also, but since the Fedora Change process is usually for releases and ELN does not have 'releases' I wasn't sure if that worked
16:16:37 <davide> I was thinking specifically about things where RHEL will be different from Fedora for $reasons
16:17:16 <sgallagh> That's a really good point
16:17:16 <davide> well, we kinda do have releases for ELN, in the sense that at some point down the road it'll get branched into CentOS Stream 10
16:18:30 <sgallagh> Well, despite not doing traditional releases, we (Red Hat) tend to use the Fedora schedule as a handy place for milestones.
16:18:47 <sgallagh> So maybe we just adapt the Change Process to use Fedora releases as date guidelines.
16:18:52 <smooge> the idea would be to have something to deal with 'wait a second why did all my tests fail last week?' 'we recompiled everything with LLVM so code looks different' 'no one told me that was going to happen.' 'we went over the change with this paper filed in Alpha Centauri'
16:19:24 <sgallagh> My Zorgon secretary hand-delivered it!
16:19:33 <smooge> and move it from Alpha Centauri to something closer... like Neptune sorry Fedora wiki
16:20:32 <sgallagh> Proposal: reuse the Fedora Change Process for ELN, treating Fedora releases as ELN milestones for the purposes of planning.
16:20:34 <smooge> sgallagh, ok so if the team is already using Fedora schedule for milestones then that answers many of my 'what about...'
16:20:58 <smooge> may I second that?
16:21:18 <davide> we should put that in the FAQ or somewhere else in the documentation if that's the expectation
16:21:29 <davide> but yeah, this sounds good to me
16:22:20 <sgallagh> smooge: I'm following FESCo proposal protocol. So +1 if you agree, -1 if you disagree, 0 if you want to be difficult :)
16:22:34 <davide> +1
16:22:49 <sgallagh> (With the person proposing assumed to be +1 unless otherwise stated)
16:24:59 <smooge> +1
16:25:27 <smooge> Eighth_Doctor, was the only other person I saw reporting to this meeting
16:25:37 <Eighth_Doctor> +1
16:26:38 <Eighth_Doctor> that's a great idea!
16:26:57 <sgallagh> #agreed reuse the Fedora Change Process for ELN, treating Fedora releases as ELN milestones for the purposes of planning. (+4, 0, -0)
16:28:56 <sgallagh> Oh, I do have one other note
16:29:46 <sgallagh> As of today, the Extras repo should now be working and populated directly from the Content Resolver view.
16:30:11 <davide> excellent, thank you
16:30:13 <sgallagh> https://odcs.fedoraproject.org/composes/odcs-26450/compose/Extras/source/tree/Packages/
16:30:45 <sgallagh> That compose is still running, but it should be promoted to latest-Production within an hour.
16:32:00 <smooge> cool
16:32:32 <smooge> i don't have anything else for the meeting and thankyou for listening
16:33:15 <sgallagh> smooge: As ever, thanks for your input.
16:33:43 <sgallagh> I'll hold the meeting open until 12:35 EDT if anyone has anything further.
16:36:27 <sgallagh> #endmeeting