#fedora-meeting: ELN (2023-12-01)

Meeting started by sgallagh at 17:01:57 UTC (full logs).

Meeting summary

  1. Init Process (sgallagh, 17:02:03)
  2. Agenda (sgallagh, 17:06:41)
    1. Agenda Item: CentOS Stream 10 import and ELN mass-rebuild (sgallagh, 17:06:58)
    2. Agenda Item: Strategy for importing packages whose git history fails git-fsck (sgallagh, 17:07:18)

  3. CentOS Stream 10 import and ELN mass-rebuild (sgallagh, 17:10:22)
    1. CentOS Stream 10 will break inheritance from Fedora ELN on 2024-02-06, co-incident with the Fedora 40 Branch from Rawhide. (sgallagh, 17:12:27)
    2. There will be a separate announcement made to identify when public contributions to CentOS Stream 10 will begin. (sgallagh, 17:14:28)
    3. https://github.com/rpm-software-management/mock/pull/1253 (sgallagh, 17:26:07)

  4. Strategy for importing packages whose git history fails git-fsck (sgallagh, 17:29:18)
    1. https://gitlab.com/gitlab-org/gitlab/-/issues/246750 (sgallagh, 17:33:11)
    2. AGREED: We will ask Fedora Infra/Releng if we can rewrite the history of these sixteen packages and archive the old branch. (sgallagh, 18:00:24)
    3. AGREED: Failing that, we will rewrite the history manually for import to CS 10 and maintain it by hand until the handoff. (sgallagh, 18:00:29)

  5. Open Floor (sgallagh, 18:02:06)
    1. We need to revisit the way that Content Resolver workloads are broken up. Currently they are more aligned to "who owns it" than "where the package belongs". (sgallagh, 18:11:15)


Meeting ended at 18:23:26 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. sgallagh (119)
  2. Son_Goku (101)
  3. neil (25)
  4. zodbot (14)
  5. tdawson (13)
  6. smooge (10)
  7. yselkowitz (6)
  8. decathorpe (1)
  9. nils (1)


Generated by MeetBot 0.4.