20:02:20 <pcalarco> #startmeeting Insight
20:02:20 <zodbot> Meeting started Tue Aug  9 20:02:20 2011 UTC.  The chair is pcalarco. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:02:38 <pcalarco> #topic Roll call
20:02:48 <pcalarco> is here
20:03:02 * stickster (a bit lurky due to $DAYJOB -- ping me if needed, but don't wait too long for me)
20:03:07 <pcalarco> #meetingname Insight
20:03:07 <zodbot> The meeting name has been set to 'insight'
20:04:45 <asrob> hi
20:04:53 <pcalarco> asrob: Hi!
20:05:13 <asrob> pcalarco, sorry, I'm late
20:05:16 <pcalarco> stickster is busy today with $DAYJOB, so he will be in and out
20:05:26 <pcalarco> no problem at all
20:05:40 <asrob> okay
20:05:41 <pcalarco> so, let's start with a review of our last meeting
20:06:02 <pcalarco> #link http://fedoraproject.org/wiki/Insight
20:06:30 <pcalarco> #link http://meetbot.fedoraproject.org/fedora-meeting/2011-08-02/insight.2011-08-02-20.01.html
20:07:09 <stickster> #topic Last week's meeting
20:07:15 <stickster> oops, I'm a nobody ;-D
20:07:26 <asrob> :)
20:07:31 <pcalarco> #chair stickster asrob
20:07:31 <zodbot> Current chairs: asrob pcalarco stickster
20:07:36 <pcalarco> :)
20:07:43 <stickster> #topic Last week's meeting
20:07:49 <pcalarco> you are a somebody, stickster :)
20:07:58 <stickster> Ha, today hopefully! :-D
20:08:08 <pcalarco> So the first action item was mine
20:08:22 <pcalarco> Recruit FWN members to help moderate content queue
20:09:00 <pcalarco> we have two new FWN team members, one of whom is going to take over the Translation beat, and the other I hope to get to help with Insight'
20:09:09 <stickster> That's awesome pcalarco!
20:09:11 <pcalarco> they are discussing which they want first
20:09:21 <asrob> wohoo \o/ it's awesome
20:09:28 <pcalarco> I should be able to report on this for next week's meeting
20:10:00 <pcalarco> stickster, you had next action item:  puppetize features_extra usage once it enters stable
20:10:56 <pcalarco> all three of us also had an action item: Visit https://fedoraproject.org/wiki/Fedora_Calendar_Project and make comments, on 'discussion' tab (Talk page)
20:11:21 <pcalarco> I confess that I haven't carved out time to do this yet, but do have time tomorrow to work on this
20:11:45 <asrob> me too
20:11:49 <pcalarco> #link https://fedoraproject.org/wiki/Fedora_Calendar_Project
20:12:20 <pcalarco> and then stickster had a second action item: Set up puppet configs so stg and prod hosts pull from 'master' branch of fedora-insight-features every 30 min and 4 hrs, respectively
20:12:54 <pcalarco> so we will report on those when stickster has a chance to pop back in, and move on
20:13:11 <pcalarco> asrob: do you have any comment on any of last week's action items?
20:13:14 <asrob> pcalarco, can I put a question into the discussion page or there are some ideas?
20:13:47 <pcalarco> asrob: sure, I think that's a good place for questions; getting discussion started is the main idea
20:14:04 <pcalarco> and a question can be a good way to get discussion going
20:14:27 <asrob> pcalarco, cool, I'm a little confused, I'm going to write some questions
20:14:38 <pcalarco> asrob: awesome
20:15:21 <pcalarco> I will also look at this, and respond to your questions, if I can
20:15:23 <asrob> for example, the calendar part of Fedora Events System is part of Insight or Fedora Calendar Project?
20:16:06 <pcalarco> or perhaps the Fedora Calendar Project will merge into Insight as a sub-project
20:16:33 <asrob> Aha, we will discuss it there
20:16:35 <pcalarco> if we can meet all of the needs with Drupal here
20:17:18 <pcalarco> this is a good opportunity to engage with those folks on the Fedora Calendar Project for Insight more as well
20:17:36 <asrob> sure
20:18:04 <pcalarco> #link https://fedoraproject.org/wiki/Fedora_Calendar_Project
20:19:08 <pcalarco> why don't we invite AdamW and Clint to a future Insight meeting to discuss the Calendar Project, since it looks like it was last discussed in 2009
20:19:18 <pcalarco> what do you think?
20:19:37 <rbergeron> woohoo, calendar project
20:19:57 <pcalarco> rbergeron, you are most welcome too!
20:21:31 <pcalarco> #action pcalarco will invite Fedora Calendar Project folks (AdamW, Clint Savage, others) to a future Fedora Insight meeting to discuss and get feedback on Calendar functionality in Insight
20:22:25 <pcalarco> #action asrob, pcalarco will write feedback, questions and ideas for Fedora Calendar Project in advance of next meeting
20:23:18 <pcalarco> asrob: anything else on last week's action items, or shall we move on?
20:23:41 <asrob> yes, we shall
20:24:13 <pcalarco> ok
20:24:32 <pcalarco> #topic Devel status: admin menu
20:24:52 <pcalarco> asrob, do you know of anything to report on this?
20:25:32 <asrob> pcalarco, I think, it's packaged and stable
20:25:49 <pcalarco> the last update from stickster last week was that we have admin_menu on insight01.dev
20:26:02 <asrob> yeah, you're right
20:26:19 <pcalarco> have we done any testing on this yet?  Do you need people to help with this?
20:26:19 <stickster> pcalarco: Sorry, just got back from a phone call (as feared)
20:26:32 <pcalarco> stickster: no probs
20:26:34 <stickster> #action stickster puppetize features_extra usage once it enters stable
20:26:43 <stickster> #action stickster Set up puppet configs so stg and prod hosts pull from 'master' branch of fedora-insight-features every 30 min and 4 hrs, respectively
20:26:53 <stickster> I did enter some comments on the calendar 'talk' page though
20:27:25 <pcalarco> stickster: great!  You are ahead of asrob and I, but we will work on this this week
20:27:42 <stickster> I would like to make sure that as we look at this calendar project, we are using it as a springboard to get more people involved in Insight -- as opposed to setting up a very small number of people to be a service org
20:27:51 <stickster> <eof>
20:27:52 <asrob> pcalarco, I guess, admin_menu module works properly
20:28:00 <pcalarco> we also thought of inviting AdamW and Clint and possibly others to a future Insight meeting for further/updated discussion
20:28:14 <stickster> asrob: Cool, so you haven't had any problems with it either? Yay!
20:28:21 <pcalarco> asrob: great, thanks for verifying
20:28:32 <asrob> yep
20:29:19 <pcalarco> #topic Devel - Features plan
20:29:39 <pcalarco> are there any updates for this other than the puppet work?
20:30:38 <pcalarco> hearing none, we can move on
20:30:52 <pcalarco> #topic Devel - mediawiki_api
20:31:22 <pcalarco> asrob: last week we spoke about perhaps forking this dormant module for our uses
20:32:18 <pcalarco> we were going to wait to hear back from stickster who will talk to person at Acquiato estimate code quality
20:32:41 <stickster> pcalarco: Yes, I did hear back from my contact there, thanks.
20:32:58 <stickster> Oh wait, wrong issue.
20:33:03 <stickster> No, I haven't heard back from that guy :-D
20:33:04 <pcalarco> stickster, ah great
20:33:11 <asrob> :)
20:33:12 <stickster> I will check on that right now
20:33:13 <pcalarco> ah, ok :)
20:33:26 <asrob> I have an idea
20:33:35 <pcalarco> asrob: go ahead
20:34:19 <asrob> we will replace flexifilter module when we are working on the basic features new version
20:34:21 <asrob> I mean...
20:34:44 <stickster> i$c
20:34:46 <stickster> oops
20:34:58 <asrob> we are fixing it now, but there are some issues in the trac
20:35:04 <pcalarco> you will create a new basic feature that does what flexifilter does, using the Features module?
20:35:29 <stickster> asrob: I don't think we can just replace it 1-for-1 that easily
20:35:42 <stickster> asrob: Because the views and other things will have to change to accommodate sending nodes to the API
20:36:02 <asrob> ahh :(
20:37:29 <asrob> well, how is it going? we will fix our issues, all of them, then we will replace flexifilter module?
20:38:21 <pcalarco> do we have any TRAC issues open on these?
20:39:18 <pcalarco> is checking TRAC
20:39:34 <asrob> pcalarco, yeah, this is it, https://fedorahosted.org/fedora-infrastructure/query?status=new&status=assigned&status=reopened&group=component&component=FedoraInsight&order=priority
20:40:33 <asrob> I did a custom query, component is FedoraInsight
20:41:23 <pcalarco> there doesn't seem to be anything on the Features module for Flexifilter functionality replacement?
20:42:07 <asrob> yep, you're right, it's "unofficial" ;)
20:42:34 <asrob> oh wait
20:42:44 <asrob> https://fedorahosted.org/fedora-infrastructure/ticket/2713
20:42:47 <asrob> here it is
20:43:12 <pcalarco> asrob: good sleuthing!
20:44:30 <pcalarco> so this is dependent on the mediawiki_api module as well
20:44:49 <asrob> yeah
20:45:29 <stickster> There's still the question about whether this module is maintainable by asrob in the long-term
20:45:48 <stickster> I have no way of judging the code quality other than by seeing this module never left a 0.x dev release
20:45:52 <pcalarco> yes, true
20:46:01 <stickster> It might be perfectly good, I'm not expert enough to tell
20:46:27 <stickster> However, this module has the best *approach* to solving the problem, which is to not reimplement wikitex t
20:46:38 <pcalarco> would averi be a good one to ask as well?
20:46:45 <stickster> simply wrap a call to the MediaWiki itself to do the work
20:47:09 <stickster> pcalarco: Yes, except he's no longer working around Insight right now, he let us know that he would no longer be able to help a while back
20:47:18 <asrob> well, I'm not expert, I may ask Gabor Hojtsy (Acquia ;) and the other members of Hungarian Drupal community
20:47:33 <pcalarco> stickster: ah, ok thx
20:48:15 <pcalarco> asrob: great; there is also a Drupal dev here at University of Waterloo that I met last Friday that I will perhaps ask
20:48:36 <asrob> I'd like to maintain while I can, at least I also learn a lot
20:48:51 <asrob> pcalarco, cool, that also would be great ;)
20:49:32 <pcalarco> we are moving our entire web presence to Drupal 6 over the next 3 years here
20:50:13 <pcalarco> so there will be resources I can draw from for us too over the next while
20:50:55 <asrob> :)
20:51:01 <pcalarco> #action pcalarco Ask Eric if he has time to look at quality of mediawiki_api
20:51:03 <stickster> wow
20:51:08 <stickster> That would be great
20:52:12 <pcalarco> I
20:52:23 <pcalarco> I'll ask him and let you guys know
20:53:19 <pcalarco> okay, next topic
20:53:25 <pcalarco> #topic Continued iteration of use cases
20:53:36 <pcalarco> anything to add for this one, gents?
20:55:00 <pcalarco> I think the next thing we could work on wrt this would be a focused meeting on Calendar
20:55:26 <asrob> https://fedoraproject.org/wiki/Insight_use_cases_for_calendar
20:55:43 <asrob> here it is some ideas of calendar
20:55:43 <pcalarco> okay, do we have any new topics? we have 5 minutes left for the mtg
20:55:49 <asrob> -
20:55:58 <pcalarco> asrob: great, thanks for the link!
20:56:11 <pcalarco> #link https://fedoraproject.org/wiki/Insight_use_cases_for_calendar
20:56:39 <pcalarco> okay, well that I think wraps it up for this week.  Thanks, asrob and stickster!
20:56:57 <asrob> thank you too
20:57:04 <pcalarco> #endmeeting