15:08:44 <langdon> #startmeeting modularity_wg
15:08:44 <zodbot> Meeting started Tue Jun  7 15:08:44 2016 UTC.  The chair is langdon. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:08:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:08:44 <zodbot> The meeting name has been set to 'modularity_wg'
15:09:13 <langdon> #chairs dgilmore, cydrobolt, harald, jkurik, langdon, mikedep333, sct, tflink
15:09:30 <langdon> #chair dgilmore, cydrobolt, harald, jkurik, langdon, mikedep333, sct, tflink
15:09:30 <zodbot> Current chairs: cydrobolt dgilmore harald jkurik langdon mikedep333 sct tflink
15:09:35 <jkurik> .hello jkurik
15:09:36 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
15:09:41 <langdon> .hello langdon
15:09:44 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
15:09:46 <langdon> #topic roll clal
15:09:51 <langdon> #undo
15:09:51 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f69de28c650>
15:09:53 <nils> .hello nphilipp
15:09:54 <langdon> #topic roll call
15:09:54 <zodbot> nils: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
15:09:56 <sct> .hello sct
15:09:56 <langdon> even
15:09:56 <zodbot> sct: sct 'Stephen Tweedie' <sct@redhat.com>
15:10:03 * tflink is here, somewhat distracted by the cloud FAD
15:10:24 <langdon> tflink, so .... your head is *literally* in the clouds??
15:10:35 <langdon> perhaps ... atomically?
15:10:42 <tflink> langdon: pretty much
15:10:45 * langdon apparently got too much sleep last night
15:10:52 <tflink> but the pain from your puns seems to have brought me back down to earth
15:11:04 <langdon> tflink, RFLMAO
15:11:11 <nils> Nothing to get grounded like sweet, soothing pain.
15:12:09 <langdon> seriously.. the meeting completely fell of my calendar.. uggh
15:12:17 <langdon> ok.. so lets move on
15:12:23 <langdon> #topic agenda
15:12:40 <langdon> anyone have anything? the major one we wanted to do, UX .. is not ready yet
15:13:49 <langdon> this feels like the council meeting yesterday
15:14:02 <langdon> ok.. im gonna do some open floor..
15:14:08 <langdon> #topic open floor
15:14:23 <langdon> #info not much of an agenda today
15:14:55 <sct> langdon: We were talking about having demo modules for flock ---
15:15:15 <langdon> sct, yes.. i think cpacheco has been working on a few..
15:15:17 <sct> what about soliciting volunteers or ideas for candidate modules?
15:15:20 <langdon> are you proposing some?
15:15:46 <langdon> sct, yeah.. we could send a "call for module makers" to the ml.. and see what shows up?
15:15:55 <sct> +1
15:16:01 * langdon chortles..
15:16:04 <sct> maybe with pointers to a module howto
15:16:10 <langdon> cpacheco, think you could write up a draft email?
15:16:22 <langdon> sct, yeah.. thats what i was thinking
15:16:36 <langdon> and fall back to here (channel) for help
15:17:16 <langdon> well.. plan anyway
15:17:45 <langdon> #action create a "call for module makers" to mailing list and then maybe get some more modules by flock
15:18:03 <langdon> #info langdon tries to convince cpacheco to author draft
15:18:31 <sct> langdon: I'd also like to see if we can get an early module volunteer to walk through our howto
15:19:01 <langdon> sct, can you elaborate on "how to"? like do you have a doc in mind? or are you proposing writing one?
15:19:05 <sct> and see how much help they need to get through it --- use it to validate our module developer howto
15:19:25 <sct> I think we need a howto if we're going to get module owners interested from outside the core modularity team
15:19:39 <sct> so I think doing the howto and getting external participation are closely linked goals here
15:19:52 <langdon> sct, yeah.. i don't disagree.. we just don't have authoring that in the current sprint
15:20:04 <langdon> new sprint ~tues though
15:20:27 <langdon> vkaras, you here? do you think there is an "epic for flock" that we have in mind?
15:21:00 <sct> Right, so let's have those both of those as goals, we can prioritise them going into the sprint.
15:21:18 <langdon> sct, reading: 1) howto 2) ??
15:21:28 <langdon> external participation?
15:21:39 <sct> 1) howto 2) soliciting module owners/suggestions
15:21:41 <sct> yes
15:22:15 <langdon> sct, ahh.. well.. "external participation" is really one of the major goals of the entire "release"
15:22:55 <langdon> #info please remember to look at https://fedoraproject.org/wiki/Modularity_Working_Group/releases/Flock_2016_Release
15:23:27 <langdon> rwilliam, can you give an update on the "module quality" doc you have been working on? or not yet?
15:23:49 <rwilliam> langdon, sure
15:24:13 <langdon> perhaps starting with a sketch of what it is :)
15:24:39 <rwilliam> langdon, I have created a document (a WIP) which attempts to provide a guidance for determining when a module can be considered test complete
15:25:14 <langdon> is there a "review-able version" yet? or is that for "end of sprint"?
15:25:48 <rwilliam> langdon, the style is in a "conversational" format with the added goal for being as concise as possible while being complete
15:26:49 <langdon> cool..
15:26:52 <rwilliam> langdon, the topics covered include:
15:27:02 <rwilliam> langdon, -- What is a module
15:27:18 <rwilliam> langdon,  -- What is meant by a module’s defined function
15:27:35 <rwilliam> langdon, -- Which packages in a module are required to be tested
15:27:37 <langdon> nils, ^^ we need to seriously look at the "cleanup of content references" or whatever you want to call it next sprint..
15:27:57 <rwilliam> langdon, -- When is a module  test complete or validated
15:28:09 <rwilliam> langdon, -- Where can I find the Module’s Defined function, supporting package and changed package lists
15:28:20 <rwilliam> langdon, -- How should I structure my test case
15:28:42 <langdon> sct, ^^ we need to be sure this connects to your docs as well
15:29:35 <langdon> i wonder if we can ask fedora-docs could help us out with this content organization problem we are starting to have..
15:29:52 <langdon> i think i already tried to rope commops in :) /cc jflory7
15:30:01 <nils> langdon: I'm on PTO (most of) next sprint, so is there something I can begin this week? Digging into the PDC updater stuff confirms what Lubos said, that there are a couple of things missing for me to actually write code there yet (orchestrator -- who sends the messages, define the info we want to store).
15:30:04 <rwilliam> langdon, ^^ agreed. I want to be sure I am using the correct terms and that it lines up with any existing information
15:31:08 <langdon> nils, are you writing cards for the blockers? so we can have people pick them up? and/or you could just pick them up.. but i would like to see all the blocker cards.. plus links to them from the pdc-updater card :)
15:31:13 <sct> langdon: ^^ Some of that is more detail than I'm going into.  The static definition of a module is something we need; derived information such as changed package lists is a lower level of detail we should work through as use cases come up
15:31:36 <nils> langdon: sure, need to learn how to link cards but that can't be rocket science
15:31:49 <langdon> nils, for now.. do you want to, parallel with the work above, reach out to fedora-docs and see if they can get connected? help us manage content?
15:32:19 <langdon> nils, "tasks" i think.. ping jkaluza (who seems to be afk at the moment)
15:32:36 <nils> langdon: yeah, I'll try to remember to scare him up in the morning
15:32:38 <langdon> bconoboy, ^^ fyi
15:32:51 <nils> if I don't figure it out by myself
15:33:00 * bconoboy blinks
15:33:11 <langdon> ok.. other "open floor" types stuff? anything from parties not normally talking in channel?
15:33:21 <nils> langdon: not sure what fedora-docs do to be frank
15:33:36 <bconoboy> Just wondering why we're meeting in here instead of one of the #fedora-meeting channels
15:33:36 <langdon> nils, lets discuss post meeting
15:33:43 <nils> yeah
15:33:54 <nils> I might be on the bus then, but can join from mobile
15:34:02 <langdon> bconoboy, cloud-fad stole our channel.. jkurik is "educating them" :)
15:34:15 <jkurik> bconoboy: because all the #fedora-meeting channels are busy
15:34:35 <bconoboy> langdon: Okay, so it's one time only?  Cool.  I'm worried that if all the other channels are booked it suggests we're going to arbitrarily limit participation of people committed to the other meetings.
15:34:43 <bconoboy> Am particularly keen to see RCM in here
15:35:03 <bconoboy> The fact that the fedora-arm meeting is at the same time means we're going to minimally lose pbrobinson
15:35:14 <bconoboy> and maybe dgilmore
15:35:21 <langdon> yeah.. hmm..
15:35:49 <langdon> jkurik used the whenisgood result to propose a time.. dgilmore (i thought) said he could make it work..
15:36:06 <jkurik> dgilmore: have agreed to this time-slot
15:36:49 <langdon> i finally managed to send out a status report yesterday.. any comments?
15:37:25 <langdon> #info investigating working with fedora docs to start to organize our content better
15:38:32 <sct> langdon: Thanks for that, looked good to me
15:39:12 <langdon> ok.. im feeling like we don't have much else to discuss today
15:39:26 <langdon> i think i should just call the meeting and we can be a bit more organized next week
15:39:48 <langdon> ok.. going once?
15:40:02 <langdon> going twice...
15:40:12 <langdon> and .. three times..
15:40:20 <langdon> #endmeeting