13:01:29 <MeWjOr> #startmeeting NeuroFedora - 2020-11-02
13:01:29 <zodbot> Meeting started Mon Nov  2 13:01:29 2020 UTC.
13:01:29 <zodbot> This meeting is logged and archived in a public location.
13:01:29 <zodbot> The chair is MeWjOr. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:01:29 <zodbot> The meeting name has been set to 'neurofedora_-_2020-11-02'
13:01:40 <MeWjOr> #meetingname neurofedora
13:01:40 <zodbot> The meeting name has been set to 'neurofedora'
13:01:47 <FranciscoD> o/
13:01:49 <FranciscoD> \o
13:01:52 <FranciscoD> \o/
13:02:00 <MeWjOr> #chair FranciscoD gicmo zbyszek
13:02:00 <zodbot> Current chairs: FranciscoD MeWjOr gicmo zbyszek
13:02:11 <MeWjOr> #chair bt0
13:02:11 <zodbot> Current chairs: FranciscoD MeWjOr bt0 gicmo zbyszek
13:02:25 <MeWjOr> Did I miss out on anyone?
13:02:37 <FranciscoD> No, that's everyone in on the IRC side
13:02:41 <FranciscoD> s/in //
13:02:52 <MeWjOr> Folks from Telegram, if possible, please join the IRC so that we can chair you
13:03:11 <FranciscoD> https://webchat.freenode.net/?channels=#fedora-neuro
13:03:22 <MeWjOr> thanks
13:03:22 <MeWjOr> :D
13:03:31 <MeWjOr> #topic Today's Agenda
13:05:16 <MeWjOr> #info Announcement e-mail: https://lists.fedoraproject.org/archives/list/neurofedora@lists.fedoraproject.org/thread/VKFCKQUXL3C6OPIJ2F7HFDBVCQB5CSAX/
13:05:28 <MeWjOr> #info introductions and roll call
13:05:34 <MeWjOr> #info Tasks from last week's meeting:
13:05:40 <MeWjOr> #info Open Pagure tickets
13:05:49 <MeWjOr> #info Open NeuroFedora bugs
13:06:00 <MeWjOr> #info Koschei packages check
13:06:07 <MeWjOr> #info CompNeuro lab compose status check
13:06:12 <MeWjOr> #info Neuroscience query of the week
13:06:18 <MeWjOr> #info Next meeting day, and chair
13:06:24 <MeWjOr> #info open floor
13:06:30 <gicmo> heya, I am here, just a bit absent minded
13:06:33 <MeWjOr> That's a lot of items in our agenda :P
13:06:53 <MeWjOr> #topic introductions and roll call
13:06:58 <MeWjOr> Heyya gicmo
13:08:23 <gicmo> o/
13:09:32 <FranciscoD> #info Ankur Sinha, FAS: ankursinha, IRC: FranciscoD; NeuroFedora, packaging, fedora-join, Ask Fedora, etc. ; UTC + 0
13:09:35 <FranciscoD> gicmo: \o
13:10:35 <MeWjOr> ookay... not a lot of people here today, I guess
13:10:39 <MeWjOr> no biggies
13:11:01 <MeWjOr> #topic Task from the last meeting
13:11:32 <MeWjOr> bt0 use koschei to file an FTBFS bug for python-lfpy: https://koschei.fedoraproject.org/package/python-lfpy
13:11:49 <MeWjOr> it's still pending, no?
13:12:33 <FranciscoD> let me check
13:13:13 <FranciscoD> I filed one now: https://bugzilla.redhat.com/show_bug.cgi?id=1893723
13:13:13 <MeWjOr> I found this
13:13:14 <MeWjOr> https://bugzilla.redhat.com/show_bug.cgi?id=1838564
13:13:22 <MeWjOr> Aye, great FranciscoD
13:13:29 <MeWjOr> #info bt0 use koschei to file an FTBFS bug for python-lfpy: https://koschei.fedoraproject.org/package/python-lfpy --- done
13:13:34 <FranciscoD> MeWjOr: the one you marked is a tracker bug
13:13:48 <MeWjOr> yep, it's not FTBFS
13:13:54 <FranciscoD> all packages that do not support any of the Fedora arches must file these tracker bugs
13:14:00 <MeWjOr> #undo
13:14:00 <zodbot> Removing item from minutes: INFO by MeWjOr at 13:13:29 : bt0 use koschei to file an FTBFS bug for python-lfpy: https://koschei.fedoraproject.org/package/python-lfpy --- done
13:14:02 <MeWjOr> oops
13:14:18 <FranciscoD> https://docs.fedoraproject.org/en-US/packaging-guidelines/#_architecture_build_failures
13:14:34 <MeWjOr> #info FTBFS marked for lfpy: https://bugzilla.redhat.com/show_bug.cgi?id=1893723
13:15:18 <MeWjOr> FranciscoD fix libneurosim: https://bugzilla.redhat.com/show_bug.cgi?id=1864029: WIP, upstream had to make a fix, reassigning --- reassigned?
13:15:35 <FranciscoD> yeh, I have the fix but not built and pushed an update yet
13:15:39 <FranciscoD> please reassign
13:15:50 <MeWjOr> Cool, I'll do it then
13:16:21 <MeWjOr> #action MeWjOr fix libneurosim: https://bugzilla.redhat.com/show_bug.cgi?id=1864029: WIP, upstream had to make a fix
13:16:43 <MeWjOr> #info FranciscoD purusharths: add koji compose link to the agenda for future meetings
13:16:49 <FranciscoD> done
13:16:55 <MeWjOr> #undo
13:16:55 <zodbot> Removing item from minutes: INFO by MeWjOr at 13:16:43 : FranciscoD purusharths: add koji compose link to the agenda for future meetings
13:17:00 <MeWjOr> #info FranciscoD purusharths: add koji compose link to the agenda for future meetings --- done
13:17:04 <MeWjOr> nice
13:17:26 <MeWjOr> I seemed to miss it in todays agenda, though... :P
13:17:36 <MeWjOr> seem*
13:17:37 <FranciscoD> MeWjOr: it's on the docs now
13:17:42 <FranciscoD> so will be easier next time
13:17:48 <MeWjOr> oooh... great
13:17:55 <FranciscoD> https://docs.fedoraproject.org/en-US/neurofedora/communicating/#_open_meetings
13:18:05 <MeWjOr> #info FranciscoD file FTBFS bug for python-mne using Koschei: https://koschei.fedoraproject.org/package/python-mne --- done
13:18:36 <MeWjOr> I'll work over mne... I've been using it quite lately, so I can do it I guess
13:18:40 <tg-fedneuro> <l​bazan> Morning!
13:18:55 <MeWjOr> #action Work over the update for python-mne
13:19:03 <MeWjOr> Hola Luis!
13:19:10 <MeWjOr> #undo
13:19:10 <zodbot> Removing item from minutes: ACTION by MeWjOr at 13:18:55 : Work over the update for python-mne
13:19:22 <MeWjOr> #action MeWjOr Work over the update for python-mne
13:19:38 <MeWjOr> #info MeWjOr check if release-monitoring.org has been set up for python-odml --- done
13:19:45 <tg-fedneuro> <l​bazan> Tomorrrow im going fix all my bugz (sorry, im busy)
13:19:56 <MeWjOr> I have too fix odml too... it's got some new deps
13:20:00 <FranciscoD> @lbazan hello!
13:20:04 <FranciscoD> sure, no worries
13:20:09 <tg-fedneuro> <l​bazan> 🙌🏻🙌🏻
13:20:19 <MeWjOr> #action MeWjOr Fix the deps for python-odml
13:20:48 <MeWjOr> That's the tasks from the last meeting
13:20:52 <MeWjOr> :D
13:20:55 <MeWjOr> #topic Open Pagure tickets
13:21:04 <MeWjOr> #info https://pagure.io/neuro-sig/NeuroFedora/issues?status=Open&tags=S%3A+Next+meeting
13:21:23 <MeWjOr> Nothing new here
13:21:50 <MeWjOr> Although, FOSDEM 21 has released a call for devrooms
13:22:12 <FranciscoD> Yeh,
13:22:25 <FranciscoD> we need to see if we want to do something for that
13:22:27 <MeWjOr> So, I was wondering if we can collab with any other org to host another scientific room this year
13:22:40 <FranciscoD> could be done, depends on who we collaborate with etc
13:22:42 <FranciscoD> any ideas?
13:22:48 <MeWjOr> #info https://fosdem.org/2021/news/2020-10-26-devroom-cfp/
13:23:21 <MeWjOr> I only know some people who hosted it last year, along with gicmo
13:23:27 <MeWjOr> They were from G-Node
13:23:39 <FranciscoD> Hrm, we may be better off doing what we did last time and applying to participate in a devroom once its announced
13:24:08 <gicmo> Yeah, so Achilleas is going to do that room again!
13:24:15 <FranciscoD> I can't see myself having time to do the organisation side of things. Got OCNS duties to fulfil, apart from NeuroFedora work
13:24:19 <gicmo> I am sure he would love some help
13:24:53 <FranciscoD> MeWjOr: if you're up for it, totally worth doing
13:25:10 <MeWjOr> gicmo, That's wonderful... I'll send them a mail, if we could help them with something
13:25:25 <MeWjOr> FranciscoD, sure, I would love to participate as well :D
13:25:54 <FranciscoD> I'll think of what we can present at fosdem---don't have anything particularly new apart from the new release
13:25:59 <FranciscoD> 🤔
13:26:55 <MeWjOr> The comp-neuro lab webpage was not there then, if I remember correctly :P
13:27:18 <FranciscoD> nah, it was up for the f32 release too
13:27:43 <MeWjOr> aahh... yes... I remember.. F32 was the first official release for comp-neuro
13:27:47 <FranciscoD> +1
13:28:00 <FranciscoD> I think we have some translation issues with it, but that's not something we can easily fix
13:28:08 <FranciscoD> been looked into even now
13:28:32 <MeWjOr> We all probably think over this week... let's add what to present ideas in the current tracker?
13:28:39 <FranciscoD> +1
13:28:56 <MeWjOr> #info https://pagure.io/neuro-sig/NeuroFedora/issue/392
13:28:59 <FranciscoD> best to action "everyone" so that it makes it to the logs
13:29:05 <MeWjOr> Hello there achilleas :D
13:29:07 <achilleas> Hi everyone.  gicmo told me you're talking about FOSDEM and devrooms.
13:29:26 <gicmo> o/ achilleas
13:29:28 <achilleas> \o
13:29:35 <MeWjOr> Yes, we were planning to probably collab with you all in hosting the devroom this year
13:29:43 <achilleas> Let me catch you up on the current status for our room.
13:29:57 <MeWjOr> Sure
13:30:19 <MeWjOr> #chair achilleas
13:30:19 <zodbot> Current chairs: FranciscoD MeWjOr achilleas bt0 gicmo zbyszek
13:30:29 <FranciscoD> hello achilleas !
13:31:48 <MeWjOr> #action everyone Think over some ideas as to what we can present at FOSDEM 21
13:32:06 <achilleas> So we were 4 main organisers last year.  We're all at varying levels of busy these days for different reasons, so the organising committee is a bit flexible right now.  A new organiser joined and we also asked one of the participants that was very active last year to join us.  If/when we get the confirmation for the room, we plan to put out a general, public call for co-organisers to join
13:32:08 <achilleas> us.
13:32:45 <achilleas> Since the online nature needs more people for organising and rooms have to have their own volunteers, there will definitely be an opportunity to expand the scope and get more people on board with the organising.
13:33:34 <FranciscoD> Sounds good
13:33:49 <MeWjOr> Sounds great, yes
13:34:02 <achilleas> yeah so it seems like this will definitely work out nicely for all of us :)
13:34:09 <FranciscoD> +1
13:34:30 <FranciscoD> I was hoping to attend in person last year, and then this year, but I guess that'll have to wait for a bit..
13:35:01 <FranciscoD> thanks very much achilleas, we'll keep an eye out for the call for co-organisers
13:35:10 <FranciscoD> I'm sure others who aren't attending the meeting will also be happy to help
13:35:12 <MeWjOr> Where would you be putting up the call for the co-organizers, though... we would very much like to help you all with the room
13:35:50 <achilleas> Probably on the FOSDEM mailing list(s), but also https://twitter.com/FosdemResearch
13:36:34 <MeWjOr> oh, thats wonderful...
13:36:35 <achilleas> I'll email the group and tell them you're interested.
13:36:48 <gicmo> \o/
13:36:54 <MeWjOr> I'm positive that the room will be approved easily, given last years turnout
13:37:03 <MeWjOr> ;D
13:37:13 <FranciscoD> #info FOSSDEM mailing lists: https://lists.fosdem.org/mailman/listinfo
13:37:24 <MeWjOr> Thanks a lot for the info achilleas :)
13:39:11 <MeWjOr> I guess we can move onto the next topic for todays meeting then
13:39:25 <FranciscoD> +1
13:39:38 <MeWjOr> #topic NeuroFedora Bugs: https://tinyurl.com/neurofedora-bugs
13:39:45 <MeWjOr> #info https://tinyurl.com/neurofedora-bugs
13:40:14 <MeWjOr> some new bugs, mainly for mne and odml that I will be working on this week
13:40:58 <FranciscoD> yeh, looks fine, nothing urgent
13:41:10 <FranciscoD> a few updates etc.
13:41:12 <FranciscoD> all in due time
13:41:31 <MeWjOr> yep +1
13:41:41 <MeWjOr> next topic...
13:41:46 <MeWjOr> #topic Koschei packages check
13:42:10 <MeWjOr> #info neuro-sig packages here: https://koschei.fedoraproject.org/groups/neuro-sig
13:42:41 <FranciscoD> hrm, pydicom is failing
13:42:53 <FranciscoD> ah, that's still numpy related
13:43:02 <FranciscoD> @Alessio: any updates from upstream on pydicom?
13:43:12 <MeWjOr> some new packages are failing
13:43:14 <FranciscoD> #info pydicom: https://bugzilla.redhat.com/show_bug.cgi?id=1838435
13:43:25 <FranciscoD> nest too
13:43:27 <FranciscoD> that's new
13:43:43 <MeWjOr> neurord as well? I think you fixed that earlier?
13:43:58 <FranciscoD> neurord has been orphaned
13:44:12 <FranciscoD> I think I e-mailed the ML about that too, in case someone wanted to take it up
13:44:12 <MeWjOr> ohh wait... it shouldn't be here then?
13:44:48 <FranciscoD> it'll get removed on its own as we branch for f34 etc
13:45:05 <FranciscoD> neuro-sig is still listed with commit access, I've left that for the time being
13:45:28 <MeWjOr> oohh... That's great then... for legacy support :P
13:45:38 <FranciscoD> the nest build is segfaulting during linking XD
13:45:44 <FranciscoD> collect2: fatal error: ld terminated with signal 11 [Segmentation fault], core dumped
13:45:51 <FranciscoD> this will be fun to debug
13:45:57 <MeWjOr> linking?
13:46:03 <MeWjOr> as in creating a symlink?
13:46:10 <FranciscoD> no, linking as in ld linking
13:46:16 <MeWjOr> oohh
13:46:23 <MeWjOr> yes, pretty interesting XD
13:46:31 <FranciscoD> i think we re-check next meeting: maybe it'll "fix itself"
13:46:39 <FranciscoD> we haven't make any changes to the spec at all
13:46:48 <FranciscoD> could be something gcc etc. related
13:46:59 <MeWjOr> yep, I'll action it to you?
13:47:05 <FranciscoD> +1
13:47:10 <FranciscoD> to check at next meeting
13:47:37 <MeWjOr> #action FranciscoD Checkout nest at the next meeting if its building fine or not
13:47:45 <FranciscoD> #action alciregi check on python-pydicom package
13:47:58 <FranciscoD> (the bug is already assigned to alciregi)
13:48:09 <MeWjOr> lol
13:48:29 <MeWjOr> next topic
13:48:40 <MeWjOr> #topic CompNeuro lab compose check
13:48:48 <MeWjOr> #info https://koji.fedoraproject.org/koji/packageinfo?packageID=30691
13:48:57 <MeWjOr> Everything's green
13:49:00 <FranciscoD> nice
13:49:02 <MeWjOr> :D
13:49:15 <FranciscoD> hopefully we'll have a few more packages to add to the next comp-neuro release
13:49:16 <FranciscoD> netpyne etc
13:49:47 <FranciscoD> I opened this too, so from next release, we should get some metrics on comp-neuro usage
13:49:48 <FranciscoD> https://pagure.io/fedora-kickstarts/pull-request/724
13:50:27 <MeWjOr> What does this PR correspond to?
13:50:51 <FranciscoD> to this: https://fedoraproject.org/wiki/Changes/DNF_Better_Counting
13:51:08 <FranciscoD> fedora-release not has info for each spin/lab so that their usage can be counted
13:51:24 <FranciscoD> s/not/now/
13:51:31 <MeWjOr> ahhh... great
13:51:50 <MeWjOr> I need to start paying more attention to -devel :P
13:52:28 <FranciscoD> or at least devel-announce :P
13:53:08 <MeWjOr> O.O Both these lists are going to the same box right now... I have to patch it up
13:53:36 <MeWjOr> next topic... so that we finish on time
13:53:39 <MeWjOr> #topic Neuroscience query of the week
13:53:58 <MeWjOr> #info https://pagure.io/neuro-sig/NeuroFedora/issue/318
13:54:43 <FranciscoD> Not much here
13:54:46 <MeWjOr> I didn't get time to read any new posts... if anyone has anything interesting to share, please bring them up
13:54:48 * FranciscoD can't think of anything interesting
13:55:12 * FranciscoD has a quick look at planet-neuroscientists
13:55:14 <FranciscoD> https://neuroblog.fedoraproject.org/planet-neuroscientists/
13:55:27 <MeWjOr> I did see a meme regarding the curly-ness of the brain (if that counts)
13:56:31 <FranciscoD> curlyness as in gyri and sulci?
13:57:01 <MeWjOr> yes, lol
13:57:13 <FranciscoD> haha, yeh, sure
13:57:16 <MeWjOr> didn't know the scientific names for that
13:57:22 <fm-neuro_> pagure.project.new -- limb created a new project "rpms/python-netpyne" https://src.fedoraproject.org/rpms/python-netpyne
13:57:24 <MeWjOr> > https://pics.me.me/yuor-brain-o-my-brain-smooth-bumpy-weird-no-weinkls-67262428.png
13:57:27 <fm-neuro_> pagure.git.branch.creation -- None https://src.fedoraproject.org
13:57:28 <fm-neuro_> pagure.git.receive -- pagure pushed 1 commit to rpms/python-netpyne (master) https://src.fedoraproject.org/rpms/python-netpyne/tree/master
13:57:29 <fm-neuro_> pagure.issue.comment.added -- limb commented on ticket releng/fedora-scm-requests#30199: "New Repo for "rpms/python-netpyne"" https://pagure.io/releng/fedora-scm-requests/issue/30199#comment-699278
13:57:31 <MeWjOr> :D
13:57:31 <fm-neuro_> pagure.issue.edit -- limb edited the close_status and status fields of ticket releng/fedora-scm-requests#30199 https://pagure.io/releng/fedora-scm-requests/issue/30199
13:57:42 <fm-neuro_> pagure.git.branch.creation -- None https://src.fedoraproject.org
13:57:45 <FranciscoD> LOL
13:57:54 <MeWjOr> netpyne seems to be almost ready
13:57:59 <fm-neuro_> pagure.git.branch.creation -- None https://src.fedoraproject.org
13:58:03 <FranciscoD> yeh, gotta import and build etc
13:58:08 <FranciscoD> will do that in a bit
13:58:18 <MeWjOr> yep, meeting's almost over now
13:58:29 <MeWjOr> #topic Next meeting day, and chair
13:58:40 <MeWjOr> Any volunteers?
13:59:15 <FranciscoD> I'll do it, or will poke someone else mid week to do it :P
13:59:33 <MeWjOr> that will do great XD
13:59:40 <MeWjOr> two weeks time?
13:59:45 <FranciscoD> yeh, same time
14:00:13 <tg-fedneuro> <b​t0dotninja> Me
14:00:15 <MeWjOr> #action FranciscoD Next meeting, same time in two weeks. Either FranciscoD will chair or will poke someone else to do it
14:00:25 <MeWjOr> aye, great then
14:00:29 <MeWjOr> #undo
14:00:29 <zodbot> Removing item from minutes: ACTION by MeWjOr at 14:00:15 : FranciscoD Next meeting, same time in two weeks. Either FranciscoD will chair or will poke someone else to do it
14:00:38 <tg-fedneuro> <b​t0dotninja> 🙂
14:00:48 <MeWjOr> #action bt0 Next meeting, same time in two weeks. bt0 will chair the meet :D
14:01:02 <FranciscoD> awesome, thanks bt0 :)
14:01:07 <MeWjOr> and with that, we move to the open floor
14:01:09 <FranciscoD> bt0++
14:01:09 <zodbot> FranciscoD: Karma for bt0dotninja changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:01:12 <MeWjOr> #topic open floor
14:01:23 <FranciscoD> nothing here from me
14:01:33 <MeWjOr> nothing new from me as well
14:01:44 <FranciscoD> feel free to close the meeting when you want: we've gone over the 1 hour mark :o
14:01:56 <MeWjOr> #action MeWjOr send out the meeting logs and everything else
14:02:04 <MeWjOr> yep, ending the meeting now
14:02:10 <MeWjOr> Thanks for everyone attending
14:02:32 <FranciscoD> thanks for chairing MeWjOr
14:02:34 <FranciscoD> MeWjOr++
14:02:34 <zodbot> FranciscoD: Karma for major changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:02:36 <MeWjOr> also, thanks achilleas ... we'll be waiting for you
14:02:36 <FranciscoD> gicmo++
14:02:37 <MeWjOr> :D
14:02:37 <zodbot> FranciscoD: Karma for gicmo changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:02:45 <FranciscoD> .thank achilleas
14:02:45 <zodbot> FranciscoD thinks achilleas is awesome and is happy they are helping! (Please also type achilleas++ since that is what gives them a cookie)
14:02:47 <MeWjOr> #endmeeting