14:05:45 <alebastr[m]> #startmeeting Sway SIG (2022-06-15)
14:05:45 <zodbot> Meeting started Wed Jun 15 14:05:45 2022 UTC.
14:05:45 <zodbot> This meeting is logged and archived in a public location.
14:05:45 <zodbot> The chair is alebastr[m]. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
14:05:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:05:45 <zodbot> The meeting name has been set to 'sway_sig_(2022-06-15)'
14:05:50 <jsck[m]> Do I need to type that if I'm attending?
14:05:58 <jsck[m]> .hello onemorebyte
14:05:58 <alebastr[m]> .hello alebbastr
14:05:58 <zodbot> jsck[m]: onemorebyte 'Jack Hildebrandt' <jack@jackhil.de>
14:06:01 <zodbot> alebastr[m]: Sorry, but user 'alebbastr' does not exist
14:06:04 <alebastr[m]> .hello alebastr
14:06:05 <zodbot> alebastr[m]: alebastr 'Aleksei Bavshin' <alebastr89@gmail.com>
14:07:17 <anthr76[m]> Sorry a couple moments late :)
14:08:14 <alebastr[m]> no worries, I almost decided to continue sleeping myself instead of doing the meeting :)
14:08:41 <Fale[m]1> .hello fale
14:08:42 <zodbot> Fale[m]1: fale 'Fabio Alessandro Locati' <me@fale.io>
14:09:11 <alebastr[m]> So I checked the dates, and code freeze for f37 is pretty close - Aug 23
14:09:47 <alebastr[m]> within the timeframe we'll also have new wayland release and quite possibly wlroots 0.16
14:11:25 <anthr76[m]> That does seem quite tight.
14:12:23 <alebastr[m]> yep. nothing bad happens if we slip to f38, but there's still enough time to try with f37
14:13:15 <alebastr[m]> anthr76: are you going to continue updating the feature page?
14:13:39 <anthr76[m]> I like that idea. How has the packaging load been?
14:14:23 <Fale[m]1> Iirc, the changes need to be approved way before the code freeze
14:14:24 <anthr76[m]> alebastr[m]: I will. I can give it a decent update today. We mentioned this earlier but maybe worth bringing up now. Is there anywhere we want to list fas's and what they're working on?
14:15:58 <anthr76[m]> The way I would like to view is try to meet f37 and if we slip to f38 no problem. I would like to either assist or host a ostree remote for whatever stable fedora release is out at the time once our rawhide ostree work is completed. IIRC Kinote did similar
14:16:36 <alebastr[m]> yep, self-contained change submission deadline is July 19, but we want to be earlier than that. I believe ostree is pretty ugly on infra side, so we'd want to talk with people about that earlier
14:17:19 <Fale[m]1> Is a new spin self contained?
14:17:30 <alebastr[m]> i3 was self-contained
14:17:43 <anthr76[m]> I believe it always is
14:17:50 <anthr76[m]> https://docs.fedoraproject.org/en-US/releases/spins/creating/
14:17:55 <Fale[m]1> Ok, we can run with self contained then ;-). We have 1month then
14:17:58 <anthr76[m]> I started the change proposal based on the above link
14:19:25 <philip_rhoades> Is there a meeting?
14:19:43 <anthr76[m]> philip_rhoades: Yes :)
14:20:07 <philip_rhoades> Here?
14:20:43 <alebastr[m]> anthr76[m]: Kevin is looking at the gitlab group ticket, so we'll get that sorted out sooner than later. We can build things in gitlab ci then and host somewhere.
14:21:08 <anthr76[m]> Sounds good
14:21:29 <anthr76[m]> I did see some movement on it yesterday
14:22:45 <alebastr[m]> rpm spin previews are a bit more complicated - we need comps, kickstarts and a place to upload preview iso images
14:22:54 <alebastr[m]> btw, hosting comps in copr seems to be broken
14:24:29 <alebastr[m]> and I honestly have no idea how to make live image even a tiniest bit user-friendly. You get sway with background and bar, and need to find how to start the installer :)
14:25:38 <anthr76[m]> I did toy with the i3 live spin last week
14:28:55 <alebastr[m]> what we can do: collect keybindings from the config, add some help text (enter `Mod4+d, anaconda` to start the installer) and show this over the background image
14:29:55 <jsck[m]> Could the bar display that message too?
14:30:33 <alebastr[m]> yes, but the bar is too small to fit more than one short line
14:30:51 <jsck[m]> Ah fair that won't be a readable
14:31:11 <jsck[m]> s/a/as/
14:31:12 <alebastr[m]> Something like https://github.com/nwg-piotr/nwg-wrapper would be better
14:31:49 <anthr76[m]> Interesting
14:31:54 <jsck[m]> I like that
14:32:57 <alebastr[m]> parsing sway config for bindings is a funny task
14:33:33 <Fale[m]1> I'm not a fan of changing the background to add instructions into it, but I do understand the importance of being user friendly. I remember that some distro started a text editor with notes. Could that work? (Or start anaconda directly if rubbed live)
14:34:34 <anthr76[m]> I wonder how the i3 folks do it. They open a terminal prompt with some basic instructions and how you want your config i.e fedoraified or vanilla IIRC
14:35:23 <alebastr[m]> Fale: that works, but too easy to accidentally close
14:36:29 <Fale[m]1> I wonder if we need to decide who is our audience in the first place
14:36:54 <alebastr[m]> besides, it would mean that we'll have to include a gui text editor :)
14:37:20 <anthr76[m]> Regardless of audience having something like this would be a nice resource https://docs.fedoraproject.org/en-US/fedora-kinoite/ even for advanced and novice users
14:38:21 <anthr76[m]> That document is obviously quite ostree focused but you know generalizing some topics of the sway spin for a possible new user.
14:38:48 <defolos> anthr76[m]: not according to my knowledge
14:39:08 <defolos> we just have a config package: i3-config-vanilla and i3-config-fedora
14:39:20 <defolos> whatever you install will give you the fedora or upstream defaults
14:39:37 <defolos> unless someone hacked something into the kickstarts without me noticing…
14:40:24 <anthr76[m]> Maybe I was off. I was using it to fix up some servers. I'm trying to boot a vm quick
14:41:21 <alebastr[m]> anthr76: so far I've been splitting comps into sway-base (with upstream config and a few optional deps) and sway-desktop (which pulls sway-config-fedora), and the user could uncheck sway-desktop in the anaconda package selection ui. obviously doesn't work with ostree
14:41:57 * anthr76[m] uploaded an image: (993KiB) < https://libera.ems.host/_matrix/media/r0/download/mozilla.org/5205a653b16126ee024c3acd37e7ba09e711d38a/image.png >
14:42:04 <anthr76[m]> Slightly off defolos, sorry :)
14:42:32 <defolos> anthr76: that's upstream's work
14:42:48 <anthr76[m]> Interesting TIL
14:42:55 <defolos> nothing fedora specific in that
14:43:13 <defolos> I wanted to extend that, but it's all just C, so I noped out
14:44:32 <anthr76[m]> <Fale[m]1> "I wonder if we need to decide..." <- To add to Aleksei Bavshin's point.. Maybe this is becoming more true
14:44:58 <alebastr[m]> https://pagure.io/fork/alebastr/fedora-comps/commits/sway btw. pagure is a bit awful when you want to develop and review things in a fork - IIUC, you can't even open pull requests to fork
14:45:11 <defolos> alebastr[m]: of course you can
14:45:45 <alebastr[m]> you can send a PR to the main project, but that's not what I want right now
14:46:49 <alebastr[m]> I'd like us to collaborate on the forked repo, and when we think it's ready - squash and send a PR to fedora-comps
14:46:59 <defolos> ah, I see
14:47:03 <defolos> ok never tried that
14:50:35 * alebastr[m] checks the meeting agenda he wrote half-unconscious after being drained by a long working day
14:52:40 <alebastr[m]> so I guess the things we can work on right now are decisions (target audience is a very good question) and reviews for things we have to implement anyways
14:54:34 <alebastr[m]> on that note I'd like to see comments for https://pagure.io/fedora-sway/fedora-sway-configs/issue/2 - it has to be done somehow, but I failed to figure out a better idea than the ones already mentioned
14:56:08 <anthr76[m]> alebastr[m]: Maybe idea 2 there?
14:56:24 <anthr76[m]> Is it possible for SDDM to run in wayland
14:56:46 <jsck[m]> I think idea 2 is the best as well
14:57:15 <anthr76[m]> That's a proving more and more weird and tough problem to solve. I will chew on it a bit after the meeting
14:58:01 <alebastr[m]> yep, let's think on that until the next meeting. I'll also draft the changes needed for #2
14:59:47 <alebastr[m]> anthr76[m]: one of the things we need to fix upstream. wayland support in sddm is incomplete :(
15:00:02 <anthr76[m]> #action anthr76 will continue to look at openQA and update the change proposal from findings in the past couple of weeks
15:00:10 <anthr76[m]> (I think I did that right?)
15:00:28 <anthr76[m]> alebastr[m]: Sad, alright sounds good
15:02:34 <alebastr[m]> #action alebastr try to finish and upstream necessary sddm patches
15:03:34 <alebastr[m]> there's one more for XDG_SESSION_DESKTOP and something to deal with keybord layouts in a greeter...
15:04:43 <alebastr[m]> at this point gdm (with mandatory dependency on gnome-shell) is starting to look attractive
15:04:48 <anthr76[m]> Sadly agreed
15:05:12 <anthr76[m]> I wish gnome shell and the deps needed for the  status bar along with the status bar itself can be stripped
15:06:52 <alebastr[m]> #action everyone continue looking at https://pagure.io/fedora-sway/fedora-sway-configs and suggest things you deem necessary for a new user or live environment
15:08:54 <alebastr[m]> and I do believe that our target audience should be at least familiar with the concept of tiling wms
15:09:06 <anthr76[m]> Agreed
15:09:36 <alebastr[m]> so we shouldn't make it a gnome-like environment (looks at nwg-shell)
15:11:15 <anthr76[m]> .. to the extend we should be open for new users looking to adopt it. Without any data proving it I'm willing to bet new users looking to try a tiling wm are going to look for sway more and more as wayland becomes more companionable and easier to use. Especially if you spent a couple years using gnome (which imo has a quite pleasant wayland experience). That's my long winded way of saying new users to the space are likely to try this
15:11:16 <anthr76[m]> (maybe?) and we shouldn't hinder them but they should bring some due diligence
15:11:57 <anthr76[m]> Nevertheless this space can be the wild west so having documents even just at least linking things like our design decisions can help higher end users on why they would want to use this
15:11:58 * alebastr[m] finds it hard to remember a perspective of a new twm user
15:14:06 <anthr76[m]> At work at least 5 of us switch to sway at about the same time, so I think ( have a decent understanding?) there also two differences to a new twm user. One that might not be familiar with linux on the desktop and the inter-workings required to make it work and one that does understand that at least to an extent and just never used a twm
15:14:36 <alebastr[m]> so new user who wants to try a twm and expects a working basic environment with some tinkering options and a good docs for to start with these?
15:14:55 <anthr76[m]> in that group of 5 some of us came from awesomewm, i3, and at least 3 just lived on gnome. All had varying degrees of success through the journey đŸ˜†
15:15:38 <anthr76[m]> alebastr[m]: I think so. Im not sure if it's too opinionated but I would like things like your volume and brightness shortcuts work OOB. Which we're doing now
15:15:46 <anthr76[m]> * doing now which I think is good
15:16:44 <anthr76[m]> I think having those things OOB makes for a pleasant experience OOB. A new user that can't tweak with their sound or whatnot may feel discouraged and nope out immediately
15:19:30 <anthr76[m]> s/OOB//
15:19:41 <alebastr[m]> I'm going to stop the meeting; we already way past the schedule and I'm on the work call in parallel. Just need one more note :)
15:19:53 <anthr76[m]> +1
15:20:06 <anthr76[m]> I have a sick cat to tend to. I shall catch up some sway things in the night
15:21:33 <alebastr[m]> #action alebastr better planning and agenda for the next meetings. keep offline and in a task tracker things that can be discussed there
15:22:02 <alebastr[m]> #endmeeting