14:03:33 <Fale[m]> #startmeeting Sway SIG
14:03:33 <zodbot> Meeting started Wed Oct  5 14:03:33 2022 UTC.
14:03:33 <zodbot> This meeting is logged and archived in a public location.
14:03:33 <zodbot> The chair is Fale[m]. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
14:03:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:03:33 <zodbot> The meeting name has been set to 'sway_sig'
14:03:46 <Fale[m]> #topic rollcall
14:04:09 <Fale[m]> .hello Fale
14:04:10 <zodbot> Fale[m]: fale 'Fabio Alessandro Locati' <me@fale.io>
14:04:34 <anthr76[m]> .hello anthr76
14:04:35 <zodbot> anthr76[m]: anthr76 'Anthony Rabbito' <hello@anthonyrabbito.com>
14:04:35 <Alessio[m]> .hello alciregi
14:04:37 <zodbot> Alessio[m]: alciregi 'Alessio C' <alciregi@posteo.net>
14:05:06 * Alessio[m] lurking
14:05:28 <jkonecny[m]> .hello jkonecny
14:05:29 <zodbot> jkonecny[m]: jkonecny 'Jiří Konečný' <jkonecny@redhat.com>
14:06:45 <Fale[m]> where shall we start from? login managers?
14:06:58 <anthr76[m]> Sure.
14:07:03 <Fale[m]> #topic Login Manager
14:07:54 <Fale[m]> tracker: https://gitlab.com/fedora/sigs/sway/SIG/-/issues/3
14:10:08 <anthr76[m]> So sometimes this topic can feel like beating a dead horse, but I feel we should try greetd in some form.... (full message at <https://libera.ems.host/_matrix/media/r0/download/libera.chat/e4eb2ddec5aaa40867ab6325abaa70923b23d48e>)
14:11:13 <Fale[m]> I think qmlgreet could be a good option, at least temporarely
14:11:13 <anthr76[m]> dngray: brought some interesting points up about SDDM yesterday, and I think i'm okay sticking it out on SDDM, but I'm going to have to dig deeper into if that's the case. I have a few issues with it currently in which I haven't dug deep into yet because Im unsure we'll stick with it
14:11:33 <Fale[m]> @anthr76 what were those about?
14:11:46 * anthr76[m] wishes he can be more help here https://gitlab.com/alebastr/qmlgreet/-/milestones/1
14:13:21 <anthr76[m]> Fale[m]: On my new alder lake laptop my screen always flickers while docked on both the laptop screen and the monitor
14:13:21 <anthr76[m]> On my work laptop (Ryzen 5000) SDDM always default's to the laptop screen during lid closed docked so I need to dig and see if there's a way to at least mirror everything
14:13:30 <anthr76[m]> To login on a fresh boot with my alder lake I basically need to be undocked during luks past SDDM to use it docked
14:13:40 <anthr76[m]> Otherwise it just flickers and freaks out
14:14:25 <Fale[m]> one thing that I don't like much about SDDM is that last release is 2 years old :-/
14:14:44 <anthr76[m]> +1
14:15:18 <anthr76[m]> IIRC They were hit pretty hard with the pandemic and Ukraine conflict
14:15:40 <Fale[m]> also, the missing integration with systemd is something that imho is problematic
14:15:59 <anthr76[m]> Fedora has nearly pressured the maintainers in the past to integrate/fix beta blockers and I don't want to burden them more. They seem to have their hands full, and they are making gradual movement against master
14:17:14 * anthr76[m] is somewhat afraid to know the state of nivida on our builds of SDDM
14:17:25 <Fale[m]> what's the issue there?
14:17:35 <anthr76[m]> It's nvidia :P
14:17:45 <anthr76[m]> Nothing known, but I'm quite confident no one has tried
14:17:55 <Fale[m]> or better: why should SDDM have more issues than other login mangers?
14:18:18 <Fale[m]> maybe @laiot#1694 has
14:18:35 <anthr76[m]> https://pagure.io/fedora-kde/SIG/issue/183#comment-785566
14:19:16 <alebastr[m]> Sorry, I missed a few alarms and just woke up :'(
14:19:19 <alebastr[m]> .hello alebastr
14:19:20 <zodbot> alebastr[m]: alebastr 'Aleksei Bavshin' <alebastr89@gmail.com>
14:19:51 <laiot[m]> I have a laptop with an Nvidia GPU, what are you asking to try?
14:20:08 <Fale[m]> @laiot#1694 have you tried SDDM login manger?
14:20:50 <laiot[m]> I don't think so, which spins or distro use it?
14:21:03 <Fale[m]> Sway Spin
14:21:43 <dngray[m]> <anthr76[m]> "dngray: brought some interesting..." <- so SDDM is very flexible
14:21:44 <alebastr[m]> > * <@anthr76:mozilla.org> is somewhat afraid to know the state of nivida on our builds of SDDM
14:21:44 <alebastr[m]> we're running it on top of Sway currently, so it's the same as with Sway
14:21:48 <dngray[m]> but it just requires a good theme
14:22:03 <dngray[m]> that's what i discovered, and the lxqt one, and default ones are not good themes.
14:22:20 <laiot[m]> Fale[m]: then yeah, I tried the nightly around... one month ago? I had no issue, I can try it again on a live environment if that's useful
14:22:20 <anthr76[m]> I would say specifically our SDDM with our patches https://download.copr.fedorainfracloud.org/results/@sway-sig/sway-spin-dev/fedora-rawhide-x86_64/04882190-sddm/sddm.spec
14:22:43 <dngray[m]> because it's QML you're literally limited only by what objects you use, the reason i think we should package and use one of those "sugar" themes is because they are modern and what a user would expect
14:22:53 <dngray[m]> those themes use modern objects
14:23:01 <dngray[m]> and they're GPLv3, so no licensing issues
14:23:15 <anthr76[m]> I think sway quirks with nivida is fairly known. Possibly SDDM with nivida on wayland not so much?
14:23:21 <Fale[m]> the 2 issues I see with sddm are: 1. 2 years with no releases and 2. no systemd integration
14:23:25 <dngray[m]> in fact it was on my to-do list to package them and put them in my copr tonight
14:23:37 <dngray[m]> anthr76[m]: i think it's gotten better
14:23:44 <dngray[m]> and it will get better now that NVIDIA officially supports GBM
14:23:47 <alebastr[m]> dngray: have you considered updating one of the sddm builtin themes to use QQC2? :)
14:24:20 <dngray[m]> alebastr[m]: i thought about it, but the sugar ones look so pretty
14:24:25 <alebastr[m]> the problem with these themes is that they were made way before QQC and haven't been updated
14:24:34 <dngray[m]> and they are better designed
14:24:39 <dngray[m]> in terms of flexability and settings
14:24:47 <dngray[m]> one of the things thats really cool is you can adjust a lot of the stuff in the config
14:24:53 <dngray[m]> and the theme will respect those options
14:25:02 <dngray[m]> https://www.opendesktop.org/p/1272122
14:25:02 <dngray[m]> https://www.opendesktop.org/p/1312658
14:25:02 <dngray[m]> https://www.opendesktop.org/p/1272119
14:25:08 <dngray[m]> is what i'm talking about
14:25:23 <dngray[m]> they all use QQC2
14:25:39 <dngray[m]> frankly the default ones are not great
14:25:46 <dngray[m]> one of them looks like a weird KDE theme
14:25:53 <dngray[m]> the other one is just so dumb blue with pink writing
14:25:55 <laiot[m]> I'm still using the one that comes with the i3 spin, no issues whatsoever. Which one was that?
14:25:59 <dngray[m]> they look like the rubbish on opendesktop lol
14:26:10 <dngray[m]> so i have no interest in updating the ones in the upstream source tree
14:26:44 <dngray[m]> im going to put in a PR with SDDM upstream and tell them to replace those crap themes
14:26:44 <dngray[m]> lol
14:26:56 <dngray[m]> because the ones they include make people think SDDM is garbage
14:26:56 <dngray[m]> also
14:27:11 <dngray[m]> everyone bases their garbage theme off that those upstream themes
14:27:17 <dngray[m]> which just are not designed very well
14:27:36 <dngray[m]> i think what happened with sugar is someone was like "i've had enough, i'm going to do this properly"
14:27:45 <dngray[m]> see https://github.com/MarianArlt/sddm-sugar-light/wiki
14:28:43 <Fale[m]> I see theming as secondary/thirdary priority. IMHO the critical parts of a login manager is stability and core features
14:28:43 <dngray[m]> https://github.com/MarianArlt
14:28:43 <dngray[m]> > Marian Arlt Grafikdesign & Illustration
14:28:49 <dngray[m]> so yeah the guy who made them is a graphics designer
14:28:58 <dngray[m]> Fale[m]: yeah, i do agree
14:29:15 <dngray[m]> however first impressions, a login screen should look decent
14:29:23 <dngray[m]> and we can do this trivially, as i am already using this theme on our ostree
14:29:44 <Fale[m]> surely, but first we should decide if sddm is going to be the login manger or not
14:29:59 <dngray[m]> what i do like about sddm is it's super lightweight
14:30:04 <dngray[m]> and very powerful
14:30:16 <dngray[m]> what else would we choose? gdm?
14:30:45 <Fale[m]> I see the 2 years with 0 releases and absence of systemd support as two red flags for sddm
14:31:06 <dngray[m]> Fale[m]: that's fair
14:31:22 <alebastr[m]> Fale: what do you mean by systemd support?
14:31:26 <alebastr[m]> environment vars?
14:31:28 <Fale[m]> systemd environment variables
14:31:35 <dngray[m]> i wonder how well it would work with something like systemd-homed
14:31:41 <dngray[m]> because eventually we will want that to work
14:31:43 <Fale[m]> https://www.freedesktop.org/software/systemd/man/environment.d.html
14:31:54 <dngray[m]> this is kind of what i came to the conclusion when looking at file managers, and other associated stuff
14:32:06 <dngray[m]> is that the GNOME options, are quite modular, and frankly, not crap
14:32:13 <anthr76[m]> It's important to point that out, but also realize that won't be better with greetd :/
14:32:14 <Fale[m]> my understanding is that sddm does not want to integrate with systemd, and therefor systemd-homed will not arrive to sddm
14:32:38 <dngray[m]> Fale[m]: well then that rules out sddm for me
14:32:44 <dngray[m]> because like it or not, systemd makes linux good
14:33:35 <dngray[m]> especially things like systemd-cryptenroll and --with-pin 👍️
14:33:42 <Fale[m]> seehttps://github.com/sddm/sddm/pull/1574
14:33:45 <dngray[m]> we're starting to get some really awesome features, soon systemd-measure
14:33:46 <Fale[m]> * see https://github.com/sddm/sddm/pull/1574
14:34:00 <dngray[m]> i used to love alpine linux, but now i refuse to use it
14:34:09 <dngray[m]> because everything else is just so fragile
14:35:32 <alebastr[m]> Fale: I don't see a complete rejection in this PR. I believe that if you send a PR that sources the variables via DBus interface, they'll accept it. It'll just take a few years :)
14:35:47 <dngray[m]> okay gdm, does have a bit more of a footprint, if you install that it installs 90MB
14:36:19 <dngray[m]> so while we could clearly get away with nautilus, gvfs, file-roller yeah that's quite a bit more for gdm
14:37:41 <Fale[m]> I'm ok with GDM if it checks all boxes
14:37:58 <laiot[m]> What about lightdm https://github.com/canonical/lightdm
14:37:59 <dngray[m]> https://clbin.com/Odn0t is gdm btw
14:38:33 <dngray[m]> looks like it pulls in a quite a bit of gnome
14:38:33 <Fale[m]> @laiot#1694 ligthdm requires X11, so it's not being considered
14:39:14 <alebastr[m]> laiot: https://github.com/canonical/lightdm/issues/126, https://github.com/canonical/lightdm/issues/63
14:39:47 <dngray[m]> does canonical even use lightdm anymore on ubuntu
14:39:51 <dngray[m]> i was pretty sure they didn't
14:39:52 <laiot[m]> Oh sorry, I read that supports Wayland and I thought X11 wasn't a requirement
14:40:20 <alebastr[m]> both can be solved by getting rid of the rootful X used by lightdm greeter. I.e. switching the greeter to wayland or something
14:40:23 <dngray[m]> i might add thunar also pulls in a lot of x11 deps
14:40:50 <dngray[m]> > <@dngray:polarbear.army> when you conisder XFCE, you're getting:... (full message at <https://libera.ems.host/_matrix/media/r0/download/libera.chat/54fc104acac458f1fe995ffcd982d874d8610a33>)
14:41:11 <alebastr[m]> but the default lightdm gtk greetter looks pretty much hopeless in that sense - when I looked into that it was heavily using x11-specific gdk APIs
14:41:33 <dngray[m]> you know what i'm really hoping, is that qubes brings back their i3 spin
14:41:35 <dngray[m]> and maybe uses our package choices, or base for that
14:41:44 <anthr76[m]> Let's try to stay on topic and express that soon
14:42:19 <dngray[m]> on feature set i don't think really anything ticks all the boxes that gdm does
14:42:21 <anthr76[m]> Does anyone know if fedora would maintain a downstream patch of sourcing `enviroment.d` ?
14:42:34 <anthr76[m]> And even if that answer is yes I at least have some bugs unaccounted for
14:42:35 <Fale[m]> I don't this Fedora will
14:42:57 <Fale[m]> s/this/think/
14:43:30 <dngray[m]> i would think at this late hour it's probably not best to try to overhaul sddm heavily
14:43:40 <dngray[m]> that is going to require some testing
14:45:23 <dngray[m]> oh i found this https://todo.sr.ht/~kennylevinsen/greetd/15 lol
14:45:44 <anthr76[m]> alebastr: as you might have seen before you hopped in I'm in no way pressuring you to qmlgreet, but I think while we can afford to break things it's worth testing in whatever state it's in. There's maybe the same amount of quirks in SDDM
14:46:49 <dngray[m]> it doesn't look hugely alive https://github.com/nowrep/qmlgreet/commits/master
14:47:11 <anthr76[m]> dngray[m]: https://gitlab.com/alebastr/qmlgreet
14:47:57 <alebastr[m]> anthr76: I've seen, yes. I've been pretty busy with a large project at work lately, but I'll try to work on the QML code refactoring I planned
14:47:58 <dngray[m]> oh :)
14:49:08 <anthr76[m]> I'm not necessary asking that instead as a whole using it AS-IS and trying to iterate before the end of November and if the milestones aren't reached we revert to SDDM
14:50:11 <dngray[m]> anthr76[m]: tbh, i'm not sure you should be using SDDM, if basic systemd features are not gonna work
14:50:11 <anthr76[m]> I should also ask at this point like I did with SDDM would we consider a friendly fork or patch consuming `enviorment.d` from dbus with greetd since it seems like upstream won't want that
14:50:26 <alebastr[m]> dngray[m]: that's fixed in greetd master, btw
14:50:56 <alebastr[m]> I can apply these patches in Fedora builds
14:51:40 <Fale[m]> so, my understanding is that we will move to qmlgreet and see if it works and in Novemeber we will decide to procceed with it or revert to sddm. Correct?
14:52:56 <anthr76[m]> I think we can at least have a vote?
14:53:14 <dngray[m]> does qmlgreet work with the environment.d variables?
14:53:40 <dngray[m]> you were saying something about systemd stuff needed for systemd-homed as well
14:55:05 <alebastr[m]> env variables - it can be done by wrapping the command sent to greetd with a session script
14:55:45 <Fale[m]> @anthr76 you mean now or in november?
14:55:48 <alebastr[m]> afaik, systemd-homed does not require anything from the display manager - it's just PAM and some missing selinux policies
14:55:55 <anthr76[m]> Fale[m]: now
14:56:04 <Fale[m]> yes, let's vote ;-)
14:56:05 <dngray[m]> alebastr[m]: that was my understanding, i have been researching it
14:56:32 <dngray[m]> so before you vote, what ate the qmlgreet pros over sddm?
14:56:36 <dngray[m]> s/ate/are/
14:57:35 <anthr76[m]> * greetd is a new project breathing some fresh air in the login manager space
14:57:35 <anthr76[m]> * It's being actively maintained and accepting patches
14:57:35 <anthr76[m]> * Maintainers don't seem huge on systemd, but overall seems worthwhile
14:57:57 <dngray[m]> > <@anthr76:mozilla.org> * greetd is a new project breathing some fresh air in the login manager space
14:57:57 <dngray[m]> > * It's being actively maintained and accepting patches
14:57:57 <dngray[m]> >   * Maintainers don't seem huge on systemd, but overall seems worthwhile
14:57:57 <dngray[m]> okay that's what i thought
14:57:57 <alebastr[m]> dngray: upstream sddm wayland support is broken. we maintain our own build with https://github.com/sddm/sddm/pull/1506 applied, but it needs to be merged to proceed with sddm
14:58:06 <dngray[m]> oh that's nasty
14:58:16 <dngray[m]> i kinda had a feeling things felt dead around upstream sddm
14:58:26 <dngray[m]> especially with those super awful default themes
14:58:57 <dngray[m]> also seems to me that qmlgreet is focusing on wayland support only, which i think is a good thing
14:59:05 <dngray[m]> whereas sddm is still trying to provide support for X11
14:59:15 <dngray[m]> i like seeing wayland only things
15:00:01 <alebastr[m]> to be fair, there's nothing that does not work with x11 in greetd+qmlgreet setup. I did experimental config which runs the greeter with startx
15:00:25 <dngray[m]> i just have this feeling x11 should be eradicated from all codebases, sorry lol
15:01:01 <dngray[m]> make things wayland only, is always going to make things simpler in terms of design
15:01:16 <dngray[m]> i look forward to the day when i can think of x11 like we all think of xfree86
15:01:35 <anthr76[m]> Before I hold this vote do we want to choose if we want to do it only in Sericea or make the comp/fedora-sway-config changes?
15:02:26 <Fale[m]> I would use the same for both if there are no specific reasons to have them different
15:05:04 <anthr76[m]> I would say the only reason for Sericea is you can do it quick and dirty but I think I'd rather have it in all places
15:05:27 <dngray[m]> yeah likely will get more exposure too
15:05:48 <anthr76[m]> +1 For switching the sway-spin entirely to qml-greet until Novemeber where we will evaluate both qmlgreet and SDDM's development progress
15:05:55 <Fale[m]> +1
15:05:59 <dngray[m]> +1
15:06:40 <alebastr[m]> +1
15:07:32 <anthr76[m]> #action anthr76 will attempt to make these changes today or tomorrow.
15:07:45 * anthr76[m] realizes that action won't be too useful after this meeting.
15:07:49 <anthr76[m]> But I wont forget :)
15:08:10 <anthr76[m]> Shall we switch to the next and final topic?
15:08:11 <Fale[m]> #decision sway-spin moves entirely to qmlgreet until November. In November we will re-evaluate between qml-greet and SDDM
15:08:13 <dngray[m]> alebastr: do you have it packaged in your COPR, i wanted to try it
15:08:42 <Fale[m]> #topic Change Proposal
15:09:10 <Fale[m]> IMHO we should propose it ASAP
15:09:10 <anthr76[m]> * Shall we switch to the next ~~and final topic~~?
15:09:16 <alebastr[m]> dngray: https://copr.fedorainfracloud.org/coprs/alebastr/greetd/, but since gtkgreet was my main inspiration you won't be happy with the UI :)
15:09:30 <anthr76[m]> Can we propose without knowing our login manager? :)
15:09:56 <dngray[m]> alebastr[m]: we can always fix that later
15:10:29 <Fale[m]> yes, we can propose it. The expectation is that we are able to produce a Beta version in February https://fedorapeople.org/groups/schedule/f-38/f-38-devel-tasks.html
15:10:49 <anthr76[m]> Any takers on the proposal or should I do it?
15:10:57 <anthr76[m]> Anything jarring to add to the change proposal?
15:11:04 <anthr76[m]> https://fedoraproject.org/w/index.php?title=Changes/Fedora_Sway_Spin
15:11:11 * Fale[m] has review it last week and I'm with it
15:11:32 <anthr76[m]> I will give it another shake down this week
15:13:46 <jkonecny[m]> sorry for missing this, I had 2 meetings
15:13:50 <jkonecny[m]> now I'm focused
15:14:02 <anthr76[m]> 👋
15:14:04 <jkonecny[m]> to the voting above, +1 for the greetd
15:14:23 <jkonecny[m]> I'm looking forward to see it in action
15:14:56 <dngray[m]> do most votes go like this?
15:15:03 <Fale[m]> I would propose to put down an action for someone to submit the change before the next meeting
15:15:12 <Fale[m]> @dngray everyone agreeing?
15:15:21 <dngray[m]> Fale[m]: yeah.
15:15:33 <anthr76[m]> Fale[m]: +1 feel free to call it
15:15:42 <dngray[m]> i kinda get the feeling they might, because the decisions made in sericea so far have been very much what i agree with.
15:15:49 <Fale[m]> @dngray yes, we tend to discuss things to a point where everyone is on the same page, and therefore this means that the votes are very alligned
15:15:52 <dngray[m]> based on my own testing
15:16:04 <dngray[m]> Fale[m]: yeah, that's what i thought
15:16:15 <dngray[m]> i guess we're fortunate there's not a heap of choices heh
15:16:35 <Fale[m]> @anthr76 do you want the action or I take it?
15:16:42 <jkonecny[m]> I think we can go with the change proposal
15:16:42 <dngray[m]> <anthr76[m]> "https://fedoraproject.org/w/..." <- btw i like the description there
15:16:51 <anthr76[m]> I can take it Fale but that may cost a few package reviews :P
15:17:03 <dngray[m]> i think one of the biggest problems for people using window managers, like sway is knowing what components they need
15:17:11 <anthr76[m]> dngray[m]: Please do not credit my creativity I did a lot of `%s/i3/sway/g` :)
15:17:29 <jkonecny[m]> I really hope it will force me to finally try to get the installation instructions on the background for Live ISO... ☹️ don't have time for things like that recently and probably won't change much anytime soon
15:17:29 <Fale[m]> @anthr76 I can trade it with 8 reviews :-D
15:17:46 <dngray[m]> one thing i would say is i expect sericea will bring sway users in general because so easy to install
15:17:48 <jkonecny[m]> by it I mean proposal of the change 😄
15:18:09 <Fale[m]> #action anthr76 to submit the Change Proposal before next meeting
15:18:37 <dngray[m]> i am curious, though, what was the reasoning behind including both rofi and wofi?
15:18:57 <Fale[m]> #topic open floor
15:19:28 <anthr76[m]> I just about have my conclusion on the file manager issue on the tracker. I planned to update it last night, but been quite busy.
15:19:48 <jkonecny[m]> I have a question on open floor. Are we decided already about the toolbx / distrobox question?
15:20:04 <anthr76[m]> I'm not thrilled with most file manager options but likely we will go with Thunar. I will as I said evaluate the footprint etc in the tracker
15:20:13 <dngray[m]> anthr76[m]: i wouldn't
15:20:16 <dngray[m]> i'd go with nautilus
15:20:23 <dngray[m]> and the reason is because the deps are about the same
15:20:23 <anthr76[m]> jkonecny[m]: I think we shouldn't deviate from silverblue thus toolbox being a default option IMO
15:20:28 <jkonecny[m]> dngray[m]: we should have only the rofi-wayland IIRC
15:20:49 <anthr76[m]> dngray[m]: Well I'll have about two weeks to consider that :)
15:20:56 <jkonecny[m]> anthr76[m]: ok thanks
15:21:01 <dngray[m]> anthr76[m]: that may change if you remove other things though
15:21:15 <jkonecny[m]> I don't have a strong opinion. I'm happy about the layering there
15:21:17 <alebastr[m]> dngray[m]: we're not adding wofi. something pulls it as a dependency
15:21:29 <dngray[m]> alebastr[m]: ah.
15:21:45 <anthr76[m]> jkonecny[m]: FWIW after you talking about it I tried the flatpak and it's actually not awful... It'll be neat to see it in flathub eventually
15:21:55 * anthr76[m] still groans about the state of CLI apps in flatpak world
15:21:57 <dngray[m]> does rofi now support wayland naively? iirc that was my reason for going to wofi in the first place
15:22:10 <anthr76[m]> dngray[m]: There's a active fork
15:22:26 * Fale[m] agrees that we should use the same SilverBlue does for toolbox/distrobox
15:23:02 <alebastr[m]> ...xdg-desktop-portal-wlr. ok, it's my fault. I'll do something with that dependency
15:23:06 <dngray[m]> > * <@fale:fale.io> agrees that we should use the same SilverBlue does for toolbox/distrobox
15:23:06 <dngray[m]> that's probably, wise, although i like the idea of distrobox
15:24:10 <Fale[m]> @dngray I think the question is always my preference vs what makes sense. IMHO we need to rememeber we are part of Fedora, and very close to Fedora SilverBlue, so we should do things differently only when it does really make sense
15:24:28 <dngray[m]> Fale[m]: that's one of my reasonings for keeping Nautilus
15:24:31 <Fale[m]> (and when it applies, it would make sense to try to convince SilverBlue to adopt the decision)
15:24:35 <dngray[m]> because it ties in with other things like gvfs
15:24:47 <dngray[m]> now i tried xarchiver, that has no gvfs support
15:24:59 <dngray[m]> so i definitely think nautilus/file-roller is the way to go
15:25:12 <dngray[m]> unless you remove something which is causing eog, and other things to be pulled in
15:25:40 <Fale[m]> I have the feeling we can close the meeting and continue discussing outside, because I don't think we are going to make any additional decision today
15:26:59 <dngray[m]> Fale[m]: unless we want to vote on the file manager
15:27:31 <dngray[m]> anthr76: btw also worth noting that XFCE dropped Xarchiver, they do not have an archiver tool officially anymore
15:27:31 <jkonecny[m]> my main concern about the file managers is dependencies
15:27:52 <jkonecny[m]> what is the difference in terms of dependencies for Nautilus
15:27:53 <dngray[m]> jkonecny[m]: presently nautilus adds very little footprint to Sericea
15:27:57 <dngray[m]> about as much as Thunar
15:28:17 <jkonecny[m]> in that case I'm happy to try it
15:28:18 <dngray[m]> that may change if there's further gnome dep trimmings to be made though
15:28:21 <anthr76[m]> nautilus being wayland native that sounds like a plus?
15:28:27 <jkonecny[m]> we can add it to Sericea just for testing by everyone
15:28:27 <dngray[m]> anthr76[m]: yes
15:28:48 <dngray[m]> i used to use Thunar, with Sway on Arch, when i switched to SB/Sway i kinda got forced into using Nautilus
15:28:52 <dngray[m]> ngl i am not regretting it
15:29:03 <dngray[m]> because when you install gvfs, you get gnome deps, and you need that with Thunar anyway
15:29:03 <Fale[m]> dngray[m]: I doubt it will happen
15:29:26 * anthr76[m] has been pleased with our deps so far
15:29:34 <Fale[m]> is gvfs a requirement?
15:29:43 <anthr76[m]> yes, even with `system-config-printers` 💩 :P
15:29:43 <dngray[m]> well if you want to mount network shares it is
15:29:56 <dngray[m]> gvfs-smb is very handy lol
15:30:03 <dngray[m]> used to use sshfs but that's unmaintained
15:30:28 <dngray[m]> btw, did someone say something about blueman?
15:30:39 <dngray[m]> because that was one of the deps with Nautilus, so if we need that anyway
15:30:43 <dngray[m]> makes sense to use Nautilus
15:30:55 <dngray[m]> >   blueman-nautilus-1:2.3.2-1.fc37.noarch
15:30:58 <anthr76[m]> Anyone willing to try to submit some form of a waybar config
15:30:58 * Fale[m] has not used gvfs for many years, so I don;t feel the need for it... not sure if it's common need or not, though
15:31:12 <dngray[m]> anthr76[m]: i showed mine off last night
15:31:19 <dngray[m]> did u guys like? i based it on Stefano Figura 🐧 (returntrip)'s config
15:31:46 <anthr76[m]> It honestly seemed a bit much for me, but I'm quite a minimalist and the css will need some re-branding I think to fit in with things
15:31:48 <anthr76[m]> It is a good start though
15:31:55 <dngray[m]> also one other thing, worth thinking about is accessability
15:32:00 <jkonecny[m]> anthr76[m]: I can propose mine with a minor modifications as base?
15:32:02 <anthr76[m]> Fonts would need to be re-worked as well
15:32:03 <dngray[m]> pretty sure GNOME has a lot of importance on that hey
15:32:11 <dngray[m]> because i know a few blind people who use tiling window managers
15:32:12 <anthr76[m]> jkonecny[m]: I'm quite happy with anything at this point :)
15:32:19 * anthr76[m] uploaded an image: (14KiB) < https://libera.ems.host/_matrix/media/r0/download/mozilla.org/6fbd0e68cd65bc632ef70210f2ab749dddd4c0a4/image.png >
15:32:30 <anthr76[m]> This is mine currently
15:32:31 <dngray[m]> so this might be another reason to use Nautilus
15:33:59 * jkonecny[m] uploaded an image: (64KiB) < https://libera.ems.host/_matrix/media/r0/download/fedora.im/f4770359b3313ea1b062f571a90c56c03f640424/2022-10-05T17%3A33%3A36%2C480609431%2B02%3A00.png >
15:34:04 <jkonecny[m]> and this is mine
15:34:06 <jkonecny[m]> it's transparent
15:34:14 * dngray[m] uploaded an image: (32KiB) < https://libera.ems.host/_matrix/media/r0/download/polarbear.army/bOPMOSQrmClsDWhsKZOQiAhN/20221006_02h03m23s_grim.png >
15:34:33 <dngray[m]> mine is black
15:34:47 <dngray[m]> jkonecny[m]: that looks difficult to read lol
15:35:31 <jkonecny[m]> ahh, just realized that we need to solve fonts there, I wonder what is available in the repo
15:35:39 <dngray[m]> jkonecny[m]: yes i currently u se nerdfont menlo
15:35:45 <jkonecny[m]> me too
15:35:54 <dngray[m]> or meslo or whatever it is
15:35:54 <anthr76[m]> dngray[m]: This doesn't looks so bad. When I was on my laptop and scalling at 2.0 the active window was cutting into my workspaces
15:36:01 <dngray[m]> with 0 SZ
15:36:21 <dngray[m]> anthr76[m]: yes my configs use the selenized color scheme
15:36:25 <dngray[m]> https://github.com/jan-warchol/selenized/
15:36:25 <anthr76[m]> Overall though I don't have much of a creativity skillset so I'm willing to take whatever because the reference waybar config is rough :)
15:36:37 <dngray[m]> selenized has 4 variants
15:36:53 <dngray[m]> and a lot of themes for various things
15:37:14 <dngray[m]> https://github.com/jan-warchol/selenized/blob/master/the-values.md
15:37:44 <dngray[m]> i would be going with something that is either that or https://www.nordtheme.com/
15:37:46 <dngray[m]> iirc has good contrast too
15:38:11 <dngray[m]> i seem to remember the selenized author saying good things about it
15:38:18 <anthr76[m]> The needful is increasing at work. I may have to drop soon.
15:39:08 <dngray[m]> personally i think for the waybar theme i'd go with something simple like mine
15:39:14 <dngray[m]> looks a bit like the gnome bar at the top anyway
15:40:33 <Fale[m]> Shall we close the meeting?
15:41:09 <anthr76[m]> I don’t think I have anything else.
15:42:14 <anthr76[m]> Sunday-Sunday I am traveling for work and last 4 days I’m going OOO. For awareness
15:42:16 <dngray[m]> https://github.com/dngray/dotfiles/blob/main/home/.chezmoiexternal.toml#L10 probably should package that
15:42:24 <dngray[m]> url = "https://github.com/ryanoasis/nerd-fonts/releases/download/v2.1.0/Meslo.zip"
15:42:57 <Fale[m]> #endmeeting