19:01:41 <franciscod> #startmeeting
19:01:42 <zodbot> Meeting started Wed Mar 31 19:01:41 2010 UTC. The chair is franciscod. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:47 <franciscod> #chair thomasj_ Subfusc
19:01:48 <zodbot> Current chairs: Subfusc franciscod thomasj_
19:01:54 <franciscod> #chair rrix
19:01:55 <zodbot> Current chairs: Subfusc franciscod rrix thomasj_
19:01:57 <franciscod> jut in case :P
19:02:02 <thomasj_> :)
19:02:33 <franciscod> #topic roll call
19:02:40 <franciscod> .fasinfo ankursinha
19:02:41 <zodbot> franciscod: User: ankursinha, Name: Ankur Sinha, email: sanjay.ankur@gmail.com, Creation: 2008-05-28, IRC Nick: franciscod, Timezone: Asia/Kolkata, Locale: en, Extension: 5106611, GPG key ID: 0x5E9BF638, Status: active
19:02:45 <zodbot> franciscod: Approved Groups: @gitfedora-tour cla_fedora cla_done ambassadors fedorabugs freemedia packager
19:03:07 <franciscod> .fasinfo Subfusc
19:03:08 <zodbot> franciscod: User "Subfusc" doesn't exist
19:03:14 <franciscod> er..
19:03:19 <franciscod> .fasinfo thomasj
19:03:20 <zodbot> franciscod: User: thomasj, Name: None, email: th.p.janssen@googlemail.com, Creation: 2008-02-10, IRC Nick: thomasj, Timezone: None, Locale: None, Extension: 5103110, GPG key ID: None, Status: active
19:03:20 <Subfusc> .fasinfo subfusc
19:03:25 <zodbot> franciscod: Unapproved Groups: qa
19:03:30 <zodbot> franciscod: Approved Groups: gitfedora-tour packager triagers cla_fedora cla_done irc-support-operators fedorabugs
19:03:34 <zodbot> Subfusc: User: subfusc, Name: Sindre Wetjen, email: sindre.w@gmail.com, Creation: 2009-06-11, IRC Nick: subfusc, Timezone: Europe/Oslo, Locale: en, Extension: 5132102, GPG key ID: 6E6598CC, Status: active
19:03:38 <zodbot> Subfusc: Approved Groups: gitfedora-tour cvsl10n cla_done cla_fedora
19:03:44 <franciscod> ah, great
19:04:02 <franciscod> #topic change to fedora-tour.py
19:04:04 <Subfusc> no uppercase in usernames ;)
19:04:33 <franciscod> Subfusc: heh, okie
19:04:43 <franciscod> Subfusc: you had asked why i made changes to fedora-tour.py
19:04:49 <Subfusc> yes
19:05:00 <Subfusc> i was only asking why you commented out the test part of the main window
19:05:03 <franciscod> (in my branch, i dont think ive pushed that to master, have i?)
19:05:09 <Subfusc> no
19:05:10 <Subfusc> ;)
19:05:30 <Subfusc> its understandable if its only for testing in your branch
19:05:32 <franciscod> Subfusc: it was just so that if someone decides to see what is going on, he sees a complete portion :P
19:05:42 <franciscod> thats all
19:05:43 <franciscod> heh
19:06:11 <Subfusc> i dont think thats necessary, but ok =) its not realy a big deal for anyone
19:06:12 <Subfusc> :p
19:06:35 <franciscod> it aint gone to master, so its fine, i dint like the thing popping up everytime i tested :P
19:06:45 <Subfusc> hehe ;)
19:06:52 <franciscod> #topic my new idea :P
19:07:01 <franciscod> Subfusc: thomasj_ : about the main menu
19:07:10 <franciscod> you wont believe it, but it came in my dream :P
19:07:10 <Subfusc> with a ":P". sounds promising
19:07:21 <thomasj_> dreams are always good :)
19:07:25 <franciscod> the main menu is to have all the tours,
19:07:27 <franciscod> right?
19:07:30 <franciscod> Subfusc: ^^ ?
19:07:51 <Subfusc> well, yeah
19:07:58 <Subfusc> it should have all the tours\
19:08:15 <thomasj_> yup
19:08:18 <Subfusc> (what do you mean by that exactly) ?
19:08:22 <franciscod> and the tours are to include tech stuff, as in "your fedora system"
19:08:50 <franciscod> and community stuff , as in "sign up to bugzilla, contribute blah blah"
19:08:54 <Subfusc> not at this point ?
19:09:20 <franciscod> Subfusc: but that is the final goal, and we will include some community stuff even in the initial release
19:09:31 <Subfusc> we have pland a tour (notice singual) for what new in your system.
19:09:52 <Subfusc> yes?
19:09:53 <franciscod> roger, then we can keep this for the future, when we begin to add more and more tours
19:10:01 <thomasj_> Yeah, but it got expanded
19:10:20 <Subfusc> thomasj_: we cant expand on something we dont have
19:10:20 <Subfusc> XD
19:10:26 <franciscod> Subfusc: thomasj_ : following the rule "release quick and frequently" :P
19:10:39 <franciscod> we start with the "whats new in your system"
19:10:47 <thomasj_> I'm fine with either, full blown, or step by step :)
19:10:47 <franciscod> and keep adding a new tour per release
19:11:04 <franciscod> that way we can get testing, and feedback with every tour
19:11:16 <franciscod> okay, so heres the idea
19:11:33 <franciscod> the "page" can just have two "buttons" side by side
19:11:44 <franciscod> aligned "center" vertically
19:11:53 <franciscod> that say "tech tours" "community tours"
19:11:58 <franciscod> or something of the sourt
19:11:59 <franciscod> sort
19:12:18 <franciscod> when you click on "tech tours", the community tour portion, say on the right, gets faded,
19:12:35 <franciscod> and the tech tours appear on that side
19:12:38 <franciscod> similiarly,
19:12:55 <franciscod> if you click on the community tours, (which is on the right),
19:12:58 <Subfusc> franciscod: that is a good idea. we should keep it for future releases
19:13:19 <franciscod> the "tech tours" portion, on the left, fades, and the community tours apper over it
19:13:29 <thomasj_> Sounds great
19:13:32 <franciscod> Subfusc: it fit ths "flashy" description :P
19:13:40 <franciscod> s/fit ths/fits the/
19:13:45 <Subfusc> yes
19:13:53 * franciscod needs #cupofcoffee :)
19:14:05 <Subfusc> my #cupofcoffie was sour :(
19:14:09 <franciscod> heh
19:14:12 <franciscod> bad milk :P
19:14:32 <franciscod> Subfusc: thomasj_ : is the idea fine?
19:14:41 <franciscod> or too far fetched to implement?
19:14:47 <Subfusc> i like the menu idea. The tabs might need diffrent names, but that we can discuss when we get there
19:14:51 <thomasj_> Sounds great
19:15:00 <franciscod> as always, i havent thought about the practical aspect yet, it was just a dream :P
19:15:19 <franciscod> #action Subfusc thomasj_ franciscod rrix hiemanshu : decide new names for tabs
19:15:20 <Subfusc> franciscod: its not that far fetched. Its a lot of code thou
19:15:20 <Subfusc> :
19:15:22 <Subfusc> :P
19:15:33 <franciscod> Subfusc: dont think we mind that, do we :P
19:15:46 <franciscod> #idea -> remember this idea for tour menu :P
19:16:20 <franciscod> Subfusc: i do realize that MenuObject.py is pending :|
19:16:31 <franciscod> do i write it with this new thing in mind?
19:16:40 <franciscod> or like we had initially planned?
19:16:54 <franciscod> thats why i sorta called the quick meet :)
19:17:06 <Subfusc> franciscod: its a minor rewrite for the backend
19:17:20 <Subfusc> so in first case, just do it like we originally intended
19:17:25 <franciscod> okay
19:17:45 <franciscod> ill do that then
19:17:49 <franciscod> thats about all that ive got
19:18:00 <Subfusc> mk
19:18:03 <franciscod> rrix: is at school so he wont make it , he had emailed me
19:18:14 <Subfusc> #topic Doc teams
19:18:35 <Subfusc> We need to contact them, have any of you heard rrix do anything about it? :/
19:18:51 <franciscod> Subfusc: the marketing team had something to do with fed-tour on agenda
19:18:51 <thomasj_> Not in #fedora-kde
19:18:59 <franciscod> but rrix is better informed,
19:19:07 <franciscod> we'll have to wait for him to tell us
19:19:13 <franciscod> as for docs team, we got nothing yet
19:19:38 <franciscod> the docs team is sorta difficult to catch hold of
19:20:13 <franciscod> ill check up the latest list of FADs etc to see if we can use on of them
19:20:30 <franciscod> i have a FAD scheduled for 29th may, but thats quite a long time away
19:20:45 <franciscod> Subfusc: thomasj_ : any ideas on doc team?
19:20:52 <Subfusc> no
19:21:13 <thomasj_> Never had anything to do with them, so sadly, no
19:21:23 <Subfusc> we need to know how they want to make the content for us
19:21:37 <franciscod> #action rrix email gitfedora-tour-commitors@fp.o regarding doc and mktg teams
19:21:48 <Subfusc> yeah
19:21:55 <franciscod> #action rrix email gitfedora-tour-members@fp.o regarding doc and mktg teams
19:22:08 <Subfusc> we are finished with that then?
19:22:14 <franciscod> yep
19:22:18 <Subfusc> we have to wait for rrix on this one?
19:22:35 <franciscod> Subfusc: yeah
19:22:40 <Subfusc> kk
19:22:49 <franciscod> #topic open floor
19:22:59 <thomasj_> I can nag him tomorrow morning in -kde ;)
19:23:03 <franciscod> any one else had any dreams ?
19:23:03 <Subfusc> we need to discuss the prores we are having
19:23:08 <franciscod> thomasj_: heh, please do that :P
19:23:15 <Subfusc> lol
19:23:17 <franciscod> prores meaning?
19:23:18 <Subfusc> progress
19:23:34 <franciscod> one thing i can say for certain : the splash is on 90% lol
19:23:43 <Subfusc> currently i cant see any commits from rrix or hiemanshu
19:23:49 <franciscod> Subfusc: we arent using gtk at all, right?
19:23:59 <Subfusc> no, not unless we have to
19:24:16 <Subfusc> minimal dependencies = good
19:24:18 <franciscod> Subfusc: then we need to figure out how to remove the title bar from clutter :)
19:24:42 <franciscod> Subfusc: the splash has title bar etc right now , heeh
19:24:43 <Subfusc> franciscod: ask the clutter dev team?
19:24:55 <franciscod> ah.. important
19:25:06 <franciscod> #action thomasj_ Subfusc rrix hiemanshu join clutter mailing list
19:25:21 <thomasj_> Another ML.. *sigh*
19:25:24 <thomasj_> ;p
19:25:34 <Subfusc> thomasj_: searchfolders are a good ting
19:25:36 <Subfusc> seriousl
19:25:37 <Subfusc> y
19:25:44 <franciscod> hhe
19:25:49 <franciscod> ive got a loooong list too
19:25:53 * franciscod goes to look for link
19:25:55 <franciscod> one sec
19:26:18 <franciscod> the email is clutter@o-hand.com
19:26:29 <thomasj_> perfect, thanks
19:26:36 <Subfusc> also, should we say that the frontend for main is up for grabs? (since there are no apparent progress from either hiemanshu or rrix) ?
19:26:36 <franciscod> the ML doesnt have a footer with link .. crap
19:26:59 <thomasj_> dont worry
19:27:10 <franciscod> Subfusc: redefine main please, its been so long since we discussed it that ive kinda forgotten :X
19:27:36 <Subfusc> main part of tour
19:27:46 <franciscod> im to write a backend which takes stuff from a conf or an xml whatever and shuffs it into the main menu
19:27:50 <franciscod> just revising :)
19:28:00 <franciscod> Subfusc: you mean the tours?
19:28:02 <Subfusc> yepp
19:28:06 <Subfusc> and yes
19:28:14 <franciscod> yep, up for grabs it is
19:28:34 <Subfusc> I think i will start on the mainwindow.
19:28:38 <thomasj_> clutter+subscribe <at> o-hand.com
19:28:45 <franciscod> #action franciscod Subfusc thomasj_ rrix hiemanshu : ask rrix hiemanshu when they plan to push regarding main :)
19:28:45 <Subfusc> thomasj_: you want to do some coding?
19:29:10 <franciscod> #link clutter+subscribe <at> o-hand.com
19:29:22 <thomasj_> Subfusc, i need some time to catch up after the hospital horror. I will then check out the ,aster branch and see what i *can* do :)
19:29:34 <thomasj_> *master
19:29:38 <Subfusc> thomasj_: sounds fine by me
19:29:39 <Subfusc> :)
19:29:43 <franciscod> Subfusc: you need to make a wiki page that defines the coding standards and style etc :P
19:29:53 <Subfusc> oh fuck, that is correct :P
19:29:56 <franciscod> #action Subfusc : you need to make a wiki page that defines the coding standards and style etc :P
19:30:11 <franciscod> anything else we had talke about?
19:30:16 <Subfusc> #action franciscod : Kick subfusc if he doesnt do it
19:30:17 <franciscod> #action franciscod post logs :)
19:30:24 <franciscod> Subfusc: gladly :P
19:30:33 <Subfusc> ;)
19:30:45 <franciscod> Subfusc: shoudl we also add the make etc to master?
19:30:54 <Subfusc> make?
19:31:04 <franciscod> by make i mean whatever we use to make the package?
19:31:11 <franciscod> i forgot what module py uses..
19:31:12 <franciscod> lol
19:31:25 <franciscod> to "build"
19:31:43 <Subfusc> like in %build for specs?
19:31:58 <franciscod> Subfusc: yeah, there's a module py uses
19:32:03 <thomasj_> I guess he means a makefile.in/makefile.am or cmake file
19:32:06 * franciscod bangs his head trying to remember
19:32:10 <franciscod> thomasj_: +1
19:32:13 <Subfusc> Setup.py?
19:32:17 <franciscod> but theres a module that py has for this !!!!!
19:32:31 <franciscod> Subfusc: maybe, ill re-find out and post
19:32:36 <franciscod> :(
19:32:43 <franciscod> wheres my brain when i need it ? :X
19:32:53 <thomasj_> It sleeps and dreams ;)
19:32:55 <Subfusc> we should include it. But its not a priority at this point :p
19:33:40 <franciscod> Subfusc: yeah, but we should keep is so it can be updated as we add new stuff,
19:33:54 <franciscod> itll become a pain in the behind when we have a lot of files etc,
19:33:57 <franciscod> IMO
19:34:16 <franciscod> this way we can add 2-3 files as we add them to the gitty
19:34:24 <thomasj_> +1
19:34:50 <franciscod> #action franciscod : RE find out what the py packaging/building shit was
19:34:57 * Subfusc doesnt quite follow
19:35:27 <franciscod> Subfusc: we have less than 10 files right now,
19:35:39 <franciscod> so we write a small "setup.py"
19:35:51 <Subfusc> so it can ?
19:36:02 <franciscod> if we dont, and we sit to write it during the first release, well have a large number of files to recall etc
19:36:13 <Subfusc> ah
19:36:17 <franciscod> Subfusc: so it can place the files in their correct locations etc etc
19:36:30 <franciscod> when someone wants to test etc etc etc
19:36:42 * franciscod is making just enough sense to get the idea across
19:36:51 <Subfusc> good point, but atleast then we have an overview of what files we have
19:36:52 <Subfusc> ;)
19:36:52 <franciscod> :)
19:37:00 <franciscod> Subfusc: yep
19:37:11 <franciscod> Subfusc: thomasj_ : anything else?
19:37:22 <franciscod> Subfusc: thomasj_ : is this time okay for you folks though?
19:37:32 <franciscod> or would you like to change it or something?
19:37:37 <thomasj_> This time is perfectly here, but i guess hard for you
19:37:40 * franciscod cant figure out a time that suits rrix
19:38:01 <thomasj_> There's no time that fits him ;p
19:38:04 <franciscod> thomasj_: i can manage.. no biggie, tomorrows a two hour class day only
19:38:15 <franciscod> thomasj_: he roams around all day on -kde :P
19:38:30 <franciscod> anyway, we done here?
19:38:40 <franciscod> nice quick productive meeting? :P :P :p
19:38:46 <Subfusc> yepp
19:38:47 <thomasj_> yep
19:38:47 <Subfusc> we are
19:38:50 <franciscod> okie
19:38:52 <franciscod> ending
19:38:55 <franciscod> #endmeeting