17:52:04 <Subfusc> #startmeeting
17:52:04 <zodbot> Meeting started Thu May  6 17:52:04 2010 UTC.  The chair is Subfusc. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:52:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:52:13 <Subfusc> #chair FranciscoD
17:52:13 <zodbot> Current chairs: FranciscoD Subfusc
17:52:31 <Subfusc> #topic whos here?
17:52:39 * Subfusc sais はい
17:52:42 <FranciscoD> .fas FranciscoD
17:52:42 <zodbot> FranciscoD: ankursinha 'Ankur Sinha' <sanjay.ankur@gmail.com>
17:52:57 <Subfusc> anyone else?
17:53:00 <Subfusc> No?
17:53:02 <FranciscoD> heh
17:53:04 <FranciscoD> nope
17:53:04 <Subfusc> kk
17:53:10 <Subfusc> #topic Agenda
17:53:26 <FranciscoD> - discussion of sources?
17:53:33 <Subfusc> This is the agenda from the mails:
17:53:34 <Subfusc> Detailed Agenda:
17:53:34 <Subfusc> 1 - What are current contributors upto?
17:53:34 <Subfusc> 2 - New people who wish to contribute in code: Query session.
17:53:35 <Subfusc> 3 - Open floor. whatever everyone has to say..
17:53:47 <FranciscoD> proceed i pray thee
17:53:58 <Subfusc> 4 - Discussion of sources?
17:54:07 <FranciscoD> yep since we're here :)
17:54:10 <Subfusc> FranciscoD: in a hurry? =P
17:54:16 <FranciscoD> nope, :P
17:54:27 <Subfusc> you seem to be inpatient XD
17:54:35 <Subfusc> im hurrying as fast as i can
17:54:42 <Subfusc> then todays agenda is set
17:54:48 <FranciscoD> heh, im just acting archaic ;)
17:54:50 <Subfusc> #topic 1 - What are current contributors upto?
17:55:02 <Subfusc> FranciscoD: What are you upto?
17:55:20 <FranciscoD> i have been assigned the task of doing the frontend of the main menu
17:55:29 <FranciscoD> im doing it without a backend right now
17:55:47 <FranciscoD> it will be integrated with the backend Objects etc once we have the sources with us
17:56:17 <Subfusc> you want sources before you do anything more on backend?
17:56:39 <FranciscoD> Subfusc: t'would be bettter
17:56:46 <Subfusc> kk
17:56:57 <FranciscoD> since the backend depends heavily on the format the sources follow
17:57:08 <Subfusc> #agreed All: Prioritize Sources for Main Menu
17:57:38 <FranciscoD> #agreed
17:57:41 <Subfusc> I myself am writing the main part of the tour frontend
17:57:46 <Subfusc> atm
17:57:59 <Subfusc> That is to say, the frame wich we put the tour in
17:58:00 <FranciscoD> i.e, the tours?
17:58:09 <FranciscoD> okay
17:58:19 <Subfusc> no, its more the Menus and bars and such for the main part
17:58:26 <Subfusc> not the rendering of the files themselfes
17:58:29 <FranciscoD> the framework basically?
17:58:33 <Subfusc> y
17:58:41 <FranciscoD> okay, makes sense :)
17:58:48 <FranciscoD> anyone else upto anything else?
17:58:48 <Subfusc> Also i am striping the sources of unnecessary jucnk
17:58:57 <Subfusc> We got A LOT of it
17:58:57 <FranciscoD> Subfusc: you've begun on that?
17:59:13 <Subfusc> i mean, the Docs foldes is essentially junk
17:59:21 <Subfusc> it should be in wiki, not in source
17:59:27 <FranciscoD> Subfusc: our docs folders, okay, heh
17:59:33 <Subfusc> that too
17:59:38 <Subfusc> i am cleaning
17:59:43 <FranciscoD> i thought you were working on the git docs already
17:59:49 <Subfusc> you should look over my branch when i have pushed next time
18:00:02 <FranciscoD> okay, ill do that
18:00:04 * FranciscoD makes notes
18:00:30 <Subfusc> no im not doing anything with git docs? I use two files in it as examples
18:00:32 <Subfusc> thats all
18:00:38 <Subfusc> we hardly need a new folder for that
18:00:38 <Subfusc> =P
18:00:43 <FranciscoD> heh, okie
18:01:01 <Subfusc> Anyone else doing anything?
18:01:07 <Subfusc> No?
18:01:10 <FranciscoD> <echo>
18:01:15 <Subfusc> Any questions on what we are doing?
18:01:17 <Subfusc> No?
18:01:22 <FranciscoD> heh
18:01:22 <Subfusc> okay then
18:01:31 <FranciscoD> proceed to the next topic i pray thee
18:01:41 <Subfusc> FranciscoD: seriously, you got any questions on what im doing? =P
18:01:58 <FranciscoD> Subfusc: nah, not currently, i might once ive seen your latest push
18:02:07 <Subfusc> #topic 2 - New people who wish to contribute in code: Query session.
18:02:15 <Subfusc> Any new people around?
18:02:23 <Subfusc> ....
18:02:25 <FranciscoD> next topic please
18:02:32 <Subfusc> What a waste
18:02:59 <Subfusc> Since it is only you and I that is going to take part 4
18:03:06 <Subfusc> we take the "open floor" now
18:03:12 <FranciscoD> Subfusc: exactly what i was going to say
18:03:16 <Subfusc> #topic 3 - Open floor. whatever everyone has to say..
18:03:22 <FranciscoD> lets discuss the sources?
18:03:32 <Subfusc> FranciscoD: got something open to share? :P
18:03:57 <Subfusc> No, k
18:04:01 <Subfusc> then we move on
18:04:06 <Subfusc> #topic 4 - Discussion of sources
18:04:14 <FranciscoD> now we can get some work done
18:04:53 <Subfusc> Okay, so since we have the basic layout for the "tour files" we need to know what we are going to use for main menu and what we are going to use for the "slideshow" part
18:05:00 <Subfusc> Also where do we get it
18:05:19 <Subfusc> should we just go ahead and say everything should be XML?
18:05:27 <FranciscoD> docbook xml?
18:05:30 <FranciscoD> or whatever it is?
18:05:32 <FranciscoD> http://git.fedorahosted.org/git/?p=docs/about-fedora.git;a=summary
18:05:42 <FranciscoD> chec that, you know more about xml etc than i do
18:05:56 <Subfusc> Not necessarily Docbook
18:06:10 <Subfusc> but we can probably make a docbook parser for the "slideshow" part
18:06:29 <FranciscoD> Subfusc: i really want to use the available sources as much as possible
18:06:31 <Subfusc> I just meant for main menu, tour package and content the general rule is that its XML
18:06:40 <FranciscoD> okay,
18:06:48 <FranciscoD> #agreed on that
18:07:01 <Subfusc> #agreed XML for sources
18:07:47 <FranciscoD> ill make up an xml and build the main menu frontend on that then?
18:07:53 <FranciscoD> i could do the backend too this way
18:08:13 <Subfusc> yes, you just baisicly need something like
18:08:44 <Subfusc> <Tour menu> <Name> </Name> <description> </description> <icon> </icon> </Tour menu?
18:08:47 <Subfusc> >
18:08:49 <Subfusc> or something
18:09:06 <FranciscoD> yaeh, i can manage tis part, hopefully ;)
18:09:47 <Subfusc> Then we can make an example "package" without content?
18:10:11 <Subfusc> then we try and pull out a DocBook page (eg fedoras whats new) and try and parse it?
18:10:22 <FranciscoD> yep
18:10:24 <Subfusc> in a way that makes sense to us
18:10:45 <Subfusc> Sounds like a good way to go?
18:10:55 <FranciscoD> yeah, make a sorta complete demo
18:11:02 <Subfusc> mm
18:11:12 <Subfusc> #agreed Make sample package
18:11:28 <Subfusc> #agreed After made sample package, try and parse a Doocbook XML file
18:11:48 <Subfusc> You got things to work on then?
18:11:56 <FranciscoD> yeah, plenty now =)
18:12:13 <FranciscoD> Subfusc: btw, im not going to take a starters session at the planened FAD later this month
18:12:14 <Subfusc> Any questions on the end?
18:12:33 <Subfusc> Whats a "starters session" ?
18:12:39 <FranciscoD> we had made it very clear that the FAD is for people to get work done, and not for them to get started on the project
18:12:59 <Subfusc> oh
18:13:03 <FranciscoD> Subfusc: a session to get folks up to date with what we've done, and maybe a short tut on the stuff.
18:13:09 <Subfusc> that indian FAD with Hiemanshu talking about Tour?
18:13:10 <Subfusc> :P
18:13:14 <FranciscoD> we've wasted enough time on that IMP
18:13:21 <FranciscoD> Subfusc: yeah, thats the one
18:13:31 <FranciscoD> fedora is sponsoring folks to the FAD
18:13:38 <FranciscoD> so i really want to get work done,
18:13:49 <FranciscoD> not get people started (again)
18:13:53 <Subfusc> Yeah, i agree. Lets just do the grunt work ourself. By the time we have used on talking, we could have made the program ourselfe
18:14:19 <FranciscoD> Subfusc: seriously, anyway we're doing well enough by ourselves :)
18:14:48 <Subfusc> okie dokie. Anything else?
18:15:13 <FranciscoD> Subfusc: nah, nothing constructive
18:15:28 <FranciscoD> ill have the main menu, backend + frontend + the xml done by the FAD
18:15:37 <Subfusc> goodie
18:15:40 <FranciscoD> that good enough? taking end sems into account ;) ?
18:15:52 <Subfusc> i look forward to reviewing your work
18:16:03 <Subfusc> y
18:16:05 <FranciscoD> Subfusc: same thing, follow th epydoc thing?
18:16:06 <Subfusc> more than enough
18:16:12 <Subfusc> always
18:16:13 <Subfusc> =)
18:16:17 * FranciscoD notes
18:16:21 <Subfusc> #endmeeting