12:01:06 <FranciscoD> #startmeeting Fedora-tour planning meet
12:01:06 <zodbot> Meeting started Sun Jan 22 12:01:06 2012 UTC.  The chair is FranciscoD. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:18 <FranciscoD> #chair Subfusc praveenkumar_ underscores kishan
12:01:18 <zodbot> Current chairs: FranciscoD Subfusc kishan praveenkumar_ underscores
12:01:25 <FranciscoD> anyone else? :P
12:01:44 <kishan> I guess not :P
12:01:47 <Subfusc> I wonder if zodbot could be its own chair and create an eternal loop
12:01:53 <underscores> O_O
12:01:59 <FranciscoD> lol
12:02:02 <FranciscoD> probably could
12:02:05 <FranciscoD> XD
12:02:11 <FranciscoD> but lets not try it ;)
12:02:13 <FranciscoD> anyway..
12:02:15 <Subfusc> No :P
12:02:22 <FranciscoD> We are gathered here today...
12:02:40 <FranciscoD> to discuss the rebirth of fedora tour
12:02:51 <FranciscoD> from *scratch*
12:02:57 <Subfusc> yeah
12:03:00 <underscores> Amen
12:03:00 <FranciscoD> #action FranciscoD clear git repo
12:03:24 <FranciscoD> #action underscores kishan praveenkumar_ apply for git commit in FAS
12:03:32 <FranciscoD> #action underscores kishan praveenkumar_ join mailing list
12:03:34 <FranciscoD> etc etc
12:03:39 <FranciscoD> so, ideas?
12:03:47 <Subfusc> So we need to decide what technology we want to use for that
12:03:47 <FranciscoD> Subfusc and me were thinking it web based
12:03:49 <FranciscoD> comments?
12:04:02 * FranciscoD lets Subfusc take over
12:04:14 <kishan> web-based as in start.fedoraproject.org ?
12:04:15 <Subfusc> No
12:04:17 <Subfusc> :P
12:04:46 <FranciscoD> html + javascript + css?
12:04:54 <Subfusc> kishan: no, as in based on web-technologies like html and javascript
12:05:27 <kishan> Subfusc: that would make it an online-thing, isn't it ?
12:05:44 <Subfusc> Not necessarily.
12:05:55 <FranciscoD> we can package it up as an rpm
12:06:03 <FranciscoD> and access it locally
12:06:07 <Subfusc> The whole gnome 3 UI is based on XML + JAVASCRIPT + CSS
12:06:12 <Subfusc> you wouldnt call that online?
12:06:13 <FranciscoD> we can also place it on a server for folks to look at over the interweb
12:06:14 <Subfusc> :P
12:06:16 <FranciscoD> aye
12:06:36 <kishan> hmm yes, then okay
12:06:37 <kishan> an online version would also be great to have though!
12:06:58 <Subfusc> Offcourse, and doing it in html would make the online version easy
12:07:21 <praveenkumar_> then it's works both way online and offline ..
12:07:27 <kishan> right! :)
12:07:57 <FranciscoD> hrm, so looks like web based tech it is
12:07:58 <Subfusc> So I was thinking along the line of really just making the application in a Webkit environment
12:08:03 <FranciscoD> what web based techs do we know?
12:08:14 <Subfusc> so we could just display a webkit window for the offline version
12:08:27 <FranciscoD> Subfusc: sounds good, got a link to a webkit demo?
12:09:24 <FranciscoD> http://www.webkit.org/demos/
12:09:51 * praveenkumar_ clicks
12:10:06 <Subfusc> FranciscoD: we would probably be working with this thou: http://trac.webkit.org/browser/trunk/Tools/GtkLauncher
12:10:16 <Subfusc> its the webkitgtk
12:10:48 <FranciscoD> clicky
12:11:05 <Subfusc> I don't know if they have a gtk3 version yet, TBH i was looking more on the qtwebkit package XD
12:11:24 <FranciscoD> doesnt exist? :P
12:12:01 <Subfusc> what doesnt exist?
12:12:21 <FranciscoD> nothing nothing
12:12:24 <FranciscoD> demos?
12:12:33 <FranciscoD> for them both?
12:12:45 <Subfusc> the GTK one has a demo on the link i sent
12:12:53 <Subfusc> its the basic launch webkit from gtk
12:13:07 <FranciscoD> this also means we'll have to break it up into a backend, and frontends?
12:13:51 <FranciscoD> since javascript is object oriented, i dont think that will be an issue?
12:14:01 <Subfusc> If we want to make it easily accessible for online usage, we would probably benefit from making a "webserver" sort of backend
12:14:03 <Subfusc> yes
12:14:47 <Subfusc> My first thought was to just pipe it through a local port to the local application
12:15:00 <Subfusc> that way we could just change port and we had a webserver
12:15:19 <Subfusc> Any ideas from you guys?
12:15:44 * FranciscoD wishes we had a web dev geek around
12:16:05 <kishan> err.. nothing much from my end :/
12:16:49 <Subfusc> FranciscoD: I don't think we would benefit from that :P
12:16:57 <Subfusc> This is the backend technology
12:18:12 <FranciscoD> Subfusc: well, anyone who has some experience in this stuff would have some insights we could use
12:18:20 <Subfusc> The real question is, do we want to extend the webkit package to do what we want, or do we want to make it fully web-realizable
12:18:21 <FranciscoD> i got no exp
12:18:58 <Subfusc> in the latter case we would probably have to conform to the web way of doing things
12:19:01 <praveenkumar> http://www.webkit.org/demos/transitions-and-transforms/  can make something like that (each tab have some information) just idea :)
12:19:16 * FranciscoD is thinking
12:19:30 <Subfusc> meaning server-technolgy -> client technolgy -> visualisation
12:20:09 <FranciscoD> Subfusc: what's simpler?
12:20:21 <Subfusc> If not we would probably have to write some sort of batch compiling program for the javascript and css to embed everything into static HTML
12:21:06 <kishan> hmm
12:21:13 <Subfusc> the batch compiling approach is probably the easiest one
12:21:24 <FranciscoD> lets start with that then
12:21:31 <Subfusc> its also the fastest one for web-serving, since the webserver only have to serve static files
12:21:33 <praveenkumar> right
12:21:50 <Subfusc> and the local webkit ONLY has to read static HTML
12:22:02 <Subfusc> so we don't need an extra backend
12:22:09 <FranciscoD> yeah, sounds okay
12:22:36 <kishan> okay then :)
12:22:58 <FranciscoD> hrm, I wish I had done something with webkit before, wouldnt be this blank
12:23:19 <Subfusc> But that means we have to conform to some layouts and probably package config files for the compiler program to understand what to use where
12:23:20 <FranciscoD> Subfusc: I'm relying on your judgement here :)
12:23:52 <Subfusc> FranciscoD: Bah, I wanted input here. :P
12:24:03 <Subfusc> I don't want to dictate everything XD
12:24:23 <FranciscoD> Subfusc: underscores : praveenkumar : kishan : how about all of us first play around with all possible methods and then go over this
12:24:44 <FranciscoD> that way everyone will know *something* about the technologies
12:24:57 <FranciscoD> right now Subfusc appears to be the only one who knows what he's talking about
12:24:57 <Subfusc> If nothing else, we can meet again in a week or two where all of you can try and break down my method in why not use it and what technology could be better
12:25:00 * FranciscoD sure dont
12:25:09 <kishan> yes, that would be better.
12:25:23 <FranciscoD> so, there are 4 of us
12:25:26 <Subfusc> Then I can make a demo of what i mean.
12:25:38 <praveenkumar> yes right, it would be great
12:25:39 <Subfusc> So you all will get a better understanding of what I'm talking about
12:25:41 <FranciscoD> Subfusc: you can take up webkit since you look like you've already worked on it
12:25:47 <FranciscoD> yeah
12:25:56 <FranciscoD> what other techs do we want considered?
12:26:11 <Subfusc> Well if i take the batch approach
12:26:16 <underscores> batch aproach?
12:26:21 <underscores> what would that mean
12:26:36 <FranciscoD> XD
12:26:46 <Subfusc> atleast one would have to concider the server approach (using server technologies like django, tomcat or my favourite pylons
12:26:48 <FranciscoD> youll know in a weeks time when Subfusc gives you a demo :P
12:27:13 <FranciscoD> praveenkumar: kishan : used django before?
12:27:13 <Subfusc> for the backend
12:27:19 <FranciscoD> I've used it a little
12:27:27 <kishan> nope
12:27:28 <praveenkumar> FranciscoD: used a little bit
12:27:28 <FranciscoD> I can look into django
12:27:36 <underscores> Subfusc: dont foget cherrypy :)
12:27:39 <underscores> forget
12:27:39 <FranciscoD> Subfusc: python-django I'm guessing?
12:27:57 <Subfusc> FranciscoD: yes, python-django. Is there anything else? ;)
12:28:09 <underscores> Subfusc: Cherrypy is an HTML framework for python ;-)
12:28:11 <Subfusc> Django: python, tomcat: java, pylos: python
12:28:16 <FranciscoD> I don't know
12:28:19 <FranciscoD> XD
12:28:22 <Subfusc> underscores: never used it :)
12:28:27 <underscores> oh :'(
12:28:37 <underscores> never had a project where I would have needed it :(
12:28:38 <FranciscoD> underscores: how about you take up Cherrypy then
12:28:40 <FranciscoD> ?
12:28:46 <FranciscoD> doesnt matter
12:28:51 <underscores> erm I think I only know a little bit about it :(
12:29:00 <FranciscoD> most of us are starting them from scratch
12:29:03 <underscores> I would have to read into that first to explain what it actually is
12:29:09 <FranciscoD> just play with it, make a tiny demo
12:29:15 <FranciscoD> ?
12:29:21 <underscores> I'm short of time atm
12:29:26 <Subfusc> I don't think we would need the server approach in more than one technology. Server technology is pretty much all the same
12:29:44 <FranciscoD> okay, if that's the case, I can look into django
12:30:00 <FranciscoD> my flatmate used it, so I have someone to kinda guide me
12:30:37 <Subfusc> The other technologies would be the more standard approaches
12:30:54 <Subfusc> using gtk3 (with and without drawing area)
12:30:57 <FranciscoD> Subfusc: list them for the logs please?
12:31:05 <Subfusc> and reconsidering clutter (?)
12:31:20 <FranciscoD> but clutter aint got py bindings
12:31:25 <FranciscoD> itll have to be C, objective C etc
12:31:34 <FranciscoD> so I think we should drop it at this point
12:31:53 <Subfusc> Yeah, in the clutter case, we would have to get hardcore, which is a big nono at this point. But it should be looked into for the sake of argument
12:32:13 <Subfusc> How many in here knows C/C++ ?
12:32:20 <FranciscoD> Subfusc: I can try looking into clutter..
12:32:29 <FranciscoD> they have a cook book I can rip off from ;)
12:32:42 <kishan> I do, but haven't used them for years now ..
12:32:46 <underscores> me does
12:32:53 <Subfusc> FranciscoD: Your doing the server thing :P
12:33:04 <FranciscoD> lol okay
12:33:15 <Subfusc> I don't want more than one task per person
12:33:15 <FranciscoD> #action Subfusc look at batch approach (whatever that is)
12:33:21 <Subfusc> its to much work for 1-2 weeks
12:33:22 <kishan> lol
12:33:23 <FranciscoD> #action FranciscoD look into django thing
12:34:15 <Subfusc> FranciscoD: Batch means running one program then the next
12:34:19 <Subfusc> in sequence
12:34:28 <Subfusc> rather than running them simultainiously
12:34:33 <FranciscoD> Subfusc: yeah, I know, batch scripting on windows..
12:34:47 <FranciscoD> by (whatever  that is) i meant the other portions :P
12:34:54 <Subfusc> So I would have to write programs that outputs the results to the next
12:35:09 <FranciscoD> so, piping, kinda?
12:35:10 <Subfusc> in this case i would have to process templates and html to make the complete result
12:35:28 <Subfusc> Piping is a way to batch, in this case I would probably not use pipes
12:35:30 <FranciscoD> doesnt sound that simple any more :P
12:35:40 <FranciscoD> but I'll decide after your demo
12:35:47 <FranciscoD> kishan: would you have free cycles to look into clutter?
12:36:02 <kishan> okay. will do
12:36:34 <Subfusc> Who will take the standard approach?
12:36:36 <FranciscoD> #action kishan look into clutter, make small demo
12:36:40 <Subfusc> gtk3+
12:36:42 <FranciscoD> praveenkumar XD
12:36:54 <FranciscoD> if his network is still alive
12:37:02 <kishan> :D
12:37:13 <Subfusc> GTK3+ has good python bindings, right?
12:37:34 <FranciscoD> yeah, I expect so
12:37:54 <praveenkumar> I never used gtk3+ but will take a look.
12:37:55 <underscores> you can create UIs with glade
12:38:02 <underscores> it will create an xml file ;-)
12:38:12 <kishan> I've done UI with glade! =)
12:38:15 <underscores> that can be accessed via self written python functions :)
12:38:34 <kishan> yep. exactly
12:38:35 <Subfusc> underscores: You just signed up for GTK3
12:38:37 <Subfusc> :)
12:38:43 <kishan> haha :P
12:38:43 <underscores> omfg ._.
12:38:52 <praveenkumar> I used Qt if any useful
12:39:05 <underscores> ok I will try to read into that ._.
12:39:10 <FranciscoD> XD
12:39:10 <Subfusc> praveenkumar: I would love for you to look into Qt, but FranciscoD would kill me
12:39:12 <Subfusc> :P
12:39:20 <FranciscoD> http://blogs.gnome.org/uraeus/2011/10/04/tutorial-for-python-gstreamer-and-gtk-3/
12:39:25 <FranciscoD> http://www.pygtk.org/
12:39:28 <FranciscoD> nah, go ahead
12:39:36 <Subfusc> Na, we cant make QT
12:39:36 <underscores> afaik you can easily create a "webinterface" that can display HTML and stuff with gtk-webkit ._.
12:39:38 <FranciscoD> at some point, we might need different front ends
12:39:57 <Subfusc> because fedora wont bundle qt with standard fedora
12:40:09 <FranciscoD> Subfusc: but for  the KDE spin? :P
12:40:09 <Subfusc> So we have to base it on gtk if we are going to do something like that
12:40:19 <Subfusc> FranciscoD: that would have to come later
12:40:28 <Subfusc> hopefully we will use something we can use everywhere
12:40:35 <Subfusc> like HTML or clutter
12:40:39 <underscores> indeed
12:40:43 <FranciscoD> #idea think about different spins including fedora-tour later
12:40:52 <FranciscoD> so what should praveenkumar look into then?
12:41:01 <FranciscoD> surely we can't let him leave empty handed ;)
12:41:10 <underscores> could :)
12:41:17 <underscores> but we should not :)
12:41:19 <praveenkumar> :)
12:41:28 <Subfusc> If he wants to be hardcore, he could look at cairo or something
12:41:43 <Subfusc> does GTK still use that?
12:41:49 <underscores> I dont know
12:41:53 <FranciscoD> praveenkumar: how many free cycles have you got?
12:42:17 <Subfusc> They have python bindings
12:42:23 <FranciscoD> if you have enough, you can look through any techs that we arent doing, and pick one on your own?
12:42:33 <praveenkumar> FranciscoD: you mean per day time or weekly?
12:42:34 <Subfusc> so it would not have to be that hardcore, but still cairo is nasty buisness
12:44:24 <FranciscoD> okay, lets look into cairo then
12:44:37 <FranciscoD> praveenkumar: can you manage that? play around with cairo, make a tiny demo?
12:44:42 <kishan> praveenkumar:  daily or weekly doesn't matter :P  you just need to get your stuff ready before the next meeting :P
12:44:52 <Subfusc> praveenkumar, kishan, underscores: when you are looking into these more "traditional technologies" think more about how easy it would be doing <thing>, not necessarily can they be done
12:45:01 <praveenkumar> I will try.
12:45:23 <Subfusc> FranciscoD: do you agree with above statement?
12:45:28 <FranciscoD> praveenkumar: great them
12:45:30 <FranciscoD> Subfusc: yeah
12:45:35 <underscores> Subfusc: ok so we should focus on the specific task instead of learning the whole thing
12:45:46 <FranciscoD> because, everything can be done in most techs, we're looking for the simplest approach
12:45:52 <Subfusc> underscores: yes
12:45:55 <underscores> oki
12:46:04 <FranciscoD> Subfusc: elaborate on that as much as possibe
12:46:13 <FranciscoD> what tasks etc
12:46:26 <FranciscoD> we can refer the logs later when we get down to implement etc
12:46:38 <Subfusc> Well, we havent made (new) mockups, so the task is sort just ideas at the moment
12:47:03 <Subfusc> but the idea is to present information to the user in a format that would be easy to navigate
12:47:26 <FranciscoD> #idea present information to the user in a format that would be easy to navigate
12:47:34 <FranciscoD> any more specifics Subfusc ?
12:47:48 <Subfusc> and in an environment which important things can be highlighted for easier reading
12:48:18 <FranciscoD> and where the information can be changed without a fight
12:48:28 <FranciscoD> since we will need to update the info every release
12:48:35 <Subfusc> yes
12:48:36 * FranciscoD looks at Subfusc
12:48:53 <FranciscoD> #idea an environment which important things can be highlighted for easier reading
12:49:03 <Subfusc> we would have to be able to make this in a format wich $RANDOM_JOE can contribute in some form
12:49:08 <FranciscoD> #idea where the information can be changed without a fight
12:49:45 <FranciscoD> hrm, i think the assignments are kinda clearer now
12:50:01 <FranciscoD> Subfusc: underscores praveenkumar kishan : next meeting in 2 weeks?
12:50:06 <FranciscoD> that should be sufficient time to play/learn/demo?
12:50:14 <Subfusc> Yes
12:50:17 <FranciscoD> Feb 5th?
12:50:23 <underscores> erm I have exams in 2 weeks
12:50:23 <Subfusc> Thats okay with me
12:50:25 <kishan> yes..
12:50:31 <praveenkumar> fine
12:50:38 <FranciscoD> underscores: lol take your time :)
12:50:38 <underscores> but ok
12:50:43 <underscores> I will try to be around :)
12:50:47 <underscores> and get something done
12:50:49 <FranciscoD> it isnt really an assignment :P
12:51:02 <underscores> besides knitting and crochet I will find some time at the evening ;-)
12:51:05 <FranciscoD> underscores: you can also just drop a mail to the ML, if irc is difficult to get to
12:51:09 <Subfusc> I say we have a presentation in 2 weeks and decide in 3 weeks
12:51:12 <FranciscoD> XD
12:51:28 <FranciscoD> #idea we have a presentation in 2 weeks and decide in 3 weeks
12:51:32 <FranciscoD> done then
12:52:18 <FranciscoD> anything else?
12:52:21 <Subfusc> Anyone have any qestions?
12:52:42 <FranciscoD> not me
12:52:54 <FranciscoD> https://fedorahosted.org/mailman/listinfo/fedora-tour
12:53:02 <FranciscoD> *our* mailing list
12:53:16 <FranciscoD> Subfusc: do I need to archive the stuff in the repo?
12:53:23 <FranciscoD> and keep it someplace?
12:53:31 <FranciscoD> or do I just delete it?
12:53:46 <Subfusc> FranciscoD: we can pull it and keep it if we want
12:53:52 <Subfusc> not necessary to keed online version
12:54:01 <FranciscoD> okay
12:54:07 <FranciscoD> I'll let it be for the time being
12:54:16 <FranciscoD> once we begin development, I'll clean up the repo
12:54:20 <Subfusc> yeah
12:54:23 <Subfusc> sounds good
12:54:27 <FranciscoD> should we halt then?
12:54:35 <FranciscoD> closing meeting in
12:54:37 <FranciscoD> 5
12:54:37 <FranciscoD> 4
12:54:40 <FranciscoD> 3
12:54:44 <FranciscoD> 2
12:54:46 <Subfusc> 1
12:54:47 <FranciscoD> 1
12:54:55 <FranciscoD> #endmeeting