17:00:07 <stoney> #startmeeting POSSE IRC Meeting 1.2
17:00:07 <zodbot> Meeting started Tue Mar 14 17:00:07 2017 UTC.  The chair is stoney. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:07 <zodbot> The meeting name has been set to 'posse_irc_meeting_1.2'
17:00:22 <stoney> #link The agenda for this meeting is here: http://foss2serve.org/index.php/IRC_Meeting_1
17:00:42 <heidie> Welcome folks!
17:00:42 <stoney> #chair heidie kussmaul
17:00:42 <zodbot> Current chairs: heidie kussmaul stoney
17:00:50 <stoney> Hi all!
17:01:01 <rhoyle> Hello
17:01:09 <howardf> Hi
17:01:11 <Clare> hi
17:01:12 * Baxter wave hello
17:01:12 <tacksoo> hello
17:01:18 <stoney> #topic Introductions
17:01:24 <OSIMasson> :-D
17:01:29 <stoney> Let's start with introductions
17:01:32 <heidie> Great! An interactive group!
17:01:49 <heidie> Just a reminder that the agenda is here:
17:01:52 <heidie> #link http://foss2serve.org/index.php/IRC_Meeting_1
17:02:05 <heidie> I'll go first.
17:02:06 <stoney> I'll model
17:02:15 <stoney> ok heidie will model :)
17:02:31 <heidie> I'm Heidi Ellis from Western New England University. I'm a prof and I've been involving students in HFOSS since 2006.
17:02:49 <stoney> as a cute exercise let's have everyone go in alpha order by nickname
17:02:55 <heidie> Baxter?
17:02:57 <stoney> so Baxter you're first :)
17:03:24 <Baxter> Hello I am Garrett Poppe from California State University, Dominguez hills and I am very interested in FOSS.
17:03:32 * howardf is chatting from my phone and can't see the nickname list
17:03:53 <stoney> I'll let you know when to go howardf
17:03:56 <stoney> camm
17:03:57 <Clare> I'm Clare Tang from Governors State Univ (Chicago). HFOSS is completely new to me. Love to learn so far.
17:04:16 * stoney thinks camm is lurking
17:04:23 * stoney thinks that is fine
17:04:28 <stoney> Thanks Clare
17:04:41 <stoney> heidie already went so howardf your'e up
17:04:43 <Baxter> |_|}
17:04:59 <heidie> Camm is a former POSSE attendee and also someone who has been very successful in involving students in HFOSS.
17:06:03 <howardf> Hi I'm Howard Francis from the university of pikeville in Kentucky. I'm a past POSSE participant trying to keep connected with the group
17:06:11 <stoney> I think kussmaul is lurking too; he is one of the POSSE team members
17:06:15 <kussmaul> I'm Clif Kussmaul, at Muhlenberg College, Allentown, PA, and one of the POSSE organizers. I've used, contributed to, and consulted with several FOSS wikis, content management systems, etc. I've had some students contribute to FOSS too. I'm also very involved in POGIL (Process Oriented Guided Inquiry Learning) - more about that later... Done.
17:06:18 <stoney> lol
17:06:28 <stoney> He's an attentive lurker! :)
17:06:38 <stoney> lintqueen_gina are you there?
17:06:51 <lintqueen_gina> hi
17:07:11 <stoney> Awesome... quick intro of yourself? Or are you lurking this meeting?
17:07:14 <lintqueen_gina> yes - mostly lurking (walking into another meeting in 8)
17:07:18 * lintqueen_gina is swamped
17:07:18 <stoney> np
17:07:33 <stoney> lintqueen_gina is from RedHat and a great source of info
17:07:42 <stoney> OSIMasson you're up
17:07:44 <OSIMasson> Hi, Patrick Masson, GM at Open Source Initiative, Instructor teaching "Open Source Principles & Practices" at UAlbany, and former CIO at State Univ. of New York, & CTO UMASS System Office.
17:07:57 <stoney> quaid your turn
17:08:28 <quaid> I'm Karsten Wade, I do open source stuff at Red Hat on the same overall team as Tom Callaway (spot), have been involved on/off with POSSE & TOS since the start; based in Santa Cruz, CA, and hoping to be an ongoing resource for folks out here in the West.
17:08:38 <quaid> (and also same team as lintqueen_gina )
17:08:47 <stoney> cool!
17:08:52 <stoney> rhoyle you're up
17:08:53 <rhoyle> Hello everyone.  I’m Roberto Hoyle, I am a new prof at Oberlin College.  I was a very heavy OSS user, and a bit of a contributor, in the early 2000’s, and am looking to get back into it.
17:09:00 <stoney> awesome
17:09:06 <stoney> rpike your turn
17:09:07 <rpike> I'm Ron Pike from Cal Poly Pomona, I was on the session last night but am tuning in here to learn so I'll be lurking on the session.  I am interested in hfoss and potential projects in the network infrastructure space given the emergence of software defined networks and the ability for anyone to contribute software to change networks in any way we choose.
17:09:11 <stoney> you all are good!
17:09:33 <stoney> spot, u on? Or will be lurking today?
17:09:46 <lintqueen_gina> spot is on the road
17:09:52 <stoney> awesome, thanks!
17:09:56 <stoney> see full of good info
17:10:02 <stoney> #info Hi, I'm Stoney Jackson. I'm a professor at WNE. I'm currently teach a course of software development. I'm part of the POSSE team.
17:10:12 <stoney> tacksoo you're up
17:10:29 <tacksoo> hi, my name is tacksoo im and i am a prof at geogia gwinnett college, i’m new to hfoss and interested to learn more
17:10:39 <stoney> ykk you're up
17:10:40 <ykk> Hi all! I’m Kate (Kharitonova). I am currently a visiting assistant professor at Harvey Mudd College. This is my first time being involved with HFOSS.
17:10:41 <ykk> I think that involving students from my Software Development course into HFOSS projects would be one of the best ways to learn about it myself.
17:10:47 <stoney> right on!
17:10:57 <stoney> and zodbot is our meetbot... not a real person
17:11:07 <stoney> it responds to commands and records our meetings
17:11:17 <stoney> Welcome all!
17:11:26 <stoney> It's good to meet all of your.
17:11:29 <stoney> you*
17:11:40 <stoney> So following the agenda...
17:11:50 <stoney> #topic iscussion of IRC basic features
17:11:51 <heidie> This is one of the fun parts of POSSE. Getting to know folks virtually before we meet face-to-face.
17:12:04 <stoney> and playing with IRC
17:12:09 * stoney is a tool junkie
17:12:32 <stoney> So everyone knows how to chat
17:12:44 * heidie agrees with Stone!
17:12:47 <heidie> stoney,
17:12:53 <Baxter> :)
17:13:13 <stoney> if you include someone's nick in the message, it will "ping" thme
17:13:17 <stoney> them*
17:13:30 <stoney> pinging depends on the client
17:13:37 <stoney> it might flash or make a noise
17:13:51 <stoney> but it usually gets the other person's attention
17:13:56 <matt___> Hi all.
17:14:01 <stoney> hi matt___
17:14:12 <stoney> quick intro? Name, school, etc.
17:14:47 <stoney> If you start a message with / you are giving a command to IRC
17:15:16 <stoney> so if you want to emote and action... /me is now emoting ... If I put that on the next line...
17:15:21 * stoney is now emoting
17:15:31 <matt___> Hi, I am Matt Bernius. I am an independent researcher doing work with Mozilla around increasing open source student engagement. I have a link with RIT as well.
17:15:41 * Baxter is also emoting
17:15:46 <stoney> awesome matt___ , thanks for joining us
17:15:53 * rhoyle has finally slept after SIGCSE
17:15:57 * Baxter cheers for matt
17:16:03 <quaid> hi matt___ are you doing work with Don Marti at all?
17:16:03 * stoney laughing at rhoyle
17:16:05 <matt___> It's a pleasure to get involved with posse.
17:16:19 <stoney> you can get help with /help
17:16:26 <matt___> No. I don't know Don (yet).
17:16:29 <quaid> note that
17:16:32 <stoney> you can change your nickname with /nick
17:16:37 <quaid> "help" results sometimes appear in a different window
17:16:38 * howardf_ is on a train returning from SIGCSE and is about to cross the Mississippi River
17:16:54 * heidie thinks that it will take her a week to get back into the right sleep schedule.
17:17:11 <matt___> I have been working with Lucy Harris and Christ's Bacaracis.
17:17:19 * rhoyle thinks that SIGCSE should not combine with daylight savings time
17:17:27 <stoney> you can also use /away and /back to let folks know you've stepped away from your keyboard
17:17:45 <stoney_> notice that it adds an _ after your nick
17:17:55 <stoney_> some like to add _afk to the end
17:18:04 <stoney_> hm...
17:18:06 * matt___ is dusting off his irc skillz *cough* *cough*
17:18:07 <stoney_> back didn't work
17:18:15 <heidie> Sometimes when people have been away from their keyboard, their nick becomes grayed out.
17:18:18 <stoney_> if not... just /nick back to your original name
17:18:19 <heidie> As in kbrown here.
17:18:39 <stoney> true true
17:18:41 <TheBaxter> 8)
17:18:58 <quaid> it can take time for the IRC server to sync back your ghost presences across the network
17:19:03 <stoney> some commands are intercepted by your client and some go through to the server
17:19:27 <stoney> you don't usually need to know which does which (thank goodness)
17:19:34 <stoney> quaid good to know
17:19:52 <stoney> #link more commands are here  http://www.ircbeginner.com/ircinfo/ircc-commands.html
17:20:12 <cxq> just found out need >= 3 letters for nick
17:20:28 <stoney> that's interesting :)
17:20:42 <stoney> what questions about IRC do folks have?
17:21:07 <stoney> feel free to play as we go! :)
17:21:14 <ykk> Is there a way to see the messages that have been exchanged before one joined the chat?
17:21:29 <stoney> ykk great question
17:21:32 <stoney> not out of the box
17:21:43 <OSIMasson> ykk: you might want to set up an IRC Bouner...
17:21:44 * TheBaxter :-)
17:21:50 <stoney> but you can put a bot on a channel to watch all the conversations for you
17:21:54 <OSIMasson> "bouncer"
17:21:58 <stoney> that's what kbrown is doing
17:22:07 <quaid> zodbot is a logging bot (that does other things for the Fedora Project), it starts logging when you do #startmeeting (and stops at #endmeeting) when done at the start of a line; you can see a full list of commands/use at https://wiki.debian.org/MeetBot
17:22:20 <stoney> right
17:22:28 <stoney> that's why we use zodbot for meetings
17:22:36 <cxq> the browser version seems working great . why installed colloquy?
17:22:45 <OSIMasson> ykk: ZNC http://wiki.znc.in/ZNC
17:22:45 <stoney> we'll talk about the meetbot momentarily
17:22:51 * ykk looks up "irc bot channel watch" and "irc bouncer"
17:23:02 <howardf_> How can I get zodbot in a channel I use for my class?
17:23:20 <stoney> great question howardf_
17:23:20 <heidie> I have hexchat installed because I wanted to have a client that wasn't attached to a browser.
17:23:26 <stoney> I'm not an expert in that
17:23:37 <stoney> but basically you have to have zodbot installed on some server
17:23:41 <heidie> So that I could open it independently and so that I didn't lose it when Firefox died on me.
17:23:42 <stoney> and have it join the channel
17:24:02 <stoney> there are probably some other configurations about where to send the results of the meeting
17:24:08 <OSIMasson> howardf_: again, you might want to check out ZNC http://wiki.znc.in/ZNC
17:24:14 <stoney> heidie who might howardf_ talk to?
17:24:20 <stoney> awesom OSIMasson !
17:24:24 <stoney> thanks!
17:24:31 <heidie> ^
17:24:34 <stoney> That's why groups rock!
17:24:41 <OSIMasson> howardf_: I use it and is very easy to set up manage
17:24:52 <howardf_> Thanks!
17:25:07 <stoney> cool
17:25:14 <stoney> let's talk about the meetbot a bit more
17:25:17 <stoney> #topic meetbot
17:25:37 <stoney> commands to the meetbot are prefixed with # (instead of /)
17:25:50 <stoney> Some commands only a chair can do
17:25:54 <stoney> some all can do
17:26:10 <stoney> like #link, #info, #action
17:26:16 <tsi> #info
17:26:30 <stoney> these raise a statement to the abreviated minutes
17:26:42 <stoney> for example
17:26:42 <quaid> #info the log from the meeting yesterday can be viewed at https://meetbot.fedoraproject.org/foss2serve/2017-03-14/irc_meeting_1.2017-03-14-00.00.html
17:26:50 <stoney> #info this will be raised to the short minutes
17:27:10 <TheBaxter> #link Check out this search engine www.google.com (test)
17:27:15 <stoney> perfect timing quaid !
17:27:36 <stoney> right... that's the idea TheBaxter
17:27:59 <stoney> that way folks don't have to read the full transcript to find the important stuff
17:28:23 <stoney> #link here is a more complete list of meetbot commands http://meetbot.debian.net/Manual.html
17:28:25 <rhoyle> Is there a live way to see what meetbot has collected?
17:28:35 <stoney> hm... I don't know
17:28:39 <stoney> anyone else?
17:28:43 <stoney> #help
17:28:43 * rhoyle keeps thinking “meatbot”.
17:28:52 <ykk> #action check out ZNC (IRC bouncer) http://wiki.znc.in/ZNC
17:29:01 <stoney> rhoyle that one helps you with lunch :)
17:29:14 <ykk> Can you nest commands?
17:29:16 <rhoyle> Bad timing for the meeting!
17:29:24 <ykk> #action #link check out ZNC (IRC bouncer) http://wiki.znc.in/ZNC
17:29:24 <stoney> ykk maybe but I don't think so
17:30:17 <stoney> btw... when I first started the meeting...
17:30:28 <stoney> you may have noticed that I made a few others chairs...
17:30:33 <stoney> using the #char command...
17:30:51 <stoney> that way, if I forget to stop the meeting... hopefully someone else will
17:31:03 <stoney> solves the "hit-by-a-bus" problem
17:31:42 <stoney> any other questions about Meetbot or IRC?
17:32:16 <stoney> if not... let's talk about ....
17:32:24 <stoney> #topic Discussion of HFOSS projects
17:32:57 <stoney> So you've explored some projects as part of the activities
17:33:17 <stoney> what do folks think so far? questions?
17:33:39 <quaid> rhoyle: in the past I've seen meetbot log the chat live, but I'm not sure that this server displays that; I was just looking and didn't find it
17:34:25 <cxq> I looked goole summer code projects. are we allow to pick from those?
17:34:31 <OSIMasson> stoney: I'm interested, not specifically in technical development, but community development across all these projects.
17:35:03 <OSIMasson> stoney: how do these projects organize and operate to promote participation and contribution
17:35:10 <heidie> OSIMasson, Ah, this is something that we're really interested in. Building community of faculty members (and others) who are supporting student involvement in HFOSS projects.
17:35:19 <OSIMasson> stoney: are there common activities, outputs that foster community
17:35:20 <OSIMasson> ?
17:35:51 <heidie> OSIMasson, Do you mean community among faculty members?
17:36:00 <heidie> Faculty members within an HFOSS community?
17:36:03 <stoney> cxq we are always on the look out for more projects
17:36:05 <heidie> Across HFOSS communities?
17:36:10 <mattb> That's something my research has been looking into at the student level.
17:36:17 <stoney> we are particularly interested in humanitarian projects
17:36:32 <heidie> cxq, One thing we try to do is help two or more faculty members organize around a project.
17:36:41 <stoney> so if you found a GSoC project that fits that bill... we'd be interested!
17:36:52 <OSIMasson> heidie: not specifically, but faculty--as a cohort within the community that promote contributions--would be part of the community
17:37:00 <heidie> We have found that having several faculty involving students in the same community provides someone to help answer questions.
17:37:32 <heidie> We've had several faculty members become community members.
17:37:52 <heidie> OSIMasson, Those faculty members tend to become "gateways" for other faculty members.
17:38:08 <OSIMasson> heidie: so I would be interested in how HFOSS communities can organize/behave to welcome/promote participation by higher ed / faculty
17:38:13 <heidie> OSIMasson, I'm not sure we're at the "cohort" level yet.
17:38:28 <OSIMasson> heidie: :-)
17:38:30 <heidie> OSIMasson, Ah, yes, we're also very interested in this.
17:38:51 * stoney is never sure what level he is at either
17:38:51 <heidie> We are currently running structured interviews with POSSE alumni about their experiences and asking them questions related to this.
17:39:03 <cxq> from your experience, how many projects a faculty work on? one project for several years? or several projects in a year?
17:39:21 <heidie> OSIMasson, For instance, what are the major barriers to supporting student involvement from the faculty perspective.
17:39:31 <heidie> We'd be happy to share the results when we get them.
17:40:01 <stoney> cxq my opinion is that ideally you could find a project that you can work with somewhat regularly...
17:40:04 <heidie> One thing that is becoming apparent is that having an identified person in the community to help mentor is very helpful.
17:40:22 <OSIMasson> heidie: yes, exactly. Many projects might not think of higher ed / students as a resource, and thus do not communicate in a way that promotes their participation.
17:40:28 <stoney> the reason is because you develop contacts and experience within the community for a project
17:40:44 <heidie> OSIMasson, Yes, right. And the mentor doesn't have to be a core contributor.
17:40:56 <heidie> But someone who knows the community and can help problem solve.
17:40:58 <OSIMasson> heidie: I think we are on the same page!
17:41:00 <heidie> Help faculty get started.
17:41:06 <heidie> :-) Yes, I think we are OSIMasson
17:41:08 <quaid> cxq: I lead GSoC efforts for Fedora, CentOS, and Red Hat for a long time, I'd be happy to help bridge the discussion
17:41:09 <heidie> !
17:41:13 <stoney> however, I know some POSSE alum  have worked across several projects
17:41:51 <stoney> cxq did I answer your question satisfactorily?
17:42:40 <heidie> Also note that one of the reasons why we're "HFOSS" instead of "FOSS" is that we have found that 'H' projects are motivating to students, especially women.
17:43:05 * heidie notes and also that NSF really likes the 'H'
17:43:25 <cxq> yes, thanks all. if I find some project interesting, I know who to ask before jump on.
17:43:56 <stoney> great! more questions anyone?
17:44:17 <OSIMasson> IMO I think intrinsic motivation is critical if one is to join/actively participate in a FOSS project. The H really helps with that for both faculty and students.
17:44:19 <cxq> agree, heidie
17:44:38 <heidie> OSIMasson, Agreed.
17:44:44 <OSIMasson> sorry--repeating
17:44:57 <ykk> Will we be talking about incorporating HFOSS into our courses?
17:45:02 * stoney agrees too :)
17:45:08 <ykk> today? or later?
17:45:22 <stoney> in fact... isn't there an #agree command...?
17:45:57 <stoney> ykk that is the point of POSSE in general... right now you are surveying potential projects
17:46:13 <ykk> Currently, I am teaching a Software Development course, where students work in teams of four on projects that have external liaisons. To incorporate HFOSS into this course, I want to have students select their projects from the provided list. Is it better to have several teams work on the same project or on different projects?
17:46:15 <stoney> in stage 2 we will spend some time figuring out ways to do so
17:46:52 <stoney> ykk... good question... the short answer is that I've seen it done both ways
17:47:16 <stoney> the challenge of teams on different projects is that it is harder for you to help direct your students
17:47:31 <stoney> this might work better with juniors and seniors
17:47:54 <stoney> an advantage of one project is that students can help each other more since they are working on the same project
17:47:55 <heidie> ykk, Generally we suggest starting with one project as that provides less overhead for instructors.
17:48:01 <ykk> stoney: yes, they are juniors
17:48:14 <heidie> And we also suggest that you may want to start with a few assignments rather than taking on an entire course.
17:48:20 <stoney> my preference would be one project
17:48:27 <ykk> I was wondering if there are any guidelines for how to select projects, and what are the various considerations around the various ways to structure the course/projects
17:48:34 <howardf_> I plan on sticking to one project.
17:48:35 <heidie> ykk, Good question!
17:48:48 <TheBaxter> Is a semester enough time to get students involved in a project? Would that be the focus of the entire course?
17:48:53 <heidie> There is a Project Evaluation activity further on in stage 1 of POSSE.
17:49:06 <heidie> TheBaxter, Depends on the course and the students.
17:49:16 <heidie> I've done it with seniors in 15 weeks.
17:49:24 <heidie> And I generally treat it as the focus of the course.
17:49:43 <OSIMasson> TheBaxter: I would also add, it depends on what "get involved" means
17:49:45 <heidie> I run a software engineering course that has a relatively traditional course description.
17:49:52 <stoney> right on OSIMasson
17:50:00 <stoney> that too :)
17:50:02 <heidie> Requirements, Architecture, Design, Test, etc.
17:50:20 <stoney> this is some good stuff!
17:50:29 <heidie> And I have students use an open source project as the source. Very few (none?) FOSS projects have an official requirements document.
17:50:43 <heidie> So students create them and contribute them to the community.
17:51:15 <heidie> Note that you can see what some others have done here:
17:51:16 <heidie> #link http://foss2serve.org/index.php/Category:Courses
17:51:28 <stoney> We have about 10 minutes left
17:51:32 <heidie> We're building a collection of courses, in addition to activities.
17:51:43 <ykk> heidie: that's great! Thank you!
17:52:06 <heidie> Glad to help! And excited to hear about folks getting students involved!
17:52:20 <stoney> #topic Good of the order
17:52:30 <cxq> heidie: that is very helpful! I'm teaching both under and grad software eng. courses.
17:52:38 <heidie> ah, good.
17:52:41 <stoney> Any announcements or other questions in general?
17:52:57 <heidie> There will also be a couple of POSSE alumni at the April POSSE who are currently teaching HFOSS in their courses.
17:53:06 <heidie> They'll be a good resource as well.
17:53:58 <OSIMasson> stoney: I assume this channel will be up from now on. We can continue to reach out, not only until the SF meeting, but also after?
17:54:10 <stoney> yes... this channel is always open
17:54:26 <heidie> Yup, and I pretty much hang out here all the time.
17:54:33 <heidie> You may just have to ping me to get my attention.
17:54:45 <OSIMasson> stoney: right, but is it the Official POSSE channel or just for the POSSE events?
17:54:52 <stoney> and we've had groups use this channel for meetings regarding particular projects and such
17:55:00 <OSIMasson> stoney: OK, thanks
17:55:02 <heidie> OSIMasson, For the general foss2serve community
17:55:14 <heidie> Note that there is also a #teachingopensource channel on freenode.
17:55:46 <heidie> Quaid and spot and glikins hang out there with some other TOS folks.
17:55:49 <stoney> #info #foss2serve is for the general foss2serve community
17:56:05 <heidie> And ykk is there too!
17:56:12 <stoney> #info #teachingopensource is a broader channel of folks wanting to teach open source
17:56:32 <heidie> No guarantee that folks on #teachingopensource have been to POSSE, but we're all part of the same effort.
17:57:00 <stoney> is there anything else anyone wants to add before we end the meeting?
17:57:20 <stoney> motion to adjourn?
17:57:29 <heidie> We've got two more meetings so look for the Doodle polls.
17:57:43 <stoney> ah yes... yup yup :)
17:58:02 <TheBaxter> #action motion to adjourn
17:58:06 <stoney> lol
17:58:10 <stoney> awesome
17:58:13 <stoney> #endmeeting