13:00:25 <stoney> #startmeeting IRC 1.1
13:00:25 <zodbot> Meeting started Thu Sep 28 13:00:25 2017 UTC.  The chair is stoney. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:25 <zodbot> The meeting name has been set to 'irc_1.1'
13:00:38 <stoney> #link Agenda: http://foss2serve.org/index.php/IRC_Meeting_1
13:00:45 <stoney> Good morning all!
13:00:55 <howardf> good morning!
13:01:00 <stoney> I just posted a link to our agenda.
13:01:08 <stoney> We'll start with introductions
13:01:13 <stoney> #topic Introductions
13:01:20 <stoney> I'll go first
13:01:36 <LB> good morning!
13:01:44 <stoney> #info Stoney Jackson, Western New England University, one of the foss2serve team members
13:02:02 <stoney> Please introduce yourselves in a similar way
13:02:14 <LB> #info
13:02:19 <stoney> No need to wait, just shout it out :)
13:02:33 <bburd> Barry Burd, Drew University in Madison, NJ. (Math/CompSci Department)
13:02:42 <LB> #info Lina Battestilli North Carolina State University, POSSE participant
13:02:42 <stoney> Welcome Barry!
13:02:46 <howardf> #info Howard Francis, University of Pikeville, second time POSSE participant
13:02:48 <stoney> Welcome Lina!
13:02:56 <stoney> Welcome Howard!
13:03:23 <stoney> the others on the channel are likely just lurking
13:03:36 <stoney> so this is a nice cozy meeting :)
13:03:42 <hislopg> #info Greg Hislop, Drexel University, also one of the foss2serve team members
13:03:47 <hislopg> Hi all!
13:03:55 <stoney> Hi Greg!
13:04:08 <hislopg> :-)
13:04:24 <hislopg> This is a small group!
13:04:35 <stoney> I was just saying, it looks like we've got 3 participants this morning
13:04:37 <stoney> oh wait...
13:04:40 <bburd> Probably larger groups later today.
13:04:55 <Suhaib> Hi Everyone
13:05:00 <LB> Glad you had different times to participate!
13:05:03 <stoney> Hi Suhaib
13:05:20 <stoney> Could you please introduce your self... name, institution would be fine
13:05:34 <stoney> Stoney Jackson, Western New England University, one of the foss2serve team members
13:05:38 <Suhaib> I’m Suhaib Obeidat. I work for Bloomfield College in NJ
13:05:52 <stoney> Great thanks! and welcome!
13:06:00 <Suhaib> Thanks, and nice to meet you
13:06:01 <hislopg> Hi Suhaib
13:06:04 <stoney> Let me repost the agenda
13:06:09 <stoney> http://foss2serve.org/index.php/IRC_Meeting_1
13:06:15 <stoney> That's a link to our agenda
13:06:28 <stoney> This meeting is being recorded by zodbot
13:06:43 <stoney> It will post the minutes automatically
13:07:16 <stoney> there is a link to past minutes at the bottom of the agenda
13:07:22 <stoney> :)
13:07:34 <stoney> next topic... :)
13:07:43 <stoney> #topic IRC
13:08:00 <stoney> for how many of you is your first IRC experience?
13:08:14 <Suhaib> It’s my first
13:08:18 <stoney> awesome!
13:08:23 <LB> me too!
13:08:32 <stoney> great! then let's have some fun
13:08:33 <bburd> My first.
13:08:45 <stoney> so you already know how to message
13:08:47 <bburd> Oh! First IRC experience — no.
13:08:56 <stoney> ;)
13:09:05 <bburd> … But … I’m still not too familiar with IRC.
13:09:14 <stoney> you can direct a message at someone by including their nickname in the message
13:09:24 <stoney> lik this LB, bburd , Suhaib
13:09:42 <stoney> that probably made a beep or flashed your screen too
13:09:52 <bburd> It beeped
13:10:10 <stoney> different clients do different things
13:10:18 <LB> No beep here ... just color coded it in green
13:10:22 <stoney> but usually it's a way to get someones attention
13:10:28 <LB> I am using hexchat
13:10:45 <Suhaib> I’m using Colloquy
13:10:52 <bburd> Colloquy for me
13:11:07 <Suhaib> Any recommendations whether this is a good client? Or others better, I have both Windows and Mac
13:11:07 <stoney> LB I'm not familiar with hexchat... however, there are usually options that you can set to change its behavior
13:11:19 <bburd> … but using a nickname doesn’t make the message private… right?
13:11:22 <stoney> I'm on a Mac and I use Textual
13:11:25 <LB> OK it was one of the clients recommended on the wiki
13:11:44 <stoney> bburd right... the message still is seen by the whole channel
13:11:49 <howardf> i'm using freenode's webchat page
13:11:58 <Suhaib> Is Textual better than Colloquy
13:12:00 <stoney> bburd it is possible to IRC message someone directly
13:12:44 <stoney> bburd off the top of my head I'm not sure how... in my client I double click on someone's name and it opens a separate private changel
13:13:18 <stoney> Suhaib I've used Colloquy before.... I liked it... I don't remember why I switched to Textual
13:13:19 <howardf> i think if you do /msg howardf this is just for howard ... it would send it just to me
13:14:06 <hislopg> bburd: I just sent you a private message
13:14:22 <bburd> In Colloquy, double clicking the person’s icon opens up another window.
13:14:24 <stoney> Suhaib better is a loaded term... I prefer simplicity over powerful configurations... I found both Textual and Colloquy are good for that
13:14:58 <stoney> howardf awesome, thanks for the /msg tip
13:15:09 <stoney> And that's a good thing to know
13:15:13 <bburd> Then in the panel on the left, it shows that you have messages in that private window.
13:15:24 <stoney> Any message that starts with a / ...
13:15:35 <stoney> is a command for the IRC server (usually)
13:16:06 <stoney> so /msg nick message asks IRC to send nick a private message
13:16:32 <stoney> we can describe what we are doing or feeling using /me
13:16:39 * stoney smiles broadly
13:16:54 * stoney checks the agenda
13:16:59 <stoney> etc
13:17:12 <stoney> You can change your nick name with /nick
13:17:21 * LB waves
13:17:26 * stoney_jackson waves back
13:18:00 <stoney> Often folks will change their nick to indicate their status
13:18:11 <stoney> If they are away from the keyboard...
13:18:17 * Suhaib checking agenda
13:18:20 <stoney_afk> like this
13:18:24 <stoney_afk> or ...
13:18:41 <stoney_> just a _ also indicates away
13:19:20 <stoney> So if you see someone AFK... and you need to talk to them... ping them by putting their nick in the message
13:19:42 <stoney> btw... most clients provide tab completion of nicks
13:19:54 <stoney> hand when it's complicated :)
13:19:55 <bburd> It will take some time to get used to all these little conventions.
13:20:27 <stoney> yah... IRC has its own little culture
13:20:32 <LB> best part is the auto-generated minutes  .. I might run all of my TA meetings in IRC :)
13:20:48 <stoney> you'll pick up on them as you sit on an active channel
13:21:09 <stoney> LB right... and that plays into the next topic
13:21:15 <stoney> LB I'll pay you later
13:21:24 * LB smiles
13:21:24 <stoney> the meetbot
13:21:43 <stoney> As I mentioned earlier zodbot is not a person
13:22:01 <stoney> it's a program listening on this channel for messages starting with #
13:22:26 <stoney> any message starting with # it reads and expects commands that it can understand
13:22:33 <stoney> #topic Meetbot
13:22:37 <stoney> Like that
13:22:42 <howardf> cool
13:22:42 <stoney> I changed the topic
13:23:12 <stoney> zodbot records everything we type
13:23:28 <stoney> however, it will also produce a short summary of the meeting
13:23:54 <stoney> we can elevate particular messages to this short summary through various commands
13:23:54 <stoney> like...
13:24:00 <stoney> #info This will be on the summary
13:24:07 <stoney> or
13:24:20 <stoney> #action Before next meeting I promise to do something
13:24:24 <stoney> or
13:24:42 <stoney> #agreed We have decided to ...
13:25:02 <LB> can anyone change the #topic ... is there a notion of moderator
13:25:03 <stoney> oh... and ...
13:25:10 <Nwokeji001> Good morning all.
13:25:15 <bburd> So, let me see if I understand… Zodbot records everything but it has a subset named meetbot that records the summary and meetbot gets that summary from the hashtag commands that we type?
13:25:18 <Nwokeji001> Sorry for joining late
13:25:24 <stoney> #link here is a link http://foss2serve.org/
13:25:27 <Nwokeji001> I had problems with the connections
13:25:45 <stoney> welcom Nwokeji001
13:25:47 <LB> Hi Nwokeji001!
13:25:56 <Nwokeji001> Thanks,
13:26:01 <stoney> please introduce yourself
13:26:24 <stoney> #info Stoney Jackson, Western New England University
13:26:26 <stoney> like that :)
13:26:33 <Nwokeji001> I am Joshua C. Nwokeji, Assistant Professor Information Systems, Gannon University Erie PA
13:26:46 <stoney> welcome Joshua!
13:26:52 <Suhaib> Hi Joshua
13:27:00 <stoney> bburd you got the idea
13:27:02 <Nwokeji001> Did I miss any important information?
13:27:13 <LB> stoney Is there a way to hold an IRC meeting with only selected people?
13:27:13 <stoney> bburd but they are not freeform hashtags like twitter
13:27:30 <bburd> stoney, I understand that
13:27:33 <stoney> bburd their are a set of commands that zodbot understand
13:27:40 <stoney> bburd ok good :)
13:27:48 <bburd> stoney, yes I see that on the manual page for meetbot
13:28:03 <stoney> LB there are ways to get that done
13:28:24 <stoney> LB one... you could create a separate channel and give only those folks the name of that channel
13:28:54 <stoney> LB someone not in the group might walk in... but that's doubtful
13:29:15 <stoney> LB I think there are ways to password protect a channel... but I'm not sure because I never do
13:29:28 <LB> OK thanks stoney
13:29:39 * stoney thinks hi missed an important question... reading back
13:29:50 <hislopg> LB: the bigger strength of IRC is that anyone can join
13:29:58 <LB> I see
13:30:08 <stoney> ah LB you asked who has permissions to use zodbot commands
13:30:10 <bburd> So if you use someone’s nickname anywhere in a message, then the client beeps or highlights it some way or other?
13:30:24 <stoney> some are protected... and only a chair use them
13:30:40 <stoney> others like #info, #action, #link can be used by all
13:31:04 <LB> maybe #topic is protected ... for moderation purpose
13:31:04 <stoney> when you are chair... it's a good idea to add one or two others in case you client crashes
13:31:10 <stoney> #chair hislopg
13:31:10 <zodbot> Current chairs: hislopg stoney
13:31:20 <stoney> because only a chair can end a meeting
13:31:29 <LB> \me gives thumbs up!
13:31:39 <stoney> ok...
13:31:47 <stoney> other questions on IRC or the meetbot?
13:32:07 <stoney> if not...
13:32:12 <bburd> Using a nickname in the middle of a sentence … still okay?
13:32:28 <stoney> sure
13:32:40 <bburd> Thanks stoney
13:32:41 <stoney> it will ping that person (depending on the client's configuration)
13:33:05 <stoney> bburd like that last one highlighted on my client
13:33:08 <stoney> (no beep)
13:33:17 <stoney> #topic Discussion of HFOSS projects
13:33:47 <stoney> So over the coming weeks you'll be investigating HFOSS projects
13:33:59 <Nwokeji001> Can someone propose a new HFOSS project?
13:34:07 <stoney> and starting to think about what might be appropriate for your classes, etc.
13:34:24 <stoney> yes... we are always looking for new HFOSS projects
13:34:46 <Nwokeji001> Okay, thanks
13:34:51 <bburd> Are there only four HFOSS projects right now?
13:34:59 <stoney> the projects that we list on foss2serve are projects that one or more foss2serve team members or POSSE alum have had some success with
13:35:03 <hislopg> Nwokeji001: do you mean an existing HFOSS project that we haven't mentioned or a new project that you want to start?
13:35:05 <Nwokeji001> Are there specific guidelines for doing so?
13:35:23 <Nwokeji001> A new project I want to start
13:35:56 <hislopg> bburd: there are lots of HFOSS projects and we find new ones regularly
13:36:22 <hislopg> Here's a list:  http://foss2serve.org/index.php/HFOSS_Projects  It's being revised, but can give you some feel for the range
13:36:43 <stoney> bburd for POSSE we direct folks to a smaller set because we try to build groups of faculty around those projects that can support each other
13:37:04 <hislopg> Nwokeji001:  that's possible and we can discuss pros and cons.  For now we'd recommend that you look at an existing project to see how they operate
13:38:02 <Nwokeji001> Okay, thanks!
13:38:09 <stoney> these are perfect questions... keep them coming :)
13:39:03 <stoney> or maybe we've exhausted them for now?
13:39:11 <LB> wow there are a lot of projects ...
13:39:16 <stoney> in coming IRC's...
13:39:29 <Nwokeji001> It appear that most HFOSS project is programming centric. But I am teaching a software requirement course that does not involve programming.
13:39:58 <stoney> Nwokeji001 that sounds cool
13:40:13 <Nwokeji001> How can my students participate in existing HFOSS projects
13:40:24 <stoney> one of the things we'll talk about during POSSE is how a contribution to a project does not have to be code
13:40:28 <Nwokeji001> I mean students in my software requirements class
13:40:39 <stoney> and we'll explore the many ways that a class can engage with a project
13:41:01 <stoney> Nwokeji001 and requirements has been one way that has been successful
13:41:24 <stoney> Nwokeji001 projects don't always list their requirements
13:41:49 <stoney> Nwokeji001 some have had their students reverse engineer a projects requirements
13:42:08 <stoney> Nwokeji001 and give this back to the project
13:42:27 <stoney> Nwokeji001 this can be valuable to a project and its community
13:42:37 <stoney> that's just one example
13:42:40 <stoney> :)
13:42:42 <bburd> I’ve found the larger list of HFOSS projects. Should we steer clear of that for now since we’re HFOSS newbies?
13:42:57 <Suhaib> Q. So while there are many projects, currently only four have faculty involvement?
13:43:37 <Suhaib> bburd I guess I have the same question
13:44:02 <stoney> bburd I think you should explore... the stage 1 activities for POSSE will direct you to specific projects... but it doesn't hurt to explore other projects as well :)
13:44:03 <hislopg> Suhaib: we recommend starting with these 4 projects for discussions in POSSE
13:44:11 <stoney> it usually just comes down to how much time you have
13:44:12 <stoney> :)
13:44:35 <hislopg> Working with particular projects provides better discussion for the workshop... you can branch out from there as you wish
13:44:53 <Suhaib> Got it, thanks hislopg
13:44:55 <stoney> ^^^^ better way of saying it :)
13:45:48 <stoney> hislopg do you have the link to the group signup page handy?
13:45:49 <bburd> Is there a quick way to find out what programming tools are used in each of the projects? That might make a difference in which project I choose.
13:46:27 <hislopg> looking...
13:46:49 <stoney> bburd I don't think our project pages go into that detail
13:47:24 <stoney> bburd we let projects maintain that information themselves...
13:47:45 <stoney> bburd we do talk about how to explore and evaluate a project for the needs of a class
13:47:57 <bburd> stoney I may have misstated my question. By “tools” I don’t mean things like IDEs. I mean which languages, which frameworks, etc.
13:49:00 <bburd> I guess if I go to each project’s website I’ll get more of that info.
13:49:01 <stoney> bburd right... each project is different and they evolve... their development environments, practices, etc... so it's usually best to let projects provide those details
13:49:22 <hislopg> http://foss2serve.org/index.php/HFOSS_Communities
13:49:26 <stoney> bburd if it's hard to find those details for a project, that should make you suspicious of using that poroject :)
13:49:59 <hislopg> All:  My apology... I need to run to a meeting...
13:50:01 <stoney> thanks hislopg !
13:50:12 <stoney> bye!
13:50:16 <stoney> too late :)
13:50:32 <stoney> #link HFOSS signups http://foss2serve.org/index.php/HFOSS_Communities
13:50:45 <stoney> so as we get closer to POSSE....
13:51:06 <stoney> we'll be asking folks to sign up for projects that they have some interest in
13:51:29 <stoney> this will help us form discussion groups at the POSSE
13:51:36 <Suhaib> Is part of the workshop going to cover how to navigate a large codebase?
13:51:53 <LB> Also how do we sign up ... via the wiki?
13:51:56 <stoney> Suhaib great question....
13:52:02 <stoney> LB yes
13:52:12 <Suhaib> I am not a S.E so not used to dealing with large amounts of code
13:52:15 <stoney> Suhaib not directly
13:52:38 <stoney> Suhaib we will have some git and github training
13:52:59 <bburd> I need git and github training !!!
13:53:30 <Suhaib> But in addition to the tools, aren’t there strategies to locating code relevant to the feature you would like to make changes to?
13:53:37 <stoney> Suhaib but we won't be teaching anything specific about navigating a code base (e.g., static analysis tools, search tools, IDEs, and such)
13:54:18 <Suhaib> I think this is essential to teach students prior to asking them to contribute to a project
13:54:41 <stoney> Suhaib I understand your concern... I'm not sure there is a silver bullet for that
13:54:46 <stoney> Suhaib in fact...
13:54:47 <LB> All I have to run to another meeting in a few mins ...
13:55:15 <stoney> Suhaib what you will learn is how to make use of the community to help you navigate the code base
13:55:37 * stoney checks the clock
13:55:38 <Suhaib> got it, thanks for clarifying
13:55:40 <stoney> ack!
13:56:11 <stoney> OK... last think is a reminder... please remember to log your progress on the sheet that was sent out
13:56:20 <stoney> Sorry for the rushed ending
13:56:34 <LB> was the sheet sent in an email?
13:56:36 <Suhaib> Thanks Stoney, nice to meet you all
13:56:40 <stoney> I think so
13:56:55 <LB> yes, nice to "meet" you all!
13:57:01 <stoney> good to meet all of you
13:57:05 <LB> \nick LB_afk
13:57:06 <stoney> LB I'll check on the sheet
13:57:11 <stoney> #endmeeting