12:13:54 <banas> #startmeeting
12:13:54 <zodbot> Meeting started Wed Nov 26 12:13:54 2014 UTC.  The chair is banas. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:13:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:14:09 <banas> .fasinfo sarupbanskota
12:14:10 <zodbot> banas: User: sarupbanskota, Name: Sarup Banskota, email: sbanskota08@gmail.com, Creation: 2013-03-28, IRC Nick: banas, Timezone: Asia/Kolkata, Locale: en, GPG key ID: , Status: active
12:14:13 <zodbot> banas: Unapproved Groups: summer-coding
12:14:16 <zodbot> banas: Approved Groups: ambassadors designteam cla_done cla_fpca
12:14:21 <banas> #topic Roll Call
12:14:27 <banas> .fasinfo sarupbanskota
12:14:29 <zodbot> banas: User: sarupbanskota, Name: Sarup Banskota, email: sbanskota08@gmail.com, Creation: 2013-03-28, IRC Nick: banas, Timezone: Asia/Kolkata, Locale: en, GPG key ID: , Status: active
12:14:32 <zodbot> banas: Unapproved Groups: summer-coding
12:14:35 <zodbot> banas: Approved Groups: ambassadors designteam cla_done cla_fpca
12:14:44 <htrap> .fasinfo htrap
12:14:45 <zodbot> htrap: User: htrap, Name: parth oberoi, email: parthoberoi@hotmail.com, Creation: 2014-11-21, IRC Nick: htrap, Timezone: UTC, Locale: en, GPG key ID: None, Status: active
12:14:48 <zodbot> htrap: Approved Groups: cla_done cla_fpca
12:14:58 <rhea> .fasinfo karanmilan
12:14:59 <zodbot> rhea: User: karanmilan, Name: Karan Jain, email: karanmilan@gmail.com, Creation: 2014-11-19, IRC Nick: None, Timezone: UTC, Locale: C, GPG key ID: None, Status: active
12:15:02 <zodbot> rhea: Approved Groups: None
12:15:09 <banas> yay \m/ everyone has a FAS now!
12:15:14 <banas> moving on
12:15:20 <banas> #topic Status Updates
12:15:40 <banas> so tell me what you guys have been up to, although I know your exams are on
12:15:53 <htrap> except for open-shift deployments everything else is done
12:16:13 <rhea> yeah
12:16:16 <banas> in the meanwhile
12:16:17 <htrap> that too we are working on a seperate branch
12:16:23 * banas goes to try the thing out locally
12:16:35 <rhea> htrap, had done it on himself and i tried deploying open id on myslef
12:16:35 <banas> #link https://www.irccloud.com/pastebin/EcAKaSgk
12:16:54 <rhea> so we both have an idea about open shift
12:17:01 <rhea> and little bit of flask
12:17:35 <banas> oops, I think I don't have flask here; is it pretty big? i don't want it to eat my 3g
12:17:40 <banas> brb, 5 minutes
12:18:13 <htrap> no not too big
12:21:10 <banas> argh, I have a troubled internet connection
12:21:21 <banas> let me try it out sometime in the night, aftre the meeting
12:21:26 <banas> i trust you both :)
12:21:43 <rhea> yeah you can try it out anytime you want
12:21:54 <rhea> and if we can we'll try getting it up on openshift
12:22:02 <banas> yes do that
12:22:09 <banas> it's important that it deploys
12:22:26 <banas> there's openshift quickstarts, that helps you set up things easy
12:22:56 <banas> #action rhea htrap Check out OpenShift QuickStarts https://www.openshift.com/quickstarts
12:23:28 <banas> so if you see that your flask app doesn't deploy, you can check if you're missing out on some configuration with the example flask app openshift provides
12:23:59 <banas> the openid thing works, isn't it
12:24:07 <rhea> yeah
12:24:08 <htrap> yup
12:24:15 <rhea> we could log in into FAS
12:24:19 <rhea> and it does work
12:24:23 <htrap> we imbedded the datagrepper feed into it
12:24:39 <banas> oh you guys played with datagrepper too! awesome :)
12:25:08 <htrap> let us know when you check it out
12:26:08 <banas> i will :) i'm currently looking at your datagrepper commit
12:26:45 <banas> cool - this seems like good activity
12:27:04 <banas> now, I'll try to give you some visual assignments
12:27:24 <banas> can you try to come up with a timeline of the user's activity?
12:27:36 <htrap> a datagrepper widget that looks at the username argument and filters the feed to display it after authentication on the home page of the user
12:28:29 <banas> list out what the user has been doing - put them under headers
12:28:43 <banas> "Activity in November 2014"
12:28:48 <banas> and so on..
12:29:02 <rhea> okay
12:29:06 <banas> also, try to style different types of activity differently
12:29:15 <banas> don't worry too much about how the activity looks
12:29:30 <banas> I'll look after the beautification part
12:29:47 <htrap> we displayed the datagrepper filtered feeds in default css in a bullet pattern form
12:29:48 <banas> just make sure you have different css classes for different types of activity
12:30:44 <htrap> but with css=True set for datagrepper widget we have uniform dimension of the images along with the feed
12:31:00 <htrap> just check that also when you try the repo
12:31:31 <htrap> *css=true
12:31:38 <banas> alright, I'll try that and tell you
12:31:41 <banas> one suggestion
12:31:45 <banas> when you make git commits
12:31:57 <banas> make them seem instructive
12:32:09 <banas> instead of "Adding working user-logins through openid"
12:32:25 <banas> "Add working user-logins through openid" is a better commit message
12:32:27 <htrap> okay ill keep that in mid
12:32:33 <banas> because when I'm looking at the log
12:32:34 <htrap> *mind
12:32:41 <banas> i want to checkout to a particular instruction
12:32:52 <banas> not a big deal, but it's good practice :)
12:33:28 <htrap> sure, we'll keep that in mind for future commits
12:34:07 <banas> #idea htrap rhea Keep commit messages instructive
12:34:30 <banas> #action htrap rhrea Come up with a timeline view of the various activity
12:34:53 <htrap> okay
12:35:05 <banas> also, if you have the time, I'll give you another assignment (optional)
12:35:22 <banas> read about visualizing stuff on charts
12:35:48 <rhea> with flask?
12:35:48 <htrap> on charts?
12:36:11 <banas> we'll want to create some sort of leaderboards/statistics on stuff like "which team had the most easyfixes solved last month" etc
12:36:25 <banas> no not flask, look at JS charts
12:36:56 <rhea> okay
12:36:56 <banas> #link http://www.chartjs.org/
12:37:02 <htrap> okay
12:37:20 <banas> there are many, so your assignment is to reasearch/read about them
12:37:30 <banas> and maybe blog about what you thought we could use, why etc :)
12:37:53 <banas> let us reduce workload for now, i don't want to be blamed if you screw up exams ;)
12:38:08 <htrap> okay like a basic graphs to display the tams performance right
12:38:10 <htrap> ?
12:38:22 <banas> htrap, that's a use case yet
12:38:27 <banas> *yes
12:38:45 <htrap> okay
12:38:48 <rhea> okay and we have to try developing many other cases
12:38:52 <banas> similarly, we might want to come up with "who answered most questions to newcomers on fedorajoin" eventually
12:39:18 <banas> so that when a new person wants to contribute to fedora infra, he/she'll know which people normally help out newcomers
12:39:21 <htrap> oh we have to create such use cases and find graphs to fit these needs?
12:40:08 <banas> we'll figure out the use cases as the need arises, for now it's sufficient if you're aware of the various charting options available and have some idea on how we'd go about playing with them
12:40:19 <htrap> okay
12:41:00 <banas> #action htrap rhea Blog about progress so far once exams are over
12:41:23 <htrap> thank you ,sure :)
12:41:38 <banas> i'm sorry I couldn't look at your work now, but I'll do it soon enough and email you
12:41:49 <banas> so can we move to open floor?
12:41:54 <htrap> no problem
12:42:00 <htrap> yup
12:42:02 <banas> #topic Open Floor
12:42:11 <banas> so any questions etc, shoot
12:42:22 <rhea> no as of now
12:42:40 <banas> I have one - do you both work together or something?
12:42:47 <banas> how do you communicate?
12:43:00 <htrap> #ssof channel
12:43:08 <htrap> on freenode
12:43:28 <banas> ah, what's that?
12:43:44 <htrap> just a freenode irc channel
12:43:53 <rhea> its reeverse of foss
12:43:53 <banas> you can feel free to use this one if you need it, it also has a zodbot running all the time :)
12:43:59 <rhea> we meet up most times also
12:44:04 <banas> lol ok
12:44:09 <rhea> and phone also :P
12:44:18 <banas> nice!
12:44:40 <htrap> okay i was messing with the zodbot earlier today
12:44:57 <banas> let's see if we can meet at GCRC, you can register for tickets now if you feel like, it's likely cheaper atm
12:45:08 <banas> i'll keep you posted about my plans in december.
12:45:19 <banas> htrap i see, zodbot is helpful
12:45:28 <htrap> sure do that
12:46:12 <banas> alright, so we'll wrap up now?
12:46:33 <banas> I'll go back to fixing what I was working on
12:47:13 <htrap> sure, just tell us when you try it out
12:47:34 <banas> i will, i'll email you both.
12:47:46 <banas> later then, going to end in
12:47:48 <banas> 3..
12:47:49 <banas> 2..
12:47:50 <banas> 1.
12:47:54 <banas> #endmeeting