16:05:10 <Technicool> #startmeeting
16:05:10 <zodbot> Meeting started Thu Sep 20 16:05:10 2012 UTC.  The chair is Technicool. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:05:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:05:24 <Technicool> #action start party
16:05:29 <johnmark> heh
16:06:31 * johnmark looks at agenda
16:06:37 <johnmark> who all is here?
16:06:38 <Technicool> as far as new docs, still working on UFO and getting ready for ohio linuxfest next week, so not a lot of news there
16:06:52 <johnmark> Technicool: ok. any feedback on docs?
16:07:29 <johnmark> so far, I've seen hagarth, semiosis and JoeJulian will be back in a bit
16:07:33 <johnmark> anyone else?
16:07:42 <Technicool> semiosis had an idea i really liked from last weeks meeting, soliciting for real world use cases, esp. interesting ones with abnormal use cases
16:07:54 <semiosis> +1
16:08:03 <johnmark> semiosis: tell us
16:08:04 <johnmark> more
16:08:16 <hagarth> Technicool: where are the new docs hosted?
16:08:23 <JoeJulian> +2?
16:08:48 <johnmark> hagarth: see http://www.gluster.org/community/documentation/index.php/Getting_started_overview and http://www.gluster.org/community/documentation/index.php/QuickStart
16:09:02 <Technicool> hagarth, sent them out to -users list the other day, and there is that link
16:10:07 <semiosis> johnmark: not much i can tell, Technicool's idea speaks for itself :)
16:10:10 <Technicool> http://www.gluster.org/community/documentation/index.php/QuickStart
16:10:14 <Technicool> oopd
16:10:15 <Technicool> oops
16:10:32 <Technicool> http://www.gluster.org/community/documentation/index.php/Getting_started_overview
16:10:33 <johnmark> heh
16:10:44 <johnmark> ok, so wrt docs...
16:10:54 <johnmark> Technicool: you sent out the link to gluster-users? did anyone comment?
16:11:05 * johnmark missed it
16:11:19 <Technicool> johnmark, didn't check will do so after meeting
16:11:23 <johnmark> Technicool: ok
16:11:32 <johnmark> so there's that piece and then the UFO piece
16:11:36 <Technicool> hagarth, everything is being hosted on the wiki
16:11:48 <johnmark> Technicool: you can probably get some help with teh UFO doc from kaleb
16:12:03 <johnmark> he seems to be doing a fair bit of work on that ATM
16:12:20 <Technicool> migrating my test setups off of AWS as well since that account got tanked
16:12:28 <johnmark> Technicool: oh right.
16:12:38 <hagarth> Technicool: jbrooks also has a guide on setting up UFO
16:12:42 <johnmark> Technicool: do you think this could be the week following OLF
16:12:48 <johnmark> hagarth: oh yeah - forgot about him
16:12:51 <Technicool> yes, and yes
16:13:00 <johnmark> Technicool: excellent :)
16:13:16 <Technicool> hagarth, have read it, great write up
16:13:36 <johnmark> cool. has anyone had the chance to look into git <-> mediawiki integration? test it out?
16:13:46 <hagarth> Technicool: +1 to that
16:13:52 <JoeJulian> kkeithley will likely redo his UFO docs since he has has to revamp the packaging.
16:13:58 <johnmark> JoeJulian: right
16:15:04 <johnmark> Ok, eventually we still have to figure out how we're going to merge new docs into the git repo under the /docs/ folder
16:16:06 <johnmark> ok, any actions wrt docs that we can assign for next week?
16:16:14 <johnmark> bueller?
16:16:20 <JoeJulian> And we'll need that documented
16:16:24 <johnmark> JoeJulian: indeed
16:16:33 <johnmark> metadocs
16:17:03 <johnmark> or shall we move on?
16:17:37 <johnmark> translation: would anyone like to volunteer to look into git <-> mediawiki integration?
16:17:50 <johnmark> hint, hint... wink, wink
16:17:51 <JoeJulian> I'll likely be bug hunting next week since I have found a bunch of issues the last couple weeks.
16:18:06 <johnmark> JoeJulian: doh, ok. then we can table it for the following week
16:18:18 <johnmark> JoeJulian: but I do look forward to some tasty bug reports
16:18:32 <JoeJulian> All my time has been spent manually healing all the self-heal fails.
16:18:36 <johnmark> ouch
16:18:40 <Technicool> ouch ouch
16:19:20 <johnmark> #topic real-world use cases
16:19:26 <johnmark> Technicool: is that how you do it?
16:19:34 <johnmark> can't remember this zodbot stuff
16:20:06 <Technicool> i only know what zodbot tells me after startmeeting ;)  but yes, seems so
16:20:15 <johnmark> Technicool: noted :)
16:20:36 <johnmark> semiosis: seems like we can just send out a notice to the lists asking how people use GlusterFS
16:20:54 <johnmark> I remember, way back when, doing a similar thing with Linux International
16:21:04 <johnmark> we had a web site with a form that had some basic questions
16:21:13 <johnmark> and people would fill out what they were using Linux for
16:21:14 <hagarth> johnmark: who's using GlusterFS might also provide some use cases
16:21:22 <johnmark> it was actually fairly popular
16:21:29 <johnmark> hagarth: exactly
16:21:43 <semiosis> johnmark: yeah i suggested last week that we reach out to some #gluster regulars, ask them to write a few paragraphs about their setup, bribe them with t-shirts/coffee mugs, and take care of the editing & publishing
16:21:43 <johnmark> semiosis: what could we use for this?
16:21:53 <johnmark> semiosis: sounds like a plan
16:22:01 <semiosis> so they dont have any overhead like setting up a blog, etc
16:22:11 <johnmark> semiosis: can you come up with a plan and work flow, and then we'll help you implement?
16:22:17 <johnmark> semiosis: nice
16:22:53 <semiosis> #action semiosis: write up a plan to get use-case stories from known glusterfs users
16:22:57 <semiosis> hope that worked
16:23:07 <johnmark> we could set up a google docs page, surveymonkey, whatever
16:23:18 <johnmark> semiosis: if not, we know where you live
16:23:23 <johnmark> heh
16:23:33 <semiosis> moving soon.  bwahahahahaha
16:24:23 <johnmark> :)
16:24:33 <johnmark> ok, next - gluster.org
16:24:41 <johnmark> #topic gluster.org web server
16:24:59 <johnmark> so... who here has experience upgrading live debian servers?
16:25:05 * semiosis ducks
16:25:11 * Technicool cringes
16:25:14 <johnmark> LOL
16:25:38 <johnmark> I took the liberty of upgrading the mirrored server
16:25:52 <JoeJulian> That's difficult?
16:25:52 <Technicool> #action Technicool to bite the live upgrade bullet
16:25:56 <johnmark> and it went down after rebooting... but then mysteriously came back online
16:26:14 <semiosis> johnmark: probably fscking the mounts since it had been up so long :)
16:26:21 <johnmark> so for the live server, we should probably figure out a way to minimize downtime
16:26:29 <johnmark> semiosis: oh! crap, you're probably right
16:26:46 <Technicool> www.makes-sense.com
16:26:47 <johnmark> forgot to run "uptime"
16:27:06 <johnmark> so we need to do this soon, because the server is running debian 5, which is woefully out of date
16:27:12 <Technicool> lol uptime is going to be close to epoch
16:27:28 <johnmark> and we run the risk of security breaches if we don't take care of it soon
16:27:45 <johnmark> Technicool: oh, you generously volunteerd :)
16:27:56 <johnmark> let's send out a notice telling people when we plan to be down
16:28:09 <johnmark> and an estimate of how long
16:28:32 <johnmark> Technicool: when is up to you. I figure the weekend is best, after you get back from Ohio
16:28:34 <Technicool> johnmark, yup...i have a new request from uriah that i want to look at, and will be out for a few hours after this meeting, but will take a look this afternoon
16:28:35 <JoeJulian> Boot up a new instance, start puppet, then change the DNS to the newly configured server. :-)
16:28:54 <semiosis> JoeJulian: i have a feeling this is a bare metal dedicated server
16:29:00 <Technicool> JoeJulian, you are the real master of puppets ;)
16:29:14 * Technicool does heavy metal ballad in JoeJulian's honor
16:29:21 <johnmark> JoeJulian: well, since we already have the mirrored server upgraded, we could just switch over to that
16:29:44 <johnmark> JoeJulian: I'll leave that to you and Technicool
16:29:46 <semiosis> +1 -- if anything goes wrong with the new one under load you can switch back
16:29:53 <johnmark> semiosis: coolio
16:30:39 <johnmark> Technicool: ok, will look for word from you on the gluster-infra list
16:30:56 <JoeJulian> Sounds good. When configuring the new server, I would do a basic dom0 and create the new gluster.org in a VM to make my suggestion possible for the next time.
16:30:58 <Technicool> works for me
16:31:52 <johnmark> and then there are the dev services running on our other set of servers
16:32:01 <johnmark> git, gerritt, and jenkins
16:32:33 <johnmark> hagarth: would you like to explain to the others what the current issues are? And then I'll fill in with recent discussions I've had to move the hosting to a permanent location
16:33:08 <JoeJulian> Once you have a virtualization platform, those others become pretty easy as well.
16:33:27 <johnmark> JoeJulian: I think that is the smart way to go
16:33:34 <johnmark> er, "smarter"
16:33:51 <hagarth> the current issues are - we have the hosting in iweb and are looking for more reliability with respect to hosting, the build infrastructure needs an OS upgrade
16:34:09 <hagarth> as well as a gerrit upgrade too
16:34:31 <johnmark> hagarth: ok. in the meantime, would it be possible to do an OS upgrade whiel we wait to sort out the permanent hosting issues?
16:34:54 <johnmark> hagarth: and if that means a CentOS upgrade, I'm fine with that
16:35:13 <johnmark> if the powers that be want pure RHEL, then they can invest the time an dresources to make that happen :)
16:35:13 <Technicool> CentOS!  egads!
16:35:24 <JoeJulian> Is fedorahosted no longer an option?
16:35:27 <hagarth> johnmark: we can probably tie the two together unless the permanent hosting issue is going to take the order of a few months :)
16:36:04 <johnmark> hagarth: there are two current options: RHIT, who wants to create a solution for all upstream projects, including gluster.org and ovirt.org
16:36:19 <johnmark> hagarth: and the open source lab at Oregon State, who could easily host all of our services
16:36:36 <johnmark> JoeJulian: that could be an option, but I don't want to be tied too closely to the fedora project
16:36:48 <JoeJulian> What's the advantage and disadvantages
16:36:53 <johnmark> hagarth: RHIT looks like end of year
16:37:04 <johnmark> OSL could potentially be next month
16:37:23 <johnmark> JoeJulian: advantages of RHIT are that I know once it's set up, it's done and will be supported with an SLA
16:37:27 <hagarth> johnmark: then we can perform the OS upgrade along with the hosting change
16:37:31 <Technicool> johnmark, if I had a pick, i would avoid RHIT if only because it seems like we will have less control there then at OSU or anywhere else
16:37:34 <johnmark> hagarth: sounds good
16:37:40 <johnmark> Technicool: agreed
16:38:04 <johnmark> and an advantage of the OSL is the issue of project independence and transparency
16:38:21 <Technicool> on the other side of that coin, we haven't had anything critical path come up that couldnt be handled within an SLA timeframe
16:38:32 <johnmark> I'm happy to give our requirements to the OSL guys, if someone can help me prepare that
16:38:38 <johnmark> Technicool: true
16:39:08 <johnmark> so, I'd like to specify our project requirements on the -infra list and submit it next week
16:39:52 <johnmark> #action johnmark, hagarth, Technicool to work on hosting requirements on -infra
16:40:14 <johnmark> anything else on servers?
16:40:38 <johnmark> ok, then
16:40:59 <johnmark> #topic gluster.org site design and software
16:41:31 <johnmark> at one time, we were going to look at alternative CMS's and an alternative to our current HelpShift Q&A site
16:42:06 <JoeJulian> I'm still working on limnor.*
16:42:14 <johnmark> although we may need to wait until we get the hosting and OS upgrades figured out before we can really proceed here
16:42:21 <johnmark> JoeJulian: limnor.*?
16:42:28 <johnmark> I don't remember that one
16:42:39 <johnmark> memory is the first thing to go :)
16:42:52 <JoeJulian> Limnoria
16:42:58 <JoeJulian> Limnora
16:43:05 <JoeJulian> Whatever it is.
16:43:11 <johnmark> heh, ok
16:43:44 * Technicool 's model is so old it only had 1MB of SIMM RAM anyway...
16:44:13 <johnmark> this? https://github.com/ProgVal/Limnoria
16:44:24 <johnmark> Technicool: lulz
16:44:27 <johnmark> haha
16:44:37 <semiosis> johnmark: you're being very cryptic
16:44:54 <johnmark> semiosis: so community.gluster.org
16:45:01 <johnmark> I dont' like it, and I want to change it
16:45:06 <semiosis> +1000
16:45:20 <johnmark> at one time, we discussed alternatives, and I know there's OSQA, which is django based
16:45:32 <johnmark> and JoeJulian suggested some Ruby monstrosity ;)
16:45:41 <JoeJulian> I think that's right. It's not loading though.
16:45:46 <johnmark> doh, ok
16:45:47 <semiosis> johnmark: while you were afk... this: https://twitter.com/pragmaticism/status/241231119381565440
16:46:16 <johnmark> semiosis: doh
16:46:24 <JoeJulian> Heh, nope
16:46:32 <Technicool> operators arent standing by
16:46:36 <johnmark> :)
16:46:45 <JoeJulian> Remembered the wrong obscure product name.
16:46:53 <johnmark> anyhoo... I'm down with setting up OSQA
16:46:56 <semiosis> helpshift
16:46:57 <semiosis> s/f//
16:47:01 <johnmark> hahaha
16:47:08 <Technicool> lol
16:47:10 <johnmark> if anybody wants to try it
16:47:11 <JoeJulian> Since I'm in the car driving, I can't get to it.
16:47:33 <johnmark> ah, ok. please send in your thoughts to gluster-infra when you get back to a 'puter
16:47:47 <johnmark> wait, WTF?
16:47:58 <semiosis> srsly
16:48:07 <JoeJulian> ... OK, I'm a passenger.
16:48:07 <johnmark> JoeJulian: oh, that's ok, don't text and drive day was yesterday
16:48:12 <johnmark> haha.. thank god
16:48:41 <johnmark> anyhoo... I'm partial to OSQA but am open to suggestions
16:49:31 <johnmark> so as for the current site design... I think ovirt is moving to more dependence on mediawiki
16:49:34 <Technicool> johnmark, do we know how much effort it would be for lance at OSU to give us access to instances?
16:49:46 <JoeJulian> But its that software that's a hosted service but they offer the source code that doesn't install. Probably because the is is so old.
16:50:03 <johnmark> Technicool: no, but we can ask
16:50:07 <Technicool> once we decide on a platform i am happy to set it up for everyone to hop on to test
16:50:10 <johnmark> JoeJulian: which? OSQA? or the other one?
16:50:20 <johnmark> JoeJulian: I've set up OSQA before with no problem
16:50:22 <JoeJulian> Other one
16:50:25 <Technicool> #action Eco to follow up with Lance at OSUOSL about getting access
16:50:26 <johnmark> ok
16:50:31 <johnmark> sweeeet
16:50:47 <JoeJulian> Other one was much better, technically.
16:50:54 <Technicool> JoeJulian, allegro?
16:51:17 <johnmark> ok, and I think we're just going to keep expanding our usage of mediawiki as the primary CMS and use wordpress for only the blog bits
16:51:22 <JoeJulian> No idea from here. Something ruby.
16:51:33 <johnmark> because it's there, it works, and everyone knows it.
16:51:40 <JoeJulian> +1
16:51:47 <semiosis> johnmark: re: OSQA... their twitter account hasnt seen activity since May '11, and https://github.com/OSQA/osqa/ hasn't seen a commit it 2 years :(
16:51:53 <johnmark> and garrett will help us design it
16:51:56 <johnmark> semiosis: doh.
16:52:12 <johnmark> that's not promising.
16:52:45 <JoeJulian> Who sent me stickers for my upcoming presentation?
16:52:56 * Technicool guesses lh
16:53:05 <JoeJulian> Yeah, she went there.
16:53:51 <JoeJulian> She probably has contacts that could help
16:54:46 <johnmark> JoeJulian: most likely
16:54:58 <johnmark> just checked on www.osqa.net
16:55:14 <johnmark> last release was March, 2011. there's a SVN repo:     svn co http://svn.osqa.net/svnroot/osqa/trunk
16:56:30 * Technicool svn reminds him of a hilarious nsfw links he saw recently regarding git and cvs
16:56:39 <johnmark> :)
16:56:41 <johnmark> anyway
16:57:08 <JoeJulian> Shapado
16:57:16 <Technicool> bless you
16:57:17 <johnmark> JoeJulian: yes, that. worth taking a look
16:57:27 <johnmark> #action JoeJulian to look at shapado
16:57:41 <johnmark> ok, and next week hopefully jdarcy can come by and tell us about dev docs
16:57:54 <johnmark> aight... anything else? I think hagarth could use some sleep :)
16:58:04 <johnmark> and does this day and time work for most people?
16:58:12 <Technicool> this is better than before, yes
16:58:14 <johnmark> going once...
16:58:16 <johnmark> ok
16:58:21 <johnmark> going twice...
16:58:30 <johnmark> floor is open to anyone who wants to discuss anything
16:58:53 <johnmark> 5
16:58:56 <johnmark> 4
16:58:58 <johnmark> 3
16:59:00 <johnmark> 2
16:59:04 <johnmark> 1
16:59:16 <johnmark> ok, done - we'll send over the meeting minutes
16:59:20 <Technicool> #endmeeting